Page 2 of 9

Re: [DEV] AOS Tag User BBCode

Posted: Sun Aug 28, 2011 7:44 pm
by modernist
Alorse wrote:You're right, wait for the next version.
Do I have to wait another ten days for the next version? ;)

Re: [DEV] AOS Tag User BBCode

Posted: Sun Aug 28, 2011 7:57 pm
by Alorse
No, only until tomorrow.
This list is version 0.1.0 [BETA], need to do some tests and create the update package.

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 3:09 am
by Alorse
MOD Updated to version 0.1.0
  • [New] Recognizes username so not well written.
  • [New] The user can choose a method of notification when tagged from the UCP.
  • [Change] The URL notification goes directly to the message tagged.
  • [Change] Removed option notification method from the ACP.
  • [Fix] Fix permissions groups.
  • [Fix] Fix tags on the same line.
  • First [BETA] version.

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 11:43 am
by daneh
How would I update the older version that was up yesterday to the new one you just added?

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 11:53 am
by modernist
Thanks for the update and the new features, Alorse.

Works fine and there were no problems with the installation on my local test forum and even though it's marked as Beta I think I'll build it into my live forum later today..

If anyone has installed the PM Read Notification MOD ( http://www.phpbb.com/community/viewtopi ... &t=2127204 ) then add one line into functions_tag_user.php:

Search

Code: Select all

        'enable_smilies' => true,
        'enable_urls' => false,
        'icon_id' => 0,
Add after

Code: Select all

		'notify_read' => 0,
@ daneh

In the contrib folder there's a update_0.0.2_to_0.1.0.xml. Use it!

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 12:05 pm
by pro_hunter
just installed this and my test post worked great and i recieved the pm.

However now when you make a post and you have line breaks it fills the line breaks in with GUEST.

thought id screenshoted it before i unistalled but looks like i never :(

Has anyone else had this prob

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 12:20 pm
by modernist
@ pro_hunter

I can't reproduce your problem. Are you sure you followed the install instructions?

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 12:32 pm
by pro_hunter
im gonna check the file edits now but ye pretty sure

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 12:36 pm
by 4_seven
pro_hunter wrote:However now when you make a post and you have line breaks it fills the line breaks in with GUEST.
try

open

includes/functions_tag_user.php

find

Code: Select all

        $usr = preg_match_all('/\[tag:(.*?)\](.*?)\[\/tag:(.*?)\]/', $message, $list); 
replace with

Code: Select all

        $usr = preg_match_all('/\[tag:(.*?)\](.*?)\[\/tag:(.*?)\]/i', $message, $list); 
or

Code: Select all

        $usr = preg_match_all('/\[tag:(.*?)\](.*?)\[\/tag:(.*?)\]/im', $message, $list); 

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 1:07 pm
by pro_hunter
before i do anything this is how it shows

Image

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 2:16 pm
by modernist
That looks quite odd.
Do you have the relevant source code as well?
Are guests allowed to post on your board? On mine they are not.

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 2:27 pm
by pro_hunter
no they can only view

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 2:30 pm
by Ather
are you using a modification that hides links from guests maybe?

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 2:31 pm
by pro_hunter
no

Re: [BETA] AOS Tag User BBCode

Posted: Mon Aug 29, 2011 2:31 pm
by modernist
Same here...so that isn't the cause of the odd behaviour.
You double checked that your changes according to the install.xml are correct? Did you tried 4_sevens suggestion?