[ABD] AOS Tag User BBCode

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
pro_hunter
Registered User
Posts: 138
Joined: Mon Nov 19, 2007 7:49 pm

Re: [BETA] AOS Tag User BBCode

Post by pro_hunter » Mon Aug 29, 2011 2:46 pm

strange this one,,,

Changed as said above and it has stopped some of it,

It now only happens if its a line break

ie

test
test
test is ok

test

test

gives guest in the line break

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Mon Aug 29, 2011 3:14 pm

Be incompatible with some other MOD.
I recommend that MOD uninstalling completely and reinstalling.
Also pay attention to find files replaced the previous version.

I have done many tests to see if I get the error you mention, but it is not.
Last edited by Alorse on Mon Aug 29, 2011 4:39 pm, edited 1 time in total.

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: [BETA] AOS Tag User BBCode

Post by modernist » Mon Aug 29, 2011 3:42 pm

There seems to be a problem with user who don't allow cookies.
When a user A with a session-id in the url tags user B, user B gets the link to the post with the session-id from user A. I'd rather see the current session-id for user B or none at all if he uses cookies.

To get rid of the session-id completely I changed in functions_tag_user.php

Code: Select all

 $topic_link = append_sid("{$phpbb_root_path}viewtopic.$phpEx", 'f=' . $row['forum_id'] . '&t=' . $row['topic_id'] . '&p=' . $row['topic_last_post_id'] . '#p' . $row['topic_last_post_id']);
to

Code: Select all

 $topic_link = ($phpbb_root_path . 'viewtopic.' . $phpEx . '?f=' . $row['forum_id'] . '&t=' . $row['topic_id'] . '&p=' . $row['topic_last_post_id'] . '#p' . $row['topic_last_post_id']);
There still a problem for users with session-ids though. They can't answer after clicking the link.
"It ain't a fit night out for man or beast."

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Mon Aug 29, 2011 7:55 pm

The function append_sid() should handle cookies, and I can not leave the URL is the function append_sid() because it would not be the correct way to program an application phpBB.
But I'll watch what you say, well if you notice any system of sending e-mails of phpBB is that way.

daneh
Registered User
Posts: 28
Joined: Sat Oct 09, 2010 5:13 pm
Contact:

Re: [BETA] AOS Tag User BBCode

Post by daneh » Mon Aug 29, 2011 9:44 pm

Where is the link for Version 0.1.0 the download on the first page is still the older version.

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Mon Aug 29, 2011 11:15 pm

daneh wrote:Where is the link for Version 0.1.0 the download on the first page is still the older version.
:| :| :| the link to download the current version is 0.1.0

daneh
Registered User
Posts: 28
Joined: Sat Oct 09, 2010 5:13 pm
Contact:

Re: [BETA] AOS Tag User BBCode

Post by daneh » Tue Aug 30, 2011 12:38 am

Your right...google chrome was messing it up...when upgrading from 0.0.2 to 0.1 do I still have to run the new aos_tag_user_bbcode_install.php?

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Tue Aug 30, 2011 1:21 am

daneh wrote:Your right...google chrome was messing it up...when upgrading from 0.0.2 to 0.1 do I still have to run the new aos_tag_user_bbcode_install.php?
Of course, you must rerun the installer to apply the new changes in the database.

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: [BETA] AOS Tag User BBCode

Post by modernist » Tue Aug 30, 2011 6:27 am

Alorse wrote:But I'll watch what you say, well if you notice any system of sending e-mails of phpBB is that way.
I'm not sure if I understand what you mean here.
I've noticed the session-ID problem with PMs so far...haven't found the time yesterday to install it live and there's no mail server for my local test forum so I couldn't control the content of the email notification.
Alorse wrote:The function append_sid() should handle cookies, and I can not leave the URL is the function append_sid() because it would not be the correct way to program an application phpBB.
I see your point, but getting to know another member's session-ID should also be avoided I think.
"It ain't a fit night out for man or beast."

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Tue Aug 30, 2011 5:46 pm

The problem of the session is that if I (Alorse) was sent a private message or email you (modernist) would have to be with my session ID because the system still does not know which is your session ID.
If you look at an e-mail phpBB (any) URLs do not handle the session ID of the users.

The URL of this MOD will not work if management IDs in the session, and do not think it can fix.

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: [BETA] AOS Tag User BBCode

Post by modernist » Wed Aug 31, 2011 9:52 am

Alorse wrote:The URL of this MOD will not work if management IDs in the session, and do not think it can fix.
Then I guess it's better to remove the session-ID entirely.

Anyway...I've installed the MOD on my forum yesterday and an odd problem occured but it wasn't always reproducible. Sometimes even non-tagged usernames got linked to the profile. That's why I now diabled the link feature.

And another thing I noticed in the emails send as notifications, {USERNAME_TO} isn't working on my board.
Since I've heavily modded my forum I can't really say if this is an incompatiblity with other MODs. I guess it worked well when you tested it?

User avatar
modernist
Registered User
Posts: 79
Joined: Mon Mar 15, 2010 9:13 pm
Location: Klopstokia

Re: [BETA] AOS Tag User BBCode

Post by modernist » Wed Aug 31, 2011 11:17 am

I've noticed another odd behaviour.
Selecting the notification method seems to work only one time. When I then switch to another option (from PM to no notification for example) and then back (to PM), no notification PM will be delivered. The value saved in the table field user_tag_type is the right one though. The problem persists when I clear the forum cache.
"It ain't a fit night out for man or beast."

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Wed Aug 31, 2011 1:06 pm

Image
I have no problem with the variable {USERNAME_TO}, nor with links to profiles http://phpbb.alorse.net/viewtopic.php?f=2&t=195
I'm in university, when I get home I check it in a forum with a large database.

thunderft
Registered User
Posts: 17
Joined: Mon Sep 06, 2010 7:17 pm

Re: [BETA] AOS Tag User BBCode

Post by thunderft » Fri Sep 02, 2011 2:01 am

I'm trying to download the ZIP file, but just get a corrupt file.

Anyone have a better way to get the file ?

I tried contacting a Team member, but was dissed :roll: and told to come back and post here.

User avatar
Alorse
Registered User
Posts: 174
Joined: Sun Apr 06, 2008 8:18 pm
Location: Colombia
Name: Fredo
Contact:

Re: [BETA] AOS Tag User BBCode

Post by Alorse » Fri Sep 02, 2011 2:13 am

thunderft wrote:I'm trying to download the ZIP file, but just get a corrupt file.
Successfully downloaded to me ... try again.

Locked

Return to “[3.0.x] Abandoned MODs”