[ABD] Share Topic Plus (for Facebook, Twitter & Google Plus)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Kroketten
I've Been Banned!
Posts: 39
Joined: Sun Dec 16, 2012 1:48 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by Kroketten »

This MOD looks great! Can I translate it to my own language or is that not allowed?

Thank you!
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by _Vinny_ »

Kroketten wrote:This MOD looks great! Can I translate it to my own language or is that not allowed?

Thank you!
Yes you can translate.
togbish
Registered User
Posts: 128
Joined: Mon May 16, 2011 8:06 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by togbish »

togbish wrote:Great job. Installation done. G+ works. Twitter works. Facebook does not. In Firefox, it opens a page where you are supposed to add your comment, then POST TO FACEBOOK, but it does not post your comment. In Opera, Safari and Google Chrome, it does not even successfully open that page. But the G+ and Twitter works no irrespective of the browser. The problem is with the Facebook.
Any help available?
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by _Vinny_ »

togbish wrote:Any help available?
I will investigate this problem.
togbish
Registered User
Posts: 128
Joined: Mon May 16, 2011 8:06 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by togbish »

_Vinny_ wrote:
togbish wrote:Any help available?
I will investigate this problem.
It was also reporting on Facebook as if someone was phishing with my account everytime I post on Facebook with it. I uninstalled it and installed the Share On but disabled the Facebook there. If a solution is found, I will enable. Thanks.
Keefy
Registered User
Posts: 405
Joined: Fri Jan 28, 2005 4:30 am

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by Keefy »

I have this installed and works great except for one thing....

I added the <!-- INCLUDE sharetopic_body.html --> to my viewtopic_body.html so it places the icons on the top bar of a new post (Topic)

Sometimes (not always) when the page is loading to show a new topic it freezes on that bar till the facebook icons have loaded then loads the rest of the page, is there anyway to get the script which I presume is the code in sharetopic_body.html (pasted below) to load/run last till the rest of the code in viewtopic_body.html as loaded.

Code: Select all

<!-- IF S_SHARE_PLUS_ENABLE --><div id="social_icons" style="text-align: right;">
<!-- IF S_SHARE_PLUS_FACEBOOK -->
<script type="text/javascript">
//<![CDATA[
(function() {
	document.write('<fb:like data-href="{U_SHARE_TOPIC}" class="fb-like" data-send="{SHARE_PLUS_FACEBOOK_SEND}" data-layout="{SHARE_PLUS_FACEBOOK_LAYOUT}" data-width="{SHARE_PLUS_FACEBOOK_WIDTH}" data-show-faces="{SHARE_PLUS_FACEBOOK_FACE}" data-action="{SHARE_PLUS_FACEBOOK_ACTION}" data-colorscheme="{SHARE_PLUS_FACEBOOK_COLOR}" data-font="{SHARE_PLUS_FACEBOOK_FONT}"><\/fb:like>');
	var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
	s.type = 'text/javascript';
	s.async = true;
	s.src = 'http://connect.facebook.net/{SHARE_PLUS_FACEBOOK_LANG}/all.js#xfbml=1';
	s1.parentNode.insertBefore(s, s1);
})();
//]]>
</script>
<!-- ENDIF -->

<!-- IF S_SHARE_PLUS_TWITTER -->
<script type="text/javascript">
//<![CDATA[
(function() {
	document.write('<a href="http://twitter.com/share" class="twitter-share-button" data-url="{U_SHARE_TOPIC}" data-text="{TOPIC_TITLE}" data-count="{SHARE_PLUS_TWITTER_BUTTON}" data-via="{SHARE_PLUS_TWITTER_VIA}" data-lang="{SHARE_PLUS_TWITTER_LANG}">Tweet<\/a>');
	var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
	s.type = 'text/javascript';
	s.async = true;
	s.src = 'http://platform.twitter.com/widgets.js';
	s1.parentNode.insertBefore(s, s1);
})();
//]]>
</script>
<!-- ENDIF -->

<!-- IF S_SHARE_PLUS_GOOGLE -->
<script type="text/javascript" src="https://apis.google.com/js/plusone.js">
//<![CDATA[
	{lang: '{SHARE_PLUS_GOOGLE_LANG}'}
//]]>
</script>
<div id="plusone-div"></div>
<script type="text/javascript">
//<![CDATA[
gapi.plusone.render ('plusone-div', {"href": "{U_SHARE_TOPIC}", "size": "{SHARE_PLUS_GOOGLE_SIZE}", "annotation": "{SHARE_PLUS_GOOGLE_COUNT}"});
//]]>
</script>
<!-- ENDIF -->
</div><!-- ENDIF -->

Thnaks for any help
wbxpress
Registered User
Posts: 150
Joined: Wed Mar 21, 2012 1:29 pm
Contact:

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by wbxpress »

When we will get a BETA version?
Eagerly waiting for this MOD. :roll:
Beregore
Registered User
Posts: 6
Joined: Sat Jan 12, 2013 1:31 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by Beregore »

Hi, I'm having two problems with this mod.

First and the most important one is, when there is an apostrophe (') in the topic title, it somehow disables twitter and it causes a huge space right next to facebook, and it creates a horizontal scrollbar on the page.

Secondly, facebook and twitter are not aligned properly (see the screenshot below). I'm using a customized theme.

Image

How can I solve these problems?
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by _Vinny_ »

wbxpress wrote:When we will get a BETA version?
Eagerly waiting for this MOD. :roll:
This version works quite fine at the moment, still need to fix some bugs before providing a new version.
Beregore wrote:Hi, I'm having two problems with this mod.

First and the most important one is, when there is an apostrophe (') in the topic title, it somehow disables twitter and it causes a huge space right next to facebook, and it creates a horizontal scrollbar on the page.

Secondly, facebook and twitter are not aligned properly (see the screenshot below). I'm using a customized theme.

Image

How can I solve these problems?
Can you provide a link to your forum?
Beregore
Registered User
Posts: 6
Joined: Sat Jan 12, 2013 1:31 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by Beregore »

_Vinny_ wrote:
wbxpress wrote:When we will get a BETA version?
Eagerly waiting for this MOD. :roll:
This version works quite fine at the moment, still need to fix some bugs before providing a new version.
Beregore wrote:Hi, I'm having two problems with this mod.

First and the most important one is, when there is an apostrophe (') in the topic title, it somehow disables twitter and it causes a huge space right next to facebook, and it creates a horizontal scrollbar on the page.

Secondly, facebook and twitter are not aligned properly (see the screenshot below). I'm using a customized theme.

Image

How can I solve these problems?
Can you provide a link to your forum?
Thanks for the quick reply.

http://www.thewhitetree.org/forum/index.php

And here's an example of a title with apostrophe (') in it.

http://www.thewhitetree.org/forum/viewt ... 51&t=13378
Beregore
Registered User
Posts: 6
Joined: Sat Jan 12, 2013 1:31 pm

Re: [DEV] Share Topic Plus (for Facebook, Twitter & Google P

Post by Beregore »

I don't mean to rush you, but have you found the problem?
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC] Share Topic Plus (for Facebook, Twitter & Google Pl

Post by _Vinny_ »

Finally new update: Version RC 1.0.0

First, who has the mod installed, remove before installing this update.

Changelog
- UMIL 1.0.5
- MODX 1.2.6
- News functions_share.php
- HTML5 to display the buttons correctly (this breaks the validation xHTML, but this isn't a serious problem.)

======================
Beregore wrote:I don't mean to rush you, but have you found the problem?
Already fixed in the new version. ;)
User avatar
kmakoto
Registered User
Posts: 234
Joined: Mon Mar 01, 2010 11:35 pm

Re: [RC] Share Topic Plus (for Facebook, Twitter & Google Pl

Post by kmakoto »

in root/includes/functions_share.php

Search

Code: Select all

$view_topic_url = generate_board_url() . "viewtopic.$phpEx?f=$forum_id&t=$topic_id";
Change to

Code: Select all

$view_topic_url = generate_board_url() . "/viewtopic.$phpEx?f=$forum_id&t=$topic_id";

solved error share in Finally new update: Version RC 1.0.0
"/viewtopic.$phpEx?f=$forum_id&t=$topic_id";
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8736
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [RC] Share Topic Plus (for Facebook, Twitter & Google Pl

Post by _Vinny_ »

kmakoto wrote:in root/includes/functions_share.php

Search

Code: Select all

$view_topic_url = generate_board_url() . "viewtopic.$phpEx?f=$forum_id&t=$topic_id";
Change to

Code: Select all

$view_topic_url = generate_board_url() . "/viewtopic.$phpEx?f=$forum_id&t=$topic_id";

solved error share in Finally new update: Version RC 1.0.0
"/viewtopic.$phpEx?f=$forum_id&t=$topic_id";
Thanks :D Fixed.
User avatar
mladiucitelj
Registered User
Posts: 586
Joined: Sun Dec 12, 2010 12:33 am
Location: Slovenia, Europe

Re: [RC] Share Topic Plus (for Facebook, Twitter & Google Pl

Post by mladiucitelj »

_Vinny_ wrote:
kmakoto wrote:in root/includes/functions_share.php

Search

Code: Select all

$view_topic_url = generate_board_url() . "viewtopic.$phpEx?f=$forum_id&t=$topic_id";
Change to

Code: Select all

$view_topic_url = generate_board_url() . "/viewtopic.$phpEx?f=$forum_id&t=$topic_id";

solved error share in Finally new update: Version RC 1.0.0
"/viewtopic.$phpEx?f=$forum_id&t=$topic_id";
Thanks :D Fixed.
I've installed new version before this fix. Should I edit it manually?
Don't forget to clear cache, refresh template, theme and imageset, double check all files :)

My mod: [MODDB] Menu System
Locked

Return to “[3.0.x] Abandoned MODs”