[ABD] Moderator Messages

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC2] Moderator Messages

Post by ABDev »

There is only one last issue to fix, and the new version will be released :).

ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC3] Moderator Messages

Post by ABDev »

Hi all,
The newest version is available :).

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC3] Moderator Messages

Post by Jessica »

[SOLVED]

Updated, but mini edit button doesn't seem to be appearing. I refreshed styles, purged cache, refreshed browser..nothing...I uploaded the files..double checked edits..

Test account:
U: Test
P: test123

topic with a moderator message: http://chenschool.elementfx.com/phpBB3/ ... =36&t=1016

EDIT: figured out why it wasn't appearing. The delete button was covering the mini edit. I change the delete button months ago to the a button that said DELETE instead of the standard small x one. so how do I adjust it so that the delete button doesn't cover the edit one? Apart from changing the delete button back to normal, that is.

EDIT #2: changed it back to the small x. problem solved
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC3] Moderator Messages

Post by Jessica »

After updating it seemed to cause a problem/conflict with the reputation system mod...the reputation popup would not close when clicking outside it. Before the update it worked fine.
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC3] Moderator Messages

Post by ABDev »

Would you have a link to download that MOD please ?

Edit : Found

ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC3] Moderator Messages

Post by ABDev »

I think there is a jQuery conflict in fact. We use the 1.10.2 version, RS uses the 1.10.1 version
Try a thing please.

Open the styles/prosilver/template/moderator_message_editor.html file and remove the first line :

Code: Select all

<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/jquery.js"></script>

User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC3] Moderator Messages

Post by Pico88 »

RS doesn't load jquery library if one is already loaded.
The problem is not caused by jquery library.

ATM, 2 libraries are loaded: 1.8.3 and 1.10.2
Please do not PM me for support.

ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC3] Moderator Messages

Post by ABDev »

Okay, so I will have a look on it tonight.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC3] Moderator Messages

Post by RMcGirr83 »

RS may not but jQuery pack does.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC3] Moderator Messages

Post by Jessica »

ABDev wrote:I think there is a jQuery conflict in fact. We use the 1.10.2 version, RS uses the 1.10.1 version
Try a thing please.

Open the styles/prosilver/template/moderator_message_editor.html file and remove the first line :

Code: Select all

<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/jquery.js"></script>
That actually fixed it. Thanks
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Theriddler1
Registered User
Posts: 448
Joined: Sat Aug 27, 2011 11:00 pm
Location: NL
Name: Theriddler❶
Contact:

Re: [RC3] Moderator Messages

Post by Theriddler1 »

Thanks for taken the time to update the mod.

After updating on our forum we get an error when trying to edit the mm edit or delete it

The error:
Something went poorly when sending the request to the server: 200 SyntaxError: JSON.parse: unexpected character

when refresh the site with F5 it does seems to take the edit
also when try to delete the mm message same error ,manually refresh page and message is gone.

i've looked with firebug console
<b>[phpBB Debug] PHP Warning</b>: in file <b>[ROOT]/mm.php</b> on line <b>98</b>: <b>json_encode() expects exactly 1 parameter, 2 given</b><br />

don't know if that has something to do with the error
Theriddler - Moderator @ phpBB.nl | phpBBservice.nl Team-member
ImageSupport Tools | Image My Extensions | buy me a beer Image

ABDev
Registered User
Posts: 905
Joined: Sun Aug 21, 2005 9:29 pm
Location: France
Name: Adrien Bonnel

Re: [RC3] Moderator Messages

Post by ABDev »

Did you have the issue just once or more ?

User avatar
Theriddler1
Registered User
Posts: 448
Joined: Sat Aug 27, 2011 11:00 pm
Location: NL
Name: Theriddler❶
Contact:

Re: [RC3] Moderator Messages

Post by Theriddler1 »

ABDev wrote:Did you have the issue just once or more ?
all the time

Image

Image
Last edited by Theriddler1 on Wed Dec 25, 2013 7:43 pm, edited 1 time in total.
Theriddler - Moderator @ phpBB.nl | phpBBservice.nl Team-member
ImageSupport Tools | Image My Extensions | buy me a beer Image

User avatar
Geolim4
Former Team Member
Posts: 1965
Joined: Sat Sep 11, 2010 3:28 pm
Location: Nantes, France
Name: Georges
Contact:

Re: [RC3] Moderator Messages

Post by Geolim4 »

This Json_encode() version require php 5.3. Contact your hosting provider.
phpBB-fr Former MOD Team Leader / Website Team Member

User avatar
Theriddler1
Registered User
Posts: 448
Joined: Sat Aug 27, 2011 11:00 pm
Location: NL
Name: Theriddler❶
Contact:

Re: [RC3] Moderator Messages

Post by Theriddler1 »

geolim4 wrote:This Json_encode() version require php 5.3. Contact your hosting provider.
ahh that's why i'm getting that error, many thanks to you both for looking.
will contact our hosting.

our PHP Version 5.2.17
Theriddler - Moderator @ phpBB.nl | phpBBservice.nl Team-member
ImageSupport Tools | Image My Extensions | buy me a beer Image

Locked

Return to “[3.0.x] Abandoned MODs”