[ABD] Reputation System

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Versusnja
Registered User
Posts: 39
Joined: Tue Jan 12, 2010 9:58 am

Re: [RC] Reputation System 0.4.3

Post by Versusnja »

Jessica wrote:two things...

1. a tiny tiny issue. when I go to "more details", at the footer it looks like this:

Code: Select all

Powered by phpBB® Forum Software © phpBB Group 
<Reputation System ©
there's this unnecessary "<". I'm not sure what file to go to in order to remove it...
You should have touched simple_footer.html
Jessica wrote: 2. can you add back the link to the post of which the rep was given on the ajax popup? I liked it...or maybe you can make an option for it?
The link is still there. We only removed the name of the topic as it took too much space.
Raul Duke
Registered User
Posts: 194
Joined: Sat Jun 25, 2005 9:03 am

Re: [RC] Reputation System 0.4.3

Post by Raul Duke »

Pico88 wrote:Everything is written in update instructions.
Sorry, I didn't explain myself very well.

I'm going to install the latest version of your mod on a vanilla 3.0.11 install of phpBB (using my current database). Obviously my database is from version 0.2.2 of your mod though. Can I just install the latest version of your mod (which will bring the reputation tables in my database up to date) or do I need to go through each upgrade step to get to the latest version?

Hope that makes sense, thanks.
I got into forum administration for the ladies.
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System 0.4.3

Post by Pico88 »

Raul Duke wrote:
Pico88 wrote:Everything is written in update instructions.
Sorry, I didn't explain myself very well.

I'm going to install the latest version of your mod on a vanilla 3.0.11 install of phpBB (using my current database). Obviously my database is from version 0.2.2 of your mod though. Can I just install the latest version of your mod (which will bring the reputation tables in my database up to date) or do I need to go through each upgrade step to get to the latest version?

Hope that makes sense, thanks.
Each step
First, make files edit.
Next run update_reputation.php and after update to 0.4.0 use install_reputation.php.
Please do not PM me for support.
Raul Duke
Registered User
Posts: 194
Joined: Sat Jun 25, 2005 9:03 am

Re: [RC] Reputation System 0.4.3

Post by Raul Duke »

Cool, thank you.
I got into forum administration for the ladies.
Raul Duke
Registered User
Posts: 194
Joined: Sat Jun 25, 2005 9:03 am

Re: [RC] Reputation System 0.4.3

Post by Raul Duke »

Just wanted to check something with this mod in case I have installed it incorrectly...

When I vote the voting buttons disappear as expected.

When I go back into the topic though the voting buttons have come back. I can't actually vote, it says I already have when I click them. Seems odd that they come back though.

Is this right?
I got into forum administration for the ladies.
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System 0.4.3

Post by Pico88 »

Check edit of viewtopic_body.html.
Please do not PM me for support.
Raul Duke
Registered User
Posts: 194
Joined: Sat Jun 25, 2005 9:03 am

Re: [RC] Reputation System 0.4.3

Post by Raul Duke »

All seems fine.

Code: Select all

<!-- IF S_REPUTATION and S_ENABLE_REPUTATION -->
			<ul class="rep-icons">
				<li class="rate-good-icon"><!-- IF postrow.S_GIVE_REPUTATION --><a href="{postrow.U_ADD_POS}" class="repo-link<!-- IF postrow.RS_VOTED_POINTS > 0 --> {postrow.RS_POST_CLASS}" title="{L_RS_YOU_HAVE_VOTED} {postrow.RS_VOTED_POINTS}"<!-- ELSE -->" title="{L_RS_ADD_POINTS} {L_RS_TO} {postrow.POST_AUTHOR}"<!-- ENDIF -->><span>{L_RS_ADD_POINTS}</span></a><!-- ENDIF --></li>
				<li class="reputation {postrow.REPUTATION_BOX}"><div title="{L_RS_POST_REPUTATION}"><!-- IF postrow.U_VIEW_REP --><a href="{postrow.U_VIEW_REP}"<!-- IF not S_RS_AJAX_ENABLE --> onclick="popup(this.href, 780, 550); return false;"<!-- ENDIF --> class="repo-link"><!-- ENDIF -->{postrow.POST_REP}<!-- IF postrow.U_VIEW_REP --></a><!-- ENDIF --></div></li>
				<li class="rate-bad-icon"><!-- IF postrow.S_GIVE_REPUTATION && postrow.S_GIVE_NEGATIVE--><a href="{postrow.U_ADD_NEG}" class="repo-link <!-- IF postrow.RS_VOTED_POINTS < 0 --> {postrow.RS_POST_CLASS}" title="{L_RS_YOU_HAVE_VOTED} {postrow.RS_VOTED_POINTS}"<!-- ELSE -->" title="{L_RS_SUBTRACT_POINTS} {L_RS_TO} {postrow.POST_AUTHOR}"<!-- ENDIF -->><span>{L_RS_SUBTRACT_POINTS}</span></a><!-- ENDIF --></li>
			</ul><br />			
			<!-- ENDIF -->	
Had to change the ul class here to <ul class="rep-icons"> to work on my custom style.

Could that have caused something?
I got into forum administration for the ladies.
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System 0.4.3

Post by Pico88 »

So you have to also replace it in reputation.js.
Please do not PM me for support.
Versusnja
Registered User
Posts: 39
Joined: Tue Jan 12, 2010 9:58 am

Re: [RC] Reputation System 0.4.3

Post by Versusnja »

Raul Duke wrote:Just wanted to check something with this mod in case I have installed it incorrectly...

When I vote the voting buttons disappear as expected.

When I go back into the topic though the voting buttons have come back. I can't actually vote, it says I already have when I click them. Seems odd that they come back though.

Is this right?
That's not right.
There's a tiny variable that changes the class of the post DIV. You must have overlooked this.
Check viewtopic template. Find

Code: Select all

	<div id="p{postrow.POST_ID}" class="post <!-- IF postrow.S_ROW_COUNT is odd -->bg1<!-- ELSE -->bg2<!-- ENDIF --><!-- IF postrow.S_UNREAD_POST --> unreadpost<!-- ENDIF --><!-- IF postrow.S_POST_REPORTED --> reported<!-- ENDIF --><!-- IF postrow.S_ONLINE and not postrow.S_IGNORE_POST --> online<!-- ENDIF --> {postrow.RS_POST_CLASS}">
Make sure you have this {postrow.RS_POST_CLASS} in the end
Raul Duke
Registered User
Posts: 194
Joined: Sat Jun 25, 2005 9:03 am

Re: [RC] Reputation System 0.4.3

Post by Raul Duke »

Ah ha!

It was there but it didn't have a space before {postrow.RS_POST_CLASS}

Sorted now.

Thanks.
I got into forum administration for the ladies.
reelbigfish
Registered User
Posts: 47
Joined: Tue Dec 30, 2008 2:21 am

Re: [RC] Reputation System 0.4.3

Post by reelbigfish »

Everything was working great until I deactivated the ability to give negative reputation. Now my icons aren't showing up on posts. The images are in the correct imageset folder. I've tried emptying cache, refreshing the imageset, and refreshing the template.

I updated to version 0.4.3 as it is the most recent version. Tried all the above steps to no avail. Any help would be much appreciated.

http://www.yosefscabin.com/mountaineermessageboard
reelbigfish
Registered User
Posts: 47
Joined: Tue Dec 30, 2008 2:21 am

Re: [RC] Reputation System 0.4.3

Post by reelbigfish »

It's working again....I don't know what happened.
User avatar
cruzerv3
Registered User
Posts: 90
Joined: Thu Jul 23, 2009 10:24 am
Location: Switzerland

Re: [RC] Reputation System 0.4.3

Post by cruzerv3 »

hi all,

I just updated to v0.4.3, everything works fine but I noticed the font size inside the box counter is a bit bigger than the v0.4.2, is it normal or I have something wrong?

thanks!

Image vs Image
before and after
Last edited by cruzerv3 on Mon Sep 10, 2012 2:41 pm, edited 1 time in total.
[sorry for my poor english]
wbxpress
Registered User
Posts: 150
Joined: Wed Mar 21, 2012 1:29 pm
Contact:

Re: [RC] Reputation System 0.4.3

Post by wbxpress »

It is absolutely normal and better looking IMHO. :)
wbxpress
Registered User
Posts: 150
Joined: Wed Mar 21, 2012 1:29 pm
Contact:

Re: [RC] Reputation System 0.4.3

Post by wbxpress »

After I disable negative points, when someone click thumbs up button, it is not instantly become inactive. Is there any problem related to "{postrow.RS_POST_CLASS}"? I have checked viewtopic_body.html inside template folder of the style; they are proper.
Locked

Return to “[3.0.x] Abandoned MODs”