[ABD] Reputation System

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Lghtning4u
Registered User
Posts: 54
Joined: Fri Jan 11, 2013 6:23 pm
Name: Mike

Re: [RC] Reputation System

Post by Lghtning4u »

vulkan3 wrote:When you press the Clear Reputation System has an error , and no buttons reputation

Code: Select all

General Error
SQL ERROR [ mysql4 ]

����������� ������� 'post_rs_count' � 'field list' [1054]

SQL

UPDATE phpbb_posts SET post_rs_count = 0

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_reputation.php
LINE: 83
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_reputation->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
This error is coming up, what is the fix?
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System

Post by Pico88 »

vulkan3 wrote:When you press the Clear Reputation System has an error , and no buttons reputation

Code: Select all

General Error
SQL ERROR [ mysql4 ]

����������� ������� 'post_rs_count' � 'field list' [1054]

SQL

UPDATE phpbb_posts SET post_rs_count = 0

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_reputation.php
LINE: 83
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_reputation->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
Open: includes/acp/acp_reputation.php
Find and delete:

Code: Select all

$db->sql_query('UPDATE ' . POSTS_TABLE . ' SET post_rs_count = 0');
Please do not PM me for support.
vulkan3
Registered User
Posts: 34
Joined: Sun Oct 18, 2009 7:38 am

Re: [RC] Reputation System

Post by vulkan3 »

Find

Code: Select all

<div class="inner"><span class="corners-top"><span></span></span>
Add after

Code: Select all

{postrow.L_RS_HIDE_POST}

Has several occurrences ( 3 times ) which one to choose, and that's what the instructions are very many recurring entries but does not specify exactly what kind of occurrence of use
User avatar
Lghtning4u
Registered User
Posts: 54
Joined: Fri Jan 11, 2013 6:23 pm
Name: Mike

Re: [RC] Reputation System

Post by Lghtning4u »

Pico88 wrote:
vulkan3 wrote:When you press the Clear Reputation System has an error , and no buttons reputation

Code: Select all

General Error
SQL ERROR [ mysql4 ]

����������� ������� 'post_rs_count' � 'field list' [1054]

SQL

UPDATE phpbb_posts SET post_rs_count = 0

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_reputation.php
LINE: 83
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_reputation->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
Open: includes/acp/acp_reputation.php
Find and delete:

Code: Select all

$db->sql_query('UPDATE ' . POSTS_TABLE . ' SET post_rs_count = 0');
Thanks Pico

That did the trick. Just curious, but the file /includes/acp/acp_reputation.php was not an edited file according to the install_mod.xml. Will that be changed?

Also, I still can't see the icon_rate_good.gif and icon_rate_bad.gif on the posts. Everything else seems to be working.
User avatar
MichaelMC
Registered User
Posts: 8
Joined: Sat Jan 26, 2013 7:35 am

Re: [RC] Reputation System

Post by MichaelMC »

MichaelMC wrote:Yes, i've done it but as usually receive following error:
Install new version of UMIL
After downloading and install UMIL last version receive the same result ("Reputation system" mod is absent).

Run "install_reputation.php" > redirect me to the ACP automatically.
Still got this error.....Any advice please.
User avatar
Lghtning4u
Registered User
Posts: 54
Joined: Fri Jan 11, 2013 6:23 pm
Name: Mike

Re: [RC] Reputation System

Post by Lghtning4u »

MichaelMC wrote:
MichaelMC wrote:Yes, i've done it but as usually receive following error:
Install new version of UMIL
After downloading and install UMIL last version receive the same result ("Reputation system" mod is absent).

Run "install_reputation.php" > redirect me to the ACP automatically.
Still got this error.....Any advice please.
Make sure you are uploading "install_reputation.php" into your root directory. Pointing your browser to http://www.yourdomain.com/install_reputation.php will take you to the ACP and you should see the following

Image
Last edited by Lghtning4u on Mon Jan 28, 2013 7:55 pm, edited 2 times in total.
User avatar
MichaelMC
Registered User
Posts: 8
Joined: Sat Jan 26, 2013 7:35 am

Re: [RC] Reputation System

Post by MichaelMC »

Lghtning4u, it's should appear direclty after run istall_reputation.php?
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System

Post by Pico88 »

Did you upload umil dir correctly?

EDIT:
@Lghtning4u, give us a link to your board and create testing account
Please do not PM me for support.
User avatar
MichaelMC
Registered User
Posts: 8
Joined: Sat Jan 26, 2013 7:35 am

Re: [RC] Reputation System

Post by MichaelMC »

Pico88 wrote:Did you upload umil dir correctly?

EDIT:
@Lghtning4u, give us a link to your board and create testing account
Yes, like it says in instruction.
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System

Post by Pico88 »

So you should see a page like some post above (post made by Lghtning4u).
If you don't see it, you do sth wrong.
You can give us a link to your board and create testing account.
Please do not PM me for support.
User avatar
MichaelMC
Registered User
Posts: 8
Joined: Sat Jan 26, 2013 7:35 am

Re: [RC] Reputation System

Post by MichaelMC »

Yea, it's work, problem solved.
It was server side problem. I've run it on my base server and it's work fine.
But have a few mistakes on a screen:
Image

I tried it on my three servers and problem was solved on each of them.
Last edited by MichaelMC on Mon Jan 28, 2013 9:14 pm, edited 6 times in total.
User avatar
Lghtning4u
Registered User
Posts: 54
Joined: Fri Jan 11, 2013 6:23 pm
Name: Mike

Re: [RC] Reputation System

Post by Lghtning4u »

Pico88 wrote:Did you upload umil dir correctly?

EDIT:
@Lghtning4u, give us a link to your board and create testing account

Pico

I sent up an account for testing
http://americanfreedomdefenders.com/phpbb/index.php

Username = test account
PW = picotest
User avatar
Pico88
Registered User
Posts: 878
Joined: Sat Mar 07, 2009 10:24 pm
Location: Poland
Name: Lukasz

Re: [RC] Reputation System

Post by Pico88 »

1. Did you enable post reputation in all forums? Probably not
2. Check permissions.

If you read the topic, you will found clues or answears what to do.
In the first post I wrote:Due to a lack of time I will not reply for any issues/questions, which were solved. Read (search) the whole topic before asking.
Please do not PM me for support.
User avatar
Lghtning4u
Registered User
Posts: 54
Joined: Fri Jan 11, 2013 6:23 pm
Name: Mike

Re: [RC] Reputation System

Post by Lghtning4u »

Pico88 wrote:1. Did you enable post reputation in all forums? Probably not
2. Check permissions.

If you read the topic, you will found clues or answears what to do.
In the first post I wrote:Due to a lack of time I will not reply for any issues/questions, which were solved. Read (search) the whole topic before asking.

Yes, I did enable post reputation in all forum, check permissions numerous times and although I haven't read all 50+ pages here no clues or answers are clear or I wouldn't have posted.
User avatar
RaidersTalk
Registered User
Posts: 61
Joined: Mon Jan 07, 2013 9:50 pm
Contact:

Re: [RC] Reputation System

Post by RaidersTalk »

I received this error after installing the MOD when I clicked a topic:

Fatal error: Cannot redeclare class reputation in /home/content/72/10025972/html/raiderstalk.com/includes/functions_reputation.php on line 20

I had backed up my forum before the install but now when I restore I still get that error. How do I fix it?
Locked

Return to “[3.0.x] Abandoned MODs”