[ABD]phpBB to WP connector 1.5.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Ozo » Wed Dec 11, 2013 12:22 am

Ok it seems the header errors went away when I entered my phpbb id to be associated with my wp admin under the editing user options.

I'm still getting logged out from wordpress when browsing out of admin panel and when I make a post I get this:
SQL ERROR [ mysql4 ]

Field 'topic_wp_xpost' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_topics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (2, 1386721234, 1386721234, 6, 1, 1, '[BLOG]: Another', 'Qtlaz', 'AA0000', 0, 0, 0)

BACKTRACE

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Danielx64 » Wed Dec 11, 2013 12:35 am

Ozo wrote:Ok it seems the header errors went away when I entered my phpbb id to be associated with my wp admin under the editing user options.

I'm still getting logged out from wordpress when browsing out of admin panel and when I make a post I get this:
SQL ERROR [ mysql4 ]

Field 'topic_wp_xpost' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_topics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (2, 1386721234, 1386721234, 6, 1, 1, '[BLOG]: Another', 'Qtlaz', 'AA0000', 0, 0, 0)

BACKTRACE

Ok it looks like I may have goof up in the install file, with not setting the correct sql type. I'll double check that to make sure that I did set it correctly.

When you say you are getting logged out, you go to your blog homepage then you type in <yoursitename>/wp-admin/ it will take you back to the login page?
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Ozo » Wed Dec 11, 2013 2:17 am

Danielx64 wrote:

When you say you are getting logged out, you go to your blog homepage then you type in <yoursitename>/wp-admin/ it will take you back to the login page?
Nope I login get into admin panel and if I go click to view the blog area, I am logged out no window or error confirmation.
in phpbb I get this if I try to logout:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/auth/auth_phpbb2wp.php on line 312: include(/../../../wordp//wp-load.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/auth/auth_phpbb2wp.php on line 312: include(): Failed opening '/../../../wordp//wp-load.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php')

Fatal error: Call to undefined function wp_logout() in /home/x/public_html/includes/auth/auth_phpbb2wp.php on line 313
It happens whether I use /../../../wordp or /../../../wordp/ in authentications set up.

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Danielx64 » Wed Dec 11, 2013 2:33 am

Ozo wrote:
Danielx64 wrote:

When you say you are getting logged out, you go to your blog homepage then you type in <yoursitename>/wp-admin/ it will take you back to the login page?
Nope I login get into admin panel and if I go click to view the blog area, I am logged out no window or error confirmation.
in phpbb I get this if I try to logout:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/auth/auth_phpbb2wp.php on line 312: include(/../../../wordp//wp-load.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/includes/auth/auth_phpbb2wp.php on line 312: include(): Failed opening '/../../../wordp//wp-load.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php')

Fatal error: Call to undefined function wp_logout() in /home/x/public_html/includes/auth/auth_phpbb2wp.php on line 313
It happens whether I use /../../../wordp or /../../../wordp/ in authentications set up.
With the auth setup have you tried putting in the full path like the example I shown you? Some servers will work with the path that you are trying to use and others wont. Also I will look into the logout issue as I got no idea what's going on. - this message was sent via my phone.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Ozo » Wed Dec 11, 2013 12:38 pm

Danielx64 wrote: With the auth setup have you tried putting in the full path like the example I shown you? Some servers will work with the path that you are trying to use and others wont. Also I will look into the logout issue as I got no idea what's going on. - this message was sent via my phone.
Yeah I didn't think to try the other way around and this fixed the logout issue.

So now just have that SQL table issue when posting and the fact I have to keep logging into wordpress each time I leave the admin panel.

I'll keep troubleshooting in the coming days and report anything new I find.

Thanks

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Danielx64 » Thu Dec 12, 2013 1:36 am

Ozo wrote:
Danielx64 wrote: With the auth setup have you tried putting in the full path like the example I shown you? Some servers will work with the path that you are trying to use and others wont. Also I will look into the logout issue as I got no idea what's going on. - this message was sent via my phone.
Yeah I didn't think to try the other way around and this fixed the logout issue.

So now just have that SQL table issue when posting and the fact I have to keep logging into wordpress each time I leave the admin panel.

I'll keep troubleshooting in the coming days and report anything new I find.

Thanks

WIth your wordpress install, have you got any plug-ins installed? I did a clean install of both wordpress and phpbb and I can't reproduce the logout issue. Also can you please post a lists of the Mods that you got installed on your forum?

I found the issue with the sql, and I'm working on a fix. I did indeed goof up in the install file.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by Ozo » Thu Dec 12, 2013 8:25 pm

Nope no widgets. it's a new install of wordpress latest version with phpbb3 3.0.12
I have ACP anti spam but without asksimet enabled
full quick reply editor
custom portal, rss/sitemap MOD not supported anywhere.
zbblock even though there are some phpbb3 and wordpress options in compatible.inc file, I disabled regardless same issue.

wp options
Path to phpbb: ../

Server root path to phpBB: (*) I use blank or home/<name>/public_html/

Server root path to WordPress: (*) home/<name>/public_html/wordpress/

Wordpress founder ID: 1

Forum founder ID: 2

phpbb authentication
phpbb2wp selected ofc
/home/<name>/public_html/wordpress/

Are you thinking that maybe my problem is that phpbb is in root and not wp?

MaFeSa
Registered User
Posts: 174
Joined: Wed Feb 11, 2009 7:48 am

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.0

Post by MaFeSa » Thu Dec 12, 2013 8:40 pm

Thanks Daniel, great mod!!

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Danielx64 » Thu Dec 12, 2013 11:24 pm

Ozo wrote:
Are you thinking that maybe my problem is that phpbb is in root and not wp?
That shouldn't matter at all as I tested it with a clean install of WordPress in a sub-folder with a clean phpBB in root and that worked fine. Mind you that was done on localhost.

Having a better look at your forum, have you got phpBB-seo installed? If that the case, you may run into issues with that mod.

Also it looks like that you made changes to the login as when I login (to your forum), it doesn't show a message that I've logged in like it does on a stock phpBB install.

Ok I've fixed up the installer and download link is on the first page.

To upgrade all you need to do is re-upload all the files and run the installer to make the required changes to the database.

Ok I think I may have found the issue, it looks like it could that the cookies are acting up. I found that if you log in via phpbb and not WordPress everything should work as expected. I just ran into an issue with cookies on my live site and that where the issue could well be.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Ozo » Fri Dec 13, 2013 2:23 am

Well for the login part i'm simply using redirect($redirect); in functions.php

Anyway you're probably right, may very well be incompatible with my current mods.

No biggie wp is pretty sweet software even without user bridging.

Thanks


--edit-- just noticed you added to your post last I read it. btw, wordpress 3.8 is out today.
Last edited by Ozo on Fri Dec 13, 2013 2:31 am, edited 1 time in total.

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Danielx64 » Fri Dec 13, 2013 2:26 am

Ozo wrote:Well for the login part i'm simply using

Code: Select all

redirect($redirect);
in functions.php

Anyway you're probably right, may very well be incompatible with my current mods.

No biggie wp is pretty sweet software even without user bridging.


Thanks
If I dig something up I'll post here but yes something odd going on, plus I got a feeling that a WordPress account is not even being created, and that's a worry.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Ozo
Registered User
Posts: 330
Joined: Mon Dec 13, 2010 7:57 pm

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Ozo » Fri Dec 13, 2013 2:39 am

I can confirm no phpbb user (my phpbb founder) was ever created over to wp and I was still able to login using wp credentials during my trouble shooting. I got preoccupied with the log out problem and forgot to make a note of it.

Thanks for looking into it

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Danielx64 » Fri Dec 13, 2013 2:47 am

Ozo wrote:I can confirm no phpbb user (my phpbb founder) was ever created over to wp and I was still able to login using wp credentials during my trouble shooting. I got preoccupied with the log out problem and forgot to make a note of it.

Thanks for looking into it

The founder accounts would be fine but it's the people who join up via your forum, when they login, the script will check to see if there an account at WordPress, if not it will create one.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by Danielx64 » Mon Dec 16, 2013 12:34 am

Just posting an update:

I've made several changes and bug fixes including the SQL error. Other changes includes:
  • Added icon and text so that users can get to the blog from the forums
  • Fixed the SQL issue
  • Added a page in the ACP where settings can be configured/changed
Please note that I'm considering moving the settings from WordPress into phpBB. Please let me know if you like that idea and why/why not.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

User avatar
pilch
Registered User
Posts: 121
Joined: Sat Oct 04, 2003 9:39 am
Location: U.K
Contact:

Re: [RC] [BRIDGE] phpBB to WordPress bridge 0.8.1

Post by pilch » Thu Jan 02, 2014 9:45 pm

Hi Mr Developer.

I think it's great that phpbb owners have good people like you and I wanted to personally express gratitude there first and foremost.

Now, will your RC MOD cope with a 10 year old site with close to 600k accounts and us heavily modded?

Thanks in advance.
Rich

Locked

Return to “[3.0.x] Abandoned MODs”