[ABD] Simple Points System 0.5.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Linxus
Registered User
Posts: 165
Joined: Sat Nov 15, 2008 6:02 am

Re: [BETA] Simple Points System 0.5.1

Post by Linxus » Sun Dec 14, 2008 10:22 pm

Ok is there a file in the db? I just wan to know the file appreciate the help.
btw the donat mod doesnt work with just doing the edits with donate in them. I did that and it didnt work. I had to restore backup because when i restored back to old one the old one wouldnt give points when someone posted. Ill just wait till ganon implements donate (if he does). If not ill just leave it how it is.

Linxus
Registered User
Posts: 165
Joined: Sat Nov 15, 2008 6:02 am

Re: [BETA] Simple Points System 0.5.1

Post by Linxus » Tue Dec 16, 2008 11:43 pm

Any answer? And people really want the donate to each other feature..

User avatar
flosser
Registered User
Posts: 29
Joined: Fri Dec 12, 2008 3:05 pm
Location: USA

Re: [BETA] Simple Points System 0.5.1

Post by flosser » Wed Dec 17, 2008 8:07 am

Hi,

I installed everything correctly...at least I think I did. I got the points to show up as 0. But after setting the permission for group and user so they "can earn point" as stated in the "install instructions", I still can't get the points to go up with new topic and reply. I know many people asked this question bc I read through almost the entire thread...checked and double checked my permissions to make sure that it is set on "can earn points" and even the Permission role for something called "acl_f_points", purge the cache many times and I still can't get it up :lol:...is there anything else am I missing? Btw, this is a fresh install...not an update so that may have something to do with it..but I'm not sure. Please help.

User avatar
madguy
Registered User
Posts: 114
Joined: Thu Sep 04, 2008 2:07 pm
Location: Russia, Moscow

Re: [BETA] Simple Points System 0.5.1

Post by madguy » Wed Dec 17, 2008 5:48 pm

I think that this mod is currently unusable. Because it doesn't work on a fresh phpBB 3.0.4 installation - the mentioned bug with permissions appears. :?

Ganon_master
Registered User
Posts: 228
Joined: Sat May 14, 2005 9:05 pm
Location: Soesterberg, Utrecht, The Netherlands

Re: [BETA] Simple Points System 0.5.1

Post by Ganon_master » Wed Dec 17, 2008 6:57 pm

madguy wrote:I think that this mod is currently unusable. Because it doesn't work on a fresh phpBB 3.0.4 installation - the mentioned bug with permissions appears. :?
Well, how is it possible that other people are able to use it in it's current state?
Please do not PM me with support questions! I'm getting fed up with people asking.

evina
Registered User
Posts: 110
Joined: Mon Nov 10, 2008 2:06 am

Re: [BETA] Simple Points System 0.5.1

Post by evina » Wed Dec 17, 2008 7:35 pm

I installed the mod and set the settings in the ACP but there are no points awarded for posting and how do you edit other user's points?

ScrapbookSupplies
Registered User
Posts: 361
Joined: Tue Jan 16, 2007 7:59 pm

Re: [BETA] Simple Points System 0.5.1

Post by ScrapbookSupplies » Wed Dec 17, 2008 9:07 pm

I have a question on this mod, please.

I installed it, ran the dB update & deleted that file, refreshed the themes & purged the cache and configured the points in the General tab/post settings. But, for some reason the posts are not adding against the number shown in the field for "Points", whether the post or reply is new or to an existing post.

Wondering if anyone might know why this is? I am using 3.0.4.

Thanks so much,
Jeanne

evina
Registered User
Posts: 110
Joined: Mon Nov 10, 2008 2:06 am

Re: [BETA] Simple Points System 0.5.1

Post by evina » Wed Dec 17, 2008 10:15 pm

ScrapbookSupplies wrote:I have a question on this mod, please.

I installed it, ran the dB update & deleted that file, refreshed the themes & purged the cache and configured the points in the General tab/post settings. But, for some reason the posts are not adding against the number shown in the field for "Points", whether the post or reply is new or to an existing post.

Wondering if anyone might know why this is? I am using 3.0.4.

Thanks so much,
Jeanne
The same thing happened to me. You kind of duplicated my post :)

User avatar
darkonia
Registered User
Posts: 1901
Joined: Tue May 13, 2008 1:10 pm
Location: Munich, Germany
Contact:

Re: [BETA] Simple Points System 0.5.1

Post by darkonia » Wed Dec 17, 2008 10:44 pm

madguy wrote:I think that this mod is currently unusable. Because it doesn't work on a fresh phpBB 3.0.4 installation - the mentioned bug with permissions appears. :?
runs good and clear with 3.0.4 8-)
MMOG-Heaven - Das Gaming Portal
Community bedeutet Gleichgesinnte finden - MMOG-Heaven ist Deine Community! Von Spielern für Spieler bietet Dir dieses Portal genau das, was ein Spieler braucht. Bleibe ständig informiert, finde die neuesten MMORPGs, oder suche die frischesten News aus der Welt des Online Gamings - dieses und vieles mehr erwartet Dich auf MMOG-Heaven.

evina
Registered User
Posts: 110
Joined: Mon Nov 10, 2008 2:06 am

Re: [BETA] Simple Points System 0.5.1

Post by evina » Wed Dec 17, 2008 11:51 pm

Maybe it's not 3.0.4. I think it's the mods that are interfering. There were several lines of code that I could not find in the PHP and HTML files because they were changed by other mods. :shock:

Can somebody help me?

http://www.phpbb.com/community/viewtopi ... 5#p8104635

NYM_Godfather
Registered User
Posts: 3
Joined: Wed Jul 23, 2008 1:40 am

Re: [BETA] Simple Points System 0.5.1

Post by NYM_Godfather » Sun Dec 21, 2008 10:10 am

You need to make sure that you all are setting each user group, to each forum that you want points to be accrued in the forum permissions within the ACP. You can do this by going to forum permissions selecting the usergroup and forum you would like for them to accrue points on, and going to teh misc option and selecting yes on the field entitled something to do with points (can't remember right now). Then Apply all permissions...

I would appreciate it if you could give me a patch to replace your removed donate feature as that was an unlikely move. I understand the concept behind it though... keeping it simple that is. However, I need it, so if you still have the edits stowed somewhere I'd like it if I could have them.

Thank You,
Godfather

User avatar
Lisbon
Registered User
Posts: 825
Joined: Wed Jan 30, 2008 12:28 pm
Location: Zermatt

Re: [BETA] Simple Points System 0.5.1

Post by Lisbon » Sun Dec 28, 2008 7:12 pm

Ganon_master wrote:Donation has been removed as I found that it was a unnecessary feature.
:( :( :(

Meados
Registered User
Posts: 9
Joined: Thu Dec 04, 2008 9:56 pm

Re: [BETA] Simple Points System 0.5.1

Post by Meados » Tue Dec 30, 2008 1:50 pm

Meados wrote:Hello great mod! I like things simple.

However I would like to use decimal points for example points for user reply = 12.5

I tried insert 12.5 in acp but it changes it back to 12.

What files/sql need I edit to it work with these numbers? Thanks you very much.
Can someone answer me?

Ganon_master
Registered User
Posts: 228
Joined: Sat May 14, 2005 9:05 pm
Location: Soesterberg, Utrecht, The Netherlands

Re: [BETA] Simple Points System 0.5.1

Post by Ganon_master » Tue Dec 30, 2008 5:51 pm

Using your favorite database management application (phpMyAdmin, the command line or whatever you want), go to the phpbb_users table. You would have to change the datatype for the column user_points from int to float. That's all.
Please do not PM me with support questions! I'm getting fed up with people asking.

dylanhenrich
Registered User
Posts: 9
Joined: Fri Jan 11, 2008 2:25 am

Re: [BETA] Simple Points System 0.5.1

Post by dylanhenrich » Thu Jan 01, 2009 7:04 pm

Forgive me if these two things have already been mentioned... I haven't read through all 42 pages. :)

In the MODX file:

Code: Select all

$message = $user->lang[$message] . '<br /><br />' . sprintf($user->lang['VIEW_MESSAGE'], '<a href="' . $redirect_url . '">', '</a>');s
Should be:

Code: Select all

$message = $user->lang[$message] . '<br /><br />' . sprintf($user->lang['VIEW_MESSAGE'], '<a href="' . $redirect_url . '">', '</a>');
Also, it should be noted in the DIY Instructions that the points configuration is found in General -> Board Configuration -> Post Settings.

Locked

Return to “[3.0.x] Abandoned MODs”