[ABD] IP Country Flag Olympus 0.5.0a [phpBB 3.0.4] + SVN

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Thu Sep 11, 2008 7:18 pm

matthewhotdude wrote:Where is the install instructions??
For 0.2.0 into my pocket, actually. :D

For 0.1.8a into the Topic Starter. :geek:
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by danswano » Thu Sep 11, 2008 10:46 pm

I can't describe how happy i'm :D

is there any date or close date to get my hands on it ? :D :D

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Fri Sep 12, 2008 12:49 pm

Very soon, if everything goes as it is now I think in some days.

Bug-fixing the known bugs it is done while re-writing some parts of code and removing the redundant ones.

I can say within the end of this Month, if I will take also care of the ACP/UCP/MCP new planned/started parts. :)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by danswano » Sat Sep 13, 2008 12:31 am

Thanks buddy, waiting you on fire. :D

Goztow
Registered User
Posts: 365
Joined: Fri Aug 17, 2007 10:31 am
Location: Belgium
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by Goztow » Sat Sep 13, 2008 7:01 am

You really should stop pushing him. It'll be ready when it's ready, as always with free code ;-).

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by danswano » Sat Sep 13, 2008 12:03 pm

You should reall stop inserting your nose in here :D

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Sat Sep 13, 2008 12:41 pm

Please guys, stop flaming.. ;)

The MOD is quite finished and the 90% of the old bugs are gone, now focused on the remaining ones (3 afair). :geek:
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Mon Sep 15, 2008 8:25 pm

What I did so far..
## 2008-09-15 - version 0.2.0 beta
## - changed the code that handles the language file board-wide (thx david63)
## - avatar flags folder is now completed (thx pjessop)
## - fixed $phpbb_root_path in db_update.php
## - fixed $phpbb_root_path in install.php
## - install text file made from the scratch
## - language file amended and rightly TABed
## - added subsilver2 style support
## - fixed the lang key of the trigger_error in 'function ip_country_to_flag'
## - added a new function: 'userid_to_userip'
## - removed about 40 occurences of the redundant - " -, should be fine with html/xhtml validator now
## - fixed a bug while reading PMs
## - fixed a bug for groups avatar
## - fixed a bug in memberlist (find/select a member's conflict)
## - fixed a bug in functions_display (last poster wrong flag)...
## - 4 alterations to the DB tables have been removed since they are not used anymore.
## - removed modifications on 4 files, not used anymore
## - 'online guests' and 'past guests flags' them work along with the built-in 'Load Settings/Enable online user listings'
## - fixed a bug when splitting posts, wrong flags
## - fixed a bug 'last edited by', wrong flags
## - mini-flags next to post (posted by also) are based on 'IP for this post' (per post/session basis)
## - added flags capability on search.php, fully.
## - added credits in overall_footer/s ---->(no credits = no support)
## - added flags capability on adm/index.php
## - added flags capability on Forum logs (admin, moderators, users, errors)
## - added flags capability on testing user's permissions
## -
and continuing, I'll release the package within the end of this month. ;)

:)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by danswano » Tue Sep 16, 2008 2:29 am

Nice job man, thank you very much, there was some bugs as far i remember, in the online users there was 2 of each users (duplicated names), also the usernames in the forum view the flags were localhost, i hope you fix them :D

User avatar
Nibiru7
Registered User
Posts: 38
Joined: Tue Sep 16, 2008 9:01 am
Location: Russia
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by Nibiru7 » Tue Sep 16, 2008 9:30 am

Hi! After setting in includes/functions_display.php

Code: Select all

function get_user_avatar($avatar, $avatar_type, $avatar_width, $avatar_height, $userip, $alt = 'USER_AVATAR')
{
	// ---- IP Country Flag Olympus -----------------------------------------
	// add
	// , $db
	global $user, $config, $phpbb_root_path, $phpEx, $db;

	if (empty($avatar) || !$avatar_type)
	{
		// ---- IP Country Flag Olympus -----------------------------------------
		// add
		$flag = ip_country_to_flag($userip);
		$country = strtoupper($flag);
		// ---- IP Country Flag Olympus -----------------------------------------
		// replace
		// return '';
		return '<img src="images/avatars/gallery/avatar_flags/' .  $flag . '.gif" alt="' . $user->lang[$country] . '" title="' . $user->lang[$country] . '"" />'
	// ---- IP Country Flag Olympus -----------------------------------------
gives out an error:

Code: Select all

Parse error: syntax error, unexpected '}' in /home/n/nibiru/my forum/public_html/includes/functions_display.php on line 1186
On flags - a country is not certain
Excuse me for my poor English, I speak Russian. Nibiru·

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Tue Sep 16, 2008 5:19 pm

Nibiru7 wrote:Hi! After setting in includes/functions_display.php

Code: Select all

function get_user_avatar($avatar, $avatar_type, $avatar_width, $avatar_height, $userip, $alt = 'USER_AVATAR')
{
	// ---- IP Country Flag Olympus -----------------------------------------
	// add
	// , $db
	global $user, $config, $phpbb_root_path, $phpEx, $db;

	if (empty($avatar) || !$avatar_type)
	{
		// ---- IP Country Flag Olympus -----------------------------------------
		// add
		$flag = ip_country_to_flag($userip);
		$country = strtoupper($flag);
		// ---- IP Country Flag Olympus -----------------------------------------
		// replace
		// return '';
		return '<img src="images/avatars/gallery/avatar_flags/' .  $flag . '.gif" alt="' . $user->lang[$country] . '" title="' . $user->lang[$country] . '"" />'
	// ---- IP Country Flag Olympus -----------------------------------------
gives out an error:

Code: Select all

Parse error: syntax error, unexpected '}' in /home/n/nibiru/my forum/public_html/includes/functions_display.php on line 1186
On flags - a country is not certain
change

Code: Select all

      return '<img src="images/avatars/gallery/avatar_flags/' .  $flag . '.gif" alt="' . $user->lang[$country] . '" title="' . $user->lang[$country] . '"" />'
to

Code: Select all

      return '<img src="images/avatars/gallery/avatar_flags/' .  $flag . '.gif" alt="' . $user->lang[$country] . '" title="' . $user->lang[$country] . '" />';
:)
Last edited by 3Di on Tue Sep 16, 2008 5:36 pm, edited 1 time in total.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Tue Sep 16, 2008 5:23 pm

danswano wrote:Nice job man, thank you very much, there was some bugs as far i remember, in the online users there was 2 of each users (duplicated names), also the usernames in the forum view the flags were localhost, i hope you fix them :D
yes, the remaining to do is this bug (I'm uncertain though if it is a bug of mine) and the language keys that interferes with some built-in language keys of phpBB3, I'm working on this, about the localhost flags in the forum view: fixed in 0.2.0. :D
## known issues:
##
## - last registered user's flag only works 100% if registration mode is NOT set to 'None' in ACP (phpbb3 bug?)
## - language file interferes with some language keys (to do)
## - Groups avatar happen to show as 'unknown IP', just set an avatar for each group.
##
also a lot more I added last night, the next release will be a huge update. :ugeek:
Regards.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by danswano » Wed Sep 17, 2008 1:10 am

Waiting you buddy, god bless you :D

User avatar
Nibiru7
Registered User
Posts: 38
Joined: Tue Sep 16, 2008 9:01 am
Location: Russia
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by Nibiru7 » Wed Sep 17, 2008 3:57 am

3Di I understood that error :

Code: Select all

 '"" />' - not correctly
 '" />'; - correctly
But for me does not show the flags of countries and writes - unknown IP

Image
Excuse me for my poor English, I speak Russian. Nibiru·

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] IP Country Flag Olympus 0.1.8a

Post by 3Di » Wed Sep 17, 2008 6:42 pm

Nibiru7 wrote:But for me does not show the flags of countries and writes - unknown IP
Do you really populated your DB with my IPs?.. I also saw you are using another MOD that uses the online stats.

Is it your 'phpbb_cf_ip_to_iso3661_1' TABLE really populated? :?:

And, why not to wait for the incoming 0.2.0 version? You are making an effort I suggest you to do not, just wait for me to release the next stage of this MOD. :ugeek:
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Locked

Return to “[3.0.x] Abandoned MODs”