Page 111 of 217

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 4:08 am
by Handyman`
jtryptophan wrote:Hi -

So, my server keeps crashing, could this be part of it?

From SQL table:

Code: Select all

phpbb_chat   	Browse  	  Structure  	Search  	  Insert  	Empty  	  Drop  	945,688  	MyISAM  	utf8_bin  	96.5 MiB  


I have very limited SQL knowledge. Should I be purging this table? If so, how often and how to do it.

Thanks.
see the very first post in this topic.

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 5:07 am
by jtryptophan
:oops: :shock:

Problem. I did that, but that is from now on correct? How do I get rid of the 940,000 old chat logs?
Click empty and hold my breath? :lol:

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 10:31 am
by Wizard Sleeve
Hey there, I installed this primarily to use as a shout box as i already have a chat room.. and I must say I am actually Rather impressed with the results.. so thank you for this awesome plugin.

One thing I have noticed though, it hasn't recognised any of my MODERATORS as moderators.. it seems to have bunched everything into either ADMINS or USERS.

I have a few different groups within my site, some are mod groups, some are special groups for long term memebers, and I was wondering how I could get their colors in the shoutbox.

Also I have noticed it has changed all my members with a space in their name to having an _ in their name.. its not a big issue, but you know how people LOVE to complain.

Anyway if their is anyone who can guide me in the right direction to fix this that would be great.. thank you :)

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 12:48 pm
by jtryptophan
Handyman` wrote:
jtryptophan wrote:Hi -

So, my server keeps crashing, could this be part of it?

From SQL table:

Code: Select all

phpbb_chat   	Browse  	  Structure  	Search  	  Insert  	Empty  	  Drop  	945,688  	MyISAM  	utf8_bin  	96.5 MiB  


I have very limited SQL knowledge. Should I be purging this table? If so, how often and how to do it.

Thanks.
see the very first post in this topic.
did that and emptied the sql table. getting this error now.
Fatal error: Call to undefined function clean_username() in /public_html/chat.php on line 75
:shock:

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 7:33 pm
by comarzysko
I've got some BUG.
Someone used 5 dashed and right-side-bracket " > " as arrow to show us something.
Then shoutbox crashes like this:

Image

Everytime when someone use 5 dashed:

Code: Select all

-----
it crashes shoutbox.

And there is screen from my PhpMyAdmin

http://i40.tinypic.com/2yumw5i.jpg

As you can see there are only 4 dashes with interstice.

Regards

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 8:18 pm
by Handyman`
jtryptophan wrote::oops: :shock:

Problem. I did that, but that is from now on correct? How do I get rid of the 940,000 old chat logs?
Click empty and hold my breath? :lol:
that will get rid of the other 940,000 as well :)
the only chat messages that it won't delete are the 25 that you see in the chat box.

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 8:59 pm
by creolejazz
Hi. I'm using board version 3.0.4 and the subsilver2 style. Should this shoutbox work with that configuration?

I followed the install to the letter replacing the "prosilver" instructions with subsilver2. Also, when it came to this instruction:

Copy: root/adm/mods/ajax_chat_version.php
To: adm/mods/ajax_chat_version.php

...my adm folder didn't have a mods subfolder so I just created it and uploaded the ajax_chat_version.php file into it.

Also the overall_header file did not have this exactly...

<a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}" class="icon-faq">{L_FAQ}</a>

...but I found the only line that was close to that so used it.

All seemed fine. I accessed the chat_install.php?mode=install in my browser and got a confirmation message about ..."the database installed correctly..." (or something like that).

I see no change at all in my board. Is there something I've forgotten or need to activate? I checked previous posts here and, like another poster, found that if I go to www.mysite.com/chat.php, the chatbox works great. But it doesn't show on the index page. Any help appreciated. Thanks.

Here's my site: http://www.leapgamers.com/messageboard/phpBB3/chat.php

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 9:29 pm
by Gigabryte
Hello,
MOD works fine with subsilver2.
You done well with ajax_chat_version.php in new folder mods. But it´s irrelevant anyway, because this file is for an updatecheck only.

You added the code

Code: Select all

<!-- INCLUDE chat_body.html -->
in styles/subsilver/template/index_body.html too?

Also the overall_header.html in subsilver2-Template is to edit for the menu-item "chat".

And you upped this files according prosilver?

Code: Select all

root/styles/subsilver2/imageset/*
root/styles/subsilver2/template/chat_body.html
The files are included in the mod, but instruction is missing.

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Tue Jan 06, 2009 10:02 pm
by comarzysko
comarzysko wrote:I've got some BUG.
Someone used 5 dashed and right-side-bracket " > " as arrow to show us something.
Then shoutbox crashes like this:

Image

Everytime when someone use 5 dashed:

Code: Select all

-----
it crashes shoutbox.

And there is screen from my PhpMyAdmin

http://i40.tinypic.com/2yumw5i.jpg

As you can see there are only 4 dashes with interstice.

Regards
handyman, what about this?

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 12:01 am
by jtryptophan
Sir, please help with this error stated at the end of quote.

Is this an error in editing the file or a database error caused by the emptyi g the table?

Thanks!
jtryptophan wrote:
Handyman` wrote:
jtryptophan wrote:Hi -


So, my server keeps crashing, could this be part of it?

From SQL table:

Code: Select all

phpbb_chat   	Browse  	  Structure  	Search  	  Insert  	Empty  	  Drop  	945,688  	MyISAM  	utf8_bin  	96.5 MiB  


I have very limited SQL knowledge. Should I be purging this table? If so, how often and how to do it.

Thanks.
see the very first post in this topic.
@@@@@@@@@@
did that and emptied the sql table. getting this error now.

Fatal error: Call to undefined function clean_username() in /public_html/chat.php on line 75
:shock:

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 1:07 am
by creolejazz
Gigabryte wrote:Hello,
MOD works fine with subsilver2.
You done well with ajax_chat_version.php in new folder mods. But it´s irrelevant anyway, because this file is for an updatecheck only.

You added the code

Code: Select all

<!-- INCLUDE chat_body.html -->
in styles/subsilver/template/index_body.html too?

Also the overall_header.html in subsilver2-Template is to edit for the menu-item "chat".

And you upped this files according prosilver?

Code: Select all

root/styles/subsilver2/imageset/*
root/styles/subsilver2/template/chat_body.html
The files are included in the mod, but instruction is missing.
I've gone through the procedure twice. Everything works at
http://www.leapgamers.com/messageboard/phpBB3/chat.php

but it will not appear on my index page:
http://www.leapgamers.com/messageboard/phpBB3/index.php.

Any ideas appreciated. Thanks.

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 1:14 am
by Gigabryte
Cache emptied in acp?

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 2:42 am
by creolejazz
Gigabryte wrote:Cache emptied in acp?
Can you help me out here? How do I empty the cache?

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 2:52 am
by creolejazz
Ah. OK, I've got it showing up at the bottom of my index page now.

http://www.leapgamers.com/messageboard/phpBB3/index.php

But it doesn't work, even after logging in. No error messages, and I can type in the box, but nothing happens when hitting submit. But it works fine when I go here to try it:

http://www.leapgamers.com/messageboard/phpBB3/chat.php

Board version 3.0.4.
Syle: subsilver2

Ideas?

Re: [Beta] AJAX Chat/Shoutbox MOD 2.0.0 Beta 8

Posted: Wed Jan 07, 2009 4:43 am
by technorepublic
im having the same problem, the chat.php shows up on the site but it doesnt show up on the main page

i tried all possible workarounds but still cant show it to main page, i got the error
"Call to a member function add_lang() on a non-object"
when i place the <!-- INCLUDE chat_body.html --> on the overall_header (as adviced on this thread http://startrekguide.com/community/view ... start=2230)

what could possibly be the cause?

my site it http://filhacks.com/chat.php and http://filhacks.com/