[ABD] WP-United: WordPress Integration v0.9.2.8 22/05/14

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

egriz wrote:If I activate plugins or create categories in the main wordpress back end do those plugins work for all member blogs? Basically, are the settings that I do in the main wordpress also affect those of the user blogs? Thanks

Hello,

Yes, they will affect all users right now.
phpBB<->WordPress Integration: www.wp-united.com
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

matgallis wrote: What if you're not tech/css/html savvy? Most of what you said above confuses me :-p is there another alternative? Why can't we simply delete that giant blue box onto of wordpress and change the background color of the wordpress page to white? is it just not that simple?
Yes, that's exactly what you need to do -- and you need to do it in your WordPress templates.
phpBB<->WordPress Integration: www.wp-united.com
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

cotp wrote:Hello :)

I installed the last version for PhpBB3

1) When I choose "To Blog or Not To Blog?" to Yes it keeps it to No even though no error appears. So There is no buttton display. What do you think should be the problem ? Can I test and put it to yes through phpmyadmin ? Which table should i look at ?

2) Another thing, where should I apply the php changes in templates such as:
<li>
<h2>Latest Blog Posts</h2>
<ul>
<?php wpu_latest_blogposts('limit=10&before=<li>&after=</li>') ?>
</ul>
</li>
Thanks in advance,

Cotp
Hi, you mean that the option never gets turned on? That's strange --- have you tried from both the Setup Wizard and the Settings On-A-Page?

The code you post is created by a widget. Most of the template content for widgets are generated in wpu-template-funcs.php (the widgets themselves are created in wpu-widgets.php).
phpBB<->WordPress Integration: www.wp-united.com
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

egriz: In fact I spotted your theme a while back. Looks fantastic.

Does it use the phpBB CSS classes? If so, be sure to zip/tar it up and send me a copy :-)
phpBB<->WordPress Integration: www.wp-united.com
gavo
Registered User
Posts: 91
Joined: Sat Jun 23, 2007 10:44 am

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by gavo »

I have made a prosilver wordpress theme, intended to be used with wp-united set to "wordpress inside phpbb"
It has left and right widget columns & no header(phpbb one will be used)

feel free to use it

Download Mirror
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

THanks very much. I need to take a closer look at it, but this looks very helpful. :-)
phpBB<->WordPress Integration: www.wp-united.com
Omarvelous
Registered User
Posts: 232
Joined: Mon Jun 25, 2007 2:24 am

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Omarvelous »

Question....

Is there a way by chance that we can use the integration aspect of your MOD.... but STILL keep the forum/blog separate?

Meaning not necessarily have the forum IN the blog or the blog IN the forum.... just blog AND forum as 2 separate entities?
egriz
Registered User
Posts: 441
Joined: Tue Jun 11, 2002 9:49 pm

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by egriz »

Omarvelous wrote:Question....

Is there a way by chance that we can use the integration aspect of your MOD.... but STILL keep the forum/blog separate?

Meaning not necessarily have the forum IN the blog or the blog IN the forum.... just blog AND forum as 2 separate entities?
yes it is possible.

in the Integrate phpBB & WordPress Templates? section of the settings, select no integration. This will do what you want.
Omarvelous
Registered User
Posts: 232
Joined: Mon Jun 25, 2007 2:24 am

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Omarvelous »

egriz wrote:
Omarvelous wrote:Question....

Is there a way by chance that we can use the integration aspect of your MOD.... but STILL keep the forum/blog separate?

Meaning not necessarily have the forum IN the blog or the blog IN the forum.... just blog AND forum as 2 separate entities?
yes it is possible.

in the Integrate phpBB & WordPress Templates? section of the settings, select no integration. This will do what you want.
fanTAStic... [/NachoLibre]

I installed it b4 on local... didn't recall that step... will look into it now!
Omarvelous
Registered User
Posts: 232
Joined: Mon Jun 25, 2007 2:24 am

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Omarvelous »

Getting some errors here....

Had version 051 installed before... Sort of removed it...

Any way, cleared the wp tables, reinstalled wp, checked all the edits, only 1 appeared new, made that change...added the new files... When i'm running the setup. After completing the first step, this is the error i'm getting when trying to proceed to next...

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 990: Undefined variable: groupList
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 991: Undefined variable: listSubs
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 992: Undefined variable: listConts
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 993: Undefined variable: listAuthors
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 994: Undefined variable: listEditors
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 995: Undefined variable: listAdmins
[phpBB Debug] PHP Notice: in file /includes/acp/acp_wp_united.php on line 996: Undefined variable: fixedList
Now, I have it setup with the htdocs/forum and htdocs/blog, each side by side. And i have the blog.php already changed to index.php and in blog root.

I'd like to run them independent of each other, which is why this is the case.

Any insight to why this is occuring? I have the debug info if needed.

Also just to clarify, I can keep the login integration AND the user's blogging capabilities EVEN while having them seperated as I plan to?
simonw
Registered User
Posts: 244
Joined: Wed Mar 22, 2006 6:26 pm

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by simonw »

Hi, Just upgraded to the latest version and I notice that the link form the forum page to the blogs looks like {BLOG}. whereas the last version was Wordpress blogs. Here is the link to my site which shows the link.

http://www.back-garden-moths.co.uk/forum/index.php

I must have done something wrong but can't work out what. I've edited Overall_header again but still the same. Any ideas how to make it look like it should would be great.

Thanks

Simon
BigBlockMopar
Registered User
Posts: 90
Joined: Tue Mar 08, 2005 3:15 pm

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by BigBlockMopar »

The install.xml-file seems to have issues when using Firefox (2.0.0.6) on a Mac (10.4.10).
I can select the code-changes, but I can't copy them.

When I open the install.xml-file with the Safari-webbrowser it works OK.
I would suggest adding a plain text file with all the code-changes.
Signatures are overrated...
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by Jhong »

0marvellous: Your setup is fine -- you should be able to achieve what you want no problem. Each element of the integration is optional. You can safely ignore those phpBB Notices if they occur in the ACP.

Simonw: That's strange. Do you have the "BLOG" language string in your-language/common.php?

BigBlockMopar: Unfortunately the ModX file is required by phpBB Mod Team for phpBB3 mods, and I'm not really willing to maintain two copies of each mod file. Mind you, I do the vast majority of my testing in Firefox (for Linux) and haven't met that problem. I'll do some more testing.

If you continue to find the bug, it is likely a problem with phpBB's prosilver.xsl file, which is created by phpBB, and you'll notice it in all mods. There should be a place for you to file a bug report for that.

P.S. On my machine, the first time I open the file, I receive a security warning from Firefox. I have to 'OK' it for the xsl scripts to run.
phpBB<->WordPress Integration: www.wp-united.com
simonw
Registered User
Posts: 244
Joined: Wed Mar 22, 2006 6:26 pm

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by simonw »

Jhong, thanks for replying. In a word I don't know. Will check but I followed the installed instructions. There is however another problem. Not sure if anyone's tried this on RC4 but I get a critical errors when trying to post topics or reply to them in the forum, so unfortunately I've had to remove it for the time being. Anyone else had this problem with RC4? Any thoughts woudl be great as keen to get it live again.

Simon
EB 22
Registered User
Posts: 208
Joined: Fri Jun 13, 2003 7:53 pm

Re: [BETA] WP-United: WordPress Integration (v0.5.5 22/07/07)

Post by EB 22 »

I installed everything and got it up and running but when I went to my blog area I got the following error:

Code: Select all

Warning: chdir(): No such file or directory (errno 2) in /home/ebtalkc/public_html/index.php on line 61

Warning: main(./common.php): failed to open stream: No such file or directory in /home/ebtalkc/public_html/index.php on line 70

Warning: main(./common.php): failed to open stream: No such file or directory in /home/ebtalkc/public_html/index.php on line 70

Warning: main(): Failed opening './common.php' for inclusion (include_path='.:/usr/local/lib/php:/usr/lib/php') in /home/ebtalkc/public_html/index.php on line 70
Any idea what I did wrong?
Locked

Return to “[3.0.x] Abandoned MODs”