Page 25 of 75

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Sat Jan 19, 2008 12:48 pm
by ~Ivy
Okay, seems I was wrong - it has nothing to do with the mod. I got the same error when users tried to register, so I made a clean installation of phpBB3 to test it, and got it again.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Sat Jan 19, 2008 10:20 pm
by Nailor
~Ivy wrote:Okay, seems I was wrong - it has nothing to do with the mod. I got the same error when users tried to register, so I made a clean installation of phpBB3 to test it, and got it again.

Try usings IE instead of FireFox

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Sun Jan 20, 2008 2:01 pm
by ~Ivy
Nailor wrote:
~Ivy wrote:Okay, seems I was wrong - it has nothing to do with the mod. I got the same error when users tried to register, so I made a clean installation of phpBB3 to test it, and got it again.
Try usings IE instead of FireFox
Same thing happened. :(

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Sun Jan 20, 2008 4:18 pm
by Nailor
ann wrote:It IS creating users but the passwords are wrong! They can log into phpBB, and when they click on "Wordpress Blogs" they are taken to the blog and on the bottom it will say "Logout[username]".

But they can't post because when they try it says their passwords are incorrect! I took a look at the database and they are indeed incorrect. If I run the original through an MD5 hash and manually edit the user database entry, they can log in.

So in short, it creates the users but does not transfer their password right, it allows them to login to phpbb but not wordpress, even though wordpress shows them as logged in, they can't get to the panel to write an entry because the login screen comes up and tells them their password is incorrect when they try to login to WP! :(
I also installed WP-United for phpbb3.
Same problem with logins telling me password is wrong.

I found out if you login with IE everything works.
If you login with FireFox you get the error.
Seems to be a rendering problem.

Here is a quick fix for that.
Install the add-on for FireFox called "IE Tab"

then when you start FF go to the bottom of your page and click on the FF icon to change rending properties to IE.

Login will be possible now.

Question for the author.
Is there going to be a permanent fix for logging in with other browsers?

Thank you.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Mon Jan 21, 2008 12:11 am
by hotrocket
I'm curious if those of you with the login/pw probs are integrating with an existing database of members or is this occuring on completely fresh/clean, unmodified installs of both wordpress and phpBB3?

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Tue Jan 22, 2008 1:42 am
by Anyasha
I tried it twice with fresh installs of both and had the password problem each time.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Tue Jan 22, 2008 3:48 am
by probablepossible
That's discouraging. I came to this thread to ask for skinning advice, but on reading about the sign-in issues, I went and tried it myself-- same problem.

I'll put it on hold for a bit-- I'm not giving up! :D

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Thu Jan 24, 2008 8:40 am
by CoenJacobs
It really is to bad that this MOD isn't supported any longer, as it seems.

I managed to get everything up and running and it works like charm, but I have my difficulties on my own. The forums work great and it looks really nice (feel free to check it) but the only thing I keep on having problems with, is the User Integration.

Since 3.0 this isn't working anymore, I guess there are some changes in the code which disables or changes some other variables. For my account it works fine, but for new accounts or existing accounts I try to integrated with a Wordpress account, it just doesn't seem to work. The MOD doesn't create a Wordpress user in the database either upon new registration... :(

I'm trying to find a solution for this problem, but ever since I'm not that into phpBB 3.x I'm hoping that the author of the MOD will pick up the support. :)

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Thu Jan 24, 2008 6:50 pm
by K2
CoenJacobs: I hope you're wrong about the drop of support. I know the wp-united author hasn't even visited his own forums in over a month of this post, but I'm hoping it's just some Real Life (tm) issues that are keeping him away, and not a lack of interest.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Fri Jan 25, 2008 5:58 am
by TPCOH
Okay.... I can not get the blog.php file to work.
Can someone explain or try to help?


I set up phpBB3 in
http://www.sitename.com/forum/

I set up Wordpress 2.3.2 in:
http://www.sitename.com/forum/wordpress

Where exactly do I put the blog.php file?


I was getting 404 errors, so I tried putting that blog.php file and testing it in:
http://www.sitename.com/forum/blog.php
and
http://www.sitename.com/forum/wordpress/blog.php

Nothing worked.
So... I changed the blog.php name in
http://www.sitename.com/forum/wordpress/blog.php
to
http://www.sitename.com/forum/wordpress/index.php
because I read that you can change the file name.... correct?
(This deleted the previous index.php file)



I am able to access the WordPress Dashboard.
I can no longer "View Site" from there.

I can access the "ACP_WP_United" tab in my Admin Control Panel.

I can run the set-up Wizzard.
The "Base WordPress URL" says "Success!" when I check the URL.

The "Filesystem Path to WordPress" says "Success!" when I check the URL.

But I think I am having issues with the "New Integration Address"

I can never seem to get to the "Blogs Homepage"

Any help?


When I have the "New Integration Address" set as:
http://www.sitename.com/forum/wordpress/

I now get the following:
Error!

The path is incorrect. Please check the path to phpBB you provided and then run the WP-United Setup Wizard again.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Fri Jan 25, 2008 8:27 am
by CoenJacobs
K2 wrote:CoenJacobs: I hope you're wrong about the drop of support. I know the wp-united author hasn't even visited his own forums in over a month of this post, but I'm hoping it's just some Real Life (tm) issues that are keeping him away, and not a lack of interest.
I'm looking forward to the day the author comes back and says; "Here is a 3.0.0 compatible version of the MOD!".

He could make several people really happy with this, I think... :)

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Sun Feb 10, 2008 11:21 pm
by Shaythong
Very cool mod!

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Mon Feb 11, 2008 10:08 am
by renet
Solutions for the user-creation and post-editing issues found!
renet wrote:1. After installing it, I am no longer able to edit any posts. The TinyMCE just appears empty. No matter, if I want to edit the admins (user 1) or my own (user 2, administrator, as well) posts.
"WP-United Settings" -> Disable in "Allow cross-posting of blog posts to forum?"
renet wrote:2. Somehow WPU doesn*t create any WordPress users, except for me, the phpBB admin...
Go to "phpBB - Administration Control Panel" -> "Users and Groups" -> "Groups’ permissions" -> "Look up usergroup: Registered users" -> "Advanced Permissions" -> "WP-United" :

Enable "Yes" for "Can integrate as a WordPress subscriber (can view profile, write comments)"
(You should do the same for COPPA-Users and Mods.)

Credit for the solutions goes to Boner from the WP-United forums. (Thanks!)

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Tue Feb 19, 2008 5:22 pm
by Nysus
TPCOH wrote: I set up phpBB3 in
http://www.sitename.com/forum/

I set up Wordpress 2.3.2 in:
http://www.sitename.com/forum/wordpress
The way I have normally gone about setting WP-U up is to have wordpress installed in the root of your site, and setting up the forums under forums.

So Wordpress would be installed at http://www.sitename.com and phpBB would be in http://www.sitename.com/forums.

I'm not sure that it will work at all with wordpress installed in the phpBB directory. Did you misunderstand the installation process or do it that way on purpose?
TPCOH wrote: Where exactly do I put the blog.php file?
This file is the front page of your Wordpress integrated page. This is where you will direct your users to view the main WP blog. For example I wanted my users to go to the root domain of http://www.yoursite.com. I renamed the blog.php file to index.php and loaded it in the root.

I think this is your main problem though. You have to edit blog.php to point it to where phpBB is installed.

Code: Select all

//the path can be absolute or relative... i.e. '/home/www/phpBB2'   './phpBB2'   or  'phpBB2'   could all be correct.
//Set the path to phpBB  below, between the quotes:
'forums'	// <--- set the path to your phpBB root here,  between the quotes	
In my case it was 'forums'. In the case that you outlined it would be '../'. Again though, I'm not totally sure that it will work set up like this.

Re: [RC1] WP-United: WordPress Integration (v0.6.0 01/12/07)

Posted: Thu Feb 28, 2008 7:04 pm
by nerone
Hi guys, I have installed wp-united into phpbb 3 but in acp to the step 5 i receved white page and i can't configure the script.

I test in local with easyphp5 and I get this error:

fatal error. Call to a member add_rule() on a non-object in ......wp-includes\rewrite.php on line 9

Help me please