[ABD] phpBB3 Portal

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
dreadnort
Registered User
Posts: 4
Joined: Fri Sep 07, 2007 10:20 am

Re: [Beta] phpBB3 Portal

Post by dreadnort » Fri Sep 07, 2007 10:27 am

a little help

i have installed the portal and it works and have been able to configure it the way i want however
if i upload the.htaccess file i get an error due to my hosting companie's sever config they only allow certain entries in the htaccess file.

how do i get the portal to be the main page ?

User avatar
johnnyvang
Registered User
Posts: 10
Joined: Thu May 31, 2007 9:19 pm

Re: [Beta] phpBB3 Portal

Post by johnnyvang » Fri Sep 07, 2007 11:19 am

dreadnort wrote:a little help

i have installed the portal and it works and have been able to configure it the way i want however
if i upload the.htaccess file i get an error due to my hosting companie's sever config they only allow certain entries in the htaccess file.

how do i get the portal to be the main page ?
Got the same problem.
When i look into my old (rc3)forum the portal was the mainpage.
No with RC5 it isn't anymore.
I also need to know how i can set the portal page as the main start page of my (new) forum.

User avatar
johnnyvang
Registered User
Posts: 10
Joined: Thu May 31, 2007 9:19 pm

Re: [Beta] phpBB3 Portal

Post by johnnyvang » Sat Sep 08, 2007 1:11 am

I think i got the answer (found out myself).

dreadnort look if you have a .htaccess file on the server.
If so delete index.php from it.
Your file looks after that like this one:

Code: Select all

# $Id: .htaccess,v 1.2 2007/04/12 06:19:39 angelside Exp $
# .htaccess for phpBB3 Portal
DirectoryIndex bb3portal.php

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
Now the portal is your startup page and not the index.php.

dreadnort
Registered User
Posts: 4
Joined: Fri Sep 07, 2007 10:20 am

Re: [Beta] phpBB3 Portal

Post by dreadnort » Mon Sep 10, 2007 5:44 am

Nope that didnt work sems the only commands i'm allowed to use in the .htaccess file is mod rewrite this is a rule of the hosting compnay..

PaSsEr
Registered User
Posts: 77
Joined: Thu Jun 12, 2003 4:04 pm

Re: [Beta] phpBB3 Portal

Post by PaSsEr » Tue Sep 11, 2007 7:00 pm

hi, i have a few questions regarding phpBB3 Portal 1.1.0b

#1: There is some files/folders included with the package thats never stated in the mod install text file. do i need to upload them too? eg.files in roots/includes/acp

#2: I also saw alot of CVS folders with some files inside, do i need to upload those too?

#3: Can i install 1.1.0b without updating from 1.0.3b?

Thanks!

Insomniac'
Registered User
Posts: 51
Joined: Tue Sep 11, 2007 11:37 pm

Re: [Beta] phpBB3 Portal

Post by Insomniac' » Wed Sep 12, 2007 12:03 am

Just 2-3 ideas witch are really important for me :


- It'll be possible to integrate a download center in the portal et present the last 5 files we add ?

- It'll be possible to create news on the portal, independently of the forum ? A little post to explain one thing about a particular subject ?

- It'll be possible to add polls on the portal ?


Thanks a lot and keep going !

User avatar
eddywatson
Registered User
Posts: 220
Joined: Wed Aug 30, 2006 8:35 pm
Location: England
Contact:

Re: [Beta] phpBB3 Portal

Post by eddywatson » Wed Sep 12, 2007 10:42 am

hey all i have a problem...

my test board is http://www.eddy.lordlebrand.net/test

and I use Prosilver template however in the install text file it says

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#

styles/prosilver/template/overall_header.html

#
#-----[ FIND ]------------------------------------------
#

<a class="icon-home" href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ REPLACE WITH ]------------------------------------------
#

<a class="icon-home" href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ FIND ]------------------------------------------
#

		<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->

#
#-----[ AFTER, ADD ]------------------------------------------
#

		<!-- IF S_PORTAL_COPY --><br />{S_PORTAL_COPY}<!-- ENDIF -->
but NONE of the things it has to find even exist in my overall_header header file, whats going on?

ALSO... even though i DO NOT use Subsilver2 Template, do i still need to edit them files it asks to do for the Subsilver2 ?

ALSO... when you browse on portal and then onto the forum, things dont load and the background goes silver/gray, any ideas?

Thanks
Image
OTHockey Forums

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: [Beta] phpBB3 Portal

Post by Raimon » Wed Sep 12, 2007 10:46 am

PaSsEr wrote:hi, i have a few questions regarding phpBB3 Portal 1.1.0b

#1: There is some files/folders included with the package thats never stated in the mod install text file. do i need to upload them too? eg.files in roots/includes/acp
When i see the cvs, yes you must upload that also, its the acp modules for the portal.
PaSsEr wrote: #2: I also saw alot of CVS folders with some files inside, do i need to upload those too?
No you do not need that :)
PaSsEr wrote: #3: Can i install 1.1.0b without updating from 1.0.3b?

Thanks!
Yess :mrgreen:
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: [Beta] phpBB3 Portal

Post by Raimon » Wed Sep 12, 2007 10:50 am

@eddywatson
Try this:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#

styles/prosilver/template/overall_header.html

#
#-----[ FIND ]------------------------------------------
#

<li class="icon-home"><a href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ REPLACE WITH ]------------------------------------------
#
<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ FIND ]------------------------------------------
#
<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->

#
#-----[ AFTER, ADD ]------------------------------------------
#

<!-- IF S_PORTAL_COPY --><br />{S_PORTAL_COPY}<!-- ENDIF -->

eddywatson wrote: ALSO... when you browse on portal and then onto the forum, things dont load and the background goes silver/gray, any ideas?

Thanks
When i view your board everything its fine by me.
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

User avatar
eddywatson
Registered User
Posts: 220
Joined: Wed Aug 30, 2006 8:35 pm
Location: England
Contact:

Re: [Beta] phpBB3 Portal

Post by eddywatson » Wed Sep 12, 2007 10:56 am

Raimon wrote:@eddywatson
Try this:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#

styles/prosilver/template/overall_header.html

#
#-----[ FIND ]------------------------------------------
#

<li class="icon-home"><a href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ REPLACE WITH ]------------------------------------------
#
<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a>

#
#-----[ FIND ]------------------------------------------
#
<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->

#
#-----[ AFTER, ADD ]------------------------------------------
#

<!-- IF S_PORTAL_COPY --><br />{S_PORTAL_COPY}<!-- ENDIF -->

eddywatson wrote: ALSO... when you browse on portal and then onto the forum, things dont load and the background goes silver/gray, any ideas?

Thanks
When i view your board everything its fine by me.
hey thanks, the 1st edit works, but i cant find

Code: Select all

<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
in the same file
Image
OTHockey Forums

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: [Beta] phpBB3 Portal

Post by Raimon » Wed Sep 12, 2007 11:02 am

I see it, i was to quick ,
The code :

Code: Select all

<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
Must you not search in /styles/prosilver/template/overall_header.html but in the file /styles/prosilver/template/overall_footer.html
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

PaSsEr
Registered User
Posts: 77
Joined: Thu Jun 12, 2003 4:04 pm

Re: [Beta] phpBB3 Portal

Post by PaSsEr » Wed Sep 12, 2007 4:53 pm

Raimon wrote:
PaSsEr wrote:hi, i have a few questions regarding phpBB3 Portal 1.1.0b

#1: There is some files/folders included with the package thats never stated in the mod install text file. do i need to upload them too? eg.files in roots/includes/acp
When i see the cvs, yes you must upload that also, its the acp modules for the portal.
PaSsEr wrote: #2: I also saw alot of CVS folders with some files inside, do i need to upload those too?
No you do not need that :)
PaSsEr wrote: #3: Can i install 1.1.0b without updating from 1.0.3b?

Thanks!
Yess :mrgreen:
For some reasons..i just can't get 1.1.0b to work properly for me.. seems to be getting some debug errors messages on top and i somehow can't get to the acp too. But 1.0.3b is working fine for me now.. so i guess i'll just stick to it first. Anyway thanks for clearing my doubts! :)

User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [Beta] phpBB3 Portal

Post by Tripp » Wed Sep 12, 2007 5:01 pm

I installed it and have been editing it and I love it. I only hasve one slight problem:

http://i1.tinypic.com/5x3jwww.jpg

Something messed up on the Who Is Online block. The borders won't come up all the way around it and when my mouse goes over it, it underlines with that color.

So I remove the block completely and then it moved the problem to the next block which is the leaders block. When I put the online block back, the problem goes back to it.

Any ideas?
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs

User avatar
eddywatson
Registered User
Posts: 220
Joined: Wed Aug 30, 2006 8:35 pm
Location: England
Contact:

Re: [Beta] phpBB3 Portal

Post by eddywatson » Wed Sep 12, 2007 6:54 pm

Raimon wrote:I see it, i was to quick ,
The code :

Code: Select all

<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
Must you not search in /styles/prosilver/template/overall_header.html but in the file /styles/prosilver/template/overall_footer.html
hey thanks buddy!

hm i now have a new problem like i said before when using IE if you click on portal then board index then portal again, the page goes all gray, any ideas for a fix?

Also i have not looked yet but... how do you change/edit/delete some of the feilds in the portal page? ie to get rid of the portal download links and the feilds there are there for tests/examples? THE SAMPLE BLOCK I MEAN. plus all the portal related stuff?

Thanks
Image
OTHockey Forums

User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [Beta] phpBB3 Portal

Post by Tripp » Wed Sep 12, 2007 7:06 pm

/public_html/forums/styles/Arrow/template/bb3portal

portal_main.php

Just remove the thing that loads them.
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs

Locked

Return to “[3.0.x] Abandoned MODs”