Page 2 of 42

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Fri May 25, 2007 7:03 pm
by G.I. Suck
Well, now that the error is gone, I have to figure out why this is happening:

Sorry, but syndication has been disabled for this forum or you do not have sufficent permissions

Forum has syndication enabled, also enabled on the site, but still running into this error. Although, selecting multiple forums does not generate this error, I just don't get anything outputted.

Recommend that there is a warning in the feed if it can't generate the forum by permission rule. But I still need help as to Why I don't have access :|

--REVISED:

Looks like I can get the feed to show up if I select mulitple entries, and make the forum number the last entry in the list. If it's any other entry, it doesn't show

This works:
generate_feed.php?content=topics&f=10,14
generate_feed.php?content=topics&f=1,10,14
This doesn't:
generate_feed.php?content=topics&f=14,10
generate_feed.php?content=topics&f=1,14,10
generate_feed.php?content=topics&f=14,1,10

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Fri May 25, 2007 7:27 pm
by G.I. Suck
I've done some troubleshooting so far:

Selecting a single item generates an error message
Selecting multiple feeds will only generate a feed for the very last forum number posted on the url.

I think I broke it... :(

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Fri May 25, 2007 7:28 pm
by G.I. Suck
I've done some troubleshooting so far:

Selecting a single item generates an error message
Selecting multiple feeds will only generate a feed for the very last forum number posted on the url.

I think I broke it... :(

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Fri May 25, 2007 7:29 pm
by G.I. Suck
I've done some troubleshooting so far:

Selecting a single item generates an error message
Selecting multiple feeds will only generate a feed for the very last forum number posted on the url. All the forums will not generate data.

I think I broke it... :(

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Sat May 26, 2007 11:27 pm
by rhstrack
I have a question about displaying the feed.
I have to be logged in to be able to see the rss feed.

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Sun May 27, 2007 11:36 am
by GalaKev
Solved my problem. Thanks

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Sun May 27, 2007 6:01 pm
by Highstreet
Great modification! I believe that there is a small typo in the full_syndication_suite.xml:

In the first edit-instruction in adm/style/acp_forums.html, Find-section: the last <dl> should be removed. Or am I wrong?

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Mon May 28, 2007 2:25 am
by musikgoat
G.I. Suck wrote:Well, now that the error is gone, I have to figure out why this is happening:

Sorry, but syndication has been disabled for this forum or you do not have sufficent permissions

Forum has syndication enabled, also enabled on the site, but still running into this error. Although, selecting multiple forums does not generate this error, I just don't get anything outputted.

Recommend that there is a warning in the feed if it can't generate the forum by permission rule. But I still need help as to Why I don't have access :|

--REVISED:

Looks like I can get the feed to show up if I select mulitple entries, and make the forum number the last entry in the list. If it's any other entry, it doesn't show
I am seeing the same issues. In the custom rss page, It seems that if one only wants a single forum, they would have to select that forum and the category above it.

Great mod though. One troublesome part is the lack of documentation on the settings for the acp and ucp. It was only guess work to find that the # of items for syndication is located in the load settings area of the panel...

Also, what is your intent for making a subsilver template? prosilver is quite bulky, subsilver seems to be popular on the live boards, and that is where it would be nice to implement the syndication mod.

Thanks.

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Mon May 28, 2007 12:22 pm
by Schumi
Highstreet wrote:I believe that there is a small typo in the full_syndication_suite.xml
You're right, thanks.
rhstrack wrote:I have to be logged in to be able to see the rss feed.
You only have to be logged in if the forums permission require it. If you are not logged in, the feed thinks you are a guest and if the forum has no read access for guests set up, you are required to log in.
musikgoat wrote:Sorry, but syndication has been disabled for this forum or you do not have sufficent permissions
I hope to have that error fixed in the next version which should be available soon.
Great mod though. One troublesome part is the lack of documentation on the settings for the acp and ucp. It was only guess work to find that the # of items for syndication is located in the load settings area of the panel...
I may add some kind of "Quickstart Guide" to explain the basic features. But that probably has to wait a bit in favour of other issues...
Also, what is your intent for making a subsilver template?
That's also on my list for the next version ;).

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Mon May 28, 2007 1:40 pm
by G.I. Suck
Hi Schumi,

As previously stated, when selecting multiple forums for feeding, only the bottommost forum in the list is in the custom feed, none of the others.

I can lend you access to my board to show you as an example if you wish, as it isn't live yet.

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Mon May 28, 2007 1:56 pm
by Schumi
Hm, I couldn't reproduce that. I suggest you try updating to version 0.9.4 first (will be released today) and see if the problem persists, as there are a few changes in the handling of forum_ids and especially categories. If it still goes wrong, we dig further into it :).

Re: [BETA] Full Syndication Suite 0.9.3b (RSS/ATOM)

Posted: Mon May 28, 2007 2:15 pm
by Schumi
New version: 0.9.4

Changelog:
  • Don't cache session ids.
  • Fixed wrong display of feeds on index.php.
  • Optimised way forum ids are handled.
  • New feature to syndicate own private messages.
  • Fixed SQL error caused by mixed up function call.
  • Fixed wrong iteration through forum_ids in case of missing permissions.
  • Added proper support for handling categories, implies various bugfixes.
  • Added instructions for subsilver2.
Download: http://www.filepub.com/public/8404/full ... -0.9.4.zip

How to update: Those who installed version 0.9.3b are able to update. The necessary steps can be found in contrib/update_0.9.3b-0.9.4.xml. To update your prosilver template, follow the instructions in contrib/templates/prosilver_update_0.9.3b-0.9.4.xml.

I hope everything went right and all files are up to date, it's not that easy to manage all those different installation files in MODX :|.

Re: [BETA] Full Syndication Suite 0.9.4 (RSS/ATOM)

Posted: Mon May 28, 2007 2:45 pm
by G.I. Suck
Stuck with:

Sorry, but syndication has been disabled for this forum or you do not have sufficent permissions.

after completing the upgrade.

You only need to enable syndication in two places correct? Board Settings, and the Forum Settings.

I have them both on, but I don't have access now. :(

Re: [BETA] Full Syndication Suite 0.9.4 (RSS/ATOM)

Posted: Mon May 28, 2007 2:59 pm
by Schumi
G.I. Suck wrote:You only need to enable syndication in two places correct? Board Settings, and the Forum Settings.
Load Settings and Forum Settings, yes. The former is not the problem, the error message would be different in this case.
Could you send me a link to your board so that I can take a look at it?

Edit:
You also have to enable permissions in your permission roles/user's permission. This is done by sql_install.php during installation, but you may check if it was successful. Take a look at Permissions -> Forum permissions -> Select a forum and user -> Advanced Permissions -> Misc -> Can use syndication.

Re: [BETA] Full Syndication Suite 0.9.4 (RSS/ATOM)

Posted: Mon May 28, 2007 3:16 pm
by G.I. Suck
Schumi wrote:
G.I. Suck wrote:You only need to enable syndication in two places correct? Board Settings, and the Forum Settings.
You also have to enable permissions in your permission roles/user's permission. This is done by sql_install.php during installation, but you may check if it was successful. Take a look at Permissions -> Forum permissions -> Select a forum and user -> Advanced Permissions -> Misc -> Can use syndication.
That seems to be the problem. I do not have "Can use syndication" in the Misc area, yet running sql_install.php resulted in OKs.

Edited

Oh! Never mind! Found it under Content, not Misc. It's all good now! :D