[ABD] phpBB Garage 2.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

JunglistPerfection -> One of your queries was you could not add a second car to your garage profile. There is a quota system in phpBB Garage that lets you control on a group by group level the number of the following items
  • Vehicles
  • Remote Images
  • Uploaded Images
The default is 1 vehicle and 5 images of each type. This is easy to change or to just grant administrators more. Head into the ACP and to the garage management section. There should be a quota module you can either adjust the default quota to allow more vehicles or enable the group quota for administrators and set them to higher levels. The highest quota wins. If you are in group a that has 5 and group b that has 10 you get 10. Although this may change in the next beta to your default group is the quota you get. I have not fully decided on that item yet :geek:

Hope that helps with that one issue. The others I will await your post on.
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

I get this error when I try to upload a image through url

Here:

Code: Select all

SQL ERROR [ mysql4 ]

Column 'attach_filesize' cannot be null [1048]

SQL

INSERT INTO phpbb_garage_images (vehicle_id, attach_location, attach_hits, attach_ext, attach_file, attach_thumb_location, attach_thumb_width, attach_thumb_height, attach_is_image, attach_date, attach_filesize, attach_thumb_filesize) VALUES ('2', 'http://www.autocult.com.au/img/gallery/RevNews371.jpg', '0', '.jpg', 'RevNews371.jpg', 'garage_vehicle-2-1180462618_thumb.jpg', 150, 100, '1', 1180462620, NULL, 4218)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 133
CALL: dbal_mysql->sql_error()

FILE: includes/mods/class_garage_image.php
LINE: 683
CALL: dbal_mysql->sql_query()

FILE: includes/mods/class_garage_image.php
LINE: 533
CALL: garage_image->insert_image()

FILE: garage_vehicle.php
LINE: 552
CALL: garage_image->process_image_attached()
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

OK.. Can you provide FTP access (via PM) and I will try solve it.

Did my post on quotas help you?
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

Yes, I did place the quotas for each group I had.
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

Sorry does that mean it fixed you problem or that quotas were setup and they did not work?
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

The quotas works, but I just have a problem uploading a image through url or from computer.
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

OK.. So I know the quota works thanks. I have stated in my previous post the quickest way to solve the other issue would be FTP access. If this is OK PM the details. If not let me know and we can try debug over the forum but will take longer.
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

I want to try it over the forum. 8-)
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

Ah think I found bug..it should only relate to remote images.

FIND in ./includes/mods/class_garage_image.php

Code: Select all

		//Remove Our Temporary File As We No Longer Need It..
		@unlink($phpbb_root_path . GARAGE_UPLOAD_PATH . $data['tmp_name']);
AFTER ADD

Code: Select all

		//Set filesize to 0 since its remote
		$data['filesize'] = '0'; 
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

I'll give it a try. :)
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

It works perfect, thanks.

Should the image be shown as a thumbnail though out the browsing pages of the vehicle? Because from looking at the images settings everything is set to yes, to show a thumbnail. No thumbnail showing up in none of the vehicles I placed in my garage.

When you click on one of your cars you created, it seems that the buttons are in the way of the text that suppose to display the stats of the car. The text is all the way to the right and jumbled up. Just to let you know.
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

Can you please give me the URL to your site. I want to register and try myself. Also I already stated the text is messed up as prosilver is still a work in progress. That particular bug was fixed yesterday on my development site.
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

Thanks for the PM. OK can you check the web server permissions to the folder? Seems we are unable to directly access the files. These two files below should both exist. Can you check that? Seems to me like it is mostly likely web server not allowing access to them.

http://xxxxx.com/forum/garage/upload/ga ... 613833.jpg
http://xxxxx.com/forum/garage/upload/ga ... _thumb.jpg
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: [BETA] phpBB Garage 2.0

Post by JunglistPerfection »

All images within the upload folder is already set to 777 and also the folder is set to 777. Or should the folder be set to 755?
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

It should be 777 for upload. However as far as I know that does not 100% mean the webserver can access those pages.Example of a correctly configured webserver will allow direct access to the files, see below.

http://www.phpbbgarage.com/phpBB3/garag ... 859996.jpg
http://www.phpbbgarage.com/phpBB3/garag ... _thumb.jpg

However for your site the files I linked (minus the actual domain as I think you do not want it public) to get the following error. Note its not a 404 not found...but a 403 forbidden. Have a talk with your webhost ... as this is permissions related

Code: Select all

Error 403 - Forbidden

You tried to access a document for which you don't have privileges.
Have a try replacing the xxxxx with the real domain and you will see what I mean. So sorry but I can not help on this. If you get that fixed and it still fails let me know.
Locked

Return to “[3.0.x] Abandoned MODs”