[ABD] phpBB Garage 2.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
streetmachine
Registered User
Posts: 27
Joined: Mon Jul 09, 2007 7:15 pm

Re: [BETA] phpBB Garage 2.0

Post by streetmachine »

Looks like this mod has died... its a real shame too as it was going to be the best one out there for car clubs that run on phpbb3... :cry:
Sisem
Registered User
Posts: 121
Joined: Fri May 25, 2007 11:52 am

Re: [BETA] phpBB Garage 2.0

Post by Sisem »

It's not died, it's just that Esmond has gone awol for 5 weeks. He has been posting on this forum much more recently tho. So looks like something has gone off with him preventing any work on the mod.

Believe me, I'm waiting for this to be released too...

Nick
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

HI guys & girls,

Sorry my time is just so tight at the moment dev work has crawled to a stop. My biggest issue is from here on in a lot of stuff is CSS related and I am terrible at it.

However I am currently negoiating with a site that needs custom work done but has a great CSS person. They needed a download MOD and as such I am making one for them. This has taken a bit longer than I thought as I have redone the $auth system to allow mutiple local auths :geek:

Anyways the plan is to have the CSS person start some work for me in a week or so. I hope then to be able to get going again.

Keep the faith, I know its tough, you all want it finished, but with a one man band things take time. Plus my wife had the rudeness to go and get pregnant!! Pregnant people = not so much time coding.

Esmond
nvsmithers
Registered User
Posts: 18
Joined: Tue Apr 01, 2008 12:42 am

Re: [BETA] phpBB Garage 2.0

Post by nvsmithers »

I had Garage version 2.0 running on phpbb3 for a few weeks now. I had a db issue and had to go back to a previous version of my database. I attempted to install garage again and have previous entries in my db thats causing the script to show the error below when trying to install. How can I work around this or what do I need to remove from my db so I can start over again? Do I need to remove all entries from the phpbb_acl_roles_data key? I also remember invoking a converter from my 1.0 garage db as well but cant find it now. Is that part of the installer? Thanks in advance for helping the dummy. :roll:

SQL ERROR [ mysql4 ]

Duplicate entry '1-161' for key 1 [1062]

SQL

INSERT INTO phpbb_acl_roles_data (role_id, auth_option_id, auth_setting) VALUES (1, 161, 1), (1, 162, 1), (1, 163, 1), (1, 164, 1), (1, 165, 1), (1, 166, 1), (1, 160, 1), (1, 167, 1), (1, 168, 1), (1, 159, 1)

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/db/dbal.php
LINE: 429
CALL: dbal_mysql->sql_query()

FILE: includes/mods/functions_garage_install.php
LINE: 51
CALL: dbal_mysql->sql_multi_insert()

FILE: garage/install/install_install.php
LINE: 1449
CALL: acl_update_role()

FILE: garage/install/install_install.php
LINE: 108
CALL: install_install->update_role_permissions()

FILE: garage/install/index.php
LINE: 317
CALL: install_install->main()

FILE: garage/install/index.php
LINE: 189
CALL: module->load()
User avatar
poyntesm
Registered User
Posts: 1671
Joined: Tue Jan 18, 2005 11:19 am
Location: Dublin, Ireland
Contact:

Re: [BETA] phpBB Garage 2.0

Post by poyntesm »

Was the DB issue related to phpBBGarage? Do you now want to fully remove all phpBBGarage DB additions (inculding vehicles etc...)?

If you are happy to remove all entries and then convert again I can send you a remover module.
nvsmithers
Registered User
Posts: 18
Joined: Tue Apr 01, 2008 12:42 am

Re: [BETA] phpBB Garage 2.0

Post by nvsmithers »

poyntesm wrote:Was the DB issue related to phpBBGarage? Do you now want to fully remove all phpBBGarage DB additions (inculding vehicles etc...)?

If you are happy to remove all entries and then convert again I can send you a remover module.

That would do the trick. Thanks!
JayWee
Registered User
Posts: 34
Joined: Wed Mar 09, 2005 7:04 pm

Re: [BETA] phpBB Garage 2.0

Post by JayWee »

Great mod, looks like it has a fair amount of features and whatnot. Very easy to install.

Couple issues though.

1st issue being that when you input the mileage for your vehicle as, lets say 70,000 miles, it truncates the 0's after the comma, so it displays as 70 Miles in the profile.

Also, when viewing a persons garage, or vehicle profile, the "User Control Panel" link takes you to your own profile, not your control panel.

Also, this may be my own error or oversight, but in the AdminCP, is the tab supposed to be named .MOD, and the second and third entries be labeled DEFAULT_MAKE and DEFAULT_MODEL or did I mess up a language file somewhere?

Thanks,
Jay
tffnguy
Registered User
Posts: 473
Joined: Mon Aug 18, 2003 10:55 am
Contact:

Re: [BETA] phpBB Garage 2.0

Post by tffnguy »

I believe I've more or less solved the dilemma of not having the Garage Mod to use on my site. I did that by creating a forum called Member's Garage and also a sub forum called Member's Garage BLOG I have permissions set to where members can start a new thread in the Member's Garage forum to post their Garage message, but no one can reply to it. I have to start a thread for that message in the member's Garage BLOG forum where members can discuss their car. Once I do that I place a link to the Member's Garage Message in it and also a link to the Member's Garage BLOG message in the Member's Garage message. I posted a template in the code format for members to cut, paste and fill out in their Garage message. On my main site I have a PHP app embedded in the index file that rotates images from the Member's Garage messages with a link to that forum. The Garage MOD it isn't, but at least it works something like it and my members and I can use it now. Also there isn't any worry about upgrading MODs when the forum software has to be upgrades. I've already waited too long for this MOD to be finished and will keep what I have. Hopefully I'll be able to find an app sooner or later that will allow people clicking on the random images on the main site to be sent to the Garage message for that particular car. For now it works for me though.

If you have a main site with forums in it this might work for you while you're waiting on this MOD to get finished? (If ever)
Some people question my sanity because of the way I run my site. I question my sanity because I do run it.
-David T. Smith-

The Ford Falcon News
Living Off Grid in Terlingua Texas
scottybt
Registered User
Posts: 130
Joined: Sun May 11, 2008 5:39 pm

Re: [BETA] phpBB Garage 2.0

Post by scottybt »

I've got quite a problem when I tried to install this mod and it went bad. Without a backup

http://www.phpbb.com/community/viewtopi ... 6&t=950285

Edit: Reinstalled forum don't need help anymore
windstar1
Registered User
Posts: 27
Joined: Fri Jun 15, 2007 6:03 pm

Re: [BETA] phpBB Garage 2.0

Post by windstar1 »

tffnguy wrote:I just tried to add a comment to my car's blog and got the following error.
General Error wrote: SQL ERROR [ mysql4 ]

Unknown column 'bbcode_flags' in 'field list' [1054]

SQL

INSERT INTO phpbb_garage_blog (vehicle_id, user_id, blog_title, blog_text, blog_date, bbcode_bitfield, bbcode_uid, bbcode_flags) VALUES ('2', '2', 'My Blog', 'You guys can start your own Blog, but it won't get started unless you start it.', 1202440814, '', '', 7)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/mods/class_garage_blog.php
LINE: 47
CALL: dbal_mysql->sql_query()

FILE: garage_blog.php
LINE: 108
CALL: garage_blog->insert_blog()
Still have the same problem, any ideas how to solve it?
henningl
Registered User
Posts: 78
Joined: Tue Aug 17, 2004 7:19 pm

Re: [BETA] phpBB Garage 2.0

Post by henningl »

Yeah, use phpmyadmin or any other db admin tool, and in the table phpbb_garage_blog rename the column 'bbcode_options' (not 100% sure on the name) to 'bbcode_flags', set the column nullable and default value "NULL".

If you are unsure, you can compare your existing table definition with the one in the schema-file in garage/install/schemas/
windstar1
Registered User
Posts: 27
Joined: Fri Jun 15, 2007 6:03 pm

Re: [BETA] phpBB Garage 2.0

Post by windstar1 »

henningl wrote:Yeah, use phpmyadmin or any other db admin tool, and in the table phpbb_garage_blog rename the column 'bbcode_options' (not 100% sure on the name) to 'bbcode_flags', set the column nullable and default value "NULL".

If you are unsure, you can compare your existing table definition with the one in the schema-file in garage/install/schemas/
If i do so the blog will work but i can't delete the car anymore. :roll:
If i try to delte my vehicle i get a blank page and the vehiocle is not deleted
If i trty to make a blank entry in the blog i get the SQL error:

Code: Select all

SQL ERROR [ mysqli ]

Incorrect integer value: '' for column 'bbcode_flags' at row 1 [1366]

SQL

INSERT INTO phpbb_garage_blog (vehicle_id, user_id, blog_title, blog_text, blog_date, bbcode_bitfield, bbcode_uid, bbcode_flags) VALUES ('2', '2', '', '', 1211732064, '', '', '')

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/mods/class_garage_blog.php
LINE: 47
CALL: dbal_mysqli->sql_query()

FILE: garage_blog.php
LINE: 108
CALL: garage_blog->insert_blog()
Grinch
Registered User
Posts: 400
Joined: Mon Apr 22, 2002 5:44 pm
Location: Toronto, Canada

Re: [BETA] phpBB Garage 2.0

Post by Grinch »

Just an FYI, the link to your Demo Site is wrong.

http://forumsphpbbgarage.com/garage.php

but it should be:

http://forums.phpbbgarage.com/garage.php


It's leading to some other website with pop-up adds.
Ford_Warrior
Registered User
Posts: 35
Joined: Thu Feb 14, 2008 1:52 pm

Re: [BETA] phpBB Garage 2.0

Post by Ford_Warrior »

During the installation it is asking me:

Modified files
The following files are modified and do not represent the original files from the old version. The updated file will be a merge between your modifications and the new file.

common.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] viewonline.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] viewtopic.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] includes/
functions_user.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] includes/
session.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] includes/acp/
acp_language.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] includes/acp/
acp_styles.php Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] styles/prosilver/template/
viewtopic_body.html Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file] styles/prosilver/template/
overall_header.html Merge modifications [ Show merged differences ] Do not merge - use new file [Show resulting file] Do not merge - use currently installed file [Show resulting file]

Then:

Conflict files
memberlist.php
Number of conflicts: 2 [ Show differences/conflicts ] Do not merge - use new file [Show resulting file] Merge differences and use new file code within conflicting block [Show resulting file] Merge differences and use modified code within conflicting block [Show resulting file] adm/
index.php
Number of conflicts: 1 [ Show differences/conflicts ] Do not merge - use new file [Show resulting file] Merge differences and use new file code within conflicting block [Show resulting file] Merge differences and use modified code within conflicting block [Show resulting file] includes/
functions.php
Number of conflicts: 5 [ Show differences/conflicts ] Do not merge - use new file [Show resulting file] Merge differences and use new file code within conflicting block [Show resulting file] Merge differences and use modified code within conflicting block [Show resulting file]

I have tried uploading the modified files which it downloads for me, but then the forum is all messed up. So what do I do with this step?
scottybt
Registered User
Posts: 130
Joined: Sun May 11, 2008 5:39 pm

Re: [BETA] phpBB Garage 2.0

Post by scottybt »

I've now downloaded this mod again and reinstalled it. This time on my test forum, with backup aswell.
If I go into the index file of the forum, I get a blank page. And if I go into /garage/install/ I also get a blank page.

Does anyone have a solution before I do the whole thing again and proberbly get the same fault?
Locked

Return to “[3.0.x] Abandoned MODs”