[ABD] phpBB Garage 2.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
n00bstorm
Registered User
Posts: 481
Joined: Sun Jan 30, 2005 7:52 pm

Re: [BETA] phpBB Garage 2.0

Post by n00bstorm »

And now even when I try to look at my Legend :: Administrators, Global moderators I get this error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'u.user_id' in 'on clause' [1054]

SQL

SELECT u.user_id, v.id as vid FROM phpbb_users u , phpbb_user_group ug LEFT JOIN phpbb_garage_vehicles v ON ( v.user_id = u.user_id AND v.main_vehicle = 1 ) WHERE u.user_type IN (0, 3) AND ug.user_pending = 0 AND u.user_id = ug.user_id AND ug.group_id = 5 ORDER BY ug.group_leader DESC, u.user_regdate ASC LIMIT 25

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: memberlist.php
LINE: 1383
CALL: dbal->sql_query_limit()
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

same error i am getting. very strange. not sure what is causing this.
n00bstorm wrote:And now even when I try to look at my Legend :: Administrators, Global moderators I get this error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'u.user_id' in 'on clause' [1054]

SQL

SELECT u.user_id, v.id as vid FROM phpbb_users u , phpbb_user_group ug LEFT JOIN phpbb_garage_vehicles v ON ( v.user_id = u.user_id AND v.main_vehicle = 1 ) WHERE u.user_type IN (0, 3) AND ug.user_pending = 0 AND u.user_id = ug.user_id AND ug.group_id = 5 ORDER BY ug.group_leader DESC, u.user_regdate ASC LIMIT 25

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: memberlist.php
LINE: 1383
CALL: dbal->sql_query_limit()
www.thejdm.com ...turn it on, y0
n00bstorm
Registered User
Posts: 481
Joined: Sun Jan 30, 2005 7:52 pm

Re: [BETA] phpBB Garage 2.0

Post by n00bstorm »

This is a great mod, I sure hope its not abandoned!
:|
User avatar
matt1206
Registered User
Posts: 213
Joined: Wed Mar 08, 2006 3:04 pm
Location: Sheffield, UK
Name: Matt Worthington

Re: [BETA] phpBB Garage 2.0

Post by matt1206 »

thejdm wrote:same error i am getting. very strange. not sure what is causing this.
n00bstorm wrote:And now even when I try to look at my Legend :: Administrators, Global moderators I get this error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'u.user_id' in 'on clause' [1054]

SQL

SELECT u.user_id, v.id as vid FROM phpbb_users u , phpbb_user_group ug LEFT JOIN phpbb_garage_vehicles v ON ( v.user_id = u.user_id AND v.main_vehicle = 1 ) WHERE u.user_type IN (0, 3) AND ug.user_pending = 0 AND u.user_id = ug.user_id AND ug.group_id = 5 ORDER BY ug.group_leader DESC, u.user_regdate ASC LIMIT 25

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: memberlist.php
LINE: 1383
CALL: dbal->sql_query_limit()
I fixed this by removing a code change added when installing the garage. Affected file is memberlist.php

Code: Select all

// Get us some users :D
                $sql = "SELECT u.user_id, v.id as vid
                        FROM " . USERS_TABLE . " u
                                $sql_from
                        LEFT JOIN " . GARAGE_VEHICLES_TABLE . " v
                                ON (
                                        v.user_id = u.user_id AND v.main_vehicle = 1
                                )
                        WHERE u.user_type IN (" . USER_NORMAL . ', ' . USER_FOUNDER . ")
                                $sql_where
                        ORDER BY $order_by";
                $result = $db->sql_query_limit($sql, $config['topics_per_page'], $start);
 
Change this back to the original code

Code: Select all

// Get us some users :D
                $sql = "SELECT u.user_id
                        FROM " . USERS_TABLE . " u
                                $sql_from
                        WHERE u.user_type IN (" . USER_NORMAL . ', ' . USER_FOUNDER . ")
                                $sql_where
                        ORDER BY $order_by";
                $result = $db->sql_query_limit($sql, $config['topics_per_page'], $start);
 
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

fantastic, have you found a problem with the garage at all since removing that code?

i switched mine and its been working, nice find. any clue what code was in there for in the first place?
www.thejdm.com ...turn it on, y0
User avatar
matt1206
Registered User
Posts: 213
Joined: Wed Mar 08, 2006 3:04 pm
Location: Sheffield, UK
Name: Matt Worthington

Re: [BETA] phpBB Garage 2.0

Post by matt1206 »

thejdm wrote:fantastic, have you found a problem with the garage at all since removing that code?

i switched mine and its been working, nice find. any clue what code was in there for in the first place?
Nope, no problems since removing the code. I'm guessing it was there to link the Vehicle to the username when viewing the memberlist.

I've been running the garage live for 2 months now, and apart from having to remove all code relating to the rating system, and adding a fix for the validation check when adding a product, it's been fine.
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

matt, maybe you could help me with this one, or anyone can take a stab at this.

in the garage_profile_integration.php file...
i changed the look of my integration but im having a problem with the {HILITE_IMAGE} part of the code.

i added a highslide image code to my garage and im using this code for my hilite image in the garage:

Code: Select all

<a href="{U_HILITE_IMAGE}" title="{HILITE_IMAGE_TITLE}" rel="highslide" onclick="return hs.expand(this)"><img src="{HILITE_IMAGE}" alt="{}" /></a><br /><span class="gensmall">{L_TOTAL_VIEWS}: {TOTAL_IMAGE_VIEWS}</span>
now my problem is in that code it pulls the {HILITE_IMAGE} code from the img src. i only want the hilite image to show in the profiles but im having a problem with that.

here is what im talking about, for example my profile on my website i have 1 image posted and it shows like this: http://thejdm.com/memberlist.php?mode=viewprofile&u=3

and now a buddy of mine who has more then 1 image posted his shows like this: http://thejdm.com/memberlist.php?mode=v ... ile&u=1624

i only want 1 images to show, the main hilite image (like in my profile) BUT i want my users to be able to have more then 1 image aloud obviously. it just really breaks & expands the profile. i don't really need to show off the modification images in the profile. just the main hilite image so the other users can take a gander @ the car. also once clicked the image opens in a new window and im trying to get the highslide to work there but once again that goes back to the {HILITE_IMAGE} code.

make sense?
www.thejdm.com ...turn it on, y0
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

thejdm wrote:under the 'shop/garage reviews' tab. my tables are not spaced they are all jammed together, would like some separation to be able to tell the shops apart more clearly. i can attach a screenshot if need be.

Image

as you can see in the image, the 2 tables are run together.

in the garage_view_shop_business.html file its something to do with this area of code

Code: Select all

			<span class="corners-bottom"><span></span></span>
		</div>
		<!-- END business_row -->
	</div>

	<div class="panel">
		<div class="inner">
			<span class="corners-top"><span></span></span>
			<!-- IF PAGINATION or TOTAL_BUSINESS -->
bumping this as well. been playing with this for hours, cannot figure this 1 out.
www.thejdm.com ...turn it on, y0
User avatar
williams-jr
Registered User
Posts: 147
Joined: Thu Jun 01, 2006 1:06 am

Re: [BETA] phpBB Garage 2.0

Post by williams-jr »

This might of already been answered so sorry if it has.

But i currently have phpbb2 running the old garage mod and it is VERY full with users info - is there a way to import this info into the phpbb3 version of garage mod, if so how?

Many thanks
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

dont want this mod to die. bumping this back up.
thejdm wrote:
thejdm wrote:under the 'shop/garage reviews' tab. my tables are not spaced they are all jammed together, would like some separation to be able to tell the shops apart more clearly. i can attach a screenshot if need be.

Image

as you can see in the image, the 2 tables are run together.

in the garage_view_shop_business.html file its something to do with this area of code

Code: Select all

			<span class="corners-bottom"><span></span></span>
		</div>
		<!-- END business_row -->
	</div>

	<div class="panel">
		<div class="inner">
			<span class="corners-top"><span></span></span>
			<!-- IF PAGINATION or TOTAL_BUSINESS -->
bumping this as well. been playing with this for hours, cannot figure this 1 out.
www.thejdm.com ...turn it on, y0
RooMeat
Registered User
Posts: 204
Joined: Sat Jun 24, 2006 10:39 pm
Contact:

Re: [BETA] phpBB Garage 2.0

Post by RooMeat »

This mod died a long long time ago lol :cry:
The mod author hasn't visited in ages and his own site is now full of spammers. I wish someone else had the courage / knowledge to take it on and finish it.
Live site: http://www.ozsportsbikes.com (Converted from Nuked phpbb2 to stand alone phpBB3)
Test site: http://www.ozsuperbikes.com
Local Test site with XAMPP
User avatar
thejdm
Registered User
Posts: 438
Joined: Sun Dec 21, 2003 4:18 pm
Location: pennsylvania
Contact:

Re: [BETA] phpBB Garage 2.0

Post by thejdm »

it was a group effort to keep the mod alive. a few posts back a few of the guys/gals were sharing info back and forth of some bugs/fixes and whatnot.

just trying to get the mod some more attention. someone might eventually start playing with it again.
www.thejdm.com ...turn it on, y0
youngjediknight
Registered User
Posts: 385
Joined: Wed Apr 22, 2009 2:58 pm

Re: [BETA] phpBB Garage 2.0

Post by youngjediknight »

Too bad this mod went by the wayside ... I'm surprised it hasn't already been ABD'ed.
User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [BETA] phpBB Garage 2.0

Post by ChriZathens »

poyntesm WILL be back... and he's completely capable of creating a final bug free version in very short time.
It just that - I guess - real life has got in his way for now...
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...
kmxak
Registered User
Posts: 21
Joined: Tue May 05, 2009 6:48 pm

Re: [BETA] phpBB Garage 2.0

Post by kmxak »

i get an error when i click on blog or pictures in the garage.

error: Allgemeiner Fehler
template->_tpl_load(): No file specified for handle body

but the site is correctly displayed for a very short time.

can anybody help me?
Locked

Return to “[3.0.x] Abandoned MODs”