[ABD] Attendance Mod (0.2.7)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
BFCUnion
Registered User
Posts: 10
Joined: Tue Feb 02, 2010 9:41 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by BFCUnion » Thu Feb 04, 2010 8:50 am

Not sure what just happened, the whole site died, restoring backup.
Be good and be good at it otherwise buy a pram.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by wired076 » Thu Feb 04, 2010 11:08 am

NetizenKane wrote:@wired: I'll check the modifications of the mod this evening (Germany). Besides, you got mail.

Because I wasn't here at phpbb.com for a while I don't know anything about AutoMod (but I will, I promise). It seems to me that AutoMod makes own installation routines obsolete. Is that right?
Hey I have replied to my mail. Thanks.

Automod is a way to install mods automatically without requiring much input from the user to install. I think that Automod still has a long way to go before it sees widespread use but we definitely need to make a priority to make this mod automod compatible and have all SQL modifications to be completed in an install.php file that can complete upgrades and installs to this mod.

Anyhow I will discuss this further with you via pm for now.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by wired076 » Thu Feb 04, 2010 11:10 am

BFCUnion wrote:Not sure what just happened, the whole site died, restoring backup.
hmm.

Do you know what the error message was?

What were you doing just before the site crashed?

Please let us know what happens when you restore the backup and try again.

We need to find out why your site just crashed and resolve it if it is in any way due to this mod.

User avatar
BFCUnion
Registered User
Posts: 10
Joined: Tue Feb 02, 2010 9:41 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by BFCUnion » Sat Feb 06, 2010 7:35 am

Sorry , loading the main page didn't complete, had an SQL error. then nothing.
I will take screen shots in future. Still learning the hard way.

Last night i transferred all the FTP and this forum to my server, I'll remote into that in case it was "Children interference".

Restored the backup, but i won't be able to reinstall the mod till tomorrow morning when i will have time to concentrate. 6:35 pm now.
Be good and be good at it otherwise buy a pram.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by wired076 » Sat Feb 06, 2010 10:02 am

BFCUnion wrote:Sorry , loading the main page didn't complete, had an SQL error. then nothing.
I will take screen shots in future. Still learning the hard way.

Last night i transferred all the FTP and this forum to my server, I'll remote into that in case it was "Children interference".

Restored the backup, but i won't be able to reinstall the mod till tomorrow morning when i will have time to concentrate. 6:35 pm now.
I have just installed the mod on another site without any issues. (Steps I undertook, copied all files from root directory across to phpBB site, modified files accordingly, ran install_am/install.php and then ran the SQL statements provided in the top of the install_mod.xml file).

Did you also via phpmyadmin(or other means) make the necessary SQL edits to your phpBB install from the SQL statements provided at the top of the install.xml file.

If you have an issue again doing it tomorrow please let us know what steps you undertook installing the site and we can help you out from there.

User avatar
BFCUnion
Registered User
Posts: 10
Joined: Tue Feb 02, 2010 9:41 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by BFCUnion » Sun Feb 07, 2010 1:55 am

Steps I undertook,
I have copied all files from root directory across to phpBB site
modified files accordingly by running install_am/install.php - Note there was no install page, Should there be ?

Now i am unsure how to run the SQL statements provided in the top of the install_mod.xml file. - This was most likely where i balls'ed it up last time. :(
wired076 wrote:via phpmyadmin(or other means) make the necessary SQL edits to your phpBB install from the SQL statements provided at the top of the install.xml file.
Is this something i should Install :?:

Remember i am not familliar with modding. The site is stock.
Be good and be good at it otherwise buy a pram.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by wired076 » Sun Feb 07, 2010 9:56 am

BFCUnion wrote:Steps I undertook,
I have copied all files from root directory across to phpBB site
modified files accordingly by running install_am/install.php - Note there was no install page, Should there be ?

Now i am unsure how to run the SQL statements provided in the top of the install_mod.xml file. - This was most likely where i balls'ed it up last time. :(
wired076 wrote:via phpmyadmin(or other means) make the necessary SQL edits to your phpBB install from the SQL statements provided at the top of the install.xml file.
Is this something i should Install :?:

Remember i am not familliar with modding. The site is stock.
Yeah that is a bug that needs to be fixed. It does what it needs to do without any message back to you! :P

It sure is!!! This is why you were receiving the SQL errors.

Ok no porblems. It is not something you need to install if you have your web site hosted already. phpmyadmin should already be provided by the web host within for example cPanel. You can then go on there and run the SQL on the database.

I am currently on IRC chat for phpBB if you would like me to run through how to do this for your setup to get you up and running! I also have msn and skype!

User avatar
BFCUnion
Registered User
Posts: 10
Joined: Tue Feb 02, 2010 9:41 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by BFCUnion » Sun Feb 07, 2010 10:37 am

just got your message, I'll be on about 5pm tomorrow melb vic time.
Be good and be good at it otherwise buy a pram.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by wired076 » Sun Feb 07, 2010 12:51 pm

BFCUnion wrote:just got your message, I'll be on about 5pm tomorrow melb vic time.
I will try and be on at that time but can't promise as it is my Birthday tomorrow so may not be available most of the day!

Please note that I am compiling a list of errors I have encountered with this mod and will ensure that I haven't made modifications to the site where I have been using this mod and then will post back here with a list of fixes that need to be made before releasing a new version of this mod.

User avatar
BFCUnion
Registered User
Posts: 10
Joined: Tue Feb 02, 2010 9:41 am

Re: [ALPHA] Attendance Mod (0.2.4)

Post by BFCUnion » Wed Feb 17, 2010 9:57 am

hi guy's after spending a good 1/2 day i now have

"Parse error: syntax error, unexpected T_GLOBAL, expecting '{' in /home/bfccomp1/public_html/lanbfc.com.au/includes/functions_posting.php on line 1639"
poping up lots on replying to existing posts

I am reloading my backup as i need to have the site up, i can bugger around again next week.
Be good and be good at it otherwise buy a pram.

User avatar
NetizenKane
Registered User
Posts: 141
Joined: Wed Oct 27, 2004 1:25 pm

Re: [ALPHA] Attendance Mod (0.2.5)

Post by NetizenKane » Wed Feb 17, 2010 9:17 pm

A new alpha version is released. Some small bugs are fixed and Automod-Support is implemented.
Greets
Kane

deauvilleuk
Registered User
Posts: 111
Joined: Sat Aug 27, 2005 5:03 pm
Location: Middlesbrough, England, UK
Contact:

Re: [ALPHA] Attendance Mod (0.2.5)

Post by deauvilleuk » Fri Feb 19, 2010 7:31 pm

Many Many Thanks for working on this again :mrgreen:

I have upgraded my previous version to PHPBB 3.0.6 by uploading the full package (but keeping my files & images folders) then installed this Alpha Version to test it out.
I have recieved no errors, did get the white screen when running /install_am/install.php (but did read this in earlier posts about it not having a feedback).

I do get the registration tab in the permissions and have set all the ones pointed out in these posts to YES, but when I create a NEW TOPIC in that forum I don't see anything about creating an attendance (Ithink someone said it should appear next to the Poll Creation Tab ?)

Any help would be greatly appreciated

Graham

User avatar
NetizenKane
Registered User
Posts: 141
Joined: Wed Oct 27, 2004 1:25 pm

Re: [ALPHA] Attendance Mod (0.2.5)

Post by NetizenKane » Fri Feb 19, 2010 7:39 pm

First of all try this:
ACP->Load Settings->Recompile stale style components: Switch to YES.
Purge the cache.

Start a new topic and have a look for the tab near "Poll creation".
Hope this helps.

Greets
Kane

deauvilleuk
Registered User
Posts: 111
Joined: Sat Aug 27, 2005 5:03 pm
Location: Middlesbrough, England, UK
Contact:

Re: [ALPHA] Attendance Mod (0.2.5)

Post by deauvilleuk » Fri Feb 19, 2010 7:47 pm

Thanks

Just tried that and still nothing ?

Might it be something in one of the template edits ?

User avatar
NetizenKane
Registered User
Posts: 141
Joined: Wed Oct 27, 2004 1:25 pm

Re: [ALPHA] Attendance Mod (0.2.5)

Post by NetizenKane » Sat Feb 20, 2010 8:22 am

One more question:
Do you use subSilver or proSilver as template? The subSilver templates aren't available at the moment, i'm working on it.

Locked

Return to “[3.0.x] Abandoned MODs”