[ABD] Last News and Messages

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
echo2k5
Registered User
Posts: 197
Joined: Sun May 21, 2006 6:09 pm
Location: 3 paces to the west.
Contact:

Re: [RC4] Last News and Messages

Post by echo2k5 » Wed Aug 08, 2007 10:06 pm

I've set this up on my main domain...however I also have a seperate test board set up in another directory on this domain and when clicking on "Next 5" for the recent post...it goes over to my test forum instead of just pulling the next 5 from the site I have this setup on. Any clue to where to fix this?

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC4] Last News and Messages

Post by orynider » Thu Aug 09, 2007 7:06 am

Hi,

Is compozing the absolute path from database, using the values you entered when you first installed phpBB3.

Use this command in PhpMyAdmin:

Code: Select all

UPDATE `phpbb_config` SET  `config_value` = '/phpbb3' WHERE `config_name` = 'script_path';
were/replace:

"phpbb_" - is your Olympus table prefix;
"/phpbb3" - is the folder with your live Olympus installation, that is acctualy used;

User avatar
echo2k5
Registered User
Posts: 197
Joined: Sun May 21, 2006 6:09 pm
Location: 3 paces to the west.
Contact:

Re: [RC4] Last News and Messages

Post by echo2k5 » Thu Aug 09, 2007 3:54 pm

I have my main site setup in the root...no folder, so do I just replace the "phpbb3" with / in that query?

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC4] Last News and Messages

Post by orynider » Thu Aug 09, 2007 8:37 pm

No, this value does not need to be with "/", so leave it emtpy. Try this:

Code: Select all

UPDATE `phpbb_config` SET  `config_value` = '' WHERE `config_name` = 'script_path';
edit: Anyone can corrent if is wrong, probably I will drop this and use $phpbb_root_path in the Olympus mods.

User avatar
MartinWh
Registered User
Posts: 111
Joined: Wed May 23, 2007 9:44 am
Location: River Thames, UK
Contact:

Re: [RC4] Last News and Messages

Post by MartinWh » Sat Aug 18, 2007 6:25 pm

I have just added this to my RC4 forum and works fine EXCEPT the date/times are showing the same for topic start and latest post.

The incorrect date/time is the one under user name in Last Post -- any ideas.

Link to my board

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC5] Last News and Messages

Post by orynider » Sun Aug 19, 2007 10:36 pm

Confirmed and fixed. This was worked with the old phpBB2 style to build the sql query, but when I upgraded, at mod team sugestion, to use the new Olympus db api features/functions, the way how the sql sintaxex were build has been simplified a lot, so many informations could not be correct anymore and was needed to get them using the new functions and features, but I fogot abot this one. Thanks for posting!

User avatar
MartinWh
Registered User
Posts: 111
Joined: Wed May 23, 2007 9:44 am
Location: River Thames, UK
Contact:

Re: [RC5] Last News and Messages

Post by MartinWh » Mon Aug 20, 2007 9:39 am

Thanks {BUT} No difference -- still showing as before.

Yes purged cache and refreshed templates

Example

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC5] Last News and Messages

Post by orynider » Tue Aug 21, 2007 4:29 am

I upgraded the download link location, please download the zip from the new location.

User avatar
MartinWh
Registered User
Posts: 111
Joined: Wed May 23, 2007 9:44 am
Location: River Thames, UK
Contact:

Re: [RC5] Last News and Messages

Post by MartinWh » Tue Aug 21, 2007 9:46 am

:D

Big thanks -- Works fine now.

User avatar
MartinWh
Registered User
Posts: 111
Joined: Wed May 23, 2007 9:44 am
Location: River Thames, UK
Contact:

Re: [RC5] Last News and Messages

Post by MartinWh » Thu Aug 23, 2007 7:01 pm

Just one last thing bugging me.

When a new post is added the 'Red' icon comes on to notify you of new post then when you have read it the icon returns to normal EXCEPT in Last Messages -- the 'Red' icon doesn't switch off when read.

The problem this causes is in a popular topic where more than one post is made in short period -- it doesn't reflect this because the 'Red' is on for about 24 hours.

Any way to fix this?

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC5] Last News and Messages

Post by orynider » Fri Aug 24, 2007 12:33 am

Thanks for pointing this, I gues is same index that cauzed the previous bug, but I'm not 100% sure since This it's a problem even with the phpBB2 version (2.3.5) of the mod that is maintained by me at phpbb.ro, at least I can upgrade the index, and we will see then. I'll look in this and study the problem, maybe there is a Olympus feaure or function that we can use.

Yep, I solved the problem by fixing the bad index and by using a Olympus function to get the topic status.

I will post back when I done upgrading the RC status and the zip.

edit:

Done ;)

User avatar
MartinWh
Registered User
Posts: 111
Joined: Wed May 23, 2007 9:44 am
Location: River Thames, UK
Contact:

Re: [RC6] Last News and Messages

Post by MartinWh » Fri Aug 24, 2007 8:53 am

Brilliant :D I look forward to it.

User avatar
SkyKnight
Registered User
Posts: 30
Joined: Wed Jun 06, 2007 7:22 pm
Location: Langen, Germany

Re: [RC6] Last News and Messages

Post by SkyKnight » Thu Aug 30, 2007 8:25 pm

Hi, the mod is perfect. But I would check variable $recent_last_visit liek this

Code: Select all

$recent_last_visit = (!empty($user->data['session_time'])) ? $user->data['session_time'] : $user->data['user_lastvisit'];
Otherwise I allways saw icons on a topics like unread topics.

User avatar
orynider
Registered User
Posts: 250
Joined: Wed Nov 16, 2005 12:48 pm
Location: Arad, România
Name: Florin Bodin
Contact:

Re: [RC6] Last News and Messages

Post by orynider » Fri Aug 31, 2007 8:29 pm

In RC6 is working fine for me. Please explain forder. With your code if the user add the forum to favorites with a sid and is using same sid and session for one year, how will work?

User avatar
SkyKnight
Registered User
Posts: 30
Joined: Wed Jun 06, 2007 7:22 pm
Location: Langen, Germany

Re: [RC6] Last News and Messages

Post by SkyKnight » Fri Aug 31, 2007 11:58 pm

orynider wrote:In RC6 is working fine for me. Please explain forder. With your code if the user add the forum to favorites with a sid and is using same sid and session for one year, how will work?
what you mean with favorites? Your mod has nothing to do with favorites, or am I wrong? :)

I'm not sure wich version of your MOD I've download, but the problem , whi I described was on my PC. Because Last visit time in DB was not updated for some reasons and was completly old.

And this code, which I've posted here i took from some phpbb3 file. If i will find it again, I'll tell you. And now on my pc your mod works prefect :)

Locked

Return to “[3.0.x] Abandoned MODs”