[ABD] Prime Anti-bot - Anti-spambot Text Verification

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Claymore
Registered User
Posts: 2
Joined: Thu Jan 25, 2007 3:52 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Claymore »

First: Thank you for the best working protection against bots. I used your modification since i installed v3.0.2 (or was it 3.0.1? I dunno).

Anyways: I was and i am everytime a bit paranoid. So i modded the 'prime_captcha_keys.php' like following:

Code: Select all

$lang = array_merge($lang, array(
	'PRIME_CAPTCHA_KEYS' => array(

		'Open <a href=".\readme.txt" target="_blank">ReadMe</a> and enter it here:'
			=> array('the text from readme.txt'),

	),
));

?>
So the bot got no chance, to read it and answer correct. I know, this scenario didn't happen until now. Maybe it never will happen. But: For paranoid users like me, maybe the best method.

greetings Claymore
.::big fan::.
Registered User
Posts: 113
Joined: Wed Jul 28, 2004 11:50 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by .::big fan::. »

Hello,

I'm using the xand theme, but I can't find this page "styles/prosilver/template/posting_editor.html" and on this page "styles/prosilver/template/ucp_register.html", I can't find this code "<!-- IF S_CONFIRM_CODE -->".
User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by IPB_Refugee »

Hello,

if you only use xand theme, then look for

styles/xand/template/posting_editor.html
styles/xand/template/ucp_register.html

You have to make the modifications for every style you have installed!

If xand is based on prosilver, try to find the correct places in the xand files using the instructions for prosilver.
If xand is based on subsilver2 (then there are a lot of tables in xand's template files), try to find the correct places in the xand files using the instructions for subsilver2. The instructions for subsilver2 are probably located in the MOD's contrib folder.

Regards
Wolfgang
kham619
Registered User
Posts: 89
Joined: Wed Apr 22, 2009 10:46 pm
Location: san diego, ca, USA

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by kham619 »

Thanks for this mod, it should help out a lot of with my Spams. :mrgreen:

Easy to install, first try.
.::big fan::.
Registered User
Posts: 113
Joined: Wed Jul 28, 2004 11:50 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by .::big fan::. »

IPB_Refugee wrote:Hello,

if you only use xand theme, then look for

styles/xand/template/posting_editor.html
styles/xand/template/ucp_register.html

You have to make the modifications for every style you have installed!

If xand is based on prosilver, try to find the correct places in the xand files using the instructions for prosilver.
If xand is based on subsilver2 (then there are a lot of tables in xand's template files), try to find the correct places in the xand files using the instructions for subsilver2. The instructions for subsilver2 are probably located in the MOD's contrib folder.

Regards
Wolfgang
Ok I've followed all the instructions and it seems to work quite while. But I don't have 'posting_editor.html', would that cause any error? I tried to register and everything seems fine!
User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by IPB_Refugee »

Hi,

posting_editor.html is not a part of subsilver2 and styles based on subsilver2. Just follow the instructions for subsilver2 in the MOD's contrib folder, and it will be fine. :)

Regards
Wolfgang
.::big fan::.
Registered User
Posts: 113
Joined: Wed Jul 28, 2004 11:50 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by .::big fan::. »

I'm using the MOD right now, but spam bots keep registering like I haven't done anything! :(
User avatar
madmartyau
Registered User
Posts: 440
Joined: Sun Sep 12, 2004 12:42 pm
Location: Brisbane,Australia
Name: Marty
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by madmartyau »

It works beautifully for me.
Call me Grumpy.
SteveMurphy
Registered User
Posts: 4
Joined: Wed Jun 17, 2009 1:10 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by SteveMurphy »

I can answer the previous poster's question about the differences with the single question mod,
and say this mod would allow you to define several questions and corresponding answers, and a random pick is made at registration time.

I think this approach would be better than the single question, as it would be harder to hardwire the robot to answer the questions.

I liked this one the best of all the mods offered on the "Robot Defense" article, so I added this mod *first* to my 3.0.5 (by upgrade) and avalon style (also updated to 3.0.5). But alas, it didn't work. Couldn't register.
No appearance of the option in the ACP. Registrations just failed. So I reverted. There's a lot of changes
to the style files; I modified all the prosilver and subsilver files as well as the avalon files, and even swapped
the styles around to see if I just was blockheaded about making the style mods. But alas, it still acted the same way.

If 3.0.5 requires any different instuctions, let me know!
User avatar
primehalo
Former Team Member
Posts: 2910
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

I'm running phpBB 3.0.5 and the MOD is working fine for me. Did you use automod to install it?
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
greenapple
Registered User
Posts: 21
Joined: Tue Feb 21, 2006 6:50 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by greenapple »

Hi,

Thanks for the mod, I just installed the mod yesterday, and it seems to work very well at stopping the bots.

Really appreciate your effort!!!
.::big fan::.
Registered User
Posts: 113
Joined: Wed Jul 28, 2004 11:50 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by .::big fan::. »

Can somebody register here just for testing:
http://www.amisha-patel.net/forums/

'Cos the MOD might not even be on the registration page but I can't figure out the problem. :(
User avatar
madmartyau
Registered User
Posts: 440
Joined: Sun Sep 12, 2004 12:42 pm
Location: Brisbane,Australia
Name: Marty
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by madmartyau »

.::big fan::. wrote:Can somebody register here just for testing:
http://www.amisha-patel.net/forums/

'Cos the MOD might not even be on the registration page but I can't figure out the problem. :(
It's not showing. Have you enabled "Text verification for registrations:" in your board settings?
Call me Grumpy.
Vinck
Registered User
Posts: 1
Joined: Wed Jun 24, 2009 3:57 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Vinck »

Edit: Was my mistake, nevermind!
Qiao
Registered User
Posts: 3
Joined: Sun May 31, 2009 3:48 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Qiao »

I installed it.

Where it is in the Admin panel? Cannot find it
--

Found it, it is with captcha settings.
You realy should point this in the instruction.

Mode is nice
Locked

Return to “[3.0.x] Abandoned MODs”