[ABD] Prime Anti-bot - Anti-spambot Text Verification

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Malshadow
Registered User
Posts: 4
Joined: Fri May 09, 2008 12:39 am

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Malshadow »

Oh god, ran into another problem.. I can do all the enabling and such but for some reason the place to enter the answer to the phrase doesn't show up, either that or I just need to add the phrases first which I actually don't know where to do that.

Edit:Well, I tried separate page, but when you enter the question correctly it tells just goes back to the accept page. I tried hitting accept and doing it again but it just kept doing the same thing of going back to the accept page under registration. Any ideas?

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

Malshadow wrote:Oh god, ran into another problem.. I can do all the enabling and such but for some reason the place to enter the answer to the phrase doesn't show up, either that or I just need to add the phrases first which I actually don't know where to do that.
Check the Author Notes section in the instructions.
Malshadow wrote:Edit:Well, I tried separate page, but when you enter the question correctly it tells just goes back to the accept page. I tried hitting accept and doing it again but it just kept doing the same thing of going back to the accept page under registration. Any ideas?
If you cleared the board's cache and it's still doing that, then nope, I don't really have any ideas.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

dtsails
Registered User
Posts: 3
Joined: Tue Nov 14, 2006 6:25 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by dtsails »

Worked like a charm. I have one question, though. Why is the subsilver in a separate doc? I missed that the first go 'round and I killed an hour or so until I found mention of it in this forum. I just now saw it in the author notes too... but who reads those? :oops: Guess I shoulda!

Thanks again for the mod. It's a lifesaver!

David
PHP is not my hobby, but a means to an end..

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

dtsails wrote:Why is the subsilver in a separate doc?
The MOD Database rules state that they are not allowed to be included in the main installation instructions file. However, the new instructions format provides the ability to link to the subsilver2 instructions. Many MODs should be shifting over to that soon.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

wiroj
Registered User
Posts: 97
Joined: Mon Jul 07, 2003 6:31 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by wiroj »

Use Seperate Page Option have an error

(clear template cache ready)

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 63: Missing argument 2 for request_var()

edit : phpBB 3.0.2

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

Sorry about that. It's fixed in version 1.0.3, available now.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

User avatar
Bard
Registered User
Posts: 449
Joined: Fri Sep 10, 2004 9:49 am
Location: Texas
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Bard »

OK, I have a weird problem.

I installed the mod. I went to the registration page to see how it looked. It looked ok but I saw that I had forgotten to turn off captcha so both were present. I went through with the registration and got the email ok.

I then went to turn off captcha. When I checked it again neither prime or regular captcha were there. I purged all caches including template still nothing. I turned settings on and off again and again still nothing.

I can turn on regular captcha but nothing I do gets prime to show. I went through the install again and all mods are there. All the included files are there. And yes, I did both xml.

Any ideas?
A computer once beat me at chess, but it was no match for me at kick boxing.
Old Time Radio Talk | Visit OTR Talk Town

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

Clear your cookies. Once a successful verification has taken place, a cookie is stored and you won't see it again until the cookie goes away.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

User avatar
Bard
Registered User
Posts: 449
Joined: Fri Sep 10, 2004 9:49 am
Location: Texas
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Bard »

It's official I am an idiot. You even said that in your instructions.

Thanks it is working just fine!
A computer once beat me at chess, but it was no match for me at kick boxing.
Old Time Radio Talk | Visit OTR Talk Town

Trel
Registered User
Posts: 507
Joined: Sun Aug 11, 2002 2:02 pm
Location: In your moniter stupid
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Trel »

When I have it set as separate page, no matter what is entered, it loops me back to the main registration page.

Also, if I have it set to disabled, I get this upon registering

Fatal error: Call to a member function update_error() on a non-object in /my path here/public_html/includes/ucp/ucp_register.php on line 210

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

Version1.0.4
  • Fixed a bug that could cause the separate page verification for registrations to redirect to the terms page.
  • Added the configuration options to the Visual confirmation settings section of the ACP.
  • Use the board's set_cookie() function now that it has been updated to allow the setting of session cookies.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

User avatar
Bard
Registered User
Posts: 449
Joined: Fri Sep 10, 2004 9:49 am
Location: Texas
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by Bard »

Just upgraded from 1.02. Upgrade was fast, simple and worked the first time!
Thank you
A computer once beat me at chess, but it was no match for me at kick boxing.
Old Time Radio Talk | Visit OTR Talk Town

axiomatic
Registered User
Posts: 2
Joined: Tue Sep 23, 2008 5:38 pm

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by axiomatic »

hi all. being new to all of this i have a little problem.
ive done a ll according to the install.xml and its partially working :)

so, the question appears in a separate window and all that, and i really like it. what comfuses me a bit is that since i installed the mod in my acp some of the menus are not accesible anymore.

in the acp -> board configuration just attachment settings, message settings and visual confirmation settings is working. the rest gives me the following:

Fatal error: Call to a member function display_acp_options() on a non-object in /mnt/sites/dnbarchive.com/web/board/includes/acp/acp_board.php on line 373

this as well happens in some acp things.

now i remeber having edited that file, did i do something wrong there? board is 3.0.2


thx for helping

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by RMcGirr83 »

axiomatic wrote: now i remeber having edited that file, did i do something wrong there? board is 3.0.2
Yep, more than likely you did.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [RC1] Prime Anti-bot - Anti-spambot Text Verification

Post by primehalo »

I would have to concur.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

Locked

Return to “[3.0.x] Abandoned MODs”