[ABD] Xbox Live Tag (1.1.0)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Dielman
Registered User
Posts: 46
Joined: Wed Oct 03, 2007 9:52 am

Re: [BETA] Xbox Live Tag (0.0.5)

Post by Dielman »

SpongeFreak52 wrote:
Dielman wrote: That can be added pretty easily, I've moved the resulting card in posts to the profile that appears in posts, changed it to a different card (a flash one, works flawlessly), added friends request and message buttons, as well as including a link to Halo 3 profiles.
Which Flash GamerTag are you referring to?
The Mygamercard.net flash card. Select the Myspace option after generating the card on their site.

SpongeFreak52
Registered User
Posts: 83
Joined: Tue May 23, 2006 12:54 am
Contact:

Re: [BETA] Xbox Live Tag (0.0.5)

Post by SpongeFreak52 »

Alright, thanks. ;)

Benely
Registered User
Posts: 137
Joined: Fri Dec 29, 2006 3:28 pm

Re: [BETA] Xbox Live Tag (0.0.1)

Post by Benely »

Fix it nevermind.

frogstick
Registered User
Posts: 2
Joined: Mon Oct 15, 2007 8:18 pm

Re: [BETA] Xbox Live Tag (0.0.5)

Post by frogstick »

Ok, dumb question, but how to I get the square gamer card to show up under the avatars? I can't find this anywhere... The signature gamercard works great. Using Dielman's code (page 6) inserts the signature card under the avatar, but it's way too wide for that area... need the small square avatar gamecard. Where do I enable this option, or what code do I add to viewtopic_body?

User avatar
CoC
Registered User
Posts: 280
Joined: Tue Jul 18, 2006 11:16 am
Location: Coventry
Contact:

Re: [BETA] Xbox Live Tag (0.0.5)

Post by CoC »

At the moment this mod doesn't enable you to add a card under the avatar, but instead adds it to the bottom of a post, and in the users profile.

frogstick
Registered User
Posts: 2
Joined: Mon Oct 15, 2007 8:18 pm

Re: [BETA] Xbox Live Tag (0.0.5)

Post by frogstick »

Ah, OK, I thought I was just missing it somewhere. In theory, it should just be a line or two needed in the viewtopic_body.html, under the postavatar code. What line is used in the memberlist.php to display the card, and could it just be copy and pasted into the viewtopic_body file to display the same thing? The card in the view profile is exactly the one I'm looking to add under the avatar. Thanks.

XBLFan
Registered User
Posts: 19
Joined: Sun Aug 26, 2007 7:30 pm

Re: [BETA] Xbox Live Tag (0.0.5)

Post by XBLFan »

frogstick wrote:Ah, OK, I thought I was just missing it somewhere. In theory, it should just be a line or two needed in the viewtopic_body.html, under the postavatar code. What line is used in the memberlist.php to display the card, and could it just be copy and pasted into the viewtopic_body file to display the same thing? The card in the view profile is exactly the one I'm looking to add under the avatar. Thanks.
You want to put the flash gamercard underneath the avatar on viewtopic right?
Assuming this is what you wanted, what I did was I followed this post on the front page. You'd have to place this code below the avatar as opposed to under the signature

Code: Select all

         <!-- IF postrow.XBOX_LIVE --><div class="signature">{postrow.XBOX_LIVE}</div><!-- ENDIF -->
Then I replaced:

Code: Select all

#
#-----[ AFTER, ADD ]------------------------------------------
#
      'XBOX_LIVE'   => ( $user_cache[$poster_id]['xbox_live'] ) ? '<img src="http://card.mygamercard.net/gelsig/blue/' . $user_cache[$poster_id]['xbox_live']. '.png" border=0">'  :'',

#
With This:

Code: Select all

'XBOX_LIVE'  => ( $user_cache[$poster_id]['xbox_live'] )
? '<embed src="http://card.mygamercard.net/' .
$user_cache[$poster_id]['xbox_live']. '.swf" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" type="application/x-shockwave-flash" width="198" height="135">
</embed>' :'',
And it gave me a flash gamercard below the avatar. I'm running an older version of this mod so my results might be different. Hope this helps and is what you were looking for :D

User avatar
CoC
Registered User
Posts: 280
Joined: Tue Jul 18, 2006 11:16 am
Location: Coventry
Contact:

Re: [BETA] Xbox Live Tag (0.0.6)

Post by CoC »

Just finished updating this - update file included - :D

Dielman
Registered User
Posts: 46
Joined: Wed Oct 03, 2007 9:52 am

Re: [BETA] Xbox Live Tag (0.0.6)

Post by Dielman »

That's the update we've been waiting for. Thank you sir.

EDIT: I'm getting an error on my sql add at 'allow_xbl', seems it can't add the field :cry: could be effecting stuff after that, and for some reason each time I try adding it, it fails.

So now when I set a gamertag I get:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'user_xbl' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_xbl = NULL, user_allow_xbl = 0, user_show_xbl = 0, allow_xbl_small = 0, user_xbl_vt_tag = NULL, user_xbl_vt_colour = NULL, user_xbl_vp_tag = NULL, user_xbl_vp_colour = NULL WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/ucp/ucp_prefs.php
LINE: 369
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_module.php
LINE: 471
CALL: ucp_prefs->main()

FILE: ucp.php
LINE: 310
CALL: p_master->load_active()
Any hints?

User avatar
CoC
Registered User
Posts: 280
Joined: Tue Jul 18, 2006 11:16 am
Location: Coventry
Contact:

Re: [BETA] Xbox Live Tag (0.0.6)

Post by CoC »

Did you run the Upgrade Database Changes from Xbox Live Tag 0.0.5 to Xbox Live Tag 0.0.6 in the install.php file or do the manual update?

Dielman
Registered User
Posts: 46
Joined: Wed Oct 03, 2007 9:52 am

Re: [BETA] Xbox Live Tag (0.0.6)

Post by Dielman »

CoC wrote:Did you run the Upgrade Database Changes from Xbox Live Tag 0.0.5 to Xbox Live Tag 0.0.6 in the install.php file or do the manual update?
I did a fresh Live Tag installation on a fresh forum installation.

User avatar
CoC
Registered User
Posts: 280
Joined: Tue Jul 18, 2006 11:16 am
Location: Coventry
Contact:

Re: [BETA] Xbox Live Tag (0.0.6)

Post by CoC »

Did you apply the sql manally or use the install.php file?

There is a spelling mistake in the manual sql which I think would cause this error.

This is the changed sql, which should fix the error you're seeing.

Code: Select all

ALTER TABLE `phpbb_users` ADD `user_xbl` TEXT CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL;
ALTER TABLE `phpbb_users` ADD `user_allow_xbl` TINYINT( 1 ) UNSIGNED DEFAULT '1' NOT NULL AFTER `user_xbl`;
ALTER TABLE `phpbb_users` ADD `user_show_xbl` TINYINT( 1 ) UNSIGNED DEFAULT '1' NOT NULL AFTER `user_allow_xbl`;
ALTER TABLE `phpbb_users` ADD `allow_xbl_small` TINYINT( 1 ) DEFAULT '0' NOT NULL AFTER `user_show_xbl` ;
ALTER TABLE `phpbb_users` ADD `user_xbl_vt_colour` VARCHAR( 12 ) DEFAULT 'blue' NOT NULL AFTER `allow_xbl_small`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vp_colour` VARCHAR( 12 ) DEFAULT 'blue' NOT NULL AFTER `user_xbl_vt_colour`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vp_tag` VARCHAR( 12 ) DEFAULT 'gel' NOT NULL AFTER `user_xbl_vp_colour`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vt_tag` VARCHAR( 12 ) DEFAULT 'gelsig' NOT NULL AFTER `user_xbl_vp_tag`;

Dielman
Registered User
Posts: 46
Joined: Wed Oct 03, 2007 9:52 am

Re: [BETA] Xbox Live Tag (0.0.6)

Post by Dielman »

CoC wrote:Did you apply the sql manally or use the install.php file?

There is a spelling mistake in the manual sql which I think would cause this error.

This is the changed sql, which should fix the error you're seeing.

Code: Select all

ALTER TABLE `phpbb_users` ADD `user_xbl` TEXT CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL;
ALTER TABLE `phpbb_users` ADD `user_allow_xbl` TINYINT( 1 ) UNSIGNED DEFAULT '1' NOT NULL AFTER `user_xbl`;
ALTER TABLE `phpbb_users` ADD `user_show_xbl` TINYINT( 1 ) UNSIGNED DEFAULT '1' NOT NULL AFTER `user_allow_xbl`;
ALTER TABLE `phpbb_users` ADD `allow_xbl_small` TINYINT( 1 ) DEFAULT '0' NOT NULL AFTER `user_show_xbl` ;
ALTER TABLE `phpbb_users` ADD `user_xbl_vt_colour` VARCHAR( 12 ) DEFAULT 'blue' NOT NULL AFTER `allow_xbl_small`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vp_colour` VARCHAR( 12 ) DEFAULT 'blue' NOT NULL AFTER `user_xbl_vt_colour`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vp_tag` VARCHAR( 12 ) DEFAULT 'gel' NOT NULL AFTER `user_xbl_vp_colour`;
ALTER TABLE `phpbb_users` ADD `user_xbl_vt_tag` VARCHAR( 12 ) DEFAULT 'gelsig' NOT NULL AFTER `user_xbl_vp_tag`;
I tried both after it failed the first time. Didn't work.

You're updated one above works though, thanks for that.

User avatar
CoC
Registered User
Posts: 280
Joined: Tue Jul 18, 2006 11:16 am
Location: Coventry
Contact:

Re: [BETA] Xbox Live Tag (0.0.7)

Post by CoC »

Glad you got it sorted - :)

But just to anoy you I have updated the mod again - :D

See first post for details - :D

Groove200uk
Registered User
Posts: 35
Joined: Fri Sep 28, 2007 3:13 pm

Re: [BETA] Xbox Live Tag (0.0.7)

Post by Groove200uk »

Im falling over with the SQL as well.

The first 10 lines go in ok , and ive checked they are there.

Line 11 gives me an error though -
Database groove_1 running on localhost
Error

SQL-query :

ALTER TABLE `phpbb_users` ADD `user_xbl` TEXT CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL

MySQL said:


#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL' at lin
Im doing a manual entry of the sql and im stumped now.

EDIT - Just tried the install.php and got this -
INSERT INTO `phpbb_config` VALUES ('acp_xbl', '1', 0)
Failed due to error: Duplicate entry 'acp_xbl' for key 1
INSERT INTO `phpbb_config` VALUES ('allow_xbl', '1', 0)
Failed due to error: Duplicate entry 'allow_xbl' for key 1
INSERT INTO `phpbb_config` VALUES ('xbl_bg_tag', 'aero', 0)
Failed due to error: Duplicate entry 'xbl_bg_tag' for key 1
INSERT INTO `phpbb_config` VALUES ('xbl_pf_tag', 'aero', 0)
Failed due to error: Duplicate entry 'xbl_pf_tag' for key 1
INSERT INTO `phpbb_config` VALUES ('allow_xbl_voice', '0', 0)
Failed due to error: Duplicate entry 'allow_xbl_voice' for key 1
INSERT INTO `phpbb_config` VALUES ('allow_xbl_small', '1', 0)
Failed due to error: Duplicate entry 'allow_xbl_small' for key 1
INSERT INTO `phpbb_config` VALUES ('allow_xbl_posts', '1', 0)
Failed due to error: Duplicate entry 'allow_xbl_posts' for key 1
INSERT INTO `phpbb_config` VALUES ('xbl_bg_colour', 'default', 0)
Failed due to error: Duplicate entry 'xbl_bg_colour' for key 1
INSERT INTO `phpbb_config` VALUES ('xbl_pf_colour', 'default', 0)
Failed due to error: Duplicate entry 'xbl_pf_colour' for key 1
ALTER TABLE `phpbb_posts` ADD `enable_xbl` tinyint(1) unsigned NOT NULL default '1'
Failed due to error: Duplicate column name 'enable_xbl'

ALTER TABLE `phpbb_users` ADD `xbl_voice_tag` tinyint(1) NOT NULL default '0'
Completed successfully!
ALTER TABLE `phpbb_users` ADD `allow_xbl_small` tinyint(1) NOT NULL default '1'
Completed successfully!
ALTER TABLE `phpbb_users` ADD `user_show_xbl` tinyint(1) unsigned NOT NULL default '1'
Completed successfully!
ALTER TABLE `phpbb_users` ADD `user_allow_xbl` tinyint(1) unsigned NOT NULL default '1'
Completed successfully!

ALTER TABLE `phpbb_users` ADD `user_xbl_vp_tag` varchar(12) collate utf8_bin NOT NULL default 'aero'
Failed due to error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate utf8_bin NOT NULL default 'aero'' at line 1

ALTER TABLE `phpbb_users` ADD `user_xbl_vt_tag` varchar(12) collate utf8_bin NOT NULL default 'aero'
Failed due to error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate utf8_bin NOT NULL default 'aero'' at line 1

ALTER TABLE `phpbb_users` ADD `user_xbl` TEXT CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL
Failed due to error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'CHARACTER SET utf8 COLLATE utf8_bin DEFAULT '' NOT NULL' at lin

ALTER TABLE `phpbb_users` ADD `user_xbl_vt_colour` varchar(12) collate utf8_bin NOT NULL default 'default'
Failed due to error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate utf8_bin NOT NULL default 'default'' at line 1

ALTER TABLE `phpbb_users` ADD `user_xbl_vp_colour` varchar(12) collate utf8_bin NOT NULL default 'default'
Failed due to error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate utf8_bin NOT NULL default 'default'' at line 1

Module xbl
Failed due to error: The module's info file has not been uploaded. The module cannot be edited without the info file.
Obviously a few failed as i had already done them , and a few more succeeded that i hadnt tried manually , but im still failing on a load of entries.....

Versions if they are any help -

Welcome to phpMyAdmin 2.5.7-pl1
MySQL 4.0.24_Debian-10sarge2


Thanks !

Locked

Return to “[3.0.x] Abandoned MODs”