[ABD] Custom Title MOD

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Whatever6750
Registered User
Posts: 77
Joined: Sat Oct 15, 2005 7:34 pm

Re: [ALPHA] Custom Title MOD

Post by Whatever6750 » Fri Sep 14, 2007 5:05 pm

Ive installed this but its not showing up in the user control pannel. Ive checked to make sure I edited everything and can't find any problems. Its like its not enabled but I added the module and enabled it.

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sat Sep 15, 2007 5:36 am

playerfr wrote:
playerfr wrote:Any way to add an option to work with cashmod ? what I mean is people can buy the rights to have a custom title. But they cant change , to change they have to buy new custom title :D that would be great :)

Thanks :)
Any plans to do this in future version ?
I'm also very interested in that!

Thanks for the mod Aexoden, bout to install.

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sat Sep 15, 2007 5:55 am

Please Delete Post.

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sat Sep 15, 2007 10:39 am

I just installed and got this error.

General Error
SQL ERROR [ mysql4 ]

Duplicate entry 'custom_title_mode' for key 1 [1062]

SQL

INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES ('custom_title_mode', 0, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/functions.php
LINE: 147
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_board.php
LINE: 405
CALL: set_config()

FILE: includes/functions_module.php
LINE: 463
CALL: acp_board->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

Thats when I'm in the admin panel and enter how many letters you can have then hit submit.

Can I please have some help. :)

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sun Sep 16, 2007 4:16 am

Please. :P

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Mon Sep 17, 2007 5:51 am

Bump.

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Mon Sep 17, 2007 1:55 pm

A very special thank you to endout.com for helping me.

To make it work you have to put a number in the days, number in the posts and a number in how many letters for you to not get the error.

Now I'm having another problem, when I go to edit someones custom title I get this error:

SQL ERROR [ mysql4 ]

Unknown column 'user_custom_title' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_icq = '', user_aim = '', user_msnm = '', user_yim = '', user_jabber = '', user_website = '', user_from = '', user_occ = '', user_interests = '', user_custom_title = NULL, user_birthday = ' 0- 0- 0' WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/acp/acp_users.php
LINE: 1060
CALL: dbal_mysql->sql_query()

FILE: includes/functions_module.php
LINE: 463
CALL: acp_users->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()



Anyone know how to fix? :)

endout.com has made a comment on this earlier. I have sent him a PM asking him for more info, if he can help me out. I'll post it here. ^_^ its basically how to edit an SQL. I've never done it before. :(

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Mon Sep 17, 2007 2:29 pm

I went to try and disable it, and couldn't find it... =/

I went to System > Admin Control Panel > Module Management > General > Board Configeration.

Adn couldn't find Custom Title Settings anywhere there. In the dropdown box or in the list... i enabled it before though.

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Wed Sep 19, 2007 2:55 am

Well, I was stupid and had no idea that I had to edit the template. Im still getting used to these. :P

Well I edited that but now I get errors whenever I try to edit someones profile. I cant find the error now because I did a restore. >_> But the error was different no matter where i clicked the persons profile. I'll give this mod another go if/when it gets an upgrade.

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: [ALPHA] Custom Title MOD

Post by Gremlinn » Thu Sep 20, 2007 5:35 pm

I noticed that chnages for the subSilver2 template don't exist in your install.

I took the liberty of quickly putting one together so I could see what this would look like in that template. Here is what I came up with (I hope others will find it useful):

Code: Select all

Open: styles/subsilver2/template/ucp_profile_profile_info.html
Find:
<!-- IF S_BIRTHDAYS_ENABLED -->
	<tr> 
		<td class="row1" width="35%"><b class="genmed">{L_BIRTHDAY}: </b><br /><span class="gensmall">{L_BIRTHDAY_EXPLAIN}</span></td>
		<td class="row2"><span class="genmed">{L_DAY}:</span> <select name="bday_day">{S_BIRTHDAY_DAY_OPTIONS}</select> <span class="genmed">{L_MONTH}:</span> <select name="bday_month">{S_BIRTHDAY_MONTH_OPTIONS}</select> <span class="genmed">{L_YEAR}:</span> <select name="bday_year">{S_BIRTHDAY_YEAR_OPTIONS}</select></td>
	</tr>
<!-- ENDIF -->
Add Before:
<tr>
	<td class="row1" width="35%"><b class="genmed">{L_CUSTOM_TITLE}:</b><br /><span class="gensmall">{L_CUSTOM_TITLE_EXPLAIN}</span></td>
	<td class="row2"><input class="post" type="text" name="custom_title" size="30" maxlength="{CUSTOM_TITLE_MAXLENGTH}" value="{CUSTOM_TITLE}" /></td>
</tr>
Open: styles/subsilver2/template/viewtopic_body.html
Find:
			<!-- IF postrow.RANK_TITLE -->
				<tr>
					<td class="postdetails">{postrow.RANK_TITLE}</td>
				</tr>
			<!-- ENDIF -->
			<!-- IF postrow.RANK_IMG -->
				<tr>
					<td>{postrow.RANK_IMG}</td>
				</tr>
			<!-- ENDIF -->
Replace with:
			<!-- IF postrow.CUSTOM_TITLE or postrow.RANK_TITLE or postrow.RANK_IMG -->
				<tr>
					<td class="postdetails">{postrow.CUSTOM_TITLE}</td>
				</tr>
				<!-- IF postrow.CUSTOM_TITLE and postrow.RANK_TITLE or postrow.CUSTOM_TITLE and postrow.RANK_IMG --><br />
				<!-- ENDIF -->
				<tr>
					<td class="postdetails">{postrow.RANK_TITLE}</td>
				</tr><!-- IF postrow.RANK_TITLE and postrow.RANK_IMG --><br />
				<!-- ENDIF -->
				<tr>
					<td>{postrow.RANK_IMG}</td>
				</tr>
			<!-- ENDIF -->
Open: styles/subsilver2/template/memberlist_view.html
Find:
			<!-- IF RANK_TITLE -->
				<tr>
					<td class="postdetails" align="center">{RANK_TITLE}</td>
				</tr>
			<!-- ENDIF -->
			<!-- IF RANK_IMG -->
				<tr>
					<td align="center">{RANK_IMG}</td>
				</tr>
			<!-- ENDIF -->
Replace with:
			<!-- IF CUSTOM_TITLE or RANK_TITLE or RANK_IMG -->
				<tr>
					<td class="postdetails" align="center">{postrow.CUSTOM_TITLE}</td>
				</tr>
				<!-- IF CUSTOM_TITLE and RANK_TITLE or CUSTOM_TITLE and RANK_IMG --><br />
				<!-- ENDIF -->
				<tr>
					<td class="postdetails" align="center">{RANK_TITLE}</td>
				</tr><!-- IF RANK_TITLE and RANK_IMG --><br />
				<!-- ENDIF -->
				<tr>
					<td align="center">{RANK_IMG}</td>
				</tr>
			<!-- ENDIF -->

noregsson
Registered User
Posts: 7
Joined: Fri Jul 27, 2007 12:01 pm

Re: [ALPHA] Custom Title MOD

Post by noregsson » Thu Sep 20, 2007 6:13 pm

Thanks for the mod! My forum whores have been nagging about this.

Ran into a small problem tho. Using subsilver2, and used above posts instructions. Now I can change the custom title in the ACP, but if I do it in the UCP it doesn't look like it gets saved: I'll enter a title, press submit, then return to the edit profile page and the field is blank.

Any ideas?

EDIT: Yeah, still doesn't show up after I've edited it in the ACP.

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: [ALPHA] Custom Title MOD

Post by Gremlinn » Thu Sep 20, 2007 6:27 pm

You have to enable the permissions for User Roles (I think it was). The Custom Title part still shows and looks like it can be edited even if the user roles say the user can't edit their own title.

noregsson
Registered User
Posts: 7
Joined: Fri Jul 27, 2007 12:01 pm

Re: [ALPHA] Custom Title MOD

Post by noregsson » Thu Sep 20, 2007 6:48 pm

well duh ... I really should get more sleep before I do these things.

Thanks! xD

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Sat Sep 22, 2007 5:21 pm

so is this working?
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Sun Sep 23, 2007 3:18 am

CrimsonThunder wrote:Now I'm having another problem, when I go to edit someones custom title I get this error:

SQL ERROR [ mysql4 ]

Unknown column 'user_custom_title' in 'field list' [1054]
I was getting the same errors and came up with the following which has worked for me.

If SQL from custom title mod install has already been run, put this through phpMyAdmin:

Code: Select all

ALTER TABLE phpbb_users MODIFY user_custom_title varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin;
Go to ACP and change the display options to either 'Replace rank only' or 'Replace rank and rank image' and submit. Then go back and chnage it to what you want. I get no more errors either on registration, when a member adds their own custom title, when an admin adds it via ACP or when the settings are changed via ACP.

If this is a new install:

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', '');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);
ALTER TABLE phpbb_users ADD COLUMN user_custom_title varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin;
Gremlinn wrote:I noticed that changes for the subSilver2 template don't exist in your install.

I took the liberty of quickly putting one together so I could see what this would look like in that template. Here is what I came up with (I hope others will find it useful)
Thank you it did help! :D

And I hope you don't mind but I took the liberty of making a few more changes ... ;)


No change here, except to add some stylin' to differentiate the Custom Title from the Rank Title.
Subsilver: styles/subsilver2/template/viewtopic_body.html

Code: Select all

Find:
        <!-- IF postrow.RANK_TITLE -->
            <tr>
               <td class="postdetails">{postrow.RANK_TITLE}</td>
            </tr>
         <!-- ENDIF -->
         <!-- IF postrow.RANK_IMG -->
            <tr>
               <td>{postrow.RANK_IMG}</td>
            </tr>
         <!-- ENDIF -->

Replace with:
			<!-- IF postrow.CUSTOM_TITLE or postrow.RANK_TITLE or postrow.RANK_IMG -->
			<tr>
			<td class="postdetails"><b>{postrow.CUSTOM_TITLE}</b></td>
			</tr>
			<!-- IF postrow.CUSTOM_TITLE and postrow.RANK_TITLE or postrow.CUSTOM_TITLE and postrow.RANK_IMG --><br />
			<!-- ENDIF -->
			<tr>
			<td class="postdetails">{postrow.RANK_TITLE}</td>
			</tr>
			<!-- IF postrow.RANK_TITLE and postrow.RANK_IMG --><br />
			<!-- ENDIF -->
			<tr>
			<td>{postrow.RANK_IMG}</td>
			</tr>
			<!-- ENDIF -->

The member will now only see the Custom Title info and field if they have permission to add or change a custom title.
Subsilver: styles/subsilver2/template/ucp_profile_profile_info.html

Code: Select all

Find:
<!-- IF S_BIRTHDAYS_ENABLED -->
   <tr> 
      <td class="row1" width="35%"><b class="genmed">{L_BIRTHDAY}: </b><br /><span class="gensmall">{L_BIRTHDAY_EXPLAIN}</span></td>
      <td class="row2"><span class="genmed">{L_DAY}:</span> <select name="bday_day">{S_BIRTHDAY_DAY_OPTIONS}</select> <span class="genmed">{L_MONTH}:</span> <select name="bday_month">{S_BIRTHDAY_MONTH_OPTIONS}</select> <span class="genmed">{L_YEAR}:</span> <select name="bday_year">{S_BIRTHDAY_YEAR_OPTIONS}</select></td>
   </tr>
<!-- ENDIF -->

Add Before:
<!-- IF S_CUSTOM_TITLE_ENABLED -->
<tr>
	<td class="row1" width="35%"><b class="genmed">{L_CUSTOM_TITLE}:</b><br /><span class="gensmall">{L_CUSTOM_TITLE_EXPLAIN}</span></td>
	<td class="row2"><input class="post" type="text" name="custom_title" size="30" maxlength="{CUSTOM_TITLE_MAXLENGTH}" value="{CUSTOM_TITLE}" /></td>
</tr>
<!-- ENDIF -->

I changed the "{postrow.CUSTOM_TITLE}" to "<b>{CUSTOM_TITLE}</b>" as having postrow in there did not work - and I wanted the Custom Title in bold.
Subsilver: styles/subsilver2/template/memberlist_view.html

Code: Select all

Find:
         <!-- IF RANK_TITLE -->
            <tr>
               <td class="postdetails" align="center">{RANK_TITLE}</td>
            </tr>
         <!-- ENDIF -->
         <!-- IF RANK_IMG -->
            <tr>
               <td align="center">{RANK_IMG}</td>
            </tr>
         <!-- ENDIF -->

Replace with:
			<!-- IF CUSTOM_TITLE or RANK_TITLE or RANK_IMG -->
			<tr>
			<td align="center"><strong>{CUSTOM_TITLE}</strong></td>
			</tr>
			<!-- IF CUSTOM_TITLE and RANK_TITLE or CUSTOM_TITLE and RANK_IMG --><br />
			<!-- ENDIF -->
			<tr>
			<td align="center">{RANK_TITLE}</td>
			</tr><!-- IF RANK_TITLE and RANK_IMG --><br />
			<!-- ENDIF -->
			<tr>
			<td align="center">{RANK_IMG}</td>
			</tr>
			<!-- ENDIF -->

Hope that helps others. :)
(you may need to use partial finds)

BTW, for more info about the wonky default and NOT NULL errors, I found the following topic helpful:
http://www.phpbb.com/community/viewtopi ... 6&t=580379


Awesome mod - thanks Aexoden. :D
Last edited by spacefish on Mon Sep 24, 2007 10:47 am, edited 3 times in total.

Locked

Return to “[3.0.x] Abandoned MODs”