[ABD] Custom Title MOD

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sun Sep 23, 2007 5:23 am

Thanks Spacefish I'm going to give that a shot..

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Sun Sep 23, 2007 6:26 am

SQL ERROR [ mysql4 ]

Duplicate entry 'custom_title_mode' for key 1 [1062]

SQL

INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES ('custom_title_mode', 0, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/functions.php
LINE: 147
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_board.php
LINE: 406
CALL: set_config()

FILE: includes/functions_module.php
LINE: 463
CALL: acp_board->main()

FILE: adm/index.php
LINE: 75
CALL: p_master->load_active()

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Sun Sep 23, 2007 10:38 pm

If anyone has installed this and are still getting SQL errors, I've edited my previous post to add:
If SQL from custom title mod install has already been run, put this through phpMyAdmin:

Code: Select all

ALTER TABLE phpbb_users MODIFY user_custom_title varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin;
Go to ACP and change the display options to either 'Replace rank only' or 'Replace rank and rank image' and submit. Then go back and chnage it to what you want. I get no more errors either on registration, when a member adds their own custom title, when an admin adds it via ACP or when the settings are changed via ACP.
It also appears to now work for CrimsonThunder. :)

User avatar
CrimsonThunder
Registered User
Posts: 340
Joined: Sun Sep 02, 2007 10:18 am

Re: [ALPHA] Custom Title MOD

Post by CrimsonThunder » Mon Sep 24, 2007 6:52 am

Sure does! Thanks spacefish. :D

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 7:14 am

are you gona update the download to the latest latest version? :?
✖✖_Matthew Gideon_✖✖

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 7:38 am

any possibility that I can let users change their own custom title? :(
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Mon Sep 24, 2007 8:13 am

mattgid wrote:any possibility that I can let users change their own custom title? :(
It's all permission based so assign permission via a user role, then give that role to the group you want to have edit their own custom titles.

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 8:19 am

I don't see it.....

Image
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Mon Sep 24, 2007 8:35 am

Go to ACP -> Permissions -> User Roles. Select the User Role you want to assign permission to and click the green 'edit' button to edit that role. Click on the 'Profile' tab and you should see "Can edit own custom title" ... yes, no and never. ;)

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 9:00 am

I editted everything accordingly but the custom profile field is still not showing in the UCP. :(
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Mon Sep 24, 2007 9:35 am

Have you checked the users permissions either via 'Administrate User' (via their profile), or ACP -> Permissions -> Users Permissions. If they show as having the correct permissions then try refreshing your templates/clearing cache for the template files (you did edit 'ucp_profile_profile_info.html' etc ?). Also, make sure they meet the settings you've made in ACP -> Custom title settings.
Last edited by spacefish on Mon Sep 24, 2007 9:41 am, edited 1 time in total.

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 9:38 am

spacefish wrote:(you did edit 'ucp_profile_profile_info.html' etc ?).

the instructions didnt tell me to edit that file?

I cleared my cache. no change.
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Mon Sep 24, 2007 9:43 am

If you're using Prosilver, have a look in the templates directory of the MOD download.

If you're using subsilver2 then check my post here:
http://www.phpbb.com/community/viewtopi ... 2#p3201782
(which I'll edit soon to make clearer)

.. and Gremlinns post here for the finds:
http://www.phpbb.com/community/viewtopi ... 7#p3199047
Last edited by spacefish on Mon Sep 24, 2007 9:46 am, edited 1 time in total.

User avatar
mattgid
Registered User
Posts: 339
Joined: Wed Sep 05, 2007 6:57 am
Location: Singapore

Re: [ALPHA] Custom Title MOD

Post by mattgid » Mon Sep 24, 2007 9:46 am

ok I just editted the files. I'm using prosilver. still no change! D:

refreshed cache and all!! :( :( :(
✖✖_Matthew Gideon_✖✖

User avatar
spacefish
Registered User
Posts: 173
Joined: Mon Oct 09, 2006 8:48 am

Re: [ALPHA] Custom Title MOD

Post by spacefish » Mon Sep 24, 2007 10:03 am

Assuming that users meet the settings you've made in ACP -> Custom title settings, have you also checked a specific users permissions? How about your own? As an admin you should have it showing in your UCP in the profile tab.

Locked

Return to “[3.0.x] Abandoned MODs”