[ABD] Armory World of Warcraft Tooltip

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by reiserfs »

delete everything inside /cache dir
go to ACP and clear the Style cache too.

Try again.
Sorian
Registered User
Posts: 6
Joined: Wed Oct 10, 2007 8:27 pm

Re: [RC3] Armory World of Warcraft Tooltip

Post by Sorian »

Ygramul wrote:I guess that's where my problem is. I've tried to do this manually as it's for a different version of phpBB and I don't know how to edit some of the files, I suppose. It seems that the files I'm supposed to edit are often files that don't exist with my version and, when I find something close or even by the same name, the code I'm told to search for and change isn't there, either. Thank you again for your help. I appreciate it.

Is there anyone who could advise me, please, on how to change the phpBB 2.0.x overall_header.tpl file to suit this? Even if you could paste a block with the code in it, or whatever. Thank you.

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{S_CONTENT_DIRECTION}">
<head>
<meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}">
<meta http-equiv="Content-Style-Type" content="text/css">
{META}
{NAV_LINKS}
<title>{SITENAME} :: {PAGE_TITLE}</title>
<script type="text/javascript" src="ajax_tooltip/js/ajax-dynamic-content.js">
</script> <script type="text/javascript" src="ajax_tooltip/js/ajax.js">
</script> <script type="text/javascript" src="ajax_tooltip/js/ajax-tooltip.js">
</script> <link rel="stylesheet" href="ajax_tooltip/css/wow-item.css" type="text/css" />

<!-- link rel="stylesheet" href="templates/aluminoid/{T_HEAD_STYLESHEET}" type="text/css" -->
<style type="text/css">
<!--
Those are the first 15 or so lines of mine. Yours may be a bit different, I use a skin called Aluminoid. Its location was /templates/(skin)/
You only need to add the lines with ajax in it. 4 lines total.
Edean
Registered User
Posts: 3
Joined: Mon Oct 15, 2007 5:07 pm

Re: [RC3] Armory World of Warcraft Tooltip

Post by Edean »

reiserfs wrote:delete everything inside /cache dir
go to ACP and clear the Style cache too.

Try again.
Clearing the cache inside the ACP did the trick, thanks so much for you promptly replies.

Best regards,

Edean.
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

Thank you very much. It works just right now. Thank you for all of your time and help and thank you for creating this, reiserfs.
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

If I may ask, could someone please let me know how to reduce the text size for the tooltip a little? I tweaked a few things in the wow-item.css file without any trouble, such as the opacity and the border color and removing the arrow, but I tried to add in a font-size bit under the text-align and it didn't do a thing. Should I be putting it somewhere else? Thanks again.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by reiserfs »

Ygramul wrote:If I may ask, could someone please let me know how to reduce the text size for the tooltip a little? I tweaked a few things in the wow-item.css file without any trouble, such as the opacity and the border color and removing the arrow, but I tried to add in a font-size bit under the text-align and it didn't do a thing. Should I be putting it somewhere else? Thanks again.
The tooltip get the forum CSS inside the POST, on firefox users. on IE users the tooltip get the css from the file.
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

Damn, do I take that to mean that I can't change it? I use Firefox, myself... I'm sure many forum members probably use others. Are you saying that the size of the text in the tooltip is dependent on the size of the text in any given post within which the tooltip is active for Firefox? Basically, there is nothing I can do to set a fixed size? Sorry if I seem dense. I just need the clarification. Thank you for your reply.

I also have another question. I've tried adjusting the CSS to make it so tooltips found near the bottom of the page don't end up partially hidden. I've tried using the "relative" property, but maybe I'm not doing it correctly. Can someone please advise me how to get the tooltip pushed up by the bottom of the page if it's found there? Thanks again.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by reiserfs »

Ygramul wrote:Damn, do I take that to mean that I can't change it? I use Firefox, myself... I'm sure many forum members probably use others. Are you saying that the size of the text in the tooltip is dependent on the size of the text in any given post within which the tooltip is active for Firefox? Basically, there is nothing I can do to set a fixed size? Sorry if I seem dense. I just need the clarification. Thank you for your reply.

I also have another question. I've tried adjusting the CSS to make it so tooltips found near the bottom of the page don't end up partially hidden. I've tried using the "relative" property, but maybe I'm not doing it correctly. Can someone please advise me how to get the tooltip pushed up by the bottom of the page if it's found there? Thanks again.
I will be honest, im good with php, but im very noob with CSS and JS, the first version of this mod i used CSS but the .postbody style from phpBB3 CSS override my CSS, then i change the code to use <font color> instead CSS.

im studing Ajax on my free time to make another tooltip code, compatible with IE7 and (Firefox, Opera) and with some better control.

But now i dont have a good solution to this issue, sorry.
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

That's okay. Thank you, anyway. Does anyone else have any insight? Thanks.
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

Sorry... I must be confused. I thought you meant that the tooltip gets its size from the font size used in a post, but I've tried different sizes of fonts when posting and the tooltip's font size stays the same. Maybe I'm confused about what you meant. Could you clarify, please?
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

Sorry, forget the thing about the font. After extensive searching and experimenting, I ended up finding the files that determine the fonts for the tooltips and just went through and manually added size properties to all of the <font> tags (quite a lot, but it worked.

The only thing I'm still stuck on now is the problem I mentioned above.
Ygramul wrote:I also have another question. I've tried adjusting the CSS to make it so tooltips found near the bottom of the page don't end up partially hidden. I've tried using the "relative" property, but maybe I'm not doing it correctly. Can someone please advise me how to get the tooltip pushed up by the bottom of the page if it's found there? Thanks again.
Thanks again.
User avatar
bigbabol
Registered User
Posts: 17
Joined: Wed Aug 01, 2007 7:23 pm
Location: Greece

Re: [RC3] Armory World of Warcraft Tooltip

Post by bigbabol »

I tried to install mod again on a 'clean' rc7 install (only phpbb portal is installed beyond this) and I can't figure out why this isn't working again xS

Link: http://magicrealm.ath.cx/ctrlme/viewtop ... t=2&p=3#p3

and here it is the code from overall_header.php

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
<meta http-equiv="content-style-type" content="text/css" />
<meta http-equiv="content-language" content="{S_USER_LANG}" />
<meta http-equiv="imagetoolbar" content="no" />
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="copyright" content="2002-2006 phpBB Group" />
<meta name="keywords" content="" />
<meta name="description" content="" />
{META}
<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>

<!--
	phpBB style name: prosilver
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      
	
	NOTE: This page was generated by phpBB, the free open-source bulletin board package.
	      The phpBB Group is not responsible for the content of this page and forum. For more information
	      about phpBB please visit http://www.phpbb.com
-->

<script type="text/javascript">
// <![CDATA[
	var jump_page = '{LA_JUMP_PAGE}:';
	var on_page = '{ON_PAGE}';
	var per_page = '{PER_PAGE}';
	var base_url = '{A_BASE_URL}';
	var style_cookie = 'phpBBstyle';
	var onload_functions = new Array();
	var onunload_functions = new Array();

	<!-- IF S_USER_PM_POPUP -->
		if ({S_NEW_PM})
		{
			popup('{UA_POPUP_PM}', 400, 225, '_phpbbprivmsg');
		}
	<!-- ENDIF -->

	/**
	* Find a member
	*/
	function find_username(url)
	{
		popup(url, 760, 570, '_usersearch');
		return false;
	}

	/**
	* New function for handling multiple calls to window.onload and window.unload by pentapenguin
	*/
	window.onload = function()
	{
		for (i = 0; i <= onload_functions.length; i++)
		{
			eval(onload_functions[i]);
		}
	}

	window.onunload = function()
	{
		for (i = 0; i <= onunload_functions.length; i++)
		{
			eval(onunload_functions[i]);
		}
	}

// ]]>
</script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/styleswitcher.js"></script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/forum_fn.js"></script>

<script type="text/javascript" src="ajax_tooltip/js/ajax-dynamic-content.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax-tooltip.js"></script>       
<link rel="stylesheet" href="ajax_tooltip/css/wow-item.css" type="text/css" />

<link href="{T_THEME_PATH}/print.css" rel="stylesheet" type="text/css" media="print" title="printonly" />
<link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />

<link href="{T_THEME_PATH}/normal.css" rel="stylesheet" type="text/css" title="A" />
<link href="{T_THEME_PATH}/medium.css" rel="alternate stylesheet" type="text/css" title="A+" />
<link href="{T_THEME_PATH}/large.css" rel="alternate stylesheet" type="text/css" title="A++" />

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css" rel="stylesheet" type="text/css" media="screen, projection" />
<!-- ENDIF -->

</head>

<body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">

<div id="wrap">
	<a id="top" name="top" accesskey="t"></a>
	<div id="page-header">
		<div class="headerbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<div id="site-description">
				<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>
				<h1>{SITENAME}</h1>
				<p>{SITE_DESCRIPTION}</p>
				<p style="display: none;"><a href="#start_here">{L_SKIP}</a></p>
			</div>

		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
			<div id="search-box">
				<form action="{U_SEARCH}" method="post" id="search">
				<fieldset>
					<input name="keywords" id="keywords" type="text" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search" value="<!-- IF SEARCH_WORDS-->{SEARCH_WORDS}<!-- ELSE -->{L_SEARCH_MINI}<!-- ENDIF -->" onclick="if(this.value=='{LA_SEARCH_MINI}')this.value='';" onblur="if(this.value=='')this.value='{LA_SEARCH_MINI}';" /> 
					<input class="button2" value="{L_SEARCH}" type="submit" /><br />
					<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}">{L_SEARCH_ADV}</a> {S_HIDDEN_FIELDS}
				</fieldset>
				</form>
			</div>
		<!-- ENDIF -->

			<span class="corners-bottom"><span></span></span></div>
		</div>

		<!-- IF not $S_IN_PORTAL -->
		<div class="navbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<ul class="linklist navlinks">
				<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a> <!-- BEGIN navlinks --> <strong>&#8249;</strong> <a href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></li>

				<li class="rightside"><a href="#" onclick="fontsizeup(); return false;" class="fontsize" title="{L_CHANGE_FONT_SIZE}">{L_CHANGE_FONT_SIZE}</a></li>

				<!-- IF U_EMAIL_TOPIC --><li class="rightside"><a href="{U_EMAIL_TOPIC}" title="{L_EMAIL_TOPIC}" class="sendemail">{L_EMAIL_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_EMAIL_PM --><li class="rightside"><a href="{U_EMAIL_PM}" title="{L_EMAIL_PM}" class="sendemail">{L_EMAIL_PM}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_TOPIC --><li class="rightside"><a href="{U_PRINT_TOPIC}" title="{L_PRINT_TOPIC}" accesskey="p" class="print">{L_PRINT_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_PM --><li class="rightside"><a href="{U_PRINT_PM}" title="{L_PRINT_PM}" accesskey="p" class="print">{L_PRINT_PM}</a></li><!-- ENDIF -->
			</ul>

			<!-- IF not S_IS_BOT and S_USER_LOGGED_IN -->
			<ul class="linklist leftside">
				<li class="icon-ucp">
					<a href="{U_PROFILE}" title="{L_PROFILE}" accesskey="u">{L_PROFILE}</a>
						<!-- IF S_DISPLAY_PM --> (<a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a>)<!-- ENDIF --> &bull; 
					<a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>
					<!-- IF U_RESTORE_PERMISSIONS --> &bull;
					<a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a>
					<!-- ENDIF -->
				</li>
			</ul>
			<!-- ENDIF -->

			<ul class="linklist rightside">
				<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
				<!-- IF not S_IS_BOT -->
					<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
					<!-- IF not S_USER_LOGGED_IN --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
					<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li>
				<!-- ENDIF -->
			</ul>

			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->

	</div>

	<a name="start_here"></a>
	<div id="page-body">
		
		 <!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) --> 
		<div id="message" class="rules">
			<div class="inner"><span class="corners-top"><span></span></span>
				<strong>{L_INFORMATION}:</strong> {L_BOARD_DISABLED}
			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->
Since this is the only edit to be made, i guess the error is arround here.. plz give it a check xS
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by reiserfs »

bigbabol wrote:I tried to install mod again on a 'clean' rc7 install (only phpbb portal is installed beyond this) and I can't figure out why this isn't working again xS

Link: http://magicrealm.ath.cx/ctrlme/viewtop ... t=2&p=3#p3

and here it is the code from overall_header.php

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
<meta http-equiv="content-style-type" content="text/css" />
<meta http-equiv="content-language" content="{S_USER_LANG}" />
<meta http-equiv="imagetoolbar" content="no" />
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="copyright" content="2002-2006 phpBB Group" />
<meta name="keywords" content="" />
<meta name="description" content="" />
{META}
<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>

<!--
	phpBB style name: prosilver
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      
	
	NOTE: This page was generated by phpBB, the free open-source bulletin board package.
	      The phpBB Group is not responsible for the content of this page and forum. For more information
	      about phpBB please visit http://www.phpbb.com
-->

<script type="text/javascript">
// <![CDATA[
	var jump_page = '{LA_JUMP_PAGE}:';
	var on_page = '{ON_PAGE}';
	var per_page = '{PER_PAGE}';
	var base_url = '{A_BASE_URL}';
	var style_cookie = 'phpBBstyle';
	var onload_functions = new Array();
	var onunload_functions = new Array();

	<!-- IF S_USER_PM_POPUP -->
		if ({S_NEW_PM})
		{
			popup('{UA_POPUP_PM}', 400, 225, '_phpbbprivmsg');
		}
	<!-- ENDIF -->

	/**
	* Find a member
	*/
	function find_username(url)
	{
		popup(url, 760, 570, '_usersearch');
		return false;
	}

	/**
	* New function for handling multiple calls to window.onload and window.unload by pentapenguin
	*/
	window.onload = function()
	{
		for (i = 0; i <= onload_functions.length; i++)
		{
			eval(onload_functions[i]);
		}
	}

	window.onunload = function()
	{
		for (i = 0; i <= onunload_functions.length; i++)
		{
			eval(onunload_functions[i]);
		}
	}

// ]]>
</script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/styleswitcher.js"></script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/forum_fn.js"></script>

<script type="text/javascript" src="ajax_tooltip/js/ajax-dynamic-content.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax-tooltip.js"></script>       
<link rel="stylesheet" href="ajax_tooltip/css/wow-item.css" type="text/css" />

<link href="{T_THEME_PATH}/print.css" rel="stylesheet" type="text/css" media="print" title="printonly" />
<link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />

<link href="{T_THEME_PATH}/normal.css" rel="stylesheet" type="text/css" title="A" />
<link href="{T_THEME_PATH}/medium.css" rel="alternate stylesheet" type="text/css" title="A+" />
<link href="{T_THEME_PATH}/large.css" rel="alternate stylesheet" type="text/css" title="A++" />

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css" rel="stylesheet" type="text/css" media="screen, projection" />
<!-- ENDIF -->

</head>

<body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">

<div id="wrap">
	<a id="top" name="top" accesskey="t"></a>
	<div id="page-header">
		<div class="headerbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<div id="site-description">
				<a href="{U_INDEX}" title="{L_INDEX}" id="logo">{SITE_LOGO_IMG}</a>
				<h1>{SITENAME}</h1>
				<p>{SITE_DESCRIPTION}</p>
				<p style="display: none;"><a href="#start_here">{L_SKIP}</a></p>
			</div>

		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
			<div id="search-box">
				<form action="{U_SEARCH}" method="post" id="search">
				<fieldset>
					<input name="keywords" id="keywords" type="text" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search" value="<!-- IF SEARCH_WORDS-->{SEARCH_WORDS}<!-- ELSE -->{L_SEARCH_MINI}<!-- ENDIF -->" onclick="if(this.value=='{LA_SEARCH_MINI}')this.value='';" onblur="if(this.value=='')this.value='{LA_SEARCH_MINI}';" /> 
					<input class="button2" value="{L_SEARCH}" type="submit" /><br />
					<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}">{L_SEARCH_ADV}</a> {S_HIDDEN_FIELDS}
				</fieldset>
				</form>
			</div>
		<!-- ENDIF -->

			<span class="corners-bottom"><span></span></span></div>
		</div>

		<!-- IF not $S_IN_PORTAL -->
		<div class="navbar">
			<div class="inner"><span class="corners-top"><span></span></span>

			<ul class="linklist navlinks">
				<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a> <!-- BEGIN navlinks --> <strong>&#8249;</strong> <a href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></li>

				<li class="rightside"><a href="#" onclick="fontsizeup(); return false;" class="fontsize" title="{L_CHANGE_FONT_SIZE}">{L_CHANGE_FONT_SIZE}</a></li>

				<!-- IF U_EMAIL_TOPIC --><li class="rightside"><a href="{U_EMAIL_TOPIC}" title="{L_EMAIL_TOPIC}" class="sendemail">{L_EMAIL_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_EMAIL_PM --><li class="rightside"><a href="{U_EMAIL_PM}" title="{L_EMAIL_PM}" class="sendemail">{L_EMAIL_PM}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_TOPIC --><li class="rightside"><a href="{U_PRINT_TOPIC}" title="{L_PRINT_TOPIC}" accesskey="p" class="print">{L_PRINT_TOPIC}</a></li><!-- ENDIF -->
				<!-- IF U_PRINT_PM --><li class="rightside"><a href="{U_PRINT_PM}" title="{L_PRINT_PM}" accesskey="p" class="print">{L_PRINT_PM}</a></li><!-- ENDIF -->
			</ul>

			<!-- IF not S_IS_BOT and S_USER_LOGGED_IN -->
			<ul class="linklist leftside">
				<li class="icon-ucp">
					<a href="{U_PROFILE}" title="{L_PROFILE}" accesskey="u">{L_PROFILE}</a>
						<!-- IF S_DISPLAY_PM --> (<a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a>)<!-- ENDIF --> &bull; 
					<a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>
					<!-- IF U_RESTORE_PERMISSIONS --> &bull;
					<a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a>
					<!-- ENDIF -->
				</li>
			</ul>
			<!-- ENDIF -->

			<ul class="linklist rightside">
				<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
				<!-- IF not S_IS_BOT -->
					<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
					<!-- IF not S_USER_LOGGED_IN --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
					<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li>
				<!-- ENDIF -->
			</ul>

			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->

	</div>

	<a name="start_here"></a>
	<div id="page-body">
		
		 <!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) --> 
		<div id="message" class="rules">
			<div class="inner"><span class="corners-top"><span></span></span>
				<strong>{L_INFORMATION}:</strong> {L_BOARD_DISABLED}
			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->
Since this is the only edit to be made, i guess the error is arround here.. plz give it a check xS

PHP Short tag is not working on your hosting

Look http://magicrealm.ath.cx/ctrlme/wow/php ... un%20Eater

I get this return from the URL

Code: Select all

<table cellspacing="0" cellpadding="5" border="0">
 <tr>
  <td width="43" valign="top"><img src="<?=$icons_url;?>43x43/<?=$item['icon'];?>.png" border="0">
  </td>
  <td> <font color="#FFFFFF">  
  <font color="<?=value_color($item['overallqualityid'])?>"><?=$item['name'];?> </font> <br />
  <?=$bonding;?>
  <?=$require_data;?>  
  <?=$type_class;?>

  <?=$damage_data;?>
  <?=$armor_data;?>
  <?=$gem_data;?>
  <?=$durability;?>
  <?=$spell_data;?>
  <?=$set_data;?>
  <?=$desc;?>
  </td>
 </tr>

</table>
User avatar
bigbabol
Registered User
Posts: 17
Joined: Wed Aug 01, 2007 7:23 pm
Location: Greece

Re: [RC3] Armory World of Warcraft Tooltip

Post by bigbabol »

PHP Short tag is not working on your hosting
You said the key-word!

Fixed and now working smooth! Thanks for the help xD

*Keep up the iMBA work xD
Ygramul
Registered User
Posts: 41
Joined: Tue Sep 05, 2006 12:30 pm
Contact:

Re: [RC3] Armory World of Warcraft Tooltip

Post by Ygramul »

Just wanted to ask again if anyone who happens by this could please advise me on the following:
Ygramul wrote:I also have another question. I've tried adjusting the CSS to make it so tooltips found near the bottom of the page don't end up partially hidden. I've tried using the "relative" property, but maybe I'm not doing it correctly. Can someone please advise me how to get the tooltip pushed up by the bottom of the page if it's found there? Thanks again.
Thanks.
Locked

Return to “[3.0.x] Abandoned MODs”