[ABD] Armory World of Warcraft Tooltip

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Axti
Registered User
Posts: 8
Joined: Thu Sep 06, 2007 1:52 pm

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Axti »

Hello. I got one question. Which code to BBCode is correct? also can u write in first post or here as next reply "Full Instruction" for installed this MOD ? Thanks

Regards
lyf
Registered User
Posts: 13
Joined: Wed Mar 30, 2005 3:55 pm
Location: Denmark

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by lyf »

bigbabol wrote:
lyf wrote:
flokohlert wrote:lyf you already made it to the right place ;)
now there should be a button "add bbcode" click it and you are done.
Sorry, but really can't find it.
It's under posting Category m8 :D
Rofl, thanks >.<

Some items aren't looking right, say "Arcanite Reaper" - it's not showing any DPS/min/max damage. How can this be? What is the "final" bbcode to use?
Zorrander
Registered User
Posts: 6
Joined: Thu Sep 06, 2007 4:25 pm

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Zorrander »

Hello!

I'm having a problem with the mod (I'm certain it's my fault), and am hoping that you can help. The links to the items show up fine and link to the correct pages in the armory. But the popup tooltip for the items does not appear when I hover over them. I'm using Firefox as my browser and a theme that I downloaded from a link on the forums here.

Here is a copy of my overall_header.html file.

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">

<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />

<meta http-equiv="content-language" content="{S_USER_LANG}" />

<meta http-equiv="content-style-type" content="text/css" />

<meta http-equiv="imagetoolbar" content="no" />

<meta name="resource-type" content="document" />

<meta name="distribution" content="global" />

<meta name="copyright" content="2002-2006 phpBB Group" />

<meta name="keywords" content="" />

<meta name="description" content="" />

{META}

<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>



<!-- IF T_STYLESHEET_LINK -->

<link rel="stylesheet" href="{T_STYLESHEET_LINK}" type="text/css" />
<!-- ELSE -->

<style type="text/css">

{T_THEME_DATA}

</style>

<!-- ENDIF -->


<script type="text/javascript" src="ajax_tooltip/js/ajax-dynamic-content.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax-tooltip.js"></script>
<link rel="stylesheet" href="ajax_tooltip/css/wow-item.css" type="text/css" />

<script type="text/javascript">

<!--

<!-- IF S_USER_PM_POPUP -->

	if ({S_NEW_PM})

	{

		window.open('{UA_POPUP_PM}', '_phpbbprivmsg', 'height=225,resizable=yes,width=400');

	}

<!-- ENDIF -->



function popup(url, width, height)

{

	window.open(url.replace(/&/g, '&'), '_popup', 'HEIGHT=' + height + ',resizable=yes,scrollbars=yes, WIDTH=' + width);

	return false;

}



function jumpto()

{

	var page = prompt('{LA_JUMP_PAGE}:', '{ON_PAGE}');

	var perpage = '{PER_PAGE}';

	var base_url = '{BASE_URL}';



	if (page !== null && !isNaN(page) && page > 0)

	{

		document.location.href = base_url.replace(/&/g, '&') + '&start=' + ((page - 1) * perpage);

	}

}



/**

* Find a member

*/

function find_username()

{

	<!-- IF UA_FIND_USERNAME -->

	window.open('{UA_FIND_USERNAME}', '_usersearch', 'height=500, resizable=yes, scrollbars=yes, width=740');

	<!-- ENDIF -->

	return false;

}



/**

* Mark/unmark checklist

* id = ID of parent container, name = name prefix, state = state [true/false]

*/

function marklist(id, name, state)

{

	var parent = document.getElementById(id);

	if (!parent)

	{

		eval('parent = document.' + id);

	}



	if (!parent)

	{

		return;

	}



	var rb = parent.getElementsByTagName('input');

	

	for (var r = 0; r < rb.length; r++)

	{

		if (rb[r].name.substr(0, name.length) == name)

		{

			rb[r].checked = state;

		}

	}

}



<!-- IF ._file -->



	/**

	* Play quicktime file by determining it's width/height

	* from the displayed rectangle area

	*

	* Only defined if there is a file block present.

	*/

	function play_qt_file(obj)

	{

		var rectangle = obj.GetRectangle();



		if (rectangle)

		{

			rectangle = rectangle.split(',')

			var x1 = parseInt(rectangle[0]);

			var x2 = parseInt(rectangle[2]);

			var y1 = parseInt(rectangle[1]);

			var y2 = parseInt(rectangle[3]);



			var width = (x1 < 0) ? (x1 * -1) + x2 : x2 - x1;

			var height = (y1 < 0) ? (y1 * -1) + y2 : y2 - y1;

		}

		else

		{

			var width = 200;

			var height = 0;

		}



		obj.width = width;

		obj.height = height + 16;



		obj.SetControllerVisible(true);



		obj.Play();

	}

<!-- ENDIF -->



//-->

</script>

</head>

<body class="{S_CONTENT_DIRECTION}">



<a name="top"></a>



<div id="wrapheader">



	<div id="logodesc">

		<table width="100%" cellspacing="0">

		<tr>

			<td><a href="{U_INDEX}">{SITE_LOGO_IMG}</a></td>

			<td width="100%" align="center"><h1>{SITENAME}</h1><span class="gen">{SITE_DESCRIPTION}</span></td>

		</tr>

		</table>

	</div>



	<div id="menubar">

		<table width="100%" cellspacing="0">

		<tr>

			<td class="genmed">

				<!-- IF not S_IS_BOT --><a class="link02" href="{U_LOGIN_LOGOUT}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="{L_LOGIN_LOGOUT}" /> </a><a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a>&nbsp;<!-- ENDIF -->

				<!-- IF U_RESTORE_PERMISSIONS --> &nbsp;<a class="link02" href="{U_RESTORE_PERMISSIONS}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="{L_RESTORE_PERMISSIONS}" /> </a><a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a><!-- ENDIF -->

				<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN --> &nbsp;<span style="color: red;">{L_BOARD_DISABLED}</span><!-- ENDIF -->

				<!-- IF not S_IS_BOT -->

					<!-- IF S_USER_LOGGED_IN -->

						<!-- IF S_DISPLAY_PM --> &nbsp;<a class="link02" href="{U_PRIVATEMSGS}"><img src="{T_THEME_PATH}/images/icon_mini_message.gif" width="12" height="13" alt="{L_MESSAGES}" /> </a><a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}<!-- IF PRIVATE_MESSAGE_INFO_UNREAD -->, {PRIVATE_MESSAGE_INFO_UNREAD}<!-- ENDIF --></a><!-- ENDIF -->

					<!-- ELSE --> &nbsp;<a class="link02" href="{U_REGISTER}"><img src="{T_THEME_PATH}/images/icon_mini_register.gif" width="12" height="13" alt="{L_REGISTER}" /> </a><a href="{U_REGISTER}">{L_REGISTER}</a>

					<!-- ENDIF -->

				<!-- ENDIF -->

			</td>

			<td class="genmed" align="{S_CONTENT_FLOW_END}">

				<a class="link02" href="{U_FAQ}"><img src="{T_THEME_PATH}/images/icon_mini_faq.gif" width="12" height="13" alt="{L_FAQ}" /> </a><a href="{U_FAQ}">{L_FAQ}</a>

				<!-- IF S_DISPLAY_SEARCH -->&nbsp; &nbsp;<a class="link02" href="{U_SEARCH}"><img src="{T_THEME_PATH}/images/icon_mini_search.gif" width="12" height="13" alt="{L_SEARCH}" /> </a><a href="{U_SEARCH}">{L_SEARCH}</a><!-- ENDIF -->

				<!-- IF not S_IS_BOT -->

					<!-- IF S_DISPLAY_MEMBERLIST -->&nbsp; &nbsp;<a class="link02" href="{U_MEMBERLIST}"><img src="{T_THEME_PATH}/images/icon_mini_members.gif" width="12" height="13" alt="{L_MEMBERLIST}" /> </a><a href="{U_MEMBERLIST}">{L_MEMBERLIST}</a><!-- ENDIF -->

					<!-- IF S_USER_LOGGED_IN -->&nbsp; &nbsp;<a class="link02" href="{U_PROFILE}"><img src="{T_THEME_PATH}/images/icon_mini_profile.gif" width="12" height="13" alt="{L_PROFILE}" /> </a><a href="{U_PROFILE}">{L_PROFILE}</a><!-- ENDIF -->

				<!-- ENDIF -->

			</td>

		</tr>

		</table>

	</div>



	<div id="datebar">

		<table width="100%" cellspacing="0">

		<tr>

			<td class="gensmall"><!-- IF S_USER_LOGGED_IN -->{LAST_VISIT_DATE}<!-- ENDIF --></td>

			<td class="gensmall" align="{S_CONTENT_FLOW_END}">{CURRENT_TIME}<br /></td>

		</tr>

		</table>

	</div>



</div>



<div id="wrapcentre">



	<table class="tablebg" width="100%" cellspacing="1" cellpadding="0" style="margin-top: 5px;">

	<tr>

		<td class="row1">

			<div class="breadcrumbs"><a href="{U_INDEX}">{L_INDEX}</a><!-- BEGIN navlinks --> &#187; <a 



href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></div>

	<div class="searchbar">

	<!-- IF S_DISPLAY_SEARCH -->

		<a href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a> &nbsp; <a href="{U_SEARCH_ACTIVE_TOPICS}">{L_SEARCH_ACTIVE_TOPICS}</a> &nbsp; <!-- IF S_USER_LOGGED_IN -->

		<a href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a> &nbsp; <a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>

		<!-- ENDIF -->

	<!-- ENDIF -->

	</div>

		</td>

	</tr>

	</table>

	<br />
Thanks in advance for any help that you can provide.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

bigbabol wrote:any news reiserfs about line 466? :D
No, please paste here all notices
access http://yourdomain.com/phpbbdir/wow/phpa ... ar%20Boots from your domain and show me all error messages.
hansjorgen wrote:This is very odd. First you have to test if you server can open a remote site.

Try this code

Code: Select all

<?
ini_set('user_agent', 'Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061010 Firefox/2.0');

$server = urlencode(utf8_encode('Your Realm Name'));
$name   = urlencode(utf8_encode('Your Guild Name'));

 $url = 'http://www.wowarmory.com/guild-info.xml?r='.$server.'&n='.$name;
 $strYourXML = file_get_contents($url);
 die(htmlentities($strYourXML));
?>
Run the code and show here what you get!

Look the code running on my webserver: http://reiserfs.killermonkeys.net/scrip ... /teste.php
Looks like it works:
http://www.darksunguild.net/test.php
yes its working, i dont know why the normal code is not. Try to enable debuggin changing this:

Code: Select all

$item = $item['itemtooltips']['itemtooltip'];

if (count($item) == 0) die("<br /> <br /> Unable to connect to Armory portal, Or item name not found. Try again <br /> <br /> <br />");

//DEBUGGING
// print_r($item);
to this

Code: Select all

//$item = $item['itemtooltips']['itemtooltip'];

//if (count($item) == 0) die("<br /> <br /> Unable to connect to Armory portal, Or item name not found. Try again <br /> <br /> <br />");

//DEBUGGING
 print_r($item);
Axti wrote:Hello. I got one question. Which code to BBCode is correct? also can u write in first post or here as next reply "Full Instruction" for installed this MOD ? Thanks

Regards
On the latest release is the last BBcode just read the instructions wow_armory_items.xml file

Got to the bottom of the file DIY Instructions and there is.

Zorrander wrote:Hello!

I'm having a problem with the mod (I'm certain it's my fault), and am hoping that you can help. The links to the items show up fine and link to the correct pages in the armory. But the popup tooltip for the items does not appear when I hover over them. I'm using Firefox as my browser and a theme that I downloaded from a link on the forums here.

Here is a copy of my overall_header.html file.

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">

<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />

<meta http-equiv="content-language" content="{S_USER_LANG}" />

<meta http-equiv="content-style-type" content="text/css" />

<meta http-equiv="imagetoolbar" content="no" />

<meta name="resource-type" content="document" />

<meta name="distribution" content="global" />

<meta name="copyright" content="2002-2006 phpBB Group" />

<meta name="keywords" content="" />

<meta name="description" content="" />

{META}

<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>



<!-- IF T_STYLESHEET_LINK -->

<link rel="stylesheet" href="{T_STYLESHEET_LINK}" type="text/css" />
<!-- ELSE -->

<style type="text/css">

{T_THEME_DATA}

</style>

<!-- ENDIF -->


<script type="text/javascript" src="ajax_tooltip/js/ajax-dynamic-content.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax.js"></script>
<script type="text/javascript" src="ajax_tooltip/js/ajax-tooltip.js"></script>
<link rel="stylesheet" href="ajax_tooltip/css/wow-item.css" type="text/css" />

<script type="text/javascript">

<!--

<!-- IF S_USER_PM_POPUP -->

	if ({S_NEW_PM})

	{

		window.open('{UA_POPUP_PM}', '_phpbbprivmsg', 'height=225,resizable=yes,width=400');

	}

<!-- ENDIF -->



function popup(url, width, height)

{

	window.open(url.replace(/&/g, '&'), '_popup', 'HEIGHT=' + height + ',resizable=yes,scrollbars=yes, WIDTH=' + width);

	return false;

}



function jumpto()

{

	var page = prompt('{LA_JUMP_PAGE}:', '{ON_PAGE}');

	var perpage = '{PER_PAGE}';

	var base_url = '{BASE_URL}';



	if (page !== null && !isNaN(page) && page > 0)

	{

		document.location.href = base_url.replace(/&/g, '&') + '&start=' + ((page - 1) * perpage);

	}

}



/**

* Find a member

*/

function find_username()

{

	<!-- IF UA_FIND_USERNAME -->

	window.open('{UA_FIND_USERNAME}', '_usersearch', 'height=500, resizable=yes, scrollbars=yes, width=740');

	<!-- ENDIF -->

	return false;

}



/**

* Mark/unmark checklist

* id = ID of parent container, name = name prefix, state = state [true/false]

*/

function marklist(id, name, state)

{

	var parent = document.getElementById(id);

	if (!parent)

	{

		eval('parent = document.' + id);

	}



	if (!parent)

	{

		return;

	}



	var rb = parent.getElementsByTagName('input');

	

	for (var r = 0; r < rb.length; r++)

	{

		if (rb[r].name.substr(0, name.length) == name)

		{

			rb[r].checked = state;

		}

	}

}



<!-- IF ._file -->



	/**

	* Play quicktime file by determining it's width/height

	* from the displayed rectangle area

	*

	* Only defined if there is a file block present.

	*/

	function play_qt_file(obj)

	{

		var rectangle = obj.GetRectangle();



		if (rectangle)

		{

			rectangle = rectangle.split(',')

			var x1 = parseInt(rectangle[0]);

			var x2 = parseInt(rectangle[2]);

			var y1 = parseInt(rectangle[1]);

			var y2 = parseInt(rectangle[3]);



			var width = (x1 < 0) ? (x1 * -1) + x2 : x2 - x1;

			var height = (y1 < 0) ? (y1 * -1) + y2 : y2 - y1;

		}

		else

		{

			var width = 200;

			var height = 0;

		}



		obj.width = width;

		obj.height = height + 16;



		obj.SetControllerVisible(true);



		obj.Play();

	}

<!-- ENDIF -->



//-->

</script>

</head>

<body class="{S_CONTENT_DIRECTION}">



<a name="top"></a>



<div id="wrapheader">



	<div id="logodesc">

		<table width="100%" cellspacing="0">

		<tr>

			<td><a href="{U_INDEX}">{SITE_LOGO_IMG}</a></td>

			<td width="100%" align="center"><h1>{SITENAME}</h1><span class="gen">{SITE_DESCRIPTION}</span></td>

		</tr>

		</table>

	</div>



	<div id="menubar">

		<table width="100%" cellspacing="0">

		<tr>

			<td class="genmed">

				<!-- IF not S_IS_BOT --><a class="link02" href="{U_LOGIN_LOGOUT}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="{L_LOGIN_LOGOUT}" /> </a><a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a>&nbsp;<!-- ENDIF -->

				<!-- IF U_RESTORE_PERMISSIONS --> &nbsp;<a class="link02" href="{U_RESTORE_PERMISSIONS}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="{L_RESTORE_PERMISSIONS}" /> </a><a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a><!-- ENDIF -->

				<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN --> &nbsp;<span style="color: red;">{L_BOARD_DISABLED}</span><!-- ENDIF -->

				<!-- IF not S_IS_BOT -->

					<!-- IF S_USER_LOGGED_IN -->

						<!-- IF S_DISPLAY_PM --> &nbsp;<a class="link02" href="{U_PRIVATEMSGS}"><img src="{T_THEME_PATH}/images/icon_mini_message.gif" width="12" height="13" alt="{L_MESSAGES}" /> </a><a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}<!-- IF PRIVATE_MESSAGE_INFO_UNREAD -->, {PRIVATE_MESSAGE_INFO_UNREAD}<!-- ENDIF --></a><!-- ENDIF -->

					<!-- ELSE --> &nbsp;<a class="link02" href="{U_REGISTER}"><img src="{T_THEME_PATH}/images/icon_mini_register.gif" width="12" height="13" alt="{L_REGISTER}" /> </a><a href="{U_REGISTER}">{L_REGISTER}</a>

					<!-- ENDIF -->

				<!-- ENDIF -->

			</td>

			<td class="genmed" align="{S_CONTENT_FLOW_END}">

				<a class="link02" href="{U_FAQ}"><img src="{T_THEME_PATH}/images/icon_mini_faq.gif" width="12" height="13" alt="{L_FAQ}" /> </a><a href="{U_FAQ}">{L_FAQ}</a>

				<!-- IF S_DISPLAY_SEARCH -->&nbsp; &nbsp;<a class="link02" href="{U_SEARCH}"><img src="{T_THEME_PATH}/images/icon_mini_search.gif" width="12" height="13" alt="{L_SEARCH}" /> </a><a href="{U_SEARCH}">{L_SEARCH}</a><!-- ENDIF -->

				<!-- IF not S_IS_BOT -->

					<!-- IF S_DISPLAY_MEMBERLIST -->&nbsp; &nbsp;<a class="link02" href="{U_MEMBERLIST}"><img src="{T_THEME_PATH}/images/icon_mini_members.gif" width="12" height="13" alt="{L_MEMBERLIST}" /> </a><a href="{U_MEMBERLIST}">{L_MEMBERLIST}</a><!-- ENDIF -->

					<!-- IF S_USER_LOGGED_IN -->&nbsp; &nbsp;<a class="link02" href="{U_PROFILE}"><img src="{T_THEME_PATH}/images/icon_mini_profile.gif" width="12" height="13" alt="{L_PROFILE}" /> </a><a href="{U_PROFILE}">{L_PROFILE}</a><!-- ENDIF -->

				<!-- ENDIF -->

			</td>

		</tr>

		</table>

	</div>



	<div id="datebar">

		<table width="100%" cellspacing="0">

		<tr>

			<td class="gensmall"><!-- IF S_USER_LOGGED_IN -->{LAST_VISIT_DATE}<!-- ENDIF --></td>

			<td class="gensmall" align="{S_CONTENT_FLOW_END}">{CURRENT_TIME}<br /></td>

		</tr>

		</table>

	</div>



</div>



<div id="wrapcentre">



	<table class="tablebg" width="100%" cellspacing="1" cellpadding="0" style="margin-top: 5px;">

	<tr>

		<td class="row1">

			<div class="breadcrumbs"><a href="{U_INDEX}">{L_INDEX}</a><!-- BEGIN navlinks --> &#187; <a 



href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></div>

	<div class="searchbar">

	<!-- IF S_DISPLAY_SEARCH -->

		<a href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a> &nbsp; <a href="{U_SEARCH_ACTIVE_TOPICS}">{L_SEARCH_ACTIVE_TOPICS}</a> &nbsp; <!-- IF S_USER_LOGGED_IN -->

		<a href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a> &nbsp; <a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>

		<!-- ENDIF -->

	<!-- ENDIF -->

	</div>

		</td>

	</tr>

	</table>

	<br />
Thanks in advance for any help that you can provide.
Check your Javascript console on your browser to see if have any error.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

bigbabol wrote:any news reiserfs about line 466? :D
Look this notice happens to everyone, BUT noone likes to report Notices from php, only warnings and errors.

Go to your php.ini and set error_reporting to:
error_reporting = E_ALL & ~E_NOTICE
restart your webserver and everything will be fine.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

New version added

2007-09-06 - Version 1.0.4

*

Version 1.0.4: Fix the Gem Data, Gems and meta gems was showing only the name not their stats Ex: [wow]Brutal Earthstorm Diamond[/wow]
*

Fix the item description, now is not invisible
Zorrander
Registered User
Posts: 6
Joined: Thu Sep 06, 2007 4:25 pm

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Zorrander »

Thanks for the quick response.

No errors are shown, have anything else in mind that might be causing my trouble?
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

I try the new codes to suport another languages posted from flokohlert, and works.

But i put the suport to one language only, i do not will put the foreach to search on all languages.

Couse the mod make two request to armory
1) Search the item by name
2) Get the item data using the itemID

If i put the foreach to all languagens the mod will
1) Search english items
2) Search spanish items
3) Search german items
4) Search french items
5) Get the item data using the itemID

Five Requests to armory will make the mod slower.

So the mod will have two options on phpArmory.class.php

Code: Select all

      /**
     * the language items get fetched
     * courtesy from flokohlert
     * @var de/en/fr/es
     */
        var $lang = "us";

        /**
     * The URL of the Armory website
     * 
     * @var string 
     */
        var $armory = "http://www.wowarmory.com/";
//       var $armory = "http://eu.wowarmory.com/";
I found only problems with special characters like á ó é ã ö ö, but i will try to fix this and release a RC2 version with multi-language suport soon.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

Zorrander wrote:Thanks for the quick response.

No errors are shown, have anything else in mind that might be causing my trouble?
can you show your forum's url?
Zorrander
Registered User
Posts: 6
Joined: Thu Sep 06, 2007 4:25 pm

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Zorrander »

reiserfs wrote:
Zorrander wrote:Thanks for the quick response.

No errors are shown, have anything else in mind that might be causing my trouble?
can you show your forum's url?
Sent you pertinent information in a PM.

Thanks again for your help on this.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

Ok, i got the problem and send to you the answer.
User avatar
reiserfs
Registered User
Posts: 125
Joined: Wed May 23, 2007 8:47 pm
Location: Maceió - Brazil
Contact:

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by reiserfs »

EQDKP + PHPBB3 - itemstats

I get the new mod to put EQDKP and phpBB3 to work together.
I made some changes to make some color show up, and make the system more cool look
http://killermonkeys.net/listmembers.php

The thing i dont want in the EQDKP Mod was the itemstats, couse i already have my own mod, the XML armory, so if you have the EQDKP and want to use XML Armory instead itemstats.

First delete the itemstats Directory
Then remove or comment all include_once($phpbb_root_path . 'itemstats/eqdkp_itemstats.php'); from EQDKP files.
then put this function code on the common.php after the EQDKP codes

Code: Select all

function itemstats_decorate_name($n)
{
            return '<a href="http://www.wowarmory.com/search.xml?searchQuery='.$n.'&searchType=items" target="new" onmouseover=\'ajax_showTooltip("wow/phparmory/item.php?v='.$n.'",this);return false\' onmouseout=\'ajax_hideTooltip()\'><strong><img src=\'wow/phparmory/wow.png\' border=\'0\'>['.$n.']</strong></a>';

}
Working without itemstats http://killermonkeys.net/viewraid.php?sid=&r=120
Axti
Registered User
Posts: 8
Joined: Thu Sep 06, 2007 1:52 pm

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Axti »

Image

Can u tell me what i got not correct?
hansjorgen
Registered User
Posts: 8
Joined: Tue Aug 29, 2006 9:06 am

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by hansjorgen »

yes its working, i dont know why the normal code is not. Try to enable debuggin changing this:

Code: Select all

$item = $item['itemtooltips']['itemtooltip'];

if (count($item) == 0) die("<br /> <br /> Unable to connect to Armory portal, Or item name not found. Try again <br /> <br /> <br />");

//DEBUGGING
// print_r($item);
to this

Code: Select all

//$item = $item['itemtooltips']['itemtooltip'];

//if (count($item) == 0) die("<br /> <br /> Unable to connect to Armory portal, Or item name not found. Try again <br /> <br /> <br />");

//DEBUGGING
 print_r($item);
This is what I get after enabling debugging:
Image
Angerphile
Registered User
Posts: 18
Joined: Sat Jan 14, 2006 6:16 am

Re: [RC1] Armory World of Warcraft Items Tooltip

Post by Angerphile »

erm, I'm also noticing an error with items like "[Helm of the Fallen Champion]"...

It's listing the info as "Classe: Shaman" instead of showing all the classes/etc.
Locked

Return to “[3.0.x] Abandoned MODs”