[ABD] My Page - Personal web page for your members

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

kevinaf wrote:Mabey josh nows how, something in de sql tables of with the call of sql data. Otherwise i trow that portal out of itt. The text i put on the mypage page seems to be no where :roll:
not sure how it would be getting data from a portal, does it do this for every page you try to create?
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

radunazar wrote:Where do i download the 0.2.0 installer ?
http://www.jtsenterprises.biz/phpbbmods ... _0.2.0.zip
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

sotis wrote:Josh,
There is not option to administrate user's pages
not yet
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

BiggDawgg wrote:Josh, any idea's on this "not an image" problem
does this happen with every image you try to upload?
this script uses getimagesize to decide if a file is an image or not. There may be a problem with the image.

Josh
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
kevinaf
Registered User
Posts: 171
Joined: Tue Aug 12, 2008 9:45 am

Re: [BETA] My Page - Personal web page for your members

Post by kevinaf »

Yes everypage i made with mypage shows portal info.

And i have tried many pic to upload, but non of them will upload.

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

kevinaf wrote:Yes everypage i made with mypage shows portal info.

And i have tried many pic to upload, but non of them will upload.
Do you have a link to the portal you are using?

Are you using at least php version 4?
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
BiggDawgg
Registered User
Posts: 356
Joined: Tue Oct 19, 2004 8:46 am
Location: USA, Illinois
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by BiggDawgg »

Josh18657 wrote:
BiggDawgg wrote:Josh, any idea's on this "not an image" problem
does this happen with every image you try to upload?
this script uses getimagesize to decide if a file is an image or not. There may be a problem with the image.

Josh

Yes, as far as I can tell it does it with every photo ... I tried several different sizes and I tried both .jpg and .gif photo's

User avatar
kevinaf
Registered User
Posts: 171
Joined: Tue Aug 12, 2008 9:45 am

Re: [BETA] My Page - Personal web page for your members

Post by kevinaf »

www.Alphaportal.net but i just discover that it was een older version i have, just uninstalled it and now mypage works fine. Soon iam gone try itt with te newer version of Alpha portal, let you knwo the results.

User avatar
BiggDawgg
Registered User
Posts: 356
Joined: Tue Oct 19, 2004 8:46 am
Location: USA, Illinois
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by BiggDawgg »

Kev, if you still have problems with that portal I would suggest trying phpbb3 portal ... I use it and love it ... you can take a look at mine by clicking the link in my sig

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

this was not tested but here may be a way to fix your upload issue

in includes/ucp/ucp_mypage.php
find

Code: Select all

					if ($size = getimagesize($_FILES['uploadedfile']['tmp_name']))
					{
after add

Code: Select all

						// new addition start here
						$size = $size;
					}
					elseif (($_FILES['uploadedfile']['type']=="image/gif") || ($_FILES['uploadedfile']['type']=="image/pjpeg") || ($_FILES['uploadedfile']['type']=="image/jpeg") || ($_FILES['uploadedfile']['type']=="image/png"))
					{
						$size['0'] = $size['1'] = $size['3'] = '0';
						$size['mime'] = $_FILES['uploadedfile']['type'];
					}
					else
					{
						$size = false;
					}
					
					if ($size)
					{
						// end new addition
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
BiggDawgg
Registered User
Posts: 356
Joined: Tue Oct 19, 2004 8:46 am
Location: USA, Illinois
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by BiggDawgg »

No such luck Josh ... I still get the same message

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 »

if the above does not work, you can do the following to allow all files and trust your members to only upload images, I highly recommend against doing this

find

Code: Select all


					if ($size = getimagesize($_FILES['uploadedfile']['tmp_name']))
					{
						// new addition start here
						$size = $size;
					}
					elseif (($_FILES['uploadedfile']['type']=="image/gif") || ($_FILES['uploadedfile']['type']=="image/pjpeg") || ($_FILES['uploadedfile']['type']=="image/jpeg") || ($_FILES['uploadedfile']['type']=="image/png"))
					{
						$size['0'] = $size['1'] = $size['3'] = '0';
						$size['mime'] = $_FILES['uploadedfile']['type'];
					}
					else
					{
						$size = false;
					}
					
					if ($size)
					{
or this

Code: Select all

					if ($size = getimagesize($_FILES['uploadedfile']['tmp_name']))
					{
and replace with this

Code: Select all

					if ($_FILES['uploadedfile']['tmp_name'])
					{
						$size['0'] = $size['1'] = $size['3'] = $size['mime'] = '0';
Keep in mind this will cause issues if a user uploads something other than an image
Josh
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
kevinaf
Registered User
Posts: 171
Joined: Tue Aug 12, 2008 9:45 am

Re: [BETA] My Page - Personal web page for your members

Post by kevinaf »

BiggDawgg wrote:Kev, if you still have problems with that portal I would suggest trying phpbb3 portal ... I use it and love it ... you can take a look at mine by clicking the link in my sig
Thanks but i was looking to Board3 portal

User avatar
BiggDawgg
Registered User
Posts: 356
Joined: Tue Oct 19, 2004 8:46 am
Location: USA, Illinois
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by BiggDawgg »

Josh, the one thing that really has me puzzled is what is different between your test site and my site? I can upload pics at your site with no problem but at my site I get that error saying "not an image" .... so something must be different.

btw ... I tried all of the changes and still no luck.

kevinroxx
Registered User
Posts: 94
Joined: Fri Dec 14, 2007 9:57 pm

Re: [BETA] My Page - Personal web page for your members

Post by kevinroxx »

Hey Josh,
Just installed the new update today. I think you are missing a file for the administration, correct me if I am wrong though.

In the newest download this file:

Code: Select all

/style/mypage/acp_general.html 
seems to be missing.

Thanks in advance,
Kevin

Locked

Return to “[3.0.x] Abandoned MODs”