[ABD] My Page - Personal web page for your members

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
JeRicHoOL
Registered User
Posts: 449
Joined: Sun Jun 01, 2008 4:02 pm

Re: [BETA] My Page - Personal web page for your members

Post by JeRicHoOL » Tue Feb 24, 2009 2:39 am

I just created a page and now I get the following error.

Code: Select all

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 1245184 bytes) in /var/kunden/webs/web158/the-kliq.com/includes/utf/data/confusables.php on line 1
Why is that? How to fix it?

EDIT: I found it it was because of the large background image. How can I allow such large wallpapers as background?

Also, it doesn't display my "MyPages" in my profile. It only displays "No pages created" but I already have pages created. :S How to fix this?

toomedic
Registered User
Posts: 141
Joined: Tue Apr 15, 2008 6:31 am

Re: [BETA] My Page - Personal web page for your members

Post by toomedic » Tue Feb 24, 2009 4:39 am

JeRicHoOL wrote:Also, it doesn't display my "MyPages" in my profile. It only displays "No pages created" but I already have pages created. :S How to fix this?
When you set the mypage up you have to change the order from 0 to 1 or more. That allows you to see it in the profile. Just goto edit your mypage, and change that value.

JeRicHoOL
Registered User
Posts: 449
Joined: Sun Jun 01, 2008 4:02 pm

Re: [BETA] My Page - Personal web page for your members

Post by JeRicHoOL » Tue Feb 24, 2009 5:17 am

toomedic wrote:
JeRicHoOL wrote:Also, it doesn't display my "MyPages" in my profile. It only displays "No pages created" but I already have pages created. :S How to fix this?
When you set the mypage up you have to change the order from 0 to 1 or more. That allows you to see it in the profile. Just goto edit your mypage, and change that value.
Where is the value thing? There is nothing where I have to enter it. :?

toomedic
Registered User
Posts: 141
Joined: Tue Apr 15, 2008 6:31 am

Re: [BETA] My Page - Personal web page for your members

Post by toomedic » Tue Feb 24, 2009 8:13 am

Goto your UCP... Click on mypage tab... Click on overview Scroll down to "order" change that from 0 to 1 And that should solve your problem.. Make sure your users know that too...

User avatar
woipi90
Registered User
Posts: 908
Joined: Mon Feb 16, 2009 5:32 pm
Location: Austria

Re: [BETA] My Page - Personal web page for your members

Post by woipi90 » Tue Feb 24, 2009 8:21 am

are you planning on a new release of mypage or not?

would be super if you release a nex one....


grz woipi
My mods: Ultimate Board Clubs
Support: only for the UBCS!
-----
function be_friends($uid, $u){return ($u == $user->['user_id']) ? false : true;}
$this->be_friends($uid, $user->['user_id']) ? $allow_pm : echo "You failed again";

JeRicHoOL
Registered User
Posts: 449
Joined: Sun Jun 01, 2008 4:02 pm

Re: [BETA] My Page - Personal web page for your members

Post by JeRicHoOL » Tue Feb 24, 2009 2:20 pm

toomedic wrote:Goto your UCP... Click on mypage tab... Click on overview Scroll down to "order" change that from 0 to 1 And that should solve your problem.. Make sure your users know that too...
OK it works now. Is there a way that I can make "1" as default value so it would automatically be displayed in the profile?

Thanks :)

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 » Tue Feb 24, 2009 4:08 pm

JeRicHoOL wrote:
toomedic wrote:Goto your UCP... Click on mypage tab... Click on overview Scroll down to "order" change that from 0 to 1 And that should solve your problem.. Make sure your users know that too...
OK it works now. Is there a way that I can make "1" as default value so it would automatically be displayed in the profile?

Thanks :)
yes but it's not recommended

all pages should have a different number with 0 being the exception

pages numbered 0 are not shown anywhere so a member can have a work in progress page that is not displayed on the site
the page numbered 1 is the one linked to in posts and also the first page listed in the users profile
the rest of the pages are listed in the profile in the order numbered
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 » Tue Feb 24, 2009 4:09 pm

woipi90 wrote:are you planning on a new release of mypage or not?

would be super if you release a nex one....


grz woipi
I work on mypage as time permits.
Hopefully soon I'll have time for a new version

Josh
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by muggins » Sat Feb 28, 2009 2:29 pm

My users are clamoring for this. I'll give it a try, thanks!
Muggins

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by muggins » Sat Feb 28, 2009 8:14 pm

Josh18657 wrote:
toomedic wrote:Need Help... I have set this Mod up in another board, but can't get it to work in the board I'm working with now. I have uploaded everything, did all the alterations to the code. I ran mypage_install with success. When I go to set it up in the UCP part of the ACP, I set it up ok.. I enable it, but it does not show up in the UCP. If I edit the module and change the module to anything other then mypage [ucp_mypage] the mypage tab appears, but without mypage info. Anytime I use mypage [ucp_mypage] the tab dissapears... Any Ideas?
You don't need to set any modules up in the acp, just need to add permissions.
To fix, remove all the mypage modules from the database using phpMyAdmin and then rerun the mypage installer.
After this edit the permissions for individual users or groups.
I am having the same problem. I don't quite understand your instructions here. My test user had his permissions set after the installation, which I assume is the only way to have the permissions.

What am I accomplishing by removing the tables and reinstalling? :?

Edit: Apparently nothing... I dropped the 4 tables and ran the installer again, with OKs for the results. Purged the cache manually and did <ctrl> F5 in the browser, still no joy. :(

I have verified that 9 modules were added, and my profile shows a "my pages" section, under which "no pages created" shows up.
Muggins

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by muggins » Tue Mar 03, 2009 11:06 pm

To those of you who have installed this mod and actually use it, I need some help.

The author seems convinced that repeating the same actions will result in some new result, but I am not.

Anyone? Josh?
Muggins

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 » Tue Mar 03, 2009 11:49 pm

muggins wrote:To those of you who have installed this mod and actually use it, I need some help.

The author seems convinced that repeating the same actions will result in some new result, but I am not.

Anyone? Josh?
if the mypage module is showing in the ucp after you add the permission and you can add a page then you simply need to change the page order to any number other then 0.

If that doesn't work and you don't mind it would be helpful for me if you made a post at the site where the download is made available. This isn't trying to get members at that site but makes it easier for me to keep track of questions.
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by muggins » Wed Mar 04, 2009 12:19 am

That is the whole point, Josh. I've been modding my board with success for nearly a year, so it isn't some n00b's confusion.

I have followed the instructions in the install, and followed those up with your suggestions to remove the tables from the database prior to running the installer again. Twice.

As a previous poster reported, any other module I attempt to display in the UCP shows up as a tab except yours...

I do not see the tab in the UCP. Nor does my sockpuppet test user. Therefore I can't add a page. I should do what? Add the permission for every group I belong to? I am the founder, the admin, a global moderator, and a registered user.

My assumption was that if I add the permission and refresh, that user would then see the tab in the UCP.

What can you suggest beyond repeating what doesn't work?
Muggins

Josh18657
Registered User
Posts: 425
Joined: Wed Nov 30, 2005 9:55 pm
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by Josh18657 » Wed Mar 04, 2009 12:32 am

muggins wrote:That is the whole point, Josh. I've been modding my board with success for nearly a year, so it isn't some n00b's confusion.

I have followed the instructions in the install, and followed those up with your suggestions to remove the tables from the database prior to running the installer again. Twice.

As a previous poster reported, any other module I attempt to display in the UCP shows up as a tab except yours...

I do not see the tab in the UCP. Nor does my sockpuppet test user. Therefore I can't add a page. I should do what? Add the permission for every group I belong to? I am the founder, the admin, a global moderator, and a registered user.

My assumption was that if I add the permission and refresh, that user would then see the tab in the UCP.

What can you suggest beyond repeating what doesn't work?
to clarify what you have already done and tried, when you look at the modules in the ucp, there should only be 9 module_langname that include "_mp_ ", do not go by the mypage in module_basename count
I can help you edit your forums at a reasonable price, send a PM if you can't get something figured out here.

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [BETA] My Page - Personal web page for your members

Post by muggins » Wed Mar 04, 2009 12:52 am

Josh18657 wrote: to clarify what you have already done and tried, when you look at the modules in the ucp, there should only be 9 module_langname that include "_mp_ ", do not go by the mypage in module_basename count
That doesn't help to clarify anything for me, I'm afraid.

Maybe this will help?

Image

Image

Image

Image

What other information can I give you?
Last edited by muggins on Thu Aug 13, 2009 3:16 pm, edited 1 time in total.
Muggins

Locked

Return to “[3.0.x] Abandoned MODs”