Page 1 of 6

[ABD] Attachment watermark mod

Posted: Fri Sep 14, 2007 3:05 am
by Josh18657
MOD Title: attachment watermark
MOD Description: Allows you to watermark image attachments with text or an image
MOD Version: 0.1.1

MOD Download: Here
Last Stable version: None

Demo Board: http://demo.jtsenterprises.biz/viewtopic.php?f=2&t=5
Demo Username: Not needed
Demo Password: Not needed

required the GD2 php module to be installed

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 3:08 am
by Josh18657
Need some testers for this as I have only been able to test the text watermark so far.

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 6:42 am
by Holger
I will test this this evening! Thank you for your work!

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 7:25 am
by Tw3nt
Will this watermark all images previously uploaded or only from the time of the mod being installed?

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 7:41 am
by Tw3nt
I tried it out but when uploading an image the result is this.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 441: Undefined variable: img
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 442: Undefined variable: type
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 441: Undefined variable: img
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 442: Undefined variable: type
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 447: getimagesize(http://www.gamevixenzone.com/images/logo.png) [function.getimagesize]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 477: Undefined variable: type
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 477: Undefined variable: img
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 228: imagesy(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 229: imagesx(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 258: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 311: imagecolortransparent(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 312: imagecolortransparent(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 312: imagecolorsforindex(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 313: imagesx(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 313: imagesy(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 313: imagecopy(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 315: Undefined variable: trans
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 323: imagecolorallocatealpha(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 332: imagecolortransparent(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/watermark/phpWatermark-0.3/phpWatermark.inc.php on line 369: imagecopy(): supplied argument is not a valid Image resource
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4188: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3692)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4190: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3692)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4191: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3692)

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 11:00 am
by Josh18657

Code: Select all

getimagesize(http://www.gamevixenzone.com/images/logo.png) [function.getimagesize]:
make sure the url to the file is correct, if so try

Code: Select all

images/logo.png

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 14, 2007 11:01 am
by Josh18657
Tw3nt wrote:Will this watermark all images previously uploaded or only from the time of the mod being installed?
just new images

Re: [BETA] Attachment watermark mod

Posted: Sat Sep 15, 2007 9:29 am
by Tw3nt
I don't think I will be paying for someone to help me install the mod when I can do it myself.
I just want to know why it isn't working. I checked everything twice over so I don't know.

Re: [BETA] Attachment watermark mod

Posted: Sat Sep 15, 2007 10:02 am
by Holger
Don't worry, it is just joshs signature.

http://www.gamevixenzone.com/images/logo.png is not existing, so the mod won't work!

Re: [BETA] Attachment watermark mod

Posted: Fri Sep 21, 2007 6:34 pm
by patx
Hi!

Thanks for this mod - but there seems to be some problem with images as watermark. My transparent PNG-24 has a black box as background. Some hints or is this a matter of the script?

Greets

PS @ Holger:
Gruß aus Hannover nach Hannover :D ;)

Re: [BETA] Attachment watermark mod

Posted: Mon Nov 05, 2007 5:22 am
by MagicMike304
This Mod still being worked on?

Re: [BETA] Attachment watermark mod

Posted: Mon Nov 05, 2007 12:39 pm
by yaw_pakhtoon
there is a imageshack uploading bar Mod.. with this mod work with that..
i mean when a person is uploading to imageshack through that mod, with this mod still ad watermark on the images..

Re: [BETA] Attachment watermark mod

Posted: Tue Nov 06, 2007 8:54 pm
by Josh18657
MagicMike304 wrote:This Mod still being worked on?
At this time no, but it should work fine as is.

In the somewhat near future I should have more time to add to this mod unless someone would like to take over.

Josh

Re: [BETA] Attachment watermark mod

Posted: Tue Nov 06, 2007 8:55 pm
by Josh18657
yaw_pakhtoon wrote:there is a imageshack uploading bar Mod.. with this mod work with that..
i mean when a person is uploading to imageshack through that mod, with this mod still ad watermark on the images..
Doubt it very highly, but maybe a future add on.

Josh

Re: [BETA] Attachment watermark mod

Posted: Tue Nov 06, 2007 8:57 pm
by Josh18657
patx wrote:Hi!

Thanks for this mod - but there seems to be some problem with images as watermark. My transparent PNG-24 has a black box as background. Some hints or is this a matter of the script?

Greets

PS @ Holger:
Gruß aus Hannover nach Hannover :D ;)
I haven't had much time to test with an image as the watermark, but it did work with the included test image. I'd say check and make sure you image has a transparent background and is small enough to fit over the uploaded image.

Josh