Page 79 of 157

Re: [Beta] Medal System MOD for phpBB3

Posted: Thu Aug 21, 2008 5:16 pm
by KPDub
Hi there, firstly great mod.

I have a very small problem with it, the icon_medal.gif doesn't dispaly at the top of the board.

Its on my server but I can't find the file that references it to check if its okay :D

Re: [Beta] Medal System MOD for phpBB3

Posted: Thu Aug 21, 2008 6:42 pm
by drewtscott
KPDub wrote:Hi there, firstly great mod.

I have a very small problem with it, the icon_medal.gif doesn't dispaly at the top of the board.

Its on my server but I can't find the file that references it to check if its okay :D
The file itself is located at your_forum/styles/prosilver/theme/images/icon_medal.gif . If it shows up when you type this into your browser, check that you made all of the template edits and refresh your imageset/cache :)

Re: [Beta] Medal System MOD for phpBB3

Posted: Thu Aug 21, 2008 7:00 pm
by KPDub
Yep, did all the edits and double checked em :)

Re: [Beta] Medal System MOD for phpBB3

Posted: Thu Aug 21, 2008 7:08 pm
by Gremlinn
For prosilver and prosilver based templates/styles, you do have to go into the ACP -> Styles tab and refresh the theme for the templates you're using. the prosilver based templates store their .css information in the database.

Re: [Beta] Medal System MOD for phpBB3

Posted: Fri Aug 22, 2008 3:43 pm
by Luigi17
Hello I have the mod installed, and then comb this error

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3546: Cannot modify header information - headers already sent by (output started at /language/de/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3548: Cannot modify header information - headers already sent by (output started at /language/de/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3549: Cannot modify header information - headers already sent by (output started at /language/de/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3550: Cannot modify header information - headers already sent by (output started at /language/de/common.php:1)





Can you help?

Re: [Beta] Medal System MOD for phpBB3

Posted: Fri Aug 22, 2008 5:20 pm
by Gremlinn
Standard error. I would have to say that you edited the language file with something like notepad. You will need to get another editor (I like using notepad++) and save the file in UTF-8 without BOM format. Notpad ( :roll: ) puts an extra character at the beginning of it's files and doesn't save them correctly.

Another possibility is that you have changed the first line of the common.php file so that it isn't "<?php" on the very first line.

Re: [Beta] Medal System MOD for phpBB3

Posted: Sat Aug 23, 2008 3:39 am
by Bredirish123
Hmm, it's odd I refreshed the templates, installed the files and edited the files it asked me to and I refreshed my cache but still I got nothing. I even switched to Prosilver to see if that worked and well it didn't.

It's a little disappointing that my first mod install doesn't work. :(

Re: [Beta] Medal System MOD for phpBB3

Posted: Sat Aug 23, 2008 4:27 am
by Gremlinn
Getting the template stuff working is probably the hardest part of applying mods.

Just to be sure... You made the template edits? Did you refresh your style's template and theme? Then clear your cache.

Are you seeing the medals link in the header menu? How about in the user's profile (not the UCP)?

As a side question.. Have you added the ACP modules and then visited the Configuration page? If so, did the database changes take effect without error?

Re: [Beta] Medal System MOD for phpBB3

Posted: Sat Aug 23, 2008 10:51 am
by Luigi17
Okay, thank you again

I now have a new problem always someone who I would like to give a medalie he logs me out

what can I do?

Re: [Beta] Medal System MOD for phpBB3

Posted: Sat Aug 23, 2008 4:27 pm
by Bredirish123
Gremlinn wrote:Getting the template stuff working is probably the hardest part of applying mods.

Just to be sure... You made the template edits? Did you refresh your style's template and theme? Then clear your cache.

Are you seeing the medals link in the header menu? How about in the user's profile (not the UCP)?

As a side question.. Have you added the ACP modules and then visited the Configuration page? If so, did the database changes take effect without error?
I did add everything to the root folder, (Even the Templates), now if there is a certain line of code I should add to my style then could it be posted.

But yeah I have refreshed my style's Template and theme, and also cleared the cache.
the configuration panel is fully functional and I can edit preferences and medals.

Re: [Beta] Medal System MOD for phpBB3

Posted: Mon Aug 25, 2008 1:32 am
by Gremlinn
Bredirish123: You're asking if you need to add something to your style? Did you apply the specific template edits to the filed in your style?

Luigi17: The problem you are having is common. It happens every once in a while when a new mod is added. The strange part is, it doesn't always happen with the same mods. First, try to delete your boards cookies (link at the bottom of you site, normally). If that doesn't do it, then you should try to change the name of your board cookie in the ACP, then delete your board cookies and clear your cache. That usually fixes it right up.

Re: [Beta] Medal System MOD for phpBB3

Posted: Mon Aug 25, 2008 12:38 pm
by azogx
General Error
SQL ERROR [ mysql4 ]

Table 'darkvis_db1.phpbb_medals_awarded' doesn't exist [1146]

SQL

SELECT user_id, nominated FROM phpbb_medals_awarded WHERE user_id = '2'

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: viewtopic.php
LINE: 1495
CALL: dbal_mysql->sql_query()

Re: [Beta] Medal System MOD for phpBB3

Posted: Mon Aug 25, 2008 12:47 pm
by Gremlinn
Did you do the DIY instructions at the bottom of the install xml file? Add the modules to the ACP, visit the Configuration panel you just added (paying attention to the SQL code and success messages)?

And, while I am asking about your install, did you perform the template install appropriate for your style?

Re: [Beta] Medal System MOD for phpBB3

Posted: Mon Aug 25, 2008 1:04 pm
by azogx
Everything is fine. Other ideas?

Re: [Beta] Medal System MOD for phpBB3

Posted: Mon Aug 25, 2008 1:26 pm
by Gremlinn
Obviously everything isn't fine else you wouldn't be posting ;) The error you are reporting tells me that you either didn't visit the ACP Medal Configuration page or you did and it reported SQL errors. If you didn't, then please do so. If you did, then some of the SQL is there and some of it isn't. Go into your config table and remove the row for medals_mod_version. Then, revisit the ACP configuration page.

Pay attention to the output. I would recommend copying it for reference later.


FYI people: My next release will have a note explaining the SQL as done by the auto install.