[ABD] Post Bot Mod - New Version 1.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
engendro666
Registered User
Posts: 15
Joined: Fri Feb 26, 2010 10:40 am
Location: uruguay
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by engendro666 » Sun Mar 07, 2010 7:23 pm

billoo wrote:oh no i corrected the above one but made install a new one

my live board gone
plz help me hurry plz all users are unable to view???


it says

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'pakvisah_mobilloo.POST_BOT_TABLE' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

how can i restore i have the back up too
or how can i correct it up

I have the same problem. how can i fix this?

User avatar
Metzle
Registered User
Posts: 113
Joined: Sat Mar 15, 2008 2:55 am
Location: Waiblingen-Neustadt (Germany)
Name: Daniel
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Metzle » Sun Mar 07, 2010 8:18 pm

Hi,

I think you haven't edit the includes/constants.php.
Metzle
phpBB.de-Support-Team
No Support via PN/E-Mail/ICQ etc.
Allround-phpBB.de

engendro666
Registered User
Posts: 15
Joined: Fri Feb 26, 2010 10:40 am
Location: uruguay
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by engendro666 » Tue Mar 09, 2010 5:11 pm

Metzle wrote:Hi,

I think you haven't edit the includes/constants.php.
Yes, i reinstall and solved. I think also that he had lost a line.

anyway, do not uninstall the mod but I'm not using. when I try to configure it. says I'm missing the prosilver folder posting_buttons.html. But I only use prosilver based style, anyway, install the prosilver style, but I keep using mine (beta7). I had no more errors. but doesnt work. The bot does not write any message that I configure.

Thanks for the answer, and sorry for my bad english

yosmc
Registered User
Posts: 192
Joined: Tue Feb 18, 2003 1:12 pm

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by yosmc » Fri Mar 12, 2010 10:14 am

Is there any update on the RSS poster that was planned for 1.0.3? (Or is there another mod providing this function?) Thanks!

User avatar
Greyhound76
Registered User
Posts: 69
Joined: Sun Nov 30, 2008 6:56 pm
Location: Germany
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Greyhound76 » Fri Mar 12, 2010 9:55 pm

Hello,

i have installed the Mod and when I click on the profile of the Bot, then available in the header is followed by error message:

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_goals.php  on line 273: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 274: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 275: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 273: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 274: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 275: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4223: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4225: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4226: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4227: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
What´s wrong?

moh3en
Registered User
Posts: 50
Joined: Wed Mar 10, 2010 6:33 pm

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by moh3en » Fri Mar 19, 2010 12:29 pm

What's problem? When i run install.xml show message error:

Code: Select all

http://opensource.org/licenses/gpl-license.php GNU General Public License v2 Post Bot Post Bot allows users to set messages and when certain condition are met a message is posted into the correct. Installation allows you to select which extensions you want to install! Allows you to set variables in the message so {USERNAME} will be replaced with persons username Welcome post on user join, posts a new message when a user joins the forum welcoming them - by Poppertom69 Birthday post on users birthday, posts a new message on a users birthday - by Poppertom69 Anonymous poster post a message anonymously without people knowing who did it - by Poppertom69 Auto reply, replys to a post automatically if in the correct forum - by sTraTo Poppertom69 Tom Martin tom.martin60@btinternet.com sTraTo 1.0.2 easy 480 3.0.4 2009-04-19 0.3.0 Initial Public Preview Release of new version 2009-04-19 0.3.1 [Fix] Form token bug in settings [Change] ACP error if extension isn't installed 2009-04-26 0.4.0 [Fix] Post checksum error [Fix] Undefined class name 'self' error [Change] Can now autoreply to multiple forums with seperate messages [Feature] Can now autoreply after a set amount of time where reply count = 0 2009-05-04 0.5.0 [Fix] Minor bugs [Feature] Anonymous poster now back 2009-05-04 1.0.0 Submitted to MODDB 2009-05-15 1.0.1 [Fix] Two small bugs in acp 2009-05-15 1.0.2 [Fix] Small fix in aninstall.php upgrade - from 0.3.1 to 1.0.2 upgrade - from 0.5.0 to 1.0.2 upgrade - from 1.0.0 to 1.0.2 require($phpbb_root_path . 'includes/constants.' . $phpEx); require($phpbb_root_path . 'includes/db/' . $dbms . '.' . $phpEx); require($phpbb_root_path . 'includes/utf/utf_tools.' . $phpEx); require($phpbb_root_path . 'includes/functions_post_bot.' . $phpEx); $config = $cache->obtain_config(); if(pb::check_extension_status('post_bot_installed')) { $post_bot = $cache->obtain_post_bot(); } $db->sql_freeresult($result); $this->put('config', $cached_config); } return $config; } /** * Obtain list of post bot configs */ function obtain_post_bot() { global $db; if (($post_bot = $this->get('_post_bot_config')) === false) { $post_bot = $cached_post_bot = array(); $sql = 'SELECT * FROM ' . POST_BOT_TABLE; $result = $db->sql_query($sql); while ($row = $db->sql_fetchrow($result)) { $cached_post_bot[$row['post_bot_config']] = $row['post_bot_value']; $post_bot[$row['post_bot_config']] = $row['post_bot_value']; } $db->sql_freeresult($result); $this->put('_post_bot_config', $cached_post_bot); } return $post_bot; } define('WORDS_TABLE', $table_prefix . 'words'); define('ZEBRA_TABLE', $table_prefix . 'zebra'); // Additional tables define('POST_BOT_TABLE', $table_prefix . 'post_bot'); if (defined('IN_CHECK_BAN') && $result['user_row']['user_type'] != USER_FOUNDER) { return; } /* * Post Bot - Welcome Post * By Poppertom69 */ if(pb::check_extension_status('post_bot_welcome_user') && $user->data['user_lastvisit'] == 0) { pb::post_bot_welcome_user(); } /* End Post Bot */ function garbage_collection() { global $cache, $db; function garbage_collection() { global $cache, $db, $post_bot; // Unload cache, must be done before the DB connection if closed if (!empty($cache)) { $cache->unload(); } /* * Post Bot - Auto Reply Time Delay * By Poppertom69 */ if (pb::check_extension_status('post_bot_auto_reply') && $post_bot['auto_reply_time_forums'] != NULL) { pb::check_timed_auto_reply(); } /* End Post Bot */ // We do not handle erasing posts here if ($mode == 'delete') { return false; } $current_time = time(); /* * Post Bot - Anonymous Poster * By Poppertom69 */ if (pb::check_extension_status('post_bot_anonymous_poster')) { global $post_bot; if ($data['forum_id'] == $post_bot['post_bot_anon_forums'] && $mode == 'post') { $switch_perm = pb::change_auth($post_bot['post_bot_id']); $user->ip = '00.000.000.000'; } } /* End Post Bot */ else if ($mode != 'post' && $post_mode != 'edit_first_post' && $post_mode != 'edit_topic') { $params .= '&t=' . $data['topic_id']; } /* * Post Bot - Auto Reply * By sTraTo & modified by Poppertom69 for the new release */ if (pb::check_extension_status('post_bot_auto_reply') && $mode == 'post') { pb::check_autoreply($data['forum_id'], $subject, $data['topic_id']); } /* End Post Bot */ /* * Post Bot - Anonymous Poster * By Poppertom69 */ if (pb::check_extension_status('post_bot_anonymous_poster')) { if ($data['forum_id'] == $post_bot['post_bot_anon_forums'] && $mode == 'post') { pb::change_auth('', 'restore', $switch_perm); } } /* End Post Bot */ if ($age = (int) substr($row['user_birthday'], -4)) { $birthday_list .= ' (' . ($now['year'] - $age) . ')'; } /* * Post Bot - Birthday Post * By Poppertom69 */ if(pb::check_extension_status('post_bot_users_birthday')) { $birth = $now['year'] - $age; pb::post_bot_user_birthday($row['username'], $row['user_id'], $birth); } /* End Post Bot */ Navigate to the installation file which is aninstall.php and your done

poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by poppertom69 » Fri Mar 19, 2010 2:39 pm

sorry guys for a long wait for an update! but the rss is still planned it is all working except the acp just been really busy!
Do one thing everyday, that scares you!

User avatar
Greyhound76
Registered User
Posts: 69
Joined: Sun Nov 30, 2008 6:56 pm
Location: Germany
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Greyhound76 » Fri Mar 19, 2010 9:40 pm

Greyhound76 wrote:Hello,

i have installed the Mod and when I click on the profile of the Bot, then available in the header is followed by error message:

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_goals.php  on line 273: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 274: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 275: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 273: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 274: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions_goals.php on line 275: Division by zero
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4223: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4225: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4226: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4227: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3513)
What´s wrong?

*push*

User avatar
Greyhound76
Registered User
Posts: 69
Joined: Sun Nov 30, 2008 6:56 pm
Location: Germany
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Greyhound76 » Sat Mar 20, 2010 11:25 pm

*push*

User avatar
Greyhound76
Registered User
Posts: 69
Joined: Sun Nov 30, 2008 6:56 pm
Location: Germany
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Greyhound76 » Mon Mar 22, 2010 9:14 am

Has it really any idea what could be wrong?

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by RMcGirr83 » Mon Mar 22, 2010 10:47 am

Greyhound76 wrote:Has it really any idea what could be wrong?
I have an idea, it has nothing to do with this mod but has to do with this one

http://www.phpbb.com/community/viewtopi ... #p10459915
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Greyhound76
Registered User
Posts: 69
Joined: Sun Nov 30, 2008 6:56 pm
Location: Germany
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Greyhound76 » Mon Mar 22, 2010 10:54 am

Interesting. But the mod I have not even installed. :oops:

Sorry, I do have ... :oops:
Last edited by Greyhound76 on Mon Mar 22, 2010 10:59 am, edited 1 time in total.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by RMcGirr83 » Mon Mar 22, 2010 10:58 am

Check your memberlist.php file for an include for function_goals.php.

Errors don't just magically appear.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
HEADLINE
Registered User
Posts: 43
Joined: Sat May 10, 2008 1:51 pm
Location: Germany

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by HEADLINE » Tue Mar 23, 2010 5:07 pm

wintstar wrote:
der-nappel wrote:Hi,

that´s a good MOD, but I´ve a little Problem with some in german used letters (Ä, Ö, Ü and ß).
If I set the Reply-Function @ ACP with a text like:

Code: Select all

Üben, üben, üben...
It´s shown this way:

Code: Select all

??ben, ??ben, ??ben...
That happens with all 4 letters.

I´ve tried what mtrs wrote here, but it doesn´t help...

How can I fix this problem?

Regards
Gregor

I've got the same problem, how I can solve the problem? When there is an update on phpbb 3.0.6?

Thanks
Stephan
I have the same problem!
Is there a solution now?

Greeting HEADLINE

poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by poppertom69 » Tue Mar 23, 2010 5:21 pm

This has been fixed locally!
Do one thing everyday, that scares you!

Locked

Return to “[3.0.x] Abandoned MODs”