[ABD] Post Bot Mod - New Version 1.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
_Al
Registered User
Posts: 203
Joined: Mon Oct 20, 2008 9:24 pm
Location: Sweetas - All your friends online
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by _Al »

I only found this botmod today and i love it, Thanks Tom

Two Feature idea's


1.)Activities Features(for other fun mods, posted to X forum)
Exp:
{USERNAME} Has the new high score on {Blahblha game}
{USERNAME} added a new image in {ALBUM_ID} check it out
{USERNAME}'s new status is "{NEWSTATUS}


2.) Last x botposts shown on index
<!-- BEGIN lastbotposts -->
{botpost.botname}:{botpost.message}
<!-- END lastbotposts -->
jyco
Registered User
Posts: 145
Joined: Thu Dec 04, 2008 9:08 pm

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by jyco »

Hi,

Would having a forum where only admin can post stop the bot from posting when a member joins (welcome post)?

All the best
conan_troutman
Registered User
Posts: 222
Joined: Mon Jul 19, 2010 11:06 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by conan_troutman »

jyco wrote:Hi,

Would having a forum where only admin can post stop the bot from posting when a member joins (welcome post)?

All the best

no it would be posted but would need approval by a mod/admin.... I know... I tried it
jyco
Registered User
Posts: 145
Joined: Thu Dec 04, 2008 9:08 pm

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by jyco »

Hi,

Just took a look in mod control and no posts awaiting approval?

The forum is for admin to post in only but read to all others, Bots have bot access, Not sure if this would cause this to happen, Might place in a forum where registered users can post just to see what happens.

Thanks for the reply.

All the best
jyco
Registered User
Posts: 145
Joined: Thu Dec 04, 2008 9:08 pm

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by jyco »

Got it wrong,I'm so sorry, I thought it posted a welcome message when a new user first registered, It does it when they first login.

Sorry people, It works fine & thank you.
Sir_Mark1994
I've Been Banned!
Posts: 99
Joined: Sun Dec 05, 2010 11:57 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Sir_Mark1994 »

If i am right, it will post automatic a post in a forum that i can make in the ACP?
User avatar
Volksdevil
Registered User
Posts: 2415
Joined: Sun Oct 03, 2010 2:03 pm
Location: Lancashire, UK
Name: Neil
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Volksdevil »

Hey, had this working for a while but all of a sudden today it has caused an error on my main page :cry:

If i turn the birthday posts off, the error is gone, any idea how to fix? Im not sure how or why this has happened? :?:
EDIT: I think it may be conflicting with the AM mod.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_posting.php on line 1639: Missing argument 7 for submit_post(), called in /includes/functions_post_bot.php on line 402 and defined
[phpBB Debug] PHP Notice: in file /includes/functions_posting.php on line 1907: Invalid argument supplied for foreach()

Warning: Cannot modify header information - headers already sent by (output started at /websites/123reg/LinuxPackage21/vo/lk/sd/volksdevil.com/public_html/forum/includes/functions.php:3715) in /websites/123reg/LinuxPackage21/vo/lk/sd/volksdevil.com/public_html/forum/includes/functions.php on line 2629
Return to the index page
General Error
SQL ERROR [ mysql4 ]

Column 'forum_id' cannot be null [1048]

SQL

INSERT INTO True_topics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (2, 1293927744, 1293927744, NULL, NULL, 1, 'Happy Birthday jagmad!', 'Volksdevil', 'FF0000', 0, 0, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 2061
CALL: dbal_mysql->sql_query()

FILE: includes/functions_post_bot.php
LINE: 402
CALL: submit_post()

FILE: index.php
LINE: 111
CALL: pb::post_bot_user_birthday()
Last edited by Volksdevil on Sun Jan 02, 2011 9:07 pm, edited 1 time in total.
My phpBB Extensions
Finally found great Website Hosting from Image KUALO!
Do NOT use 123-reg.co.uk - Incapable of running phpBB!
:ugeek: TekNeil - Streamer on Mixer | My Volkswagen Corrado G60
Akbaio
Registered User
Posts: 49
Joined: Fri Dec 05, 2008 1:33 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Akbaio »

Issue: many times this mod send double and triple pms to new users on first login.
User avatar
wads24
Registered User
Posts: 603
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by wads24 »

I love this mod!!!

When I want to delete timed forum auto post, it says me: "Post Bot value deleted", but it isn't fully removed, the text is removed but forum id stays still there. Also I noticed that I cannot change the value of the "Post topic in which forum", or "Is timed delayed?". If I do change the value of it, and then click save, nothing saves.

I did notice that if I go to Settings, and then disable auto post, then come back in. Then the auto post that I set up before is deleted. Seems like a bug on the windshield to me? What do you guys think?
Thanks in advance for a reply.
User avatar
wads24
Registered User
Posts: 603
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by wads24 »

First of all! I love this mod!

The mod was working great, but now it is double posting. Does anyone else have this issue, and how cna i fix it so that it doesn't double post.
Thanks in advance for a reply.
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by poppertom69 »

I will hopefully fix this in the next release of this mod I haven't worked out what is making this happen at the moment.
Do one thing everyday, that scares you!
fraggit
Registered User
Posts: 4
Joined: Tue Jan 25, 2011 11:07 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by fraggit »

When I install this mod I get the following errors:

Code: Select all

Adding a new database table: phpbb_post_bot
Success

Adding new config variable: post_bot_installed
Success

Adding acp module: Post Bot
ERROR: The parent category specified for this module does not exist.

Adding acp module: settings
ERROR: The parent category specified for this module does not exist.

Adding acp module: welcome post
ERROR: The parent category specified for this module does not exist.

Adding acp module: birthday post
ERROR: The parent category specified for this module does not exist.

Adding acp module: auto reply
ERROR: The parent category specified for this module does not exist.

Adding new config variable: post_bot_auto_lc
Success

Adding acp module: anonymous poster
ERROR: The parent category specified for this module does not exist.

Adding new config variable: post_bot_version
Success
What have I missed? :D
fraggit
Registered User
Posts: 4
Joined: Tue Jan 25, 2011 11:07 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by fraggit »

Can anyone help with the last post?

I've had a quick look at the code but not knowing much about modding phpbb I'm not sure what I am looking for :)

What is the parent category and how do I add it?

Thanks
Sam
User avatar
Mahoney
Registered User
Posts: 196
Joined: Sun Mar 16, 2008 4:07 pm
Contact:

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by Mahoney »

Hello
Look here http://www.flying-bits.org/viewtopic.php?p=1945

best regards Mahoney
fraggit
Registered User
Posts: 4
Joined: Tue Jan 25, 2011 11:07 am

Re: [RC] Post Bot Mod - New Version 1.0.2

Post by fraggit »

Mahoney wrote:Hello
Look here http://www.flying-bits.org/viewtopic.php?p=1945

best regards Mahoney
But on looking further into the install script...

It first creates a module ACP_POST_BOT, which the message above states was successfull
Next it creates settings, welcome etc etc modules. Which fail because they cannot find the ACP_POST_BOT module, which indeed is not listed in the SQL.

So does this not seem to be an issue with the installer??
Locked

Return to “[3.0.x] Abandoned MODs”