[ABD] Post Bot Mod - New Version 1.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
ATCS2003
Registered User
Posts: 10
Joined: Sat May 27, 2006 11:42 pm

Re: [Beta] Post Bot Mod

Post by ATCS2003 »

Thanks man that was the problem :)
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [Beta] Post Bot Mod

Post by madtay »

This sounds like a great mod. Im gonna give it a try later and will post back with how it goes :)
User avatar
KellyBean
Registered User
Posts: 270
Joined: Wed Nov 07, 2007 3:06 pm
Location: Massachusetts
Contact:

Re: [Beta] Post Bot Mod

Post by KellyBean »

I was wondering if someone could maybe help me out a bit...

I love love love the sound of this mod... however, I have another really important mod installed that is conflicting with this mod because of the "anonymous" language it uses. The mod I have installed is this one:

http://www.phpbb.com/community/viewtopi ... 0&t=717605

It allows users to choose whether or not they'd like to post anonymously... But anyway, I installed the post-bot mod and it was giving me a HUGE sql error... it was saying that the annon field can't be null (sorry, I meant to c&p the exact error, but I had to get the backups restored before there was mass panic. :grin: )

Anyway, if there is a conflict, is there any chance anyone can help me figure out a work-around so that I can use both of these mods? Please? Thanks for the help in advance. :)
My Forum | My Design/How-to Site
Need help MODing or customizing your site? I can do it for a very reasonable fee. Contact me!

Image
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [Beta] Post Bot Mod

Post by poppertom69 »

i'll try and look into this for you
Do one thing everyday, that scares you!
User avatar
KellyBean
Registered User
Posts: 270
Joined: Wed Nov 07, 2007 3:06 pm
Location: Massachusetts
Contact:

Re: [Beta] Post Bot Mod

Post by KellyBean »

Thanks!! I really appreciate that! :)
My Forum | My Design/How-to Site
Need help MODing or customizing your site? I can do it for a very reasonable fee. Contact me!

Image
CrazyCatoon
Registered User
Posts: 79
Joined: Tue Aug 28, 2007 12:30 pm

Re: [Beta] Post Bot Mod

Post by CrazyCatoon »

Ok, I've installed this mod. It works brilliantly, thanks ;)

One problem. When a new user registers, it creates the post, but the forum icon doesn't go red (as in the new post hasn't been recognised). If you go in there, and delete the post, it has this strange SQL error:

Code: Select all

SQL ERROR [ mysqli ]

Out of range value adjusted for column 'forum_posts' at row 1 [1264]

SQL

UPDATE phpbb_forums SET forum_topics_real = forum_topics_real - 1, forum_posts = forum_posts - 1, forum_topics = forum_topics - 1, forum_last_post_id = 0, forum_last_post_subject = '', forum_last_post_time = 0, forum_last_poster_id = 0, forum_last_poster_name = '', forum_last_poster_colour = '' WHERE forum_id = 9

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 1512
CALL: dbal_mysqli->sql_query()

FILE: posting.php
LINE: 1442
CALL: delete_post()

FILE: posting.php
LINE: 279
CALL: handle_post_delete()
I refresh the page, and the topic's gone, but the overall post count was a -1 when I did this (the new user post was the only one), meaning that it hadn't worked out the post was there, but it worked out that it had deleted it.

Any ideas, anyone?
Last edited by CrazyCatoon on Sun Apr 13, 2008 7:20 pm, edited 1 time in total.
Hi! I'm CrazyCatoon, and I ♥ phpBB!
CrazyCatoon
Registered User
Posts: 79
Joined: Tue Aug 28, 2007 12:30 pm

Re: [Beta] Post Bot Mod

Post by CrazyCatoon »

Also, I've noticed that it says that there's 1 topic, but no posts.

When I resynch the forum, everything seems fine.

I'm just curious why it doesn't happen automatically... :?
Hi! I'm CrazyCatoon, and I ♥ phpBB!
User avatar
MasterHand
Registered User
Posts: 170
Joined: Sat Jun 17, 2006 6:34 pm
Location: includes/functions_user.php

Re: [Beta] Post Bot Mod

Post by MasterHand »

Possibly a bug? For the post not being recognized error, could that maybe be a feature? So you wouldn't get spamed up with topics about new users? Just a thought. I'll go install this and see what happens.
One more thing....No support via PM!
CrazyCatoon
Registered User
Posts: 79
Joined: Tue Aug 28, 2007 12:30 pm

Re: [Beta] Post Bot Mod

Post by CrazyCatoon »

Maybe, but it's just one forum that I've made just for it to post there, so it's better if the users know that they have one.

The thing is, it just says that there's no posts. Even in the statistics part where it says how many posts and topics there are in each forum...
Hi! I'm CrazyCatoon, and I ♥ phpBB!
Dondon2d
Registered User
Posts: 7
Joined: Sun Feb 11, 2007 6:29 am

Re: [Beta] Post Bot Mod

Post by Dondon2d »

Does this mod have an uninstall file? Damn this MOD lol. Now I'm getting a lot of header information errors.
chase_turpin
Registered User
Posts: 469
Joined: Fri Jun 10, 2005 12:02 am
Location: South Carolina
Contact:

Re: [Beta] Post Bot Mod

Post by chase_turpin »

Any one know if this works with 3.0.1
My current project Gamer Union Any and all help is welcome!
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [Beta] Post Bot Mod

Post by Stitch625 »

Hey Tom,

can I limit the bot to only post when a new member joins? The only time I want the bot to post is to welcome a new member.

Thanks..
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [Beta] Post Bot Mod

Post by poppertom69 »

just turn off the birthday in acp and don't include the anonymous.php file
Do one thing everyday, that scares you!
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [Beta] Post Bot Mod

Post by Stitch625 »

Sweet! Thanks Tom.
319
Registered User
Posts: 144
Joined: Fri Dec 21, 2007 12:47 am
Contact:

Re: [Beta] Post Bot Mod

Post by 319 »

demo?
Locked

Return to “[3.0.x] Abandoned MODs”