Page 2 of 49

Re: [Beta] Post Bot Mod

Posted: Sat Oct 27, 2007 2:42 am
by poppertom69
RedTrinity wrote:
Information

The requested user does not exist.
Hmm thats is pulling your user info out of the default phpbb variables so it should work. what is your user id normally, is it 4 or 2?

Re: [Beta] Post Bot Mod

Posted: Sat Oct 27, 2007 10:57 am
by RedTrinity
poppertom69 wrote:
RedTrinity wrote:
Information

The requested user does not exist.
Hmm thats is pulling your user info out of the default phpbb variables so it should work. what is your user id normally, is it 4 or 2?
User ID is 4 for my account - and the one I would like to use, if it let me :lol:

Re: [Beta] Post Bot Mod

Posted: Sat Oct 27, 2007 11:20 am
by poppertom69
Do you pick the user from find user or write in the name in the box?

On another note just found a known issue with this mod which is:
Welcome message can only be 255 characters long as it is a config value, so i am going to release a new version later today of this mod which will have its own table so you can have a long message, if someone registers to your forum at the moment the message may not display. So i'll update the old system and then i will start work on the new features.

Re: [Beta] Post Bot Mod

Posted: Sat Oct 27, 2007 10:24 pm
by RedTrinity
poppertom69 wrote:Do you pick the user from find user or write in the name in the box?
I had to write my name in the box, for some reason the link to find a member does not do anything :S

Re: [Beta] Post Bot Mod

Posted: Sat Oct 27, 2007 10:33 pm
by poppertom69
Hmm that is very wierd as i use the phpbb function to do that! Is the name exactly the same as your username?

Another way to get around this is to manually edit the config value, the config is called 'an_poster_id'.

A am just working on the next release which is should be coming very soon so you can just wait for that because this will be addressing some major changes!

Re: [Beta] Post Bot Mod

Posted: Sun Oct 28, 2007 6:36 pm
by saaiberke
After installing the mod, setting all bot settings I tried to register a new account and I got this message:

Code: Select all

SQL ERROR [ mysql ]

Column 'topic_first_poster_name' cannot be null [1048]
Any idea what is going wrong?

Another question I have, does the automatic post at registration will be posted upon registration or upon activating? When a user never activates his account, it will look a bit stupid to welcome him/her on the forum, won't it? :)

Grtz,

Nic

Re: [Beta] Post Bot Mod

Posted: Mon Oct 29, 2007 4:03 pm
by poppertom69
saaiberke wrote:After installing the mod, setting all bot settings I tried to register a new account and I got this message:

Code: Select all

SQL ERROR [ mysql ]

Column 'topic_first_poster_name' cannot be null [1048]
Are you sure you have set a post bot user? that is why that error is coming up.

saaiberke wrote:Another question I have, does the automatic post at registration will be posted upon registration or upon activating? When a user never activates his account, it will look a bit stupid to welcome him/her on the forum, won't it? :)

Grtz,

Nic
I can change it to on first login if you wish, what does everyone think to that or do you want a setting for you to choose?

Re: [Beta] Post Bot Mod

Posted: Mon Oct 29, 2007 8:27 pm
by darcie
What a neat looking mod! I echo RedTrinity's request to be able to set more than one bot for different uses, if possible. And yes, I agree that the post should be upon activation or first login rather than registration.

Hmm... now I want to figure out a use for this just because it sounds so fun. :D

Re: [Beta] Post Bot Mod

Posted: Tue Oct 30, 2007 12:43 am
by RedTrinity
Ok I sorted out the problem with the ID, its working now :D Didn't have any luck getting the "find a member" link working but I just attempted to retype in my username this morning into it and it accepted it with no probs.

Seems to be working very well sofar, a new member just signed up and sure enough the welcome thread popped up straight away!

Great MOD, can't wait for some of the suggestions to be implemented into it and seeing what it grows into :)

Re: [Beta] Post Bot Mod

Posted: Tue Oct 30, 2007 2:25 pm
by poppertom69
3.1 released! view first post for new download link!

Added Permissions,
Set two bots,
New sql layout so you can now have longer welcome messages,

Like always how you enjoy and let me know what you think.

Re: [Beta] Post Bot Mod

Posted: Wed Oct 31, 2007 9:53 pm
by ChrisRLG
I would like to request a couple of extra features.

First I will explain how it would be used.
In a support type forum, (such as say the support rooms in phpBB.com) when no one has replied within a time frame, I would like a 'bot' to be able to post a request for the user to do something. In my case it would be to post in a stick topic that they still required assistance.

So it would need to be able to post to xxx forum only, to those topics over xxx hours old, where the reply count is zero (or even xxx), with a set post which could include veriables for username etc of the inintial poster.

This currently seems very close to what I require - those extra feature would make it work.
example post wrote:
Hi "USENAMEHERE"

We are sorry no one has replied to you but this forum is busy and topics can get overlooked.

If your still require assistance could you please post in this topic:- (URL of Topic) when one of the staff will try to assist.

Yours - Your Forum RoBOT.
It would probably be best to be run as a batch process.

Re: [Beta] Post Bot Mod

Posted: Wed Oct 31, 2007 11:32 pm
by RedTrinity
poppertom69 wrote:3.1 released! view first post for new download link!

Added Permissions,
Set two bots,
New sql layout so you can now have longer welcome messages,

Like always how you enjoy and let me know what you think.
Have just tried to upgrade but am getting the following for the install file:
Parse error: syntax error, unexpected T_STRING in /home/****/public_html/phpbb3/aninstall.php on line 241
:(

Also are you able to supply the SQL changes/upgrades since the original version seperately?

Thanks :D

Re: [Beta] Post Bot Mod

Posted: Thu Nov 01, 2007 1:01 am
by poppertom69
ChrisRLG wrote:I would like to request a couple of extra features.

First I will explain how it would be used.
In a support type forum, (such as say the support rooms in phpBB.com) when no one has replied within a time frame, I would like a 'bot' to be able to post a request for the user to do something. In my case it would be to post in a stick topic that they still required assistance.

So it would need to be able to post to xxx forum only, to those topics over xxx hours old, where the reply count is zero (or even xxx), with a set post which could include veriables for username etc of the inintial poster.

This currently seems very close to what I require - those extra feature would make it work.
example post wrote:
Hi "USENAMEHERE"

We are sorry no one has replied to you but this forum is busy and topics can get overlooked.

If your still require assistance could you please post in this topic:- (URL of Topic) when one of the staff will try to assist.

Yours - Your Forum RoBOT.
It would probably be best to be run as a batch process.
I really like this idea and i'll see what i can do!!!

Re: [Beta] Post Bot Mod

Posted: Thu Nov 01, 2007 1:07 am
by poppertom69
RedTrinity wrote:
poppertom69 wrote:3.1 released! view first post for new download link!

Added Permissions,
Set two bots,
New sql layout so you can now have longer welcome messages,

Like always how you enjoy and let me know what you think.
Have just tried to upgrade but am getting the following for the install file:
Parse error: syntax error, unexpected T_STRING in /home/****/public_html/phpbb3/aninstall.php on line 241
:(

Also are you able to supply the SQL changes/upgrades since the original version seperately?

Thanks :D
Sorry for that packaged an old install file. Please re-download and run the script again!

Re: [Beta] Post Bot Mod

Posted: Thu Nov 01, 2007 3:58 am
by RedTrinity
Now I have:
General Error
SQL ERROR [ mysql4 ]

Table 'POST_BOT_TABLE' already exists [1050]

SQL

CREATE TABLE POST_BOT_TABLE ( post_bot_config varchar(255) DEFAULT '' NOT NULL, post_bot_value mediumtext NOT NULL, PRIMARY KEY (post_bot_config) ) CHARACTER SET `utf8` COLLATE `utf8_bin`;

BACKTRACE
I am going to need the new database changes only (since the original version), since I am upgrading and not installing for the first time :) Thanks in advance!