[ABD] Knowledge Base 0.2.14

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
digitalchaos13
Registered User
Posts: 91
Joined: Sun Sep 23, 2007 4:24 pm

Re: [BETA] Mini Knowledge Base

Post by digitalchaos13 » Mon Nov 19, 2007 7:23 am

The only thing I get in my mcp for knowledge base is can add articles

MrC
Registered User
Posts: 857
Joined: Mon Jun 30, 2003 4:11 pm
Location: The Netherlands
Name: Ivo
Contact:

Re: [BETA] Mini Knowledge Base

Post by MrC » Mon Nov 19, 2007 11:26 am

digitalchaos13 wrote:The only thing I get in my mcp for knowledge base is can add articles
Same here, there are a lot of fixes in several posts. Is it possible to update the download package with all working fixes? (or has that already been done?)

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 1:33 pm

bonelifer wrote:
When you search on the main page the results come up like this.

Gefunden in:

I assume that should be "Found in:"

Also I have a question why are the Module names in German? Shouldn't those be included in the language files and then pulled based on the users language settings?

Also shouldn't the Configuration page have it's own text in its header. Currently it has the same header as the Sub category page, ie it currently has this:
Maybe Tas forgot to use Redtrinity translated files, because was fixed previously.

Tas,
i have another sugestion: when i create subcategories, they are organized in alphabetic way, could you put this like in forum categories, with arrows that move they up and down :?:

I'm using numbers to organize then
1.example
2.example

;)

I'm gonna try to find or create a knowlegdebase icon to put in navbar. If anyone have an idea, just send to me and i create it!

User avatar
Sniper_E
Registered User
Posts: 789
Joined: Wed May 09, 2007 12:18 am
Location: Shreveport, Louisiana
Name: Ed Humphrey
Contact:

Re: [BETA] Mini Knowledge Base

Post by Sniper_E » Mon Nov 19, 2007 2:54 pm

Is it possible to have the layout in the prosilver style AND in the subsilver2 style?
I have friends that would love to use this but they don't favor the prosilver style look.
Can you offer both style layouts for this?
Image
No is NEVER an Option and NEVER is the only Option when it comes to Giving Up!
:!: Sniper_E Styles | phpbbmodders :!:

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 5:09 pm

ok,
now i got some problems: the "add an article" and "MCP" buttons doesn't appear.

All (users and moderator) permissions is set to 'yes', but still not appearing... :cry:

Something i realized is if i turn permissions to "NO", when i come back to confirme it, the permission still turn on "YES"

I think is some bug with permissions rules, because all i did was remove all files and database codes to reinstall the last version, but i don't know how to uninstall database codes inserted in phpbb_config...(all "insert into" codes)

and the Last thing i did, was change my forum root path from mysite/ to mysite/forum/

User avatar
PatPatten
Registered User
Posts: 56
Joined: Thu Dec 07, 2006 10:29 pm
Location: Sittard - Netherlands
Contact:

Re: [BETA] Mini Knowledge Base

Post by PatPatten » Mon Nov 19, 2007 5:18 pm

.:: Chico ::. wrote:ok,
now i got some problems: the "add an article" and "MCP" buttons doesn't appear.

All (users and moderator) permissions is set to 'yes', but still not appearing... :cry:

Something i realized is if i turn permissions to "NO", when i come back to confirme it, the permission still turn on "YES"
Same here ! :cry:

MOD Version: 0.1.6 (downloaded from Author site)
StarTrekGuide Forum Moderation Team Member
phpBB3 MODs and Styles Development - Olympus MOD Database - phpBB programming Academy

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 5:36 pm

PatPatten wrote:
.:: Chico ::. wrote:ok,
now i got some problems: the "add an article" and "MCP" buttons doesn't appear.

All (users and moderator) permissions is set to 'yes', but still not appearing... :cry:

Something i realized is if i turn permissions to "NO", when i come back to confirme it, the permission still turn on "YES"
Same here ! :cry:

MOD Version: 0.1.6 (downloaded from Author site)
Ok,
i restored my original DB before when i installed Knowlegde base and now, i can't set to YES KB permissions.

EDIT

I added all "insert into" database codes and the permissons turned to "YES". Maybe there is a problem with database INSERT INTO codes.

EDIT 2:

now it's working with my db restore. but i think there is in fact a bug.

User avatar
PatPatten
Registered User
Posts: 56
Joined: Thu Dec 07, 2006 10:29 pm
Location: Sittard - Netherlands
Contact:

Re: [BETA] Mini Knowledge Base

Post by PatPatten » Mon Nov 19, 2007 5:55 pm

Chico,

do the MCP/Post button's appear on yours ?

purge the cache several times.

On the author site the MOD runs Ok ??
StarTrekGuide Forum Moderation Team Member
phpBB3 MODs and Styles Development - Olympus MOD Database - phpBB programming Academy

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 6:02 pm

PatPatten wrote:Chico,

do the MCP/Post button's appear on yours ?

purge the cache several times.

On the author site the MOD runs Ok ??
Now is showing.

I do DB backup everyday, so, i have a database backup a moment before install this mod.
I realized that database code "insert into" add permissions rules for forum, at "acl_options", in this way, i made a backup in ACP without select "acp_options" table and i restored my old database, after that, i restored the last database (without acp_options table). In this way, the permissions are set to "NO" for KB permission rules.

After that, i use the INSERT INTO database codes at SQL (phpmyadmin) and all options did show to me again!

EDIT

Tas,
i found another bug. When i edit some article and submit it again, the options:
"Click here to view the article.", don't lead me to article, give me an 404 not found.

Example,
link in "click here": http://my-site/forum/knowledge/show_artikel.php?id=%201

real link of the article: http://my-site/forum/knowledge/kb_show.php?id=1

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3476
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Re: [BETA] Mini Knowledge Base

Post by bonelifer » Mon Nov 19, 2007 7:28 pm

.:: Chico ::. wrote:I'm gonna try to find or create a knowlegdebase icon to put in navbar. If anyone have an idea, just send to me and i create it!
I've already posted to the Icon, Ranks, Logo Request thread.
Knowledge Base | phpBB Board Rules | Search Customisation Database
Image
Please don't contact me via PM or email for phpBB support .

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 7:44 pm

bonelifer wrote:
.:: Chico ::. wrote:I'm gonna try to find or create a knowlegdebase icon to put in navbar. If anyone have an idea, just send to me and i create it!
I've already posted to the Icon, Ranks, Logo Request thread.
and where is this ... thread :?:

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3476
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Re: [BETA] Mini Knowledge Base

Post by bonelifer » Mon Nov 19, 2007 7:57 pm

It's in the phpBB2 forum, but that's just because it dates back to 2002.

Ranks, Logos, Buttons or any other graphics requests! -->> http://www.phpbb.com/community/viewtopi ... 4#p3273884

Also I have put together some code to add the icons for both prosilver and subsilver2.

Code: Select all

OPEN: styles/prosilver/template/overall_header.html

FIND:
<li class="icon-faq"><a href="{U_FAQ}
BEFORE, ADD:
<li class="icon-minikb"><a href="{U_KB}" title="{L_KB}" class="icon-minikb">{L_KB}</a>&nbsp;</li> 


OPEN: styles/prosilver/theme/buttons.css

FIND: 
.icon-faq

IN-LINE FIND:
.icon-faq

IN-LINE AFTER, ADD:
, .icon-minikb


OPEN: styles/prosilver/theme/colours.css

FIND:
.icon-faq						{ background-image: url("{T_THEME_PATH}/images/icon_faq.gif"); }

AFTER, ADD:
.icon-minikb						{ background-image: url("{T_THEME_PATH}/images/icon_minikb.gif"); }



OPEN: styles/subsilver2/template/overall_header.html

FIND:
<a href="{U_FAQ}">

IN-LINE FIND:
<a href="{U_FAQ}">

IN-LINE ADD, BEFORE:
<a href="{U_KB}"><img src="{T_THEME_PATH}/images/icon_mini_minikb.gif" width="12" height="13" alt="{L_KB}" /> {L_KB}</a>&nbsp; &nbsp;
Knowledge Base | phpBB Board Rules | Search Customisation Database
Image
Please don't contact me via PM or email for phpBB support .

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 8:07 pm

bonelifer wrote:It's in the phpBB2 forum, but that's just because it dates back to 2002.

Ranks, Logos, Buttons or any other graphics requests! -->> http://www.phpbb.com/community/viewtopi ... 4#p3273884

Also I have put together some code to add the icons for both prosilver and subsilver2.

Code: Select all

OPEN: styles/prosilver/template/overall_header.html

FIND:
<li class="icon-faq"><a href="{U_FAQ}
BEFORE, ADD:
<li class="icon-minikb"><a href="{U_KB}" title="{L_KB}" class="icon-minikb">{L_KB}</a>&nbsp;</li> 


OPEN: styles/prosilver/theme/buttons.css

FIND: 
.icon-faq

IN-LINE FIND:
.icon-faq

IN-LINE AFTER, ADD:
, .icon-minikb


OPEN: styles/prosilver/theme/colours.css

FIND:
.icon-faq						{ background-image: url("{T_THEME_PATH}/images/icon_faq.gif"); }

AFTER, ADD:
.icon-minikb						{ background-image: url("{T_THEME_PATH}/images/icon_minikb.gif"); }



OPEN: styles/subsilver2/template/overall_header.html

FIND:
<a href="{U_FAQ}">

IN-LINE FIND:
<a href="{U_FAQ}">

IN-LINE ADD, BEFORE:
<a href="{U_KB}"><img src="{T_THEME_PATH}/images/icon_mini_minikb.gif" width="12" height="13" alt="{L_KB}" /> {L_KB}</a>&nbsp; &nbsp;
I thought you already had create an icon.

Ok, this week i'm gonna create something.

yaw_pakhtoon
Registered User
Posts: 107
Joined: Wed Sep 12, 2007 12:18 am

Re: [BETA] Mini Knowledge Base

Post by yaw_pakhtoon » Mon Nov 19, 2007 8:19 pm

is there any other way of activating this mod without going to the module section, cause my hosting doesn't let me do that.. :(
Image

.:: Chico ::.
Registered User
Posts: 463
Joined: Fri Aug 03, 2007 6:35 am
Location: Rio de Janeiro
Contact:

Re: [BETA] Mini Knowledge Base

Post by .:: Chico ::. » Mon Nov 19, 2007 8:32 pm

yaw_pakhtoon wrote:is there any other way of activating this mod without going to the module section, cause my hosting doesn't let me do that.. :(
Ahn :?: :x

Module section is into your ACP -> Tab SYSTEM.

how your server block your acess to it :?:

Locked

Return to “[3.0.x] Abandoned MODs”