[ABD] Knowledge Base 0.2.14

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: [BETA] Knowledge Base 0.2.13

Post by azzam »

You should update from 2.11 . I will test out other probs you are facing .I will soon reply.

Edit:
1)Report is working fine.
2)But rating is not working because of file is not found error.
3)Some categories are not showing up in index page.But when adding article it listed in drop down menu to slect in which category i want to add article.
4)Permissions of categories are messing up.Some time it Shows forum categories.and some time no permission to set .
Hope author will soon solve all this problems.
Azzam Malik
I love mods :)
padlets
Registered User
Posts: 76
Joined: Fri Feb 13, 2009 9:36 pm

Re: [BETA] Knowledge Base 0.2.13

Post by padlets »

i update from 0.2.10 to 0.2.11 and then to 0.2.13...
ALSO i install FRESH copy of pbpbb and FRESH copy of 0.2.13 and i get the same problem.
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: [BETA] Knowledge Base 0.2.13

Post by azzam »

Hmm i think you should then wait for author reply.But i think you are not doing intall/update right.
becauase all the error you mentioned i can not reproduce.Just the rating isn't working because kb_show.php file isn't include in the 2.13 folder.And in the update instruction he mentioned to delete kb_show and kb_category.php file.Don't know what the problem with rating.And also the article viewed is ashowing a lot more counts 20,000 .lolz
:)
Azzam Malik
I love mods :)
Souleyman
Registered User
Posts: 33
Joined: Mon Mar 09, 2009 11:52 pm

Re: [BETA] Knowledge Base 0.2.11

Post by Souleyman »

Stickygreen wrote:Is there a fix for the article count not showing up in classic view?
tas2580 wrote:Look that in the phpbb_kb_categorie table cat_articles is by default 0 and not NULL, this will fix the problem.
The problem is not with even not showing up article count. And also If it shows when I change the categorie for an article both categories (primary and target) won't to change teir counts...
User avatar
tas2580
Registered User
Posts: 295
Joined: Wed May 30, 2007 1:56 am
Location: Stuttgart, Germany
Contact:

Re: [BETA] Knowledge Base 0.2.14

Post by tas2580 »

Update to 0.2.14

All known bugs are fixed
padlets
Registered User
Posts: 76
Joined: Fri Feb 13, 2009 9:36 pm

Re: [BETA] Knowledge Base 0.2.14

Post by padlets »

thanks but i still have problem with reporting article, i get the error:

Code: Select all

SQL ERROR [ mysql4 ]

Table 'cg.phpbb_reports_reasons' doesn't exist [1146]

SQL

SELECT * FROM phpbb_reports_reasons ORDER BY reason_order ASC

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/functions_display.php
LINE: 919
CALL: dbal_mysql->sql_query()

FILE: knowledge/kbreport.php
LINE: 78
CALL: display_reasons()


and the view count still buged.
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: [BETA] Knowledge Base 0.2.14

Post by azzam »

I think you are right about count system still buggy.Hope he looks in to this problem.And also solve your problem.
Azzam Malik
I love mods :)
wiesieks
Registered User
Posts: 8
Joined: Wed Aug 06, 2008 6:22 am

Re: [BETA] Knowledge Base 0.2.14

Post by wiesieks »

hi

Ive got problem: When i ad new module in acp:

Install ACP module ("Configuration [acp_kb]")
Install ACP module ("Categories [acp_kb]")
Install ACP module ("Article types [acp_kb]")
Install ACP module ("Categorie permissions [acp_kb_permissions]")
Install MCP module ("Overview [mcp_kb]")
Install MCP module ("Acrtivate article [mcp_kb]")
Install MCP module ("Reported articles [mcp_kb]")


i have only:
("Configuration [acp_kb]")
("Categories [acp_kb]")
("Article types [acp_kb]")
("Acrtivate article [mcp_kb]")
("Reported articles [mcp_kb]")

but when i add:
("Acrtivate article [mcp_kb]")
("Reported articles [mcp_kb]")

their didnt show

ps sorry for my english :mrgreen:
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: [BETA] Knowledge Base 0.2.14

Post by azzam »

Have you enabled all modules in mcp?And check there if any duplicate rows you inserted?
Azzam Malik
I love mods :)
DoRyN
Registered User
Posts: 41
Joined: Wed Sep 01, 2004 5:03 pm
Location: Romania
Contact:

Re: [BETA] Knowledge Base 0.2.14

Post by DoRyN »

tas2580 wrote:Update to 0.2.14

All known bugs are fixed
how update from 0.2.13 to 0.2.14 ?

I have some problems when trying to set permissions to certain categories. In ACP after select permissions category - category / subcategory - add group - but when I add these permissions do not appear although I defined a role KB.

Thank You !
wiesieks
Registered User
Posts: 8
Joined: Wed Aug 06, 2008 6:22 am

Re: [BETA] Knowledge Base 0.2.14

Post by wiesieks »

azzam wrote:Have you enabled all modules in mcp?And check there if any duplicate rows you inserted?
thanks man :D
WebSnail
Registered User
Posts: 524
Joined: Sun Nov 11, 2001 2:20 pm
Location: South Yorkshire, UK
Contact:

Re: [BETA] Knowledge Base 0.2.14

Post by WebSnail »

DoRyN wrote:I have some problems when trying to set permissions to certain categories. In ACP after select permissions category - category / subcategory - add group - but when I add these permissions do not appear although I defined a role KB.
There's something a bit odd going on with the ACL system with regard to this mod.

It somehow seems to be mixing up the settings for one permission and applying it to another. I'm still trying to backtrack what it's doing and why but so far I've drawn a blank.
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: [BETA] Knowledge Base 0.2.14

Post by azzam »

wiesieks wrote:
azzam wrote:Have you enabled all modules in mcp?And check there if any duplicate rows you inserted?
thanks man :D
:mrgreen:
WebSnail wrote:
DoRyN wrote:I have some problems when trying to set permissions to certain categories. In ACP after select permissions category - category / subcategory - add group - but when I add these permissions do not appear although I defined a role KB.
There's something a bit odd going on with the ACL system with regard to this mod.

It somehow seems to be mixing up the settings for one permission and applying it to another. I'm still trying to backtrack what it's doing and why but so far I've drawn a blank.
I think permission is just messed up in this mod.I tried more than 10 times to show all categories in index page.

And still article view counts buggy.

Hope he solve all these problems :)
Azzam Malik
I love mods :)
WebSnail
Registered User
Posts: 524
Joined: Sun Nov 11, 2001 2:20 pm
Location: South Yorkshire, UK
Contact:

Re: [BETA] Knowledge Base 0.2.14

Post by WebSnail »

azzam wrote:
WebSnail wrote:
DoRyN wrote:I have some problems when trying to set permissions to certain categories. In ACP after select permissions category - category / subcategory - add group - but when I add these permissions do not appear although I defined a role KB.
There's something a bit odd going on with the ACL system with regard to this mod.

It somehow seems to be mixing up the settings for one permission and applying it to another. I'm still trying to backtrack what it's doing and why but so far I've drawn a blank.
I think permission is just messed up in this mod.I tried more than 10 times to show all categories in index page.
Oh I know what he's done.. or rather, has NOT done..

He's not using the proper permissions syntax in the phpbb_acl_options table... kb_ is not a valid prefix and needs to be changed to u_ ... plus a whole host of other things...

I think there's a wee bit of development work required here... but it is beta I guess :)


EDIT: Actually nope... I'm wrong there... I think... It seems you can define a whole other "role" using a prefix kb_ which makes my point moot... Hmm.. well, it's all a learning experience :)
masterbas
Registered User
Posts: 51
Joined: Tue Aug 14, 2007 5:19 pm
Location: The Netherlands
Contact:

Re: [BETA] Knowledge Base 0.2.14

Post by masterbas »

I want to upgrade from 0.2.10 to 0.2.14, how? I only see update instructions from 0.2.12 to 0.2.13...
Locked

Return to “[3.0.x] Abandoned MODs”