[ABD] TS Photo Gallery Mod for phpBB3

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Jord070
Registered User
Posts: 21
Joined: Mon Jun 16, 2008 7:52 am
Location: Perth, West Australia
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by Jord070 » Wed Jun 18, 2008 8:50 am

Hmm,
Ok i have got the icon and menu showing up now,

but back to the errors,
Now i cant access anything, it has general errors, for adminCP and just when you click on it,

here is one of the general errors from when you click photo gallery from main index

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'album_parent_id' in 'where clause' [1054]

SQL

SELECT a.*, COUNT(DISTINCT p.pic_id) AS pics, COUNT(DISTINCT c.comment_id) AS comments FROM phpbb_gallery_albums AS a LEFT JOIN phpbb_gallery_comment AS c ON a.album_id = c.comment_album_id LEFT JOIN phpbb_gallery_pics AS p ON a.album_id = p.pic_album_id WHERE album_user_id = 0 AND album_parent_id = 0 GROUP BY album_id ORDER BY album_left_id ASC

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: gallery/menu.php
LINE: 378
CALL: dbal_mysqli->sql_query()
Admin CP error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 'album_parent_id' in 'field list' [1054]

SQL

SELECT album_id, album_parent_id, album_name, album_desc FROM phpbb_gallery_albums WHERE album_parent_id = 0 AND album_user_id > 0 ORDER BY album_left_id

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/acp/acp_gallery.php
LINE: 426
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_gallery.php
LINE: 62
CALL: acp_gallery->manage_albums()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_gallery->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

sorry to be such a pain with all the questions :roll:

danielnguyen
Registered User
Posts: 287
Joined: Thu Jan 24, 2008 11:44 am
Location: Vietnam
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by danielnguyen » Wed Jun 18, 2008 3:10 pm

Hi VisibleThunder! Can you let me know when you will release a newer version of this mod :) ? I have waited for a long time :) . Your mod is great :D
Regards!
My forum, for just teen only with many happy things
Cộng Đồng Teen Online - Cộng Đồng Teen Việt - Teen Việt Nam
Hội Ngộ - Giao Lưu - Học Hỏi - Giải Trí - Kết Bạn
http://www.congdongteenonline.net

VISIBLETHUNDER
Registered User
Posts: 463
Joined: Fri Mar 02, 2007 8:41 pm
Location: Bolton (UK)
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by VISIBLETHUNDER » Wed Jun 18, 2008 7:52 pm

Jord070,

Looking at your last two posts it looks as though you have at some point installed the gallery then deleted the gallery tables from the DB and attempted a re-install

The only thing you can do is remove all the gallery related DB info by following the thread "how to remove ....." in the FAQ section of the preview board and then re-run the SQL install script.

danielnguyen,

I will try to let everyone know as soon as I can make the next release available :)
TS Gallery related FAQs, DOWNLOADS and LANG PACKS can be found @ the TS MOD PREVIEW BOARD

Because Version 3 is taking longer than anticipated, I have uploaded a few temporary tools/add-ons to the preview board.

dutchkg
Registered User
Posts: 6
Joined: Thu Jun 19, 2008 12:05 pm

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by dutchkg » Thu Jun 19, 2008 12:22 pm

Hello world,
I know this is an old one but I've not solved it yet. On my comp localhost (xampp server) gallery works fine (except that'{GALLERY}' label on link that is solved on web) but when I put it on web I can NOT upload pictures. I get the error:

ERROR: Image dimensions exceed maximum permitted size,
Please resize the image or select an alternate image.

I've read all posts on this problem but found no soulution for mine. I tryed:

1. diferent images (size and ext). I have 'You can upload...',
2. checked modifications 3x,
3. diferent settings (one post had problem with wathermark on/off; turned guest upload on/off),
4. cleared cache (by admin CP and manualy),
5. changed chmod (even to 777),
6. rechecked instalation procedure.

Checked everything from the top of the post on 'http://www.threesixes.co.uk/phpBB3/view ... p?f=8&t=54', image files are NOT being uploaded to gallery/upload/pics even after chmod 777 and I do not receive an image size error when uploading any image despite my max size settings.
One more problem I have on web gallery - there is no 'Member's Gallery' (dafault) on gallery CP.

Best gallery I've seen but can NOT get it to work over web, just my localhost. :cry:

Please 'HELP, I NEED SOMEBODY....'!!!

VISIBLETHUNDER
Registered User
Posts: 463
Joined: Fri Mar 02, 2007 8:41 pm
Location: Bolton (UK)
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by VISIBLETHUNDER » Thu Jun 19, 2008 7:25 pm

Check your GD INFO

ACP->PHP information (scroll down to GD)

gd
GD Support enabled
GD Version bundled (2.0.28 compatible) <-- Minimum requirement
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
TS Gallery related FAQs, DOWNLOADS and LANG PACKS can be found @ the TS MOD PREVIEW BOARD

Because Version 3 is taking longer than anticipated, I have uploaded a few temporary tools/add-ons to the preview board.

dutchkg
Registered User
Posts: 6
Joined: Thu Jun 19, 2008 12:05 pm

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by dutchkg » Thu Jun 19, 2008 9:10 pm

gd
GD Support enabled
GD Version bundled (2.0.34 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

:cry:

OK, so now when I use subsilver2 style my netmeter shows net trafic - picture is uploaded, but its not in gallery/upload/pics and not in my gallery. If a picture is bigger size then alowed it puts me back on upload screen with no error. If the image is smaller I get the same error: image dimensions... Just to make it clear when I use prosilver style my upload does not even start (no net activity) and error apears.

VISIBLETHUNDER
Registered User
Posts: 463
Joined: Fri Mar 02, 2007 8:41 pm
Location: Bolton (UK)
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by VISIBLETHUNDER » Thu Jun 19, 2008 10:28 pm

Does your host have any restrictions in the php.ini file ?
TS Gallery related FAQs, DOWNLOADS and LANG PACKS can be found @ the TS MOD PREVIEW BOARD

Because Version 3 is taking longer than anticipated, I have uploaded a few temporary tools/add-ons to the preview board.

dutchkg
Registered User
Posts: 6
Joined: Thu Jun 19, 2008 12:05 pm

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by dutchkg » Fri Jun 20, 2008 7:02 am

I checked php.ini but no clue what I'm suppose to look for. Everything is set by default. What should I look for, and what should be on/off or...? I can send You the file but I think it's to big for posting?!? Here is part of php.ini that I think You could be interested in:
engine = On
zend.ze1_compatibility_mode = Off
safe_mode = Off
safe_mode_gid = Off
expose_php = On
max_execution_time = 60
max_input_time = 60
memory_limit = 16M
post_max_size = 16M
enable_dl = On
file_uploads = On
upload_max_filesize = 16M
allow_url_fopen = On
default_socket_timeout = 60

Anything else? Would You like the whole php.ini, or is there something else I can look for? Oh, and if host has any restrictions shouldn't it affect my localhost site (on witch I can upload)???

VISIBLETHUNDER
Registered User
Posts: 463
Joined: Fri Mar 02, 2007 8:41 pm
Location: Bolton (UK)
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by VISIBLETHUNDER » Sat Jun 21, 2008 9:27 am

If the both sites are running from the same server then this is a very peculiar issue indeed.

I don't need to see the php.ini file my question was answered in the section you posted and unfortunately that is not the issue either :(

I don't have any other ideas as yet

Sorry
TS Gallery related FAQs, DOWNLOADS and LANG PACKS can be found @ the TS MOD PREVIEW BOARD

Because Version 3 is taking longer than anticipated, I have uploaded a few temporary tools/add-ons to the preview board.

dutchkg
Registered User
Posts: 6
Joined: Thu Jun 19, 2008 12:05 pm

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by dutchkg » Sat Jun 21, 2008 3:19 pm

No, no. See, site on my local 'server' (xampp), on my comp works fine. I don't need internet conection to access this. It's acting as a web server on my comp ('web server simulation' is the best word I can find). But when I put everything on web server, my net host, I get error. I hope I'm clear with my english :) (if not sorry). Is there any way (simple way) that I can check if the server is even receiving the file? What I need to know is if the user can upload anything. By the way, I get the same error when I try to upload any other file like .php, .txt, .zip, .avi. Would You like my site address so You can see for Your self? I can make gust upload on.

User avatar
Kudlaty
Registered User
Posts: 62
Joined: Sat Feb 10, 2007 8:24 pm
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by Kudlaty » Tue Jun 24, 2008 10:48 pm

thx for that mod... it's really great.. but there should be limiter for user about how much photo they can upload.
Or limit size of their albums.. :)

crankyboy
Registered User
Posts: 2
Joined: Mon Jun 16, 2008 6:02 am

Upload Error But dimension change doesn't help...

Post by crankyboy » Fri Jun 27, 2008 5:33 am

When trying to upload pics I get...

'ERROR: Image dimensions exceed maximum permitted size,
Please resize the image or select an alternate image.'

I have changed the maximum size to 980Kb and 1500x1500 pixels, purged cache, go back to the gallery upload, and it says I can upload to those dimensions but even trying a 4Kb 20x20px image returns the same error. Have turned watermark off to see if this helps but no luck. Tried both jpegs and gifs.

Any Ideas??

CemetaryMan
Registered User
Posts: 59
Joined: Sat Jun 21, 2008 2:29 pm
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by CemetaryMan » Fri Jun 27, 2008 10:24 am

Have you tried to chmod the upload/cache folders to 777?
I had to do that to get it working.

VISIBLETHUNDER
Registered User
Posts: 463
Joined: Fri Mar 02, 2007 8:41 pm
Location: Bolton (UK)
Contact:

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by VISIBLETHUNDER » Fri Jun 27, 2008 7:58 pm

If anyone is having trouble submitting / viewing images when using the TS gallery then ALL the help I can currently offer can be found on the TS preview board

http://threesixes.co.uk/phpBB3/viewtopic.php?f=8&t=54
TS Gallery related FAQs, DOWNLOADS and LANG PACKS can be found @ the TS MOD PREVIEW BOARD

Because Version 3 is taking longer than anticipated, I have uploaded a few temporary tools/add-ons to the preview board.

newcastlefishing.com
Registered User
Posts: 228
Joined: Sun May 08, 2005 4:57 am

Re: [DEV] TS Photo Gallery Mod for phpBB3

Post by newcastlefishing.com » Sun Jun 29, 2008 6:16 am

If i delete the sql and re install it will i loose all my pictures?

Where do i go to back up all my photos and comments so i can delete and do a fresh reinstall, and can i add back in the backed up photos and comments if i do this, how is this done please.

The other thing is in the acp under gallery management, where you can create new albums is missing, what code do i need to fix to get this back, not sure why its not there anymore.

Locked

Return to “[3.0.x] Abandoned MODs”