[ABD] OurTube [YouTube/Uploaded Video Streaming]

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Gleasonator
Registered User
Posts: 652
Joined: Tue Jun 05, 2007 2:19 pm
Location: Texas
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Gleasonator »

yhelp wrote:What files did you edit? As i see no change. :?

And i fixed the add video by myself. I am about to fix this as well..

Image

The next problem is because my board is offline i tested it with videos and you even have errors there...

Image

So it looks like....

Image

And as you can see you have not fixed the categories problem.
What I meant is, the file edit from my previous post. This:

Open tube/index.php

Find:

Code: Select all

			while ($row = $db->sql_fetchrow($result))
			{
				$x++;
				$y++;
				$sql2 = 'SELECT COUNT(item_id)
					FROM ' . TUBE_ITEMS_TABLE . "
					WHERE category_id = '" . $db->sql_escape($row['category_id']) . "'";
				$result2 = $db->sql_query($sql2);
				$row2 = $db->sql_fetchrow($result2);
	                        $template->assign_block_vars('category', array(
					'S_ROW'			=> $x % 3,
					'S_COL'			=> $y,
					'U_CATEGORY'		=> append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $row['category_id']),
					'CATEGORY'		=> $row['title'],
					'COUNT'			=> $row2['COUNT(item_id)'],
					'DESCRIPTION'		=> (strlen($row['description']) > 150) ? substr($row['description'], 0, 150) . '...' : $row['description'],
					'THUMB'			=> ($row['thumb'] != '') ? (($row['youtube'] != '') ? $row['thumb'] : append_sid("{$phpbb_root_path}" . $row['thumb'])) : '',
				));
				$db->sql_freeresult($result2);
			}
After add:

Code: Select all

			$db->sql_freeresult($result);
			make_tabs($id);
			$template->assign_vars(array(
				'U_CATEGORY'		=> append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
				'CATEGORY'		=> $category,
				'PAGINATION'		=> generate_pagination(append_sid("{$phpbb_root_path}tube/index.$phpEx", 'mode=category&id=' . $id), $total_items, 12, $start),
				'PAGE_NUMBER'		=> on_page($total_items, 12, $start),
			));
			$template->assign_block_vars('navlinks', array(
				'U_VIEW_FORUM'  	=> append_sid("{$phpbb_root_path}tube/index.$phpEx"),
				'FORUM_NAME'    	=> $user->lang['TUBE'],
			));
			$template->assign_block_vars('navlinks', array(
				'U_VIEW_FORUM'  	=> append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
				'FORUM_NAME'    	=> $category,
			));
			$template->set_filenames(array(
				'body'  		=> 'tube_category.html')
			);
			$page_title = $user->lang['TUBE'] . ' • ' . $category;
This doesn't fix the categories? Make sure it's in the right place... it should be under the "categories" case of the switch.

But about "We Didn't Start The Flame War" (love that video, by the way), it must be breaking it since the video name is long. I haven't messed with that yet... I haven't tried using a long video name. I'll work on fixing it though, thanks.

EDIT:

By the way, while I'm here, does anybody know of a solution to my problem, or at least have any helpful advice?
Gleasonator wrote:
masterdxl wrote:hello this is a cool mod but i have one error

i get this when trying to upload a video

Code: Select all

template->_tpl_load(): No file specified for handle body
any idea what the problem is?
I get this same problem, but I've discovered that this only occurs when uploading videos with large filesizes. However, see what happens for me when uploading a smaller video: http://gleasonator.com/tube/index.php?m ... 6223681400

"Video stream not found" is shown over the video.

masterdxl, do you get the same problem? Try uploading a video smaller than 1 MB, like this one: http://www.legendofzeldaseries.com/comm ... a3adjp.wmv

daemonic, any fix for either of these problems? Thanks. :)
Sorry for my bad Engrish !
gleason|design

Image
yhelp
Registered User
Posts: 31
Joined: Fri Nov 16, 2007 10:20 pm
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by yhelp »

Code: Select all

            
			             $db->sql_freeresult($result);
             make_tabs($id);
             $template->assign_vars(array(
                'U_CATEGORY'      => append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
                'CATEGORY'      => $category,
                'PAGINATION'      => generate_pagination(append_sid("{$phpbb_root_path}tube/index.$phpEx", 'mode=category&id=' . $id), $total_items, 12, $start),
                'PAGE_NUMBER'      => on_page($total_items, 12, $start),
             ));
             $template->assign_block_vars('navlinks', array(
                'U_VIEW_FORUM'     => append_sid("{$phpbb_root_path}tube/index.$phpEx"),
                'FORUM_NAME'       => $user->lang['TUBE'],
             ));
             $template->assign_block_vars('navlinks', array(
                'U_VIEW_FORUM'     => append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
                'FORUM_NAME'       => $category,
             ));
             $template->set_filenames(array(
                'body'        => 'tube_category.html')
             );
             $page_title = $user->lang['TUBE'] . ' • ' . $category;
You need to look at this code....... Its not right.

And there's problems with missing parameters...

and that's why you get....

Code: Select all

template->_tpl_load(): No file specified for handle body
I have gone back to the other layout, and i would say to every one to do the same thing till he/she has fixed it.
Y! Help - Our fresh approach is friendly and informative but above all we work at your pace your level of computer knowledge and take nothing for granted.
User avatar
Gleasonator
Registered User
Posts: 652
Joined: Tue Jun 05, 2007 2:19 pm
Location: Texas
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Gleasonator »

yhelp wrote:

Code: Select all

            
			             $db->sql_freeresult($result);
             make_tabs($id);
             $template->assign_vars(array(
                'U_CATEGORY'      => append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
                'CATEGORY'      => $category,
                'PAGINATION'      => generate_pagination(append_sid("{$phpbb_root_path}tube/index.$phpEx", 'mode=category&id=' . $id), $total_items, 12, $start),
                'PAGE_NUMBER'      => on_page($total_items, 12, $start),
             ));
             $template->assign_block_vars('navlinks', array(
                'U_VIEW_FORUM'     => append_sid("{$phpbb_root_path}tube/index.$phpEx"),
                'FORUM_NAME'       => $user->lang['TUBE'],
             ));
             $template->assign_block_vars('navlinks', array(
                'U_VIEW_FORUM'     => append_sid("{$phpbb_root_path}tube/index.$phpEx", "mode=category&id=" . $id),
                'FORUM_NAME'       => $category,
             ));
             $template->set_filenames(array(
                'body'        => 'tube_category.html')
             );
             $page_title = $user->lang['TUBE'] . ' • ' . $category;
You need to look at this code....... Its not right.

And there's problems with missing parameters...

and that's why you get....

Code: Select all

template->_tpl_load(): No file specified for handle body
I have gone back to the other layout, and i would say to every one to do the same thing till he/she has fixed it.
If you'd have read the thread, you'd have found that masterdxl was having this exact same problem one week before I made those template changes. I also tested this mod before making a single change to any file, and got that error. It was afterward that I decided modify my own files, despite that I wasn't able to get it to properly function yet.

http://gleasonator.com/downloads/index.zip

Here is my tube/index.php file. Try it and see if it works. I would have just uploaded it to begin with, but I wanted people to be able to see what I was doing with their code.
Sorry for my bad Engrish !
gleason|design

Image
User avatar
Bruno36
Registered User
Posts: 287
Joined: Fri Mar 02, 2007 2:16 pm
Location: france
Name: bruno astie
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Bruno36 »

Hello!

I make changes to the theme
http://www.phpbb.com/community/viewtopi ... 5#p9334335
and no change in the presentation :shock:
I empty the cache
http://www.scooter-chinois-4t.com/tube/index.php
Excuse me for my poor English, I speak french
Bruno36
User avatar
Locou
Registered User
Posts: 80
Joined: Wed Apr 30, 2008 11:47 am
Location: Germany

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Locou »

Sounds cool.
I'll hope it works on my forums. :D
User avatar
Locou
Registered User
Posts: 80
Joined: Wed Apr 30, 2008 11:47 am
Location: Germany

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Locou »

Hello, again. :|
I have a permissions problem with this mod. At klicking on Ourtube I'm getting a "You aren't logged in. Please Log in" page.
Registered Users have permission to view and add videos. guests can only view ourtube. But it doesn't work.

I've checked my database and everthing looks fine for me.
There a these new tables:
phpbb_tube_categories
phpbb_tube_items
phpbb_tube_ratings

and phpbb_acl_options have these new options:
u_tube_add and u_tube_view.

I alos tried to debug with this instructions: link
But 0 nor 1 shows up on the index.php-

whats wrong now?
User avatar
ameisez
Registered User
Posts: 1166
Joined: Sun Nov 04, 2007 7:04 am

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by ameisez »

Hi,

Wondering if anyone is interested in sharing dedicated server so that we can use this MOD at its max :)

This MOD is really fantastic and promising. Only thing that hold us back is the requirements.

I am also thinking of signing up on a dedicated server with reseller account. Configure it to support this MOD and resell the spaces. But I surely won't be able to hold it up for a long time if there will be few to sign up.

I setup a poll HERE to see how feasible it is. If you are interested please cast a vote.

Thanks

By the way... does anyone knows how shall I configure xampp so I can test this including the upload video feature.
PHPBB on HOSTGATOR SERVER. MY PERSONAL CHOICE ;)
Need phpBB images and buttons? HIRE ME
my MOD: BB3 Media Player | a phpbb based media player
yhelp
Registered User
Posts: 31
Joined: Fri Nov 16, 2007 10:20 pm
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by yhelp »

ameisez wrote:Hi,

Wondering if anyone is interested in sharing dedicated server so that we can use this MOD at its max :)

This MOD is really fantastic and promising. Only thing that hold us back is the requirements.

I am also thinking of signing up on a dedicated server with reseller account. Configure it to support this MOD and resell the spaces. But I surely won't be able to hold it up for a long time if there will be few to sign up.
Most hosts that support ffmpeg will support this mod there not hard to find.....

Here are few i would recommend for this mod.

http://www.hostupon.com/ This one is the one i would go for out of the 3. Try it for a mouth before you buy a years hosting but you not be dissapoitned, We use to get hosting from them till we setup are own servers.
http://www.apthost.com/
http://www.cirtexhosting.com/

There not hard to find (Google :D) i would even recommend my free host but we pulled ffmpeg support for free users due to abuse.
Y! Help - Our fresh approach is friendly and informative but above all we work at your pace your level of computer knowledge and take nothing for granted.
dicho
Registered User
Posts: 7
Joined: Thu Feb 08, 2007 7:29 am

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by dicho »

I am using hostupon but got "video stream not found" error message after I uploaded the video even though there is a thumbnail image of the video available. Do we need to upload the ffmpeg.exe file and modify the index.php file as well? Please help!
yhelp
Registered User
Posts: 31
Joined: Fri Nov 16, 2007 10:20 pm
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by yhelp »

dicho wrote:I am using hostupon but got "video stream not found" error message after I uploaded the video even though there is a thumbnail image of the video available. Do we need to upload the ffmpeg.exe file and modify the index.php file as well? Please help!
Depends on what hosting you have from them is it: Starter or Business

As the starter dose not come with ffmpeg support?

If you have business do you have the right path in your ACP settings? Ad give the files that need 777 permissions?
Y! Help - Our fresh approach is friendly and informative but above all we work at your pace your level of computer knowledge and take nothing for granted.
dicho
Registered User
Posts: 7
Joined: Thu Feb 08, 2007 7:29 am

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by dicho »

I can get the ffmpeg features and they can be found by the search features also. All the videos and tmp directories have 777 permissions as well. I recall to have seen discussion about the modification to the index.php file some place, but could not located it again. Anyway, anyone knows how to effectively upload the file via ffmpeg and can provide help will be appreciated.
yhelp
Registered User
Posts: 31
Joined: Fri Nov 16, 2007 10:20 pm
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by yhelp »

Looks like its not converting the video right i will try it on my site and get back to ya.

Edit: Yes it not encoding the video right and putting in in the video file.
Y! Help - Our fresh approach is friendly and informative but above all we work at your pace your level of computer knowledge and take nothing for granted.
User avatar
ameisez
Registered User
Posts: 1166
Joined: Sun Nov 04, 2007 7:04 am

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by ameisez »

yhelp wrote:
dicho wrote:I am using hostupon but got "video stream not found" error message after I uploaded the video even though there is a thumbnail image of the video available. Do we need to upload the ffmpeg.exe file and modify the index.php file as well? Please help!
Depends on what hosting you have from them is it: Starter or Business

As the starter dose not come with ffmpeg support?
According to their plan, starter should have ffmpeg. http://www.hostupon.com/ffmpeg-hosting.html

If they don't in the real world, then it is a bad point to them.
yhelp wrote:Looks like its not converting the video right i will try it on my site and get back to ya.

Edit: Yes it not encoding the video right and putting in in the video file.
Make it work and let us know :)
PHPBB on HOSTGATOR SERVER. MY PERSONAL CHOICE ;)
Need phpBB images and buttons? HIRE ME
my MOD: BB3 Media Player | a phpbb based media player
yhelp
Registered User
Posts: 31
Joined: Fri Nov 16, 2007 10:20 pm
Contact:

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by yhelp »

ameisez wrote:
yhelp wrote:
dicho wrote:I am using hostupon but got "video stream not found" error message after I uploaded the video even though there is a thumbnail image of the video available. Do we need to upload the ffmpeg.exe file and modify the index.php file as well? Please help!
Depends on what hosting you have from them is it: Starter or Business

As the starter dose not come with ffmpeg support?
According to their plan, starter should have ffmpeg. http://www.hostupon.com/ffmpeg-hosting.html

If they don't in the real world, then it is a bad point to them.
Yes sorry i was looking at it wrong it was 2am lol.
ameisez wrote:
yhelp wrote:Looks like its not converting the video right i will try it on my site and get back to ya.

Edit: Yes it not encoding the video right and putting in in the video file.
Make it work and let us know :)
PHPBB coding is not something i get in to if it don't benefit my site and at this time this mod dose not benefit my site. But i will take a look.
Y! Help - Our fresh approach is friendly and informative but above all we work at your pace your level of computer knowledge and take nothing for granted.
User avatar
Locou
Registered User
Posts: 80
Joined: Wed Apr 30, 2008 11:47 am
Location: Germany

Re: [BETA] OurTube [YouTube/Uploaded Video Streaming]

Post by Locou »

Oh help me, please. :(

acl_options
Image
acl_roles
Image
acl_roles_data
Image

I still can't view ourtube. :?
Locked

Return to “[3.0.x] Abandoned MODs”