[ABD] TUT Forum Page Hits 0.1.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
tauno
Registered User
Posts: 24
Joined: Wed Aug 01, 2007 6:36 pm

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by tauno » Mon Dec 31, 2007 1:09 am

Hmm, major problems here, my forum is just showing blank white page. I don't know what might have gone wrong, I tried to install in on another template, that's the only difference. I overwrote all edited files with backups and I think I undid the sql command, but still white page. Server log doesn't show a thing :| . Any ideas ?

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by RedTrinity » Mon Dec 31, 2007 1:53 am

TheUniqueTiger wrote:As saaiberke has said that he followed the install instructions and successfully has it working, I don't think there is any errors in the install instructions...
Oh ok, I suppose I will just have to go without then :( I have already looked over my edits on what has been an almost vanilla copy of PHPBB3 Gold and everything is where it should be.

So I don't know what else I can do unless anybody else is willing to help me get it working.

saaiberke
Registered User
Posts: 1126
Joined: Wed Jul 20, 2005 8:13 am
Location: Gent/Belgium
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by saaiberke » Mon Dec 31, 2007 7:00 am

I am not sure, maybe it has something to do with the fact you are using the Stargate portal? Maybe you have to test it on a new phpBB3 setup on your server?

Grtz,

Nic

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Mon Dec 31, 2007 11:21 am

@ RedTrinity,
I truly have no idea of whats happening with you... and I don't have any idea of the Stargate portal MOD either, but please have patience. Please note that all the pagehits calculation and display is done in the page_footer function in includes/functions.php... So please check if the page_footer function is being called in index.php (near the last lines) and whether any changes have been done to the same page_footer function (in includes/functions.php) by any other MOD... I know this must be frustrating for you but its got nothing to do with this MOD... Please try this MOD on a test installation to confirm for yourself.
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by RedTrinity » Mon Dec 31, 2007 12:07 pm

TheUniqueTiger wrote: So please check if the page_footer function is being called in index.php (near the last lines) and whether any changes have been done to the same page_footer function (in includes/functions.php) by any other MOD... I know this must be frustrating for you but its got nothing to do with this MOD... Please try this MOD on a test installation to confirm for yourself.
Thank you for your support Tiger, I appreciate it.

This is what I have at the end of Index.php:

Code: Select all

// Output page
page_header($user->lang['INDEX']);

$template->set_filenames(array(
	'body' => 'index_body.html')
);

page_footer();

?>
And this is the same page that is being called throughout includes/functions.php as well. There doesn't appear to be any changes I can see.

The portal (Stargate 3.0) has its own portal_footer.html, however this is added underneath the general one - as you can see here: http://www.theparentingsanctuary.com.au/forum

So yeah, would love any more ideas you may have as to what the problem could be.

Thanks in advance!

Nikki.

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Mon Dec 31, 2007 12:22 pm

This is the first time that I visited a site with such a portal for phpBB3... Its good... The style is also great.

Coming back to the point...
I noticed that the footer contains far more data than the normal... But in index.php it is calling only page_footer and not portal_footer... So there surely has been some modification to page_footer to call portal_footer too... However I couldn't find any other situation that could have caused the problem...

If I get time out of my busy schedule, I may download the portal MOD and look for any possible conflicting lines...
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by RedTrinity » Mon Dec 31, 2007 1:35 pm

TheUniqueTiger wrote: I noticed that the footer contains far more data than the normal... But in index.php it is calling only page_footer and not portal_footer... So there surely has been some modification to page_footer to call portal_footer too...
Yep that is right, this is the code in question from overall_footer.php:

Code: Select all

<div id="wrapfooter">
	<!-- IF U_ACP --><span class="gensmall">[ <a href="{U_ACP}">{L_ACP}</a> ]</span><br /><br /><!-- ENDIF -->
	<span class="copyright">
	Powered by <a href="http://www.phpbb.com/">phpBB</a> &copy; phpBB Group.<br />
	<!-- IF STARGATE --><!-- INCLUDE portal_footer.html --><!-- ENDIF -->
	<br />Designed by <a href="http://www.stsoftware.biz/">Vjacheslav Trushkin</a> for <a href="http://www.freeforums.org" title="Free Forum Hosting">Free Forums</a>/<a href="http://www.divisioncore.com">DivisionCore</a>.
	<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
	<!-- IF DEBUG_OUTPUT --><br /><bdo dir="ltr">[ {DEBUG_OUTPUT} ]</bdo><!-- ENDIF --></span>
</div>
And yeah its an awesome portal, mine is a bit messed up atm due to teething probs I am in the process of getting support for... but generally its a great addition to any portal page. This is what it normally looks like and where you can download it from: http://www.phpbbireland.com/phpBB3/

The package is available in the downloads forum, in a stickied topic as an attachment.

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Mon Dec 31, 2007 1:57 pm

You posted the overall_footer.html, but it would be better if you could post the page_footer function in includes/functions.php... Or you may PM me...
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Mon Dec 31, 2007 9:25 pm

I've noticed a small bug while viewing the pagehits in ACP for the year 2008. Will be fixed for next version.

Meanwhile you can do the following edit... (Next version will contain update instructions including this fix)

open includes/acp/acp_pagehits.php
find

Code: Select all

				$first_month = ($period == $board_startdate['year']) ? $board_startdate['mon'] : 1;
after-add

Code: Select all

				if ($first_month < 10)
				{
					$first_month = '0' . $first_month;
				}
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

annepenullar
Registered User
Posts: 137
Joined: Sun Oct 21, 2007 7:01 am

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by annepenullar » Thu Jan 10, 2008 5:40 pm

:( I don't know why or how...but it seems that the counter is not logging the hits. I'm still down to 0 even though I have users online. I have tried the fixes from the previous post, but to no avail.

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Thu Jan 10, 2008 6:52 pm

This is the second or third such problem reported here... Has anyone got it to work with the given install instructions?
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

mladen88
Registered User
Posts: 158
Joined: Wed May 30, 2007 9:06 pm

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by mladen88 » Fri Jan 11, 2008 8:31 am

i have installed your mod and everything is ok, but i see there 0 total pages hits...but i know that it's not 0.

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Fri Jan 11, 2008 3:02 pm

Ok... then there seems to be something fishy here... Will have to look more into it... whether I missed some install instructions or anything more serious... All I can say that there is not a major issue as the test board on which I'm developing is really going well with the pagehits... So I'll have to review the edits, nothing more. I'll advise you to install the next version.
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

mladen88
Registered User
Posts: 158
Joined: Wed May 30, 2007 9:06 pm

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by mladen88 » Sat Jan 12, 2008 1:57 pm

Total posts 232757 • Total topics 3387 • Total members 3344 • Total page hits 3032 • Our newest member |<BBCW>|*CVELE*

Hmmm, now works :D but yesterday was 0 hits, which is update delay ??

User avatar
TheUniqueTiger
Registered User
Posts: 303
Joined: Wed Sep 05, 2007 7:57 pm
Location: India
Contact:

Re: [BETA] TUT Forum Page Hits 0.1.0

Post by TheUniqueTiger » Sat Jan 12, 2008 6:24 pm

So do you mean the page hits are counted and displayed the next day, but today's pagehits are shown as zero?
You have only One Life... So before you are History, make sure you make it to the History books! - TheUniqueTiger

Locked

Return to “[3.0.x] Abandoned MODs”