[ABD] phpBB Calendar 0.1.1 (alightner)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
SpankinPartier
Registered User
Posts: 4
Joined: Thu Jul 26, 2007 7:03 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by SpankinPartier »

alightner wrote:
oxfordsi wrote:I've installed the calender MOD and all appears fine apart from the following 3 errors:

1. The entire background to the calender is dark blue and not the colour as featured in the example. I have refreshed all templates, imagesets and theme. I have also purged the cache.

2. The calender refuses to be shown on the index page. I have enabled this feature in the ACP.

3. The little logos with each entry are not being shown either (eg. the star, calendar etc)

Any ideas what the above errors may be?
This sure sounds like a cache problem... even though you've refreshed/purged things, I've observed on at least one occassion where I had to purge my cache in the ACP more than once before a change showed up (this happened when I installed some new modules - but if it could happen once for me, it could probably happend once for you too). If you want to be extra sure, I recommend you open your browser and delete all of your temporary files, then repeat the steps to purge your cache and refresh all the elements of your style. Then reload the page. See if that helps :)
I've just had the exact same issue and Oxfordsi had, and you were right, it was a cache problem.
  1. Styles --> Templates --> prosilver Refresh
  2. Styles --> Themes --> prosilver Refresh
  3. Styles --> Imagesets --> prosilver Refresh
  4. General --> Purge the Cache Run Now
  5. Browse back to the forum with your browser, and refresh the page[/b]
The funny thing is, I know I did at least part of that. But I must have missed something on both boards I installed this on. :roll:

Anyways, I hope this help anyone else who has this issue. This is a Great Mod! Thanks for all your long hours of work! :D
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

alightner wrote:frec - there isn't any UCP support to manage the subscriptions... it only manages events you've rsvp'd yes or maybe on.

As for the uninitialized variable this is a known issue with the fix already documented in this thread: http://www.phpbb.com/community/viewtopi ... #p10576465
ok, thank you for the fix.
One more thing, I noticed that when I viewing an event with "Who can see this event?" option to "group", the link to the group is not correct in the event view page. it always shows memberlist.php?mode=group&g=0 for all of the groups, but the color and the list of the groups are correct. is there a fix for that?
dpower_20@hotmai.com
Registered User
Posts: 29
Joined: Fri Sep 25, 2009 11:49 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by dpower_20@hotmai.com »

Hiya!

I've got the calender installed and it is just perfect but I'm wondering how I could put the events of the week on other pages than the index?
alightner
Registered User
Posts: 1118
Joined: Fri Mar 23, 2007 12:42 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by alightner »

frec wrote:
alightner wrote:frec - there isn't any UCP support to manage the subscriptions... it only manages events you've rsvp'd yes or maybe on.

As for the uninitialized variable this is a known issue with the fix already documented in this thread: http://www.phpbb.com/community/viewtopi ... #p10576465
ok, thank you for the fix.
One more thing, I noticed that when I viewing an event with "Who can see this event?" option to "group", the link to the group is not correct in the event view page. it always shows memberlist.php?mode=group&g=0 for all of the groups, but the color and the list of the groups are correct. is there a fix for that?
I can't reproduce that issue in the demo... please provide a link to the event in question on your calendar (and username/password if I need to log into view the event).
dpower_20@hotmai.com wrote:Hiya!

I've got the calender installed and it is just perfect but I'm wondering how I could put the events of the week on other pages than the index?
This has been answered many times before... http://www.phpbb.com/community/viewtopi ... y#p9568395
My phpbb3 mods:
Calendar
User Attachment Quota
Do not PM me with questions about my mods.
Support will only be given through the topic threads above.
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

alightner wrote:
frec wrote:
alightner wrote:frec - there isn't any UCP support to manage the subscriptions... it only manages events you've rsvp'd yes or maybe on.

As for the uninitialized variable this is a known issue with the fix already documented in this thread: http://www.phpbb.com/community/viewtopi ... #p10576465
ok, thank you for the fix.
One more thing, I noticed that when I viewing an event with "Who can see this event?" option to "group", the link to the group is not correct in the event view page. it always shows memberlist.php?mode=group&g=0 for all of the groups, but the color and the list of the groups are correct. is there a fix for that?
I can't reproduce that issue in the demo... please provide a link to the event in question on your calendar (and username/password if I need to log into view the event).
here is the link to the event note the link on the invited list, it's linking to memberlist.php?mode=group&g=0 for all groups.
alightner
Registered User
Posts: 1118
Joined: Fri Mar 23, 2007 12:42 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by alightner »

OK, it is a known bug with a published fix. I thought I had updated the download zip, but apparently not. This is why I recommend everyone start with the first post of the current release 0.1.0 and read through the current posts looking for any updated bug fixes. If anything is broken, I always post the fix as soon as I find it: http://www.phpbb.com/community/viewtopi ... #p10341835
My phpbb3 mods:
Calendar
User Attachment Quota
Do not PM me with questions about my mods.
Support will only be given through the topic threads above.
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

alightner wrote:OK, it is a known bug with a published fix. I thought I had updated the download zip, but apparently not. This is why I recommend everyone start with the first post of the current release 0.1.0 and read through the current posts looking for any updated bug fixes. If anything is broken, I always post the fix as soon as I find it: http://www.phpbb.com/community/viewtopi ... #p10341835
I'm sorry but I thought that fix is specific to recurring events only.

edit:
I just now tried to add all of the 12 instances, but it still does not repair it.
my problem is that the link of the groups are not correct in the invited list.
on the link i provided earlier (that is not a recuring event), look at the invited list's link.
Invited: Guests, Registered users
the link for both guest and registered users are pointing to memberlist.php?mode=group&g=0, which should have been memberlist.php?mode=group&g=1 and memberlist.php?mode=group&g=2
this bug also happens in UCP manage my events and manage event registration on "invited" column.

Also, I found one more bug, the events shown in manage event registration is not properly colored.
alightner
Registered User
Posts: 1118
Joined: Fri Mar 23, 2007 12:42 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by alightner »

OK, it seems to happen whenever you select multiple groups for the invite list. Go into functions_calendar.php and find the function get_event_invite_list_and_poster_url()

Look for:

Code: Select all

		case 1:
			if( $event_data['group_id'] != 0 )
			{
				// group event... only members of specified group are invited
				$sql = 'SELECT group_name, group_type, group_colour FROM ' . GROUPS_TABLE . '
						WHERE group_id = '.$db->sql_escape($event_data['group_id']);
				$result = $db->sql_query($sql);
				$group_data = $db->sql_fetchrow($result);
				$db->sql_freeresult($result);
				$temp_list = (($group_data['group_type'] == GROUP_SPECIAL) ? $user->lang['G_' . $group_data['group_name']] : $group_data['group_name']);
				$temp_url = append_sid("{$phpbb_root_path}memberlist.$phpEx", "mode=group&g=".$event_data['group_id']);
				$temp_color_start = "";
				$temp_color_end = "";
				if( $group_data['group_colour'] !== "" )
				{
					$temp_color_start = "<span style='color:#".$group_data['group_colour']."'>";
					$temp_color_end = "</span>";
				}
				$invite_list = "<a href='".$temp_url."'>".$temp_color_start.$temp_list.$temp_color_end."</a>";
			}
			else
			{
Inside the else block you should see a snippet of code like:

Code: Select all

$temp_url = append_sid("{$phpbb_root_path}memberlist.$phpEx", "mode=group&g=".$event_data['group_id']);
Change it to:

Code: Select all

$temp_url = append_sid("{$phpbb_root_path}memberlist.$phpEx", "mode=group&g=".$group_data['group_id']);
That should do it.
My phpbb3 mods:
Calendar
User Attachment Quota
Do not PM me with questions about my mods.
Support will only be given through the topic threads above.
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

I got this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions_calendar.php on line 1871: Undefined index: group_id
[phpBB Debug] PHP Notice: in file /includes/functions_calendar.php on line 1871: Undefined index: group_id
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3870: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3260)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3872: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3260)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3873: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3260)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3874: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3260)
alightner
Registered User
Posts: 1118
Joined: Fri Mar 23, 2007 12:42 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by alightner »

Oops, sorry about that you also need to find the place in the same else block that says:

Code: Select all

$sql = 'SELECT group_name, group_type, group_colour FROM ' . GROUPS_TABLE . '
							WHERE group_id = '.$db->sql_escape($group_list[$i]);
And change it to:

Code: Select all

$sql = 'SELECT group_id, group_name, group_type, group_colour FROM ' . GROUPS_TABLE . '
							WHERE group_id = '.$db->sql_escape($group_list[$i]);
See if that fixes it.
My phpbb3 mods:
Calendar
User Attachment Quota
Do not PM me with questions about my mods.
Support will only be given through the topic threads above.
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

Thank you!
That fixes it.
I also found another bug; the event color is not correct on manage event registration in UCP.
User avatar
fulleffect
Registered User
Posts: 78
Joined: Sun Jan 14, 2007 6:54 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by fulleffect »

oke, i understand al my questions. i only got one,or maybe a suggestion for the next update:

now you make the recurring options (supers, i like it) only i want to make it like "every last sunday of the month" is this possible? or is this good idea for next update?

question 2 :mrgreen: (i want to know everything): i translate everything to dutch (after little bit testing you wil get the translation also (like always ;) ))and when i get email about changings event, the subject of the mail is " unknown subject"
it's just the way it is ;-)
alightner
Registered User
Posts: 1118
Joined: Fri Mar 23, 2007 12:42 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by alightner »

fulleffect wrote:oke, i understand al my questions. i only got one,or maybe a suggestion for the next update:

now you make the recurring options (supers, i like it) only i want to make it like "every last sunday of the month" is this possible? or is this good idea for next update?

question 2 :mrgreen: (i want to know everything): i translate everything to dutch (after little bit testing you wil get the translation also (like always ;) ))and when i get email about changings event, the subject of the mail is " unknown subject"
You already have the ability to create events the last sunday of every month.
If the subject is unknown, perhaps you have yet to translate the string used for the subject?
My phpbb3 mods:
Calendar
User Attachment Quota
Do not PM me with questions about my mods.
Support will only be given through the topic threads above.
frec
Registered User
Posts: 43
Joined: Tue Jul 21, 2009 6:35 am

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by frec »

frec wrote:I also found another bug; the event color is not correct on manage event registration in UCP.
this is what i meant:

in calendar view month:

Image



in ucp manage event registration:

Image

note the event in manage event registration is not colored.
Rarehero
Registered User
Posts: 3
Joined: Fri Oct 23, 2009 3:04 pm

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Post by Rarehero »

Hey guys,

first of all I want to say thank you for this mod.
Unfortunately I have a problem with the mod. Everything seems to work fine, but the calendar setting don't I appear in the acp. Since I'm using a german phpBB installation I suggest, that the error has something to do wie the language integration. Here's what I've done so far:

1. Installed the mod very, very accordingly to the given manual.
2. Reinstalled the mod three times (didn't touch the database since the entries seem to be fine), again very accordingly to the manual.
3. Applied every change to the english language files and folders to the german language files as well.
4. Pruned the cache and checked the permissions again and again and again.

My suggestion, is that something went wrong with the integration into the german acp files. Everything else seems to be fine. When I activate the week overview directly in the database, the week overview appears on the index page. So my questions are:

1. Which files and have to be present to make the mod appear in the acp?
2. Which files have to be altered?
3. Does it have anything to do with missing files?

Thank you
Locked

Return to “[3.0.x] Abandoned MODs”