Page 255 of 284

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Fri Mar 18, 2011 7:42 am
by gec100
hmm ... at the beginning i had the same problem with the icons but they just showed up by them selves after few page refreshes.

must be some cache issue.

also my forum is inside joomla so i had to add .mainCell in front of .buttons.

i've done thet cause bridge creator told me to. i have no idea what that does, and if it is importnant for this case.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Fri Mar 18, 2011 7:50 am
by TwiztedIndian
Yeah, I have no clue at this point... ugh.. ok, I am going to head to bed since I'm about to start pulling hair out lol... Thanks for the help hopefully you or someone else will have an epiphany overnight :)

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Fri Mar 18, 2011 8:25 am
by skybound
Have the dark blue colour issue. Have refreshed template, styles and imagesets followed by purge cache. Also manually deleted all files in cache folder.

Manually Deleted all files in Temp internet folder on my machine.

Still remains dark blue. If I hover over it - then I get the correct colour.

Which lines of code govern the colours anyway?

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Fri Mar 18, 2011 4:14 pm
by keith10456
skybound wrote:Have the dark blue colour issue. Have refreshed template, styles and imagesets followed by purge cache. Also manually deleted all files in cache folder.

Manually Deleted all files in Temp internet folder on my machine.

Still remains dark blue. If I hover over it - then I get the correct colour.

Which lines of code govern the colours anyway?
Did you do the style edits? Keep in mind that the style edits are listed in the xml folder of the download. Likewise, be sure to do the edits to the style that you're using.

Lastly, make sure you upload the files in the prosilver folder of the download to the directory of the style you're using.

Of course, Refresh your Theme, Imageset, and Template in the ACP.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Mon Mar 21, 2011 3:48 am
by lanesharon
I am having the same problem, with the icons not showing, and have refreshed, multiple times. :?

I can tell you that the dark color doesn't seem to go away until you add a new event.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Tue Mar 22, 2011 10:55 am
by libracorn
Just installed this mod on the latest phpBB version and it's working great for me. I have one question and after searching for awhile in this thread can't figure out if this has been asked before or not...

I currently have the mod set to display the current week on the index page. Is there a way to change that to display two weeks ahead instead of just the current week?

Thanks.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Tue Mar 22, 2011 4:20 pm
by Elysea
I've installed this yesterday on a new phpbb forum install. The forum isn't live but a sandbox.
The live forum users have been waiting for something like this for a long time and finally I felt I was rdy to take up the challeng.
I have no larger problems with php and following instructions.

I have the code to past into mysql from this thread. but, I have no idea how to find the mysql to put it into. :oops:
What is missing is the settings in the user controle panel and the features in acp as shown here http://phpbbcalendarmod.com/screenshots ... ttings.jpg

I know that this mod isn't adviced for beginners but I decided to try it out anyway.
http://forum. graphic-labs.com if anyone want to se it.

I hope someone have patience enough to tell me what to do.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Tue Mar 22, 2011 9:29 pm
by marian0810
Here you can read about MySQL and phpMyAdmin: http://www.phpbb.com/community/viewtopi ... 0&t=588697

You'll also need to upload the subsilver2 files, you can find those here: http://www.phpbb.com/community/viewtopi ... #p10568715

And for adding your ACP modules read this: http://wiki.phpbb.com/Tutorial.Adding_modules

Good luck!

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Wed Mar 23, 2011 12:39 pm
by Elysea
Thank you for all the links, much appriciated and impressed by the system you must have to remember where it all is.

First part were added on another fresh installed sandbox and gave me an error so I added this without error to the linked and no error.

Code: Select all

CREATE TABLE IF NOT EXISTS `phpbb_calendar_recurring_events` (
  `recurr_id` mediumint(8) unsigned NOT NULL auto_increment,
  `etype_id` tinyint(4) NOT NULL,
  `frequency` tinyint(4) NOT NULL default '1',
  `frequency_type` tinyint(4) NOT NULL default '0',
  `first_occ_time` bigint(20) unsigned NOT NULL,
  `final_occ_time` bigint(20) unsigned NOT NULL,
  `event_all_day` tinyint(2) NOT NULL default '0',
  `event_duration` bigint(20) unsigned NOT NULL,
  `week_index` tinyint(2) NOT NULL default '0',
  `first_day_of_week` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0,
  `last_calc_time` bigint(20) unsigned NOT NULL,
  `next_calc_time` bigint(20) unsigned NOT NULL,
  `event_subject` varchar(255) character set utf8 collate utf8_unicode_ci NOT NULL default '',
  `event_body` longblob NOT NULL,
  `poster_id` mediumint(8) unsigned NOT NULL default '0',
  `poster_timezone` decimal(5,2) NOT NULL default '0.00',
  `poster_dst` tinyint(1) unsigned NOT NULL default '0',
  `event_access_level` tinyint(1) NOT NULL default '0',
  `group_id` mediumint(8) unsigned NOT NULL default '0',
  `group_id_list` varchar(255) character set utf8 collate utf8_unicode_ci NOT NULL default ',',
  `enable_bbcode` tinyint(1) unsigned NOT NULL default '1',
  `enable_smilies` tinyint(1) unsigned NOT NULL default '1',
  `enable_magic_url` tinyint(1) unsigned NOT NULL default '1',
  `bbcode_bitfield` varchar(255) character set utf8 collate utf8_bin NOT NULL default '',
  `bbcode_uid` varchar(8) character set utf8 collate utf8_bin NOT NULL,
  `track_rsvps` tinyint(1) unsigned NOT NULL default '0',
  `allow_guests` tinyint(1) unsigned NOT NULL default '0',
  PRIMARY KEY  (`recurr_id`)
);

CREATE TABLE IF NOT EXISTS `phpbb_calendar_rsvps` (
  `rsvp_id` mediumint(8) unsigned NOT NULL auto_increment,
  `event_id` mediumint(8) unsigned NOT NULL default '0',
  `poster_id` mediumint(8) unsigned NOT NULL default '0',
  `poster_name` varchar(255) collate utf8_bin NOT NULL default '',
  `poster_colour` varchar(6) collate utf8_bin NOT NULL default '',
  `poster_ip` varchar(40) collate utf8_bin NOT NULL default '',
  `post_time` int(11) unsigned NOT NULL default '0',
  `rsvp_val` tinyint(1) unsigned NOT NULL default '0',
  `rsvp_count` smallint(4) unsigned NOT NULL default '1',
  `rsvp_detail` mediumtext collate utf8_bin NOT NULL,
  `bbcode_bitfield` varchar(255) collate utf8_bin NOT NULL default '',
  `bbcode_uid` varchar(8) collate utf8_bin NOT NULL,
  `bbcode_options` tinyint(1) unsigned NOT NULL default '7',
  PRIMARY KEY (`rsvp_id`),
  KEY `event_id` (`event_id`),
  KEY `poster_id` (`poster_id`),
  KEY `eid_post_time` (`event_id`,`post_time`)
);


CREATE TABLE IF NOT EXISTS `phpbb_calendar_events_watch` (
  `event_id` mediumint(8) unsigned NOT NULL default '0',
  `user_id` mediumint(8) unsigned NOT NULL default '0',
  `notify_status` tinyint(1) unsigned NOT NULL default '0',
  `track_replies` tinyint(1) unsigned NOT NULL default '0',
  KEY `event_id` (`event_id`),
  KEY `user_id` (`user_id`),
  KEY `notify_stat` (`notify_status`)
);

CREATE TABLE IF NOT EXISTS `phpbb_calendar_watch` (
  `user_id` mediumint(8) unsigned NOT NULL default '0',
  `notify_status` tinyint(1) unsigned NOT NULL default '0',
  KEY `user_id` (`user_id`),
  KEY `notify_stat` (`notify_status`)
);

After doing everything else, it didn't make any different.

Isn't ther suppose to be an alert for users when using:
Watch this event
Watch the calendar


There isn't any calender sittings avalible in UCP.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Thu Mar 24, 2011 9:26 pm
by marian0810
Elysea wrote: After doing everything else, it didn't make any different.
When I look at your board it seems to be working fine. Looks like only the changes to overall_header.html are still missing.
Isn't ther suppose to be an alert for users when using:
Watch this event
Watch the calendar


There isn't any calender sittings avalible in UCP.
There isn't supposed to be anything in the UCP, members get an email when they subscribed and something is new.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Fri Mar 25, 2011 7:59 am
by Martin Day
MartectX, I still have an issue with recurring events and daylight saving and I get twitchy every time DST changes come around. Is there and chance you could look into this again?
Martin Day wrote:
Martin Day wrote:
MartectX wrote:
Martin Day wrote:MartectX, I realise you have put considerable effort into this issue already, but I don't feel equipped to take your thoughts on this further myself. Is there any chance you could turn your pseudo code into real code?
I'm helping my grandparents move these days, but I think I may have some time in about a week from now. I'll let you know when I come up with something - I won't forget about this.
MartectX, I hope your grandparents are settled in... I was just wondering if you would have any time to finish the fix you had started to craft. There is obviously no particular rush at the moment as the spring DST change has passed but it would be great to have a solution before the next time change comes over the horizon. Thanks.
MartectX, you will probably remember this one. Well I'm wondering it you are at all in the mood for pushing this one one a little further as the next daylight saving time change is coming up on the horizon? And my board members will soon be in confusion again. thanks

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Sun Mar 27, 2011 7:02 pm
by UniformGolfOscar
I've got trouble when running the "Move all event -1h" routine. It looks like it's trying to change the "all day event", but since they got no "start time" and "end time" it won't work.

The quick solution I made was to delete all "All day" events or change the to time limited events (00:00 - 23:45). (Boring!!!) After that the "Move all event -1h" routine worked without errors.

It worked last year, maybe it's due to updating the board from 3.0.6 to 3.0.8?

Any suggestions?

How to delete and edit events posted by others

Posted: Tue Mar 29, 2011 7:43 pm
by Boomn4x4
It seems that, even as an admin, I cannot edit or delete events posted by other users. Is this by design or do I not know what I'm doing?

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Tue Mar 29, 2011 9:17 pm
by wolfman24
Even as an admin you need to set the permissions first, also for administrative permissions.

Re: [Beta] phpBB Calendar 0.1.0 (alightner)

Posted: Thu Mar 31, 2011 12:12 pm
by Boomn4x4
wolfman24 wrote:Even as an admin you need to set the permissions first, also for administrative permissions.
Thanks for the reply... I set the registered user and admin permissions, but didn't set the moderator permissions... and that is where the "edit" permissions are.