Page 19 of 25

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 8:40 am
by henmedia
Please post your translation part of config file and a hardcopy to see, which fields are not show correctly.

Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 10:45 am
by SuurSuomalainen
All of these russian words are displyed incorrectly. Perhaps I had to save the config file as an Unicode-document?

Code: Select all

 // russian (ru)

  $n2m_TEXT[ru][mode]         = "Тип";
  $n2m_TEXT[ru][forum]        = "Форум";
  $n2m_TEXT[ru][thread]       = "Тема";
  $n2m_TEXT[ru][subject]      = "Заголовок";
  $n2m_TEXT[ru][user]         = "От:";
  $n2m_TEXT[ru][ip_hostname]  = "IP";
  $n2m_TEXT[ru][host_na]      = "(н/д)";
  $n2m_TEXT[ru][actions]      = "Действия";
  $n2m_TEXT[ru][reply]        = "ответить";
  $n2m_TEXT[ru][quote]        = "цитировать";
  $n2m_TEXT[ru][edit]         = "редактировать";
  $n2m_TEXT[ru][delete]       = "удалить";
  $n2m_TEXT[ru][info]         = "инфо";
  $n2m_TEXT[ru][pm]           = "Личн.Сообщ.";
  $n2m_TEXT[ru][email]        = "E-mail";
  $n2m_TEXT[ru][attachments]  = "Вложения";
  $n2m_TEXT[ru][edited_by]    = "отредактировано";
  $n2m_TEXT[ru][edit_reason]  = "причина правки";

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 11:42 am
by henmedia
Saving as unicode will not work, sorry.

You have to use numerical codes for each character as listed on http://www.landisreed.com/pages/russian_ascii.php, meaning the codes beginning with "&#", this should work.

Gruß
Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 2:28 pm
by SuurSuomalainen
Thank you again, now it works!
But again new problem, I hope it's the last one. It's a css issue. I cannot change background, font sizes etc. It all remains the same. And the current theme is working in a strange way. Header and footer is displayed in color other than bodytext, and even the bodytext's color itself sometimes turns to that color.

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 4:57 pm
by henmedia
this may be a problem with your eMail client ... to make sure please try another client first.

Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 21, 2010 5:32 pm
by SuurSuomalainen
Well, you're right again. It's displayed fine in Outlook 2007, but incorrectly in Gmail.

Vielen Dank!

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 28, 2010 8:16 am
by colorwarphotos
hello Steffan.
I would really like this for my forum.
But I have version 3.07 the newest version.
I made all the changed to the posting.php file. every thing i think and when i make a reply. i get this message:


[phpBB Debug] PHP Notice: in file /newpost2mail.php on line 305: mail() [function.mail]: SMTP server response: 501 5.5.4 Invalid Address

Warning: Cannot modify header information - headers already sent by (output started at \\nas01\nas\c\o\colorwarphotos.com\web\includes\functions.php:3493) in \\nas01\nas\c\o\colorwarphotos.com\web\includes\functions.php on line 4284

Warning: Cannot modify header information - headers already sent by (output started at \\nas01\nas\c\o\colorwarphotos.com\web\includes\functions.php:3493) in \\nas01\nas\c\o\colorwarphotos.com\web\includes\functions.php on line 4286

Warning: Cannot modify header information - headers already sent by (outpu


can you please help me/
Thank you.
Ian

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 28, 2010 8:31 am
by henmedia
SMTP server response: 501 5.5.4 Invalid Address

Which address are you trying to send to?
If you did not change anything to the config file, it should work without this error because Mails are only sent to the board contact address configured in your phpBB installation, did you try this?

Stefan

newpost2mail: Exclamation marks are sometimes randomly inser

Posted: Thu Oct 28, 2010 12:10 pm
by SuurSuomalainen
Hello Stefan. I've got two new problems. The first one: messages sent by newpost2mail differ from forum originals: exclamation marks are being inserted randomly among the russian message body text (rarely, like one "!" per 1000-5000 characters).
The second problem: some russian words/chars suddenly (and pretty often, like 2-4 per A4 page) become corrupted. Here are examples:
"рукоÐ! �одят" instead of "руководят" (letter "в" is corrupted here)
"пребыватÑ! Œ" instead of "пребывать" (letter "ь" is corrupted here)
"разобÑ! �ался" instead of "разобрался" (letter "р" is corrupted here)

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Oct 28, 2010 1:01 pm
by henmedia
SuurSuomalainen, please try this:

in newpost2mail.php after line 236 insert the following line:

before:

Code: Select all

$message .= "</td></tr></table></BODY></HTML>\n";
after:

Code: Select all

$message .= "</td></tr></table></BODY></HTML>\n";

$message = wordwrap($message, 127);
If this does not fix it, I've no further idea :-(

Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Thu Nov 04, 2010 11:40 am
by henmedia
SuurSuomalainen, did the above work for you?

Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Mon Nov 08, 2010 8:40 am
by SuurSuomalainen
Excuse me for the delay. I'm glad to tell the fix does really work!

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Mon Nov 08, 2010 9:43 am
by henmedia
Fine, so it's time for an official update:

beta 20: Display fixes, better display in Mozilla Thunderbird and better support for languages with foreign character sets (kyrillic etc.)

Stefan

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Mon Nov 08, 2010 2:23 pm
by jbygden
I've seen some discussion about sending mail to a group.

But how do I combine the mail to group, and monitor a specific forum?

I want to send mail to a group of users if a new post is posted in a specific forum. Any tips?

/Jonas

Re: [BETA] newpost2mail: Send new posts as email to admin

Posted: Mon Nov 08, 2010 8:51 pm
by jbygden
Never mind, copied the if-statement about n2m_MONITOR_FORUM around the final foreach that actually sends the mail. That solved my problem.