[ABD] User Reputation Points 0.3.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
acid2k1
Registered User
Posts: 25
Joined: Thu Jun 10, 2010 5:41 pm

Re: [BETA] User Reputation Points 0.3.1

Post by acid2k1 »

I just looked they are already replaced :?

Do you know whats wrong?

Thanks
ShadowFS
Registered User
Posts: 38
Joined: Mon Aug 10, 2009 10:37 pm
Location: Brasil

Re: [BETA] User Reputation Points 0.3.1

Post by ShadowFS »

This is strange on my board works perfect... Did you refreshed your styles? Purged cache? Try using other program to edit the files like notepad++. Something like this happened with a short time ago, but i installed this mod with AutoMod. Try unnistall and install it again.
acid2k1
Registered User
Posts: 25
Joined: Thu Jun 10, 2010 5:41 pm

Re: [BETA] User Reputation Points 0.3.1

Post by acid2k1 »

ShadowFS wrote:This is strange on my board works perfect... Did you refreshed your styles? Purged cache? Try using other program to edit the files like notepad++. Something like this happened with a short time ago, but i installed this mod with AutoMod. Try unnistall and install it again.
Il try reinstall it again now. What theme are you using?

Thanks
ShadowFS
Registered User
Posts: 38
Joined: Mon Aug 10, 2009 10:37 pm
Location: Brasil

Re: [BETA] User Reputation Points 0.3.1

Post by ShadowFS »

X-Silver
It's prosilver based style.
veebilahendus
Registered User
Posts: 3
Joined: Thu Jul 01, 2010 9:25 am

Re: [BETA] User Reputation Points 0.3.1

Post by veebilahendus »

richazey wrote:Anyone got this mod working on 3.0.7-pl-1?

As in inlcudes/functions_users.php this bit of code does not exist

Code: Select all

	// Those are group-only attributes
	$group_only_ary = array('group_receive_pm', 'group_legend', 'group_message_limit', 'group_max_recipients', 'group_founder_manage');
so where has people put this:

Code: Select all

// idiotnesia wuz here - user rep point
	$attribute_ary['group_reputation_power'] = 'int';
	$group_only_ary[] = 'group_reputation_power';
// end

I have the same problem?! :? Please someone help.

I need and i want install this mod in my forum.

(I know, i have bad English :roll: )
User avatar
Ashley.S.
Registered User
Posts: 469
Joined: Mon Aug 04, 2008 6:01 pm
Location: Falmouth, Cornwall, UK
Name: Ashley .S.
Contact:

Re: [BETA] User Reputation Points 0.3.1

Post by Ashley.S. »

have we al tried to do the 3.0.6 fixes instead located at: http://www.phpbb.com/community/viewtopi ... #p10939565 ???

because I've installed this mod perfectly fine on 3.0.7-PL1 using the instructions in the install file and then doing the edits listed in the 3.0.6 fixes post where the edits in the install file are outdated.
Regards,
-Ashley.S. [ PurephpBB Founder ]
veebilahendus
Registered User
Posts: 3
Joined: Thu Jul 01, 2010 9:25 am

Re: [BETA] User Reputation Points 0.3.1

Post by veebilahendus »

Ashley.S. wrote:have we al tried to do the 3.0.6 fixes instead located at: http://www.phpbb.com/community/viewtopi ... #p10939565 ???

because I've installed this mod perfectly fine on 3.0.7-PL1 using the instructions in the install file and then doing the edits listed in the 3.0.6 fixes post where the edits in the install file are outdated.
I tried this, but I got litle mysql error, now I restore my forum :D I try one more time step by step.

One more thing.

First i to install.xml manual and then use 3.0.6 fix manual?

And i use Serenity template.

Still bad English :ugeek:
User avatar
Ashley.S.
Registered User
Posts: 469
Joined: Mon Aug 04, 2008 6:01 pm
Location: Falmouth, Cornwall, UK
Name: Ashley .S.
Contact:

Re: [BETA] User Reputation Points 0.3.1

Post by Ashley.S. »

veebilahendus wrote:
Ashley.S. wrote:have we al tried to do the 3.0.6 fixes instead located at: http://www.phpbb.com/community/viewtopi ... #p10939565 ???

because I've installed this mod perfectly fine on 3.0.7-PL1 using the instructions in the install file and then doing the edits listed in the 3.0.6 fixes post where the edits in the install file are outdated.
I tried this, but I got litle mysql error, now I restore my forum :D I try one more time step by step.

One more thing.

First i to install.xml manual and then use 3.0.6 fix manual?

And i use Serenity template.

Still bad English :ugeek:
you should still use the install.xml and then also use the 3.0.6 fix edits along with it, making sure that none of the edits are doubled up, because the 3.0.6 fixes are the replacement finds/adds for some listed in the install.xml
Regards,
-Ashley.S. [ PurephpBB Founder ]
veebilahendus
Registered User
Posts: 3
Joined: Thu Jul 01, 2010 9:25 am

Re: [BETA] User Reputation Points 0.3.1

Post by veebilahendus »

worket :D , but only prosilver template, how i get this work in serenity template?
Khamosh-Saya
Registered User
Posts: 871
Joined: Fri Nov 23, 2007 6:46 am
Location: UAE
Name: Jamshed Ansari
Contact:

Re: [BETA] User Reputation Points 0.3.1

Post by Khamosh-Saya »

Is it possible that User will get Choice to Give Another user rep point with his choice
Mean Admin will select The Rep Point 1 to 5
After that now its Depend on User how much he want to give the Point to another User like 2 point 3 point 4 point or 5 Point

Thanks...
Thor89
Registered User
Posts: 36
Joined: Thu Oct 18, 2007 4:43 pm

Re: [BETA] User Reputation Points 0.3.1

Post by Thor89 »

Hello. This is a great mod that works like it should in about half a year now. But recently, the rep system has been used to flame other users instead of saying "thanks". Is there some way to force it to only give positive feedback?
User avatar
Ashley.S.
Registered User
Posts: 469
Joined: Mon Aug 04, 2008 6:01 pm
Location: Falmouth, Cornwall, UK
Name: Ashley .S.
Contact:

Re: [BETA] User Reputation Points 0.3.1

Post by Ashley.S. »

Thor89 wrote:Hello. This is a great mod that works like it should in about half a year now. But recently, the rep system has been used to flame other users instead of saying "thanks". Is there some way to force it to only give positive feedback?
I believe you can disable it in the usergroup permissions and disable the "Can give negative point" option in the permissions by setting it to no or never
Regards,
-Ashley.S. [ PurephpBB Founder ]
freebike
Registered User
Posts: 1
Joined: Tue Jul 06, 2010 6:47 am

Re: [BETA] User Reputation Points 0.3.1

Post by freebike »

Hello
I'm French
I just wanted to know if there was the same for phpbb2
thank you for your help
saber210
Registered User
Posts: 37
Joined: Thu Jul 15, 2010 1:54 am
Contact:

Re: [BETA] User Reputation Points 0.3.1

Post by saber210 »

Can you help me.. I got this error..

Image

I am already done editing the styles but i cannot start editing the quickfix 3.0.6 RC because i dont know where to find the bold text below..

i am using 3.0.7 please help me.. thanks!

idiotnesia wrote:[at] moonlightkisu

quick fix for 3.0.6 rc

note. Please do it manually make sure there is no duplicate line :)

find

Code: Select all

	<dl>
		<dt><label for="group_legend">{L_GROUP_LEGEND}:</label></dt>
		<dd><input name="group_legend" type="checkbox" value="1" class="radio" id="group_legend"{GROUP_LEGEND} /></dd>
	</dl>
after-add

Code: Select all

	<dl>
		<dt><label for="group_reputation_power">{L_RP_GROUP_POWER}:</label></dt>
		<dd><input name="group_reputation_power" type="text" id="group_reputation_power" maxlength="4" size="4" value="{GROUP_REPUTATION_POWER}" /></dd></dd>
	</dl>
[/b]

open: includes/functions_user.php
find

Code: Select all

	// Attributes which also affect the users table
	$user_attribute_ary = array('group_colour', 'group_rank', 'group_avatar', 'group_avatar_type', 'group_avatar_width', 'group_avatar_height');

add-after

Code: Select all

// idiotnesia wuz here - user rep point
	$user_attribute_ary[] = 'group_reputation_power';
// end
open: includes/acp/acp_groups.php

Code: Select all

						foreach ($test_variables as $test => $type)
add-before

Code: Select all

// idiotnesia wuz here - user rep point
						$test_variables['reputation_power'] = 'int';
// end
find

Code: Select all

					'L_AVATAR_EXPLAIN'	=> sprintf($user->lang['AVATAR_EXPLAIN'], $config['avatar_max_width'], $config['avatar_max_height'], round($config['avatar_filesize'] / 1024)),
				));
add-after

Code: Select all

// idiotnesia wuz here - user rep point
				$template->assign_vars(array(
					'GROUP_REPUTATION_POWER'	=> (isset($group_row['group_reputation_power'])) ? $group_row['group_reputation_power'] : 0,
					)
				);
// end
Open: styles/prosilver/template/memberlist_view.html
find

Code: Select all

						<dt>{L_TOTAL_POSTS}:</dt>
				<dd>{POSTS} <!-- IF S_DISPLAY_SEARCH -->| <strong><a href="{U_SEARCH_USER}">{L_SEARCH_USER_POSTS}</a></strong><!-- ENDIF -->
					<!-- IF POSTS_PCT --><br />({POSTS_PCT} / {POSTS_DAY})<!-- ENDIF -->
					<!-- IF POSTS_IN_QUEUE and U_MCP_QUEUE --><br />(<a href="{U_MCP_QUEUE}">{L_POSTS_IN_QUEUE}</a>)<!-- ELSEIF POSTS_IN_QUEUE --><br />({L_POSTS_IN_QUEUE})<!-- ENDIF -->
				</dd>
add-after

Code: Select all

			<!-- IF S_REPUTATION -->
			<dt>{L_RP_TOTAL_POINTS}:</dt> <dd>{REPUTATION}</dd>
			<dt>{L_RP_POWER}:</dt> <dd>{REP_POWER}</dd>
			<!-- ENDIF -->

The grove by rockwell - Self hosted Pinoy Forum TeamPH
User avatar
architecxp
Registered User
Posts: 1
Joined: Fri Jul 23, 2010 10:18 am

Re: [BETA] User Reputation Points 0.3.1

Post by architecxp »

Tell please, in what a problem? Reputation figures are not displayed. It repeats and in style sublilver2...

Image Image Image
Locked

Return to “[3.0.x] Abandoned MODs”