[ABD] User Reputation Points 0.3.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
idiotnesia
Registered User
Posts: 509
Joined: Sun Jun 18, 2006 10:58 am
Location: www.phpbbindonesia.com
Name: Pungky Putra
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by idiotnesia »

madtay wrote:idiotnesia - could you let me know where th form checks a comment has been submitted as currently its allowing rep to be given without a comment even though force comment option is selected in admin panel. Thanks :)
i will check it....
Cstsxyfry212 wrote:ok, i edited all the files. but when i put in the command in phpmyadmin, i just get errors like "this table already exists" and "this table doesnt exist." also, the modules dont show up after i add them to the acp and enable them. on top of all that, it doesnt show up in group permissions either.

please help, i really want this mod :( :(
is it new installation or update installation?
DJ Jonny
Registered User
Posts: 145
Joined: Sat Nov 10, 2007 10:58 pm

Re: [Beta] User Reputation Points 0.2.0a

Post by DJ Jonny »

Just updated from 0.1.1 to the latest vir and i carnt seem to get the modual to show up in my admin panel i have made a new cat for them and put the 2 mods inside that cat, but the cat i have made with the mods inside are not showing up :S. i have tryed cacheing the forum but still no joy. any 1 got any ideas ?

Thanks
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by madtay »

idiotnesia wrote:
madtay wrote:idiotnesia - could you let me know where th form checks a comment has been submitted as currently its allowing rep to be given without a comment even though force comment option is selected in admin panel. Thanks :)
i will check it....
Thanks :D

I would also still like to see as a feature in the user control panel for the latest rep.. a green, red, or grey block instead of a number like on the new viewreputation page 8-)

Edit: I firgured out how to get the rep images instead of numbers in the user control panel main page for latest reputation recieved table :D
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by madtay »

For anyone who wants a rep image showing in user control panel instead of the rep points like below (note: im using a different template so the screenshot looks diff to the prosilver/subsilver templates)...

Image


Edit: includes/ucp/ucp_main.php

Find:

Code: Select all

//  user reputation points
				if ($config['rp_enable'])
				{
					$sql_array = array(
						'SELECT'	=> 'p.post_id, p.post_subject, p.forum_id, u.username, u.user_id, u.user_colour, r.*',

						'FROM'		=> array(
							POSTS_TABLE			=> 'p',
							REPUTATIONS_TABLE	=> 'r',
							USERS_TABLE			=> 'u'
				
						),

						'WHERE'		=> 'r.rep_to =' . $user->data['user_id'] . '
							AND u.user_id = r.rep_from
							AND r.rep_post_id = p.post_id',

						'ORDER_BY'	=> 'rep_id DESC'
					);

					$sql = $db->sql_build_query('SELECT', $sql_array);	
					$result = $db->sql_query_limit($sql, $config['rp_recent_points']);
					while ($row = $db->sql_fetchrow($result))
					{
						$row['bbcode_options'] = (($row['enable_bbcode']) ? OPTION_FLAG_BBCODE : 0) +
						(($row['enable_smilies']) ? OPTION_FLAG_SMILIES : 0) + 
						(($row['enable_urls']) ? OPTION_FLAG_LINKS : 0);
	
						$template->assign_block_vars('reputation', array(
							'FROM'			=> get_username_string('full', $row['user_id'], $row['username'], $row['user_colour'], $row['username']),
							'POINT'			=> $row['rep_point'],
							'POST_SUBJECT'	=> censor_text($row['post_subject']),
							'U_POST'		=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", 'f=' . $row['forum_id'] . '&p=' . $row['post_id']) . '#p' . $row['post_id'],
							'COMMENT'		=> generate_text_for_display($row['rep_comment'], $row['bbcode_uid'], $row['bbcode_bitfield'], $row['bbcode_options']))
	);
					}
					$db->sql_freeresult($result);
				}
// end user reputation points
Replace with:

Code: Select all

//  user reputation points
				if ($config['rp_enable'])
				{
					$sql_array = array(
						'SELECT'	=> 'p.post_id, p.post_subject, p.forum_id, u.username, u.user_id, u.user_colour, r.*',

						'FROM'		=> array(
							POSTS_TABLE			=> 'p',
							REPUTATIONS_TABLE	=> 'r',
							USERS_TABLE			=> 'u'
				
						),

						'WHERE'		=> 'r.rep_to =' . $user->data['user_id'] . '
							AND u.user_id = r.rep_from
							AND r.rep_post_id = p.post_id',

						'ORDER_BY'	=> 'rep_id DESC'
					);

					$sql = $db->sql_build_query('SELECT', $sql_array);	
					$result = $db->sql_query_limit($sql, $config['rp_recent_points']);
					while ($row = $db->sql_fetchrow($result))
					{
						$row['bbcode_options'] = (($row['enable_bbcode']) ? OPTION_FLAG_BBCODE : 0) +
						(($row['enable_smilies']) ? OPTION_FLAG_SMILIES : 0) + 
						(($row['enable_urls']) ? OPTION_FLAG_LINKS : 0);

					$point_img = '<img src="' . $phpbb_root_path . 'images/reputation/neutral.gif" alt="" title="' . $row['rep_point'] . '" />';
	
					if ($row['rep_point'] < 0)
					{
						$point_img = '<img src="' . $phpbb_root_path . 'images/reputation/neg.gif" alt="" title="' . $row['rep_point'] . '" />';
					}
	
					else if ($row['rep_point'] > 0)
					{
						$point_img = '<img src="' . $phpbb_root_path . 'images/reputation/pos.gif" alt="" title="' . $row['rep_point'] . '" />';
					}

	
						$template->assign_block_vars('reputation', array(
							'FROM'			=> get_username_string('full', $row['user_id'], $row['username'], $row['user_colour'], $row['username']),
							'POINT'			=> $row['rep_point'],
							'POINT_IMG'		=> $point_img,
							'POST_SUBJECT'	=> censor_text($row['post_subject']),
							'U_POST'		=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", 'f=' . $row['forum_id'] . '&p=' . $row['post_id']) . '#p' . $row['post_id'],
							'COMMENT'		=> generate_text_for_display($row['rep_comment'], $row['bbcode_uid'], $row['bbcode_bitfield'], $row['bbcode_options']))
	);
					}
					$db->sql_freeresult($result);
				}
// end user reputation points

Edit: styles/prosilver/template/ucp_main_front.html

Find:

Code: Select all

<th class="name">{L_RP_POINTS}</th>
Replace with:

Code: Select all

<th class="name">&nbsp;</th>

Find:

Code: Select all

<td><span>{reputation.POINT}</span></td>
Replace with:

Code: Select all

<td><span>{reputation.POINT_IMG}</span></td>
Thats it :mrgreen:
Cstsxyfry212
Registered User
Posts: 48
Joined: Thu Jul 31, 2008 2:24 am

Re: [Beta] User Reputation Points 0.2.0a

Post by Cstsxyfry212 »

i will check it....
Cstsxyfry212 wrote:ok, i edited all the files. but when i put in the command in phpmyadmin, i just get errors like "this table already exists" and "this table doesnt exist." also, the modules dont show up after i add them to the acp and enable them. on top of all that, it doesnt show up in group permissions either.

please help, i really want this mod :( :(
is it new installation or update installation?
new installation, and also when i try to look at a users profile, i get this error (screenshot attatched)

Image
DJ Jonny
Registered User
Posts: 145
Joined: Sat Nov 10, 2007 10:58 pm

Re: [Beta] User Reputation Points 0.2.0a

Post by DJ Jonny »

Cstsxyfry212 wrote:i will check it....
new installation, and also when i try to look at a users profile, i get this error (screenshot attatched)

Image
Thats telling u that the groups_reputation_power table hasnt been created in ur database create tha then ya sud be alrite, sorry if am wrong
User avatar
iyeru42
Registered User
Posts: 1120
Joined: Wed Feb 01, 2006 7:22 pm
Location: Madison, WI
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by iyeru42 »

Will there be an option for admins to turn on/off if users can see the users who have given bad/good reputation?
My Website | My MOD Requests | Foreign Key Docs (some topics are not requests)
"It's easy to rebel, but it's hard to be recognized."
Cstsxyfry212
Registered User
Posts: 48
Joined: Thu Jul 31, 2008 2:24 am

Re: [Beta] User Reputation Points 0.2.0a

Post by Cstsxyfry212 »

DJ Jonny wrote:
Cstsxyfry212 wrote:i will check it....
new installation, and also when i try to look at a users profile, i get this error (screenshot attatched)

Image
Thats telling u that the groups_reputation_power table hasnt been created in ur database create tha then ya sud be alrite, sorry if am wrong
well i entered it in the sql command box and it said i need to have at least one field or something, and i have almost no experience with sql, so i dont want to mess it up. thanks anyway :)
efeltee
Registered User
Posts: 15
Joined: Sat Aug 16, 2008 10:33 am

Re: [Beta] User Reputation Points 0.2.0a

Post by efeltee »

When I go to the main page of the UCP, you get a message with your latest rep points. BUT it's just showing this for me:

Code: Select all

{ RP_RECENT_POINTS }
{ RP_POINTS } 	{ RP_COMMENTS }
greetings
drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: [Beta] User Reputation Points 0.2.0a

Post by drankur »

efeltee wrote:When I go to the main page of the UCP, you get a message with your latest rep points. BUT it's just showing this for me:

Code: Select all

{ RP_RECENT_POINTS }
{ RP_POINTS } 	{ RP_COMMENTS }
greetings

i don't know much about php but u should check the language files :idea:
User avatar
gara
Registered User
Posts: 40
Joined: Wed Mar 12, 2008 4:10 am
Location: Colombia
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by gara »

I have this mod, and today i Update 0.1.1 to 0.2.0a...

I have a problem that is that when a user give reputation to other user (positive or negative) the added reputation appeared "zero"

In this link you can see this: http://www.mundomedellin.com/viewreputation.php?id=7273

thanks
Nueva Comunidad

PaginaLatinos.Com Aqui
PaginaLatinos.Com Aqui
drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: [Beta] User Reputation Points 0.2.0a

Post by drankur »

gara wrote:I have this mod, and today i Update 0.1.1 to 0.2.0a...

I have a problem that is that when a user give reputation to other user (positive or negative) the added reputation appeared "zero"

In this link you can see this: http://www.mundomedellin.com/viewreputation.php?id=7273

thanks

plz set the reputataion power in reputation settings
User avatar
gara
Registered User
Posts: 40
Joined: Wed Mar 12, 2008 4:10 am
Location: Colombia
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by gara »

check my configuration in this image: http://img397.imageshack.us/img397/6600/reputapb1.jpg

the strange thing is that, before updating, the system of reputation was working well
Nueva Comunidad

PaginaLatinos.Com Aqui
PaginaLatinos.Com Aqui
User avatar
gara
Registered User
Posts: 40
Joined: Wed Mar 12, 2008 4:10 am
Location: Colombia
Contact:

Re: [Beta] User Reputation Points 0.2.0a

Post by gara »

SOLVED... modify the information of points of reputation of groups..
I believe that I was lacking that.

thank you very much
Nueva Comunidad

PaginaLatinos.Com Aqui
PaginaLatinos.Com Aqui
Cstsxyfry212
Registered User
Posts: 48
Joined: Thu Jul 31, 2008 2:24 am

Re: [Beta] User Reputation Points 0.2.0a

Post by Cstsxyfry212 »

can someone help me??
Locked

Return to “[3.0.x] Abandoned MODs”