[ABD] Topic Preview 0.7.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
eman80
Registered User
Posts: 327
Joined: Tue Aug 19, 2008 1:49 pm

Re: [BETA] Topic Preview 0.7.1

Post by eman80 »

eman80 wrote:
DJ Skitzo wrote:Yeah I did the edit & then refreshed my themes and templates and purged the cache
Try to click (ctrl + F5) to purge your browser cache.

I faced this problem too when I installed this mod but it was solved when I did that.
Edit: sorry for repeat the message it was mistake I wanted to edit but I click on qoute by mistake. :oops:
welcome to my forum:
http://www.elibrary4arab.com

DJ Skitzo
Registered User
Posts: 596
Joined: Sun Aug 12, 2007 7:25 pm

Re: [BETA] Topic Preview 0.7.1

Post by DJ Skitzo »

eman80 wrote:
DJ Skitzo wrote:Yeah I did the edit & then refreshed my themes and templates and purged the cache
Try to click (ctrl + F5) to purge your browser chace.

I faced this problem too when I installed this mod but it was solved when I did that.
I just tried that, its now loading the background to the box, but I'm still facing the problem of the preview appearin really far away from the cursor.

femu
Registered User
Posts: 1070
Joined: Tue Sep 27, 2005 10:03 am

Re: [BETA] Topic Preview 0.7.1

Post by femu »

Where can I change size and color of the preview box?

Thanks,
femu
Regards, femu
_____________________________________________
[My development page] - [My normal homepage (German only)]

femu
Registered User
Posts: 1070
Joined: Tue Sep 27, 2005 10:03 am

Re: [BETA] Topic Preview 0.7.1

Post by femu »

Found it in the changes for the common.css file ;-)
Regards, femu
_____________________________________________
[My development page] - [My normal homepage (German only)]

User avatar
Dugi
Registered User
Posts: 1386
Joined: Sun May 25, 2008 5:36 pm

Re: [BETA] Topic Preview 0.7.1

Post by Dugi »

how can i make this mod only for image preview (not text):

Image
PM me for custom extension pricing / My validated MODs / My MODs in development

pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.7.0a

Post by pgarvin76 »

globetrotting wrote:awesome, works very well except one thing:
autinhyeu wrote: when i search new posts, this MOD not work...
in reply
IPB_Refugee wrote: this MOD is not supposed to work with searches for posts. ...This MOD only works when you search for topics.
When I search for new posts since last login, there is a viewforum-like list of new topics.
There is no preview shown on this page, which I believe is a bug - and I think that autinhyeu meant the same thing.

My 0.7.1 -download shows within the modifications needed in search.php two "FIND"-Instructions in a row without giving any instruction what to do with the first one:

Code: Select all

In search.php 

Find 
Tip: This may be a partial find and not the whole line.
Code: Select All
                    $shadow_topic_list[$row['topic_moved_id']] = $row['topic_id'];

Find 

Tip: This may be a partial find and not the whole line.
Code: Select All
                $rowset[$row['topic_id']] = $row;
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.
Code: Select All
				// mod: Topic Preview
				$topic_preview->set_post_ids($row['topic_first_post_id'], $row['topic_last_post_id']);
				// end: Topic Preview


maybe that is the reason?
The mod does work in New Posts searches. I thought that there was two instances of the line

Code: Select all

$rowset[$row['topic_id']] = $row;
in search.php but I just looked through the file and there is only the one instance. At any rate the 1st find is to get you in the correct area of the file. Maybe I left if there after copy/pasting from the viewforum.php instructions where there are two lines that are the same but he mod only goes after one of them. Since there is only one instance of the line the 1st find whould be removed.

As to your problem please double check your edits in search.php and search_results.html.

pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.7.1

Post by pgarvin76 »

DJ Skitzo wrote:
eman80 wrote:
DJ Skitzo wrote:Yeah I did the edit & then refreshed my themes and templates and purged the cache
Try to click (ctrl + F5) to purge your browser chace.

I faced this problem too when I installed this mod but it was solved when I did that.
I just tried that, its now loading the background to the box, but I'm still facing the problem of the preview appearin really far away from the cursor.
Have not heard of this one before. What version of IE are you experiencing this problem on?

pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.7.1

Post by pgarvin76 »

dugi wrote:how can i make this mod only for image preview (not text):

Image
You would have to change to code in functions_topic_preview.php. The foreach loop on lines 73-93 strips out bbcode tags and smilies. You would have to re-write the regular expressions to strip out everything except img bbcodes. Then you would have to turn the img bbcode into html. the phpBB function generate_text_for_display() may be able to do it for you. But I think you will need to pull out the bbode_uid and bbode_options from the posts table which means modifying the query on line 59 and the while loop on line 66. You'll also what to remove the size limits from the box that hovers and let the image dictate the size. The css for that is in common.css.

User avatar
Dugi
Registered User
Posts: 1386
Joined: Sun May 25, 2008 5:36 pm

Re: [BETA] Topic Preview 0.7.1

Post by Dugi »

pgarvin76 wrote:
dugi wrote:how can i make this mod only for image preview (not text):

Image
You would have to change to code in functions_topic_preview.php. The foreach loop on lines 73-93 strips out bbcode tags and smilies. You would have to re-write the regular expressions to strip out everything except img bbcodes. Then you would have to turn the img bbcode into html. the phpBB function generate_text_for_display() may be able to do it for you. But I think you will need to pull out the bbode_uid and bbode_options from the posts table which means modifying the query on line 59 and the while loop on line 66. You'll also what to remove the size limits from the box that hovers and let the image dictate the size. The css for that is in common.css.
can you make this for me, I'm still learning php, so I can't do things such this :)]
And I need this only for images (not text)
PM me for custom extension pricing / My validated MODs / My MODs in development

User avatar
takufner
Registered User
Posts: 209
Joined: Mon Oct 23, 2006 10:39 am
Location: Rio de Janeiro - Brasil
Name: Prof. Caju
Contact:

Re: [BETA] Topic Preview 0.7.1

Post by takufner »

After upgrading my board to phpBB 3.0.3 this mod stopped working. Is there some patch to 3.0.3?

Thanks

User avatar
eman80
Registered User
Posts: 327
Joined: Tue Aug 19, 2008 1:49 pm

Re: [BETA] Topic Preview 0.7.1

Post by eman80 »

takufner wrote:After upgrading my board to phpBB 3.0.3 this mod stopped working. Is there some patch to 3.0.3?

Thanks
Hi

works fine with me on v 3.0.3 .. maybe you have to re edit your files that contain changes for this mod.

Regards
Eman
welcome to my forum:
http://www.elibrary4arab.com

User avatar
zenrei
Registered User
Posts: 172
Joined: Fri Oct 06, 2006 1:34 pm

Re: [BETA] Topic Preview 0.7.1

Post by zenrei »

I have installed this on all of my themes and it works on all but one.

The one it doesn't work on, has the popup, but it's not populating.

Where should i start troubleshooting?

It HAS to be in one of the 4 files I edited for the style, right? (since it's working in my other 3 themes)

User avatar
zenrei
Registered User
Posts: 172
Joined: Fri Oct 06, 2006 1:34 pm

Re: [BETA] Topic Preview 0.7.1

Post by zenrei »

oh crap! it's the font color in the box that's too light... which part of css is that??

User avatar
zenrei
Registered User
Posts: 172
Joined: Fri Oct 06, 2006 1:34 pm

Re: [BETA] Topic Preview 0.7.1

Post by zenrei »

This mod is fantastic...

for those that need to change the font color, just add it to the preview css add....

color: #whatever hex color code you want

I added it to both the entries and it worked great

User avatar
takufner
Registered User
Posts: 209
Joined: Mon Oct 23, 2006 10:39 am
Location: Rio de Janeiro - Brasil
Name: Prof. Caju
Contact:

Re: [BETA] Topic Preview 0.7.1

Post by takufner »

I made again the changes in viewforum.php and it is now working in my phpBB3.0.3.

I am using this mod version 0.7.0 and would like to know that if the only manner to upgrade for 0.7.1 is to uninstall 0.7.0 and install 0.7.1 or there is some way to do just the upgradeable things...

Thanks

Locked

Return to “[3.0.x] Abandoned MODs”