[ABD] Topic Preview 0.7.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by pgarvin76 »

LeNeR wrote:I have installed it but it is not working. I have purge the cache and refreshed templates. I have also enabled it in ACP. But no preview when mousing over...

my board: http://www.barneprat.com

What must I do.

Thanks in advance.
Do you have it enabled to be user configurable or board wide? If user config did you turn it on in the UCP? I also noticed you only have one post and topic. Have you tried making other posts and see if it works then? Do you have an opcode cache like memcached or eAccelerator running (probably not but worth asking)? Do you have any other mods installed which also user the "user_options" database field?
Last edited by pgarvin76 on Fri May 09, 2008 5:23 pm, edited 1 time in total.
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by pgarvin76 »

Anyasha wrote:I wish this could be done with a simple title tag like I use on phpbb2, because I'm one of those geeks that likes to keep my XHTML valid.
Actually you alter the your viewforum_body and search_results template to put the text in a title tag if that is what you wanted to do. Being a geek who cares about valid XHTML Strict you should be able to figure out how to do this.
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: HOWTO: Enable Topic Preview for all users

Post by pgarvin76 »

golgoth wrote:
pgarvin76 wrote: To make Topic Preview enabled by default for all new users:
Open: includes/functions_user.php

Find:

Code: Select all

'user_options'    =>    895,
Inline find:

Code: Select all

895
Replace with:

Code: Select all

2943
That is all. :)
Hey garvin i just tried to do that, but in functions_user i found only 1919 insted of 895.

What am i supposed to do to enable topic preview by default for all new users?
Use 3967.
LeNeR
Registered User
Posts: 182
Joined: Sat Feb 23, 2008 10:22 pm

Re: [BETA] Topic Preview 0.6.1

Post by LeNeR »

Problem is fixed. It was never really a problem. I hadn't enabled it in my UCP. Thanks.
kott
Registered User
Posts: 25
Joined: Fri May 28, 2004 12:12 pm
Location: Cleveleys, UK

Re: [BETA] Topic Preview 0.6.1

Post by kott »

Has anyone ever found a way of avoiding the flicker problem in IE?
LeNeR
Registered User
Posts: 182
Joined: Sat Feb 23, 2008 10:22 pm

Re: [BETA] Topic Preview 0.6.1

Post by LeNeR »

I like this mod but have two questions. Tha preview background is very dark and the font color also it is somwhat hard to read the preview sometimes. Have to look really close. Is there somwhere I can change the background colour an font colours for the prevew.

Also. When I put my mousecursor over the topic headline the preview lies all over the link and that makes it not clickable. I have to point the cursor right under the topic headline so that the preview wont cover it. Is it possible to change that? So that the preview always shows up right under or next to the headline no matter where I put my cursor?
danielnguyen
Registered User
Posts: 287
Joined: Thu Jan 24, 2008 11:44 am
Location: Vietnam
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by danielnguyen »

Good Mod!
No update needed at this time? And How long I can use final version? I love this mod! :D
My forum, for just teen only with many happy things
Cộng Đồng Teen Online - Cộng Đồng Teen Việt - Teen Việt Nam
Hội Ngộ - Giao Lưu - Học Hỏi - Giải Trí - Kết Bạn
http://www.congdongteenonline.net
User avatar
Sunka
Registered User
Posts: 566
Joined: Wed Mar 26, 2008 2:48 pm
Location: Croatia, Zvoneca

Re: [BETA] Topic Preview 0.6.1

Post by Sunka »

kott wrote:Has anyone ever found a way of avoiding the flicker problem in IE?
Same Question
J.o.h
Registered User
Posts: 32
Joined: Tue May 11, 2004 12:47 pm

Re: [BETA] Topic Preview 0.6.1

Post by J.o.h »

LeNeR wrote:I like this mod but have two questions. Tha preview background is very dark and the font color also it is somwhat hard to read the preview sometimes. Have to look really close. Is there somwhere I can change the background colour an font colours for the prevew.

Also. When I put my mousecursor over the topic headline the preview lies all over the link and that makes it not clickable. I have to point the cursor right under the topic headline so that the preview wont cover it. Is it possible to change that? So that the preview always shows up right under or next to the headline no matter where I put my cursor?
In \root\styles\prosilver\template\topic_preview.html you can change everything you want.

;)
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by pgarvin76 »

Sunka wrote:
kott wrote:Has anyone ever found a way of avoiding the flicker problem in IE?
Same Question
I'm still working on it. It's been much tougher then I thought.
Petesat
Registered User
Posts: 63
Joined: Thu Apr 10, 2008 8:42 am

Re: [BETA] Topic Preview 0.6.1

Post by Petesat »

Hi guys,

I have installed this mod, and it works in the forums but if you click onto the Catagory headers it then gives errors as listed below.
General Error
SQL ERROR [ mysql4 ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE


FILE: includes/db/dbal.php
LINE: 385
CALL: dbal_mysql->sql_error()

FILE: includes/functions_topic_preview.php
LINE: 50
CALL: dbal_mysql->sql_in_set()

FILE: viewforum.php
LINE: 599
CALL: topicpreview->get_preview_text()
Now to give more information, I am using X-Treme_Skin_v3.2__phpBB3_v.3.0.1 for the MAIN forum and the other 2 X-Treme styles, I.E. for the admin and MODS lounges respectively. Green style for MODS and red for ADMINS lounge.

I am hosted by Bluehost.

I have numerous addons including: -

Advanced quick reply
Manage groups order
Donation mod - created through PAYPAL themselves.
Primelink mod
Top posters
A scrolling marquee added by myself
NOTE: all of the above MODS work perfectly and it seems to be this latest edition that has thrown things into chaos.

On instalation I updated all three styles of X-Treme in the same fashion, and the fact that they work correctly except for the Catagory button, is the reason I am posting, the forum headers on my forum are not even set for posting, they are just index's of what's actually in the catagory.

If you simply click on the individual forums in the index, there is no problem and the MOD itself works correctly, it is only when the Catagory header is depresed.

I really like this MOD so I would rather fix the prob than use theback-ups and uninstall it, maybe this is good info for the DEV team.

My site is listed here: -

Code: Select all

http://satlightning.com/
Thankyou for your assistance and time. :oops:

And regard to all

Pete
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by pgarvin76 »

J.o.h wrote:
LeNeR wrote:I like this mod but have two questions. Tha preview background is very dark and the font color also it is somwhat hard to read the preview sometimes. Have to look really close. Is there somwhere I can change the background colour an font colours for the prevew.

Also. When I put my mousecursor over the topic headline the preview lies all over the link and that makes it not clickable. I have to point the cursor right under the topic headline so that the preview wont cover it. Is it possible to change that? So that the preview always shows up right under or next to the headline no matter where I put my cursor?
In \root\styles\prosilver\template\topic_preview.html you can change everything you want.

;)
J.o.h is correct. To answer your second question yes, it could be made to do that. It''s not a simple thing to do though. Because of the different ways the browsers calculate the position of elements and because IE does not make the value of "this" refer to the trigger element in an event fires function it would make for more then a few lines on code. It's like to get this flicker thing smashed first.
pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.6.1

Post by pgarvin76 »

Petesat wrote: I have installed this mod, and it works in the forums but if you click onto the Catagory headers it then gives errors as listed below.
<snip>
I have numerous addons including: -

Advanced quick reply
Manage groups order
Donation mod - created through PAYPAL themselves.
Primelink mod
Top posters
A scrolling marquee added by myself
NOTE: all of the above MODS work perfectly and it seems to be this latest edition that has thrown things into chaos.

On instalation I updated all three styles of X-Treme in the same fashion, and the fact that they work correctly except for the Catagory button, is the reason I am posting, the forum headers on my forum are not even set for posting, they are just index's of what's actually in the catagory.

If you simply click on the individual forums in the index, there is no problem and the MOD itself works correctly, it is only when the Catagory header is depresed.
Are you the same person that posted on my forum?

Topic Preview should not be invoked when you view a category. When I viewed your board I noticed there is an "Active topics list" that shows up on the index and when I clicked on a category. This is via a mod is it not? I think this may be causing your problem. Do you know which mod is providing this functionality? Can you post up your viewforum.php?
Petesat
Registered User
Posts: 63
Joined: Thu Apr 10, 2008 8:42 am

Re: [BETA] Topic Preview 0.6.1

Post by Petesat »

I am the actual owner and the person who did the upgrade, he is my chief admin, but I have been on nightshift so I asked him to look into it.

I am sorry if this caused any fuss.

Pete
Petesat
Registered User
Posts: 63
Joined: Thu Apr 10, 2008 8:42 am

Re: [BETA] Topic Preview 0.6.1

Post by Petesat »

I will get the actual mod for you and show you, it was from here as well, a I do all my upgrades from this great forum, 1 minute please.

Pete
Locked

Return to “[3.0.x] Abandoned MODs”