Page 10 of 24

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 6:09 pm
by pgarvin76
I am pleased to announce the release of Topic Preview Version 0.7.0, "the flicker is gone edition"! I have spent a significant amount of time researching and testing JavaScript code to eliminate the issues present in Internet Explorer. Most of the JavaScript code has been re-written, and the way in which the topic preview text is passed to the template file has changed as well. Upgrade instructions from the previous version, 0.6.1, are provided in the contrib directory.

The JavaScript code developed was inspired by and borrows ideas from Prototip by Nick Stakenburg and borrows some code from the Prototype JavaScript framework. I have tested the code in Internet Explorer 6 (WinXP), Internet Explorer 7 (WinXP & Vista), Firefox 2 (WinXP, Vista, Linux), Firefox 3 (WinXP), Safari 3.1 (WinXP), and Konqueror 3.5.8 (Linux). There is still one known issue in IE6. If the preview box floats over any dropdown boxes such as the sort boxes at the bottom of a topic list, the dropdown boxes will show through the preview box. This is a known bug in IE6 and hopefully most of you have migrated away from it by now.

Please see the first post in this thread for the download link.

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 6:22 pm
by plazm
Let me be the first to say congratulations on solving a very difficult issue. And THANK YOU! :mrgreen:

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 6:24 pm
by LeNeR
Thank you, that is really a great job you have done. I wil go right ahead and do the upgrade from 0.6.1 thanks.

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 7:04 pm
by LeNeR
I was so excited, but now I am so dissapointed. I did the upgrade instruction for 0.6.1. After installing look what happend to the preview:

http://i35.photobucket.com/albums/d185/ ... lde1-4.png

The background is trasparent which make it hard to se what the preveiw says. And the line is way out to the right.

Please help.

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 9:11 pm
by pgarvin76
LeNeR wrote:I was so excited, but now I am so dissapointed. I did the upgrade instruction for 0.6.1. After installing look what happend to the preview:

http://i35.photobucket.com/albums/d185/ ... lde1-4.png

The background is trasparent which make it hard to se what the preveiw says. And the line is way out to the right.

Please help.
1. Go into the ACP -> Styles -> and refresh your Theme (I may have only told you to refresh your Templates and am sorry for that mistake).
2. Press Refresh or Reload in your browser.

Re: [BETA] Topic Preview 0.7.0

Posted: Thu Jun 19, 2008 11:11 pm
by takufner
Hi,

I've installed this MOD in my forum and it work like a charm.

I just want to say two ideas I had that could improve a lot this MOD.

1) Mouse over the post's title shows the first topic preview, and mouse over last post's username (right hand column) shows the last post preview;

2) An alternative way to the administrator choose to show de preview with a link instead of mouse over.

Thanks

Re: [BETA] Topic Preview 0.7.0

Posted: Fri Jun 20, 2008 5:07 am
by stopgo
Outstanding! Just installed this and it works perfectly. Thanks so much for all your work, pg.

Re: [BETA] Topic Preview 0.7.0

Posted: Fri Jun 20, 2008 12:23 pm
by LeNeR
pgarvin76 wrote:
LeNeR wrote:I was so excited, but now I am so dissapointed. I did the upgrade instruction for 0.6.1. After installing look what happend to the preview:

http://i35.photobucket.com/albums/d185/ ... lde1-4.png

The background is trasparent which make it hard to se what the preveiw says. And the line is way out to the right.

Please help.
1. Go into the ACP -> Styles -> and refresh your Theme (I may have only told you to refresh your Templates and am sorry for that mistake).
2. Press Refresh or Reload in your browser.
Did both. Doesn't work

Re: [BETA] Topic Preview 0.7.0

Posted: Fri Jun 20, 2008 2:20 pm
by sam_xp
is this mod compatible with 3.0.0 ?

Re: [BETA] Topic Preview 0.7.0

Posted: Fri Jun 20, 2008 2:28 pm
by stopgo
sam_xp wrote:is this mod compatible with 3.0.0 ?
I've got it running on 3.0.0.

Re: [BETA] Topic Preview 0.7.0

Posted: Fri Jun 20, 2008 4:18 pm
by danielnguyen
Sorry! I cannot open upgrade_from_0.6.1.xml file by my browser! I think there are some code wrong! Please check back!
Regards!

Re: [BETA] Topic Preview 0.7.0

Posted: Sat Jun 21, 2008 4:30 am
by pgarvin76
LeNeR wrote:
pgarvin76 wrote:
LeNeR wrote:I was so excited, but now I am so dissapointed. I did the upgrade instruction for 0.6.1. After installing look what happend to the preview:

http://i35.photobucket.com/albums/d185/ ... lde1-4.png

The background is trasparent which make it hard to se what the preveiw says. And the line is way out to the right.

Please help.
1. Go into the ACP -> Styles -> and refresh your Theme (I may have only told you to refresh your Templates and am sorry for that mistake).
2. Press Refresh or Reload in your browser.
Did both. Doesn't work
Well it's clear that it is not picking up the style info. Maybe try clearing your browser cache. Did you make sure you edited the correct stylesheet? One of my IE users had to refresh 4 times. I think that was a proxy server getting in the way.

Re: [BETA] Topic Preview 0.7.0

Posted: Sat Jun 21, 2008 4:34 am
by pgarvin76
danielnguyen wrote:Sorry! I cannot open upgrade_from_0.6.1.xml file by my browser! I think there are some code wrong! Please check back!
Regards!
Using FF3? Looks like I missed one file when I was an issue for that. Open it up in IE or open up the XML file in a text editor and change:

Code: Select all

../modx.prosilver.en.xsl
to:

Code: Select all

modx.prosilver.en.xsl
It's right at the top of the file.

Re: [BETA] Topic Preview 0.7.0

Posted: Sat Jun 21, 2008 11:00 am
by IPB_Refugee
Hi pgarvin76,

would it be possible to get BBCode and smilies parsed in topic preview like the MOD for phpBB-2 does? This link might be helpful to add the mentioned function:

http://www.ktuk.net/phpBB3/viewtopic.php?f=32&t=2680

Thanks for developing this MOD for Olympus!
Wolfgang

Re: [BETA] Topic Preview 0.7.0

Posted: Sun Jun 22, 2008 3:30 am
by wOxxOm
Great MOD!
  • yeah, two posts (first + last) showing on a preview would be great! either in one floating DIV or separately for the 1st and last columns in the topic table.
     
  • btw, the new 0.7 mousemove event contains an IE-specific substantial flaw :-) which made the poor ms-thingy load my 2x-cpu at 100% - js mousemove event is bound to document object which is a tremendous redundancy.

    topic_preview.html should have this fixed:
       showpreview: function() {
          if (document.addEventListener) this.topiclink.addEventListener('mousemove', this.followmouse.bindObj(this), false);
          else if (document.attachEvent) this.topiclink.attachEvent('onmousemove', this.followmouse.bindObj(this));
     
  • installation xml instruction contain an easy typo, which may however cause some naive soul a trouble (jokin'))) - it should read as 'ADD AFTER' instead of 'Add before'
    'U_MCP_QUEUE' => $u_mcp_queue,
    );