[ABD] Topic Preview 0.7.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
swbfguy
Registered User
Posts: 75
Joined: Tue Dec 11, 2007 6:26 am

Re: [BETA] Topic Preview 0.7.0a

Post by swbfguy » Sat Aug 02, 2008 4:20 am

Code: Select all

General Error
SQL ERROR [ mysqli ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 385
CALL: dbal->sql_error()

FILE: includes/functions_topic_preview.php
LINE: 50
CALL: dbal->sql_in_set()

FILE: viewforum.php
LINE: 617
CALL: TopicPreview->get_preview_text()
this was addressed earlier here however, the user had fixed it themself apparently.

pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.7.0a

Post by pgarvin76 » Sat Aug 02, 2008 1:34 pm

swbfguy wrote:

Code: Select all

General Error
SQL ERROR [ mysqli ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 385
CALL: dbal->sql_error()

FILE: includes/functions_topic_preview.php
LINE: 50
CALL: dbal->sql_in_set()

FILE: viewforum.php
LINE: 617
CALL: TopicPreview->get_preview_text()
this was addressed earlier here however, the user had fixed it themself apparently.
I believe this indicates a problem with your edits in viewforum.php. Please double check your edits. The location of one of them is kind of tricky.

swbfguy
Registered User
Posts: 75
Joined: Tue Dec 11, 2007 6:26 am

Re: [BETA] Topic Preview 0.7.0a

Post by swbfguy » Sat Aug 02, 2008 7:35 pm

pgarvin76 wrote:
swbfguy wrote:

Code: Select all

General Error
SQL ERROR [ mysqli ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 385
CALL: dbal->sql_error()

FILE: includes/functions_topic_preview.php
LINE: 50
CALL: dbal->sql_in_set()

FILE: viewforum.php
LINE: 617
CALL: TopicPreview->get_preview_text()
this was addressed earlier here however, the user had fixed it themself apparently.
I believe this indicates a problem with your edits in viewforum.php. Please double check your edits. The location of one of them is kind of tricky.
correct. the missing piece was the addition of:

Code: Select all

// mod: Topic Preview
    $preview_post_ids[] = $row[$topic_preview->first_last];
// end: Topic Preview
apparantly when i went to add the portion after "$rowset[$row['topic_id']] = $row;", i searched for "$preview_post_ids[] = $row[$topic_preview->first_last];" Noticing that the bit was already entered, i went on ahead to the next step.

thanks

Mr.AmiT
Registered User
Posts: 83
Joined: Wed Apr 09, 2008 7:01 pm

Re: [BETA] Topic Preview 0.7.0a

Post by Mr.AmiT » Sat Aug 02, 2008 9:51 pm

I have a problem with this MOD,
Indeed the MOD works buy when I marker a subject,the forum accomplished very wide?

Any solutions?
phpBB.co.il
phpBB Israel.

Thanks.
Amit.

User avatar
Melvine
Registered User
Posts: 53
Joined: Sun Jul 27, 2008 3:09 am
Location: France

Re: [BETA] Topic Preview 0.7.0a

Post by Melvine » Sun Aug 03, 2008 5:06 am

Hello Mr.AmiT,

Sorry I don't know why . For me all is ok.

Have you did that ? :
After making all file edits, Navigate to the ACP Styles [tab] and choose Templates -> prosilver -> Refresh. Then choose Themes -> prosilver -> Refresh

idem for subsilver

And Thank you very much pgarvin76 , it's a very great Mod ;)

Mr.AmiT
Registered User
Posts: 83
Joined: Wed Apr 09, 2008 7:01 pm

Re: [BETA] Topic Preview 0.7.0a

Post by Mr.AmiT » Sun Aug 03, 2008 10:17 am

Yes,
0.6.0 version works fine..
I try this MOD twice of time.
phpBB.co.il
phpBB Israel.

Thanks.
Amit.

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [BETA] Topic Preview 0.7.0a

Post by IPB_Refugee » Sun Aug 03, 2008 2:39 pm

IPB_Refugee wrote:I think there is one more small bug: When I visit the topic preview page in ACP and change the settings, the administration protocol tells {TOPIC PREVIEW LOG CONFIG} Seems like there is a language variable missing.
This one is still open. You can look e.g. at this MOD how to add a proper logging part to an ACP module MOD: [Beta] NV user topics 0.1.1 (Or look at Highway's Add User MOD.)
IPB_Refugee wrote:When you search for topics, everything is okay. But when you search for posts, you get this warning:
[phpBB Debug] PHP Notice: in file /search.php on line 546: Undefined variable: topic_preview
[phpBB Debug] PHP Notice: in file /search.php on line 546: Trying to get property of non-object
To avoid this debug notice, OPEN search.php and REPLACE

Code: Select all

		'S_TOPIC_PREVIEW'		=> $topic_preview->enabled,
with

Code: Select all

		'S_TOPIC_PREVIEW'		=> ($show_results == 'topics') ? $topic_preview->enabled : '', //mod: Topic Preview
Regards
Wolfgang

pgarvin76
Registered User
Posts: 136
Joined: Sun Mar 20, 2005 5:33 am
Location: Philadelphia, USA
Contact:

Re: [BETA] Topic Preview 0.7.0a

Post by pgarvin76 » Mon Aug 04, 2008 3:29 am

Thanks Wolfgang. I have been working on all this stuff. I did debugging of my changes on my board this weekend. I'm working updating the MODX files now. Should be released soon.

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [BETA] Topic Preview 0.7.0a

Post by IPB_Refugee » Mon Aug 04, 2008 3:46 am

Hi pgarvin76,

you are welcome! :)

I just have to accelerate things because I want to upgrade my main board within 2 weeks. If you have the time to spend some time on this MOD, it will be soon a release candidate or even finally released by the phpBB.com-team - I'm sure!

Best wishes for you and thanks again for re-creating this great MOD for Olympus!
Wolfgang

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [BETA] Topic Preview 0.7.0a

Post by autinhyeu » Thu Aug 07, 2008 9:07 am

autinhyeu wrote:when i search new posts, this MOD not work...
sr
Up :?
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [BETA] Topic Preview 0.7.0a

Post by IPB_Refugee » Thu Aug 07, 2008 9:23 am

Hi,

this MOD is not supposed to work with searches for posts. When you search for (new) posts, you already have a preview of these posts by default, provided by Olympus itself.

This MOD only works when you search for topics.

(Or do you mean the debug notice when you search for posts? Then please look here: http://www.phpbb.com/community/viewtopi ... 5#p6473155)

Did I get you wrong? Then please explain what exactly you would expect or want.

Regards
Wolfgang

regisg
Registered User
Posts: 48
Joined: Fri Apr 14, 2006 11:29 am

Re: [BETA] Topic Preview 0.7.0a

Post by regisg » Thu Aug 07, 2008 6:38 pm

Hello,

Great MOD but what about the counter of views (on viewforum)... does it still increment ?

Thx.

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: [BETA] Topic Preview 0.7.0a

Post by IPB_Refugee » Thu Aug 07, 2008 6:55 pm

Hi,

yes, it does. But only when you read the topic - not when you only get the preview from this MOD.

Regards
Wolfgang

regisg
Registered User
Posts: 48
Joined: Fri Apr 14, 2006 11:29 am

Re: [BETA] Topic Preview 0.7.0a

Post by regisg » Thu Aug 07, 2008 7:05 pm

OK, thx for your quick reply.

I think it should be interresting, for next versions, to add the incrementation of this counter as an option in the ACP ;)

Mr.AmiT
Registered User
Posts: 83
Joined: Wed Apr 09, 2008 7:01 pm

Re: [BETA] Topic Preview 0.7.0a

Post by Mr.AmiT » Fri Aug 08, 2008 10:47 am

Melvine wrote:Hello Mr.AmiT,

Sorry I don't know why . For me all is ok.

Have you did that ? :
After making all file edits, Navigate to the ACP Styles [tab] and choose Templates -> prosilver -> Refresh. Then choose Themes -> prosilver -> Refresh

idem for subsilver

And Thank you very much pgarvin76 , it's a very great Mod ;)
Yes,I deed
phpBB.co.il
phpBB Israel.

Thanks.
Amit.

Locked

Return to “[3.0.x] Abandoned MODs”