[ABD] lastRSS autoposting bot MOD (0.1.4)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
nexum
I've Been Banned!
Posts: 156
Joined: Tue May 25, 2004 8:36 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by nexum »

It would be cool if you could select a different poster for each feeds

why isn't $config['lastrss_ap_bot_id'] in "phpbb_lastrss_autopost" table ??

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Mess »

nexum wrote:It would be cool if you could select a different poster for each feeds
You can do that with the fix on page35 (here)

nexum
I've Been Banned!
Posts: 156
Joined: Tue May 25, 2004 8:36 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by nexum »

Mess wrote:
nexum wrote:It would be cool if you could select a different poster for each feeds
You can do that with the fix on page35 (here)
thanks ;)

i didn't want to read through 70 pages !!

btw there's a few typos errors in the functions_lastrss_autopost.php patch code

PureMB
Registered User
Posts: 13
Joined: Thu Jun 18, 2009 12:21 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by PureMB »

Having problems when I upgraded to 3.0.5

Table 'purembco_phpb1.LASTRSS_AP_TABLE' doesn't exist [1146]

SQL

SELECT * FROM LASTRSS_AP_TABLE WHERE next_check <"1257944262" AND enabled ="1"


What does this mean?

User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Tripp »

The table isn't there, you need to rerun the SQL query.
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs

User avatar
madmartyau
Registered User
Posts: 440
Joined: Sun Sep 12, 2004 12:42 pm
Location: Brisbane,Australia
Name: Marty
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by madmartyau »

Tripp wrote:The table isn't there, you need to rerun the SQL query.
Or the table isn't defined in includes/constants.php

Code: Select all

// lastrss autopost mod begin
define('LASTRSS_AP_TABLE',				$table_prefix . 'lastrss_autopost');
// lastrss autopost mod end
Call me Grumpy.

asujibkk
Registered User
Posts: 1
Joined: Thu Nov 12, 2009 5:34 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by asujibkk »

I have installed this bot everything went well as planned but it's not posting, There are no errors popping up also all the short cuts on SMiXs forum are broken :(.

Also the white page pops up :( any ideas ? (fopen is open same with curl)

PureMB
Registered User
Posts: 13
Joined: Thu Jun 18, 2009 12:21 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by PureMB »

madmartyau wrote:
Tripp wrote:The table isn't there, you need to rerun the SQL query.
Or the table isn't defined in includes/constants.php

Code: Select all

// lastrss autopost mod begin
define('LASTRSS_AP_TABLE',				$table_prefix . 'lastrss_autopost');
// lastrss autopost mod end

That fixed it, THANKS!!!!

The 3.0.5 upgrade overwrote the constants.php file so I didn't have this piece of code in there.

fasko
Registered User
Posts: 185
Joined: Wed Jan 28, 2009 9:49 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by fasko »

asujibkk wrote:I have installed this bot everything went well as planned but it's not posting, There are no errors popping up also all the short cuts on SMiXs forum are broken :(.

Also the white page pops up :( any ideas ? (fopen is open same with curl)

http://phpbb3.smika.net/index.php?optio ... s&Itemid=3
Sorry for my english

User avatar
Nawid
Registered User
Posts: 329
Joined: Sat Jun 27, 2009 4:32 pm
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Nawid »

still, this is with no ACP management?
Last edited by Nawid on Tue Nov 17, 2009 7:45 am, edited 1 time in total.
Image
Check SuperNova Orange style on:
SchoolLife.nl
phpBB.com

jamiet757
Registered User
Posts: 54
Joined: Sat Aug 01, 2009 2:03 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by jamiet757 »

I am interested in this MOD also, but it appears to be very old, and from what I could tell nothing much has happened to it. You would think in 2 years he would eventually get around to including the ACP functions. Is there another alternative to this MOD that doesn't involve manual database editing?

alexfs
Registered User
Posts: 1
Joined: Tue Nov 17, 2009 2:20 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by alexfs »

This mod is amazing but I would like to show the original author of every rss, not the admin nick.

I have tested the "script" posted in the page 35 and it doesn't works, any idea?

Also could be very interesting if the author of every rss post appeared writed by GUESTS, is this possible?

Thanks

User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Smix »

Hello,

as I stated before, I was awaiting for phpBB 3.0.6 release and it´s finally there so I´m again able to push this mod a step forward ... ;-)
I´ll also try to fix the problems with the broken links ...

@jamiet757
Hello,
ACP functions are not available, because we are debugging the core at first ... Which, I´ve decided as final decision, I´ll have to rework and forget the lastRSS parser class, because it´s not as much usable as I hoped and has more bugs than I´m able to fix and at first find ...
And yes, it´s in development for two years and not much happened, because at first I have to do a payed work and my free time is short and high-priced actually, secondly I wasn´t able to find the bugs which are reported in basic functions of lastRSS parser class, which really slowered me - and that´s why I´ve decided to rework the parser class ...

@Nawid
Hello,
sorry, no further progress to add ACP yet :roll:

@asujibkk
Hello,
check the error log on your server for more informations, what´s broken ... White page is only a suppresed error ...

@Nexum
why isn't $config['lastrss_ap_bot_id'] in "phpbb_lastrss_autopost" table ??
Hello,
... because the original idea wasn´t thinking on this ...
... and also thanks for idea how to stop removing line breaks from the feeds ;-) ... Coool! ...

@Mess & @moisur
Hello,
well, wow.com feed is using CDATA tag almost everywhere and it´s not working, because data are not parsed ... Try to use some other feed at this time ... :cry:

@Satviewers
Hello,
the bot is trying to post everything from the feed what he gets ... But, it´s not 100% working :| and for example CDATA tag or other HTML tags are stripped ...
On the other hand, we are facing the fact, and that wasn´t already mentioned there yet, that you are (and it´s not only a my opinion) not automatically welcomed to copy the content from the feed without the author permission and use it on your own website/board as complete text (that´s why there is always a link to the original/author´s website) ... But I think, it´s on the original website, what they´ll give in RSS feed - they can restrict the RSS output theirself.

...

If I´ve forget to reply to any other questions, please feel free to post the question again please ... Thanks

User avatar
Nawid
Registered User
Posts: 329
Joined: Sat Jun 27, 2009 4:32 pm
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Nawid »

Thanks for the update. I think I'm going to wait for final release. although it'll take some time :)
Image
Check SuperNova Orange style on:
SchoolLife.nl
phpBB.com

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] lastRSS autoposting bot MOD (0.1.4)

Post by Mess »

Thanks allot for the update Smix.
Very much looking forward to the next release. :)

I'm using the following modifications, and all is working as expected:
Feed formating, different poster IDs, topic sync, bots update feeds and user update feeds, all feeds need confirmation.

Locked

Return to “[3.0.x] Abandoned MODs”