[ABD] lastRSS autoposting bot MOD (0.1.4)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Shadow1980
Registered User
Posts: 24
Joined: Wed May 07, 2008 8:54 am
Location: York, UK
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Shadow1980 »

Hi Smix,

Both your mods are brilliant and add a whole new dimension to any phpBB. As for my question, I have installed the autoposting bot and it is working very well so far. I'm however pulling an rss feed in which contains images and I am wondering how I would go about having these images displayed in the posts which are created.
Mana Pool PC Game Reviews
User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Tripp »

Shadow1980 wrote:Hi Smix,

Both your mods are brilliant and add a whole new dimension to any phpBB. As for my question, I have installed the autoposting bot and it is working very well so far. I'm however pulling an rss feed in which contains images and I am wondering how I would go about having these images displayed in the posts which are created.
That's not supported yet.
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs
User avatar
Shadow1980
Registered User
Posts: 24
Joined: Wed May 07, 2008 8:54 am
Location: York, UK
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Shadow1980 »

Drugs wrote: That's not supported yet.
I'm quite aware of this ;) I am hoping Smix is willing to look into this :)
Mana Pool PC Game Reviews
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Smix »

Hello Shadow1980,

as I said previously, I´ll try to do everything to get the images working ... :)

Thank you ;)
User avatar
Shadow1980
Registered User
Posts: 24
Joined: Wed May 07, 2008 8:54 am
Location: York, UK
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Shadow1980 »

Ah I wasn't aware this issue had been dealt with previously, my apologies ;)

Looking forward to the next release then - two thumbs up for the work put in so far!
Mana Pool PC Game Reviews
NWCPNE1
Registered User
Posts: 222
Joined: Sat Feb 02, 2008 8:28 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by NWCPNE1 »

Got this working a while ago, and it posts, but its not checking regulary. I have more than 1 Rss feed posting, in different sections, but it posts every 2 weeks instead of every hour. I set the next check after value to 1, but posts every 2 weeks instead of when the news is new. Any reasons for this?
http://www.nwcpnefc.co.uk for PNE Fans in North Wales and Cheshire, but we welcome all, including fans from other clubs.
GFreeman
Registered User
Posts: 23
Joined: Fri Feb 22, 2008 11:42 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by GFreeman »

Having a problem here.. installed the mod, I get a blank forum index page. Please help. Put the original index.php file back.. problem solved but mod not working. I'm running the 3.0.1. version of phpbb

Edit: I assume this is a standalone mod? not needing something else to make this installation work? The index file stays blank.. :cry:

Edit: got it working now.. I had to install the other mod too lol.. How do I know when it updates again..?
GFreeman
Registered User
Posts: 23
Joined: Fri Feb 22, 2008 11:42 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by GFreeman »

Hummm getting a mysql error.. something todo with the syntax of the post title used.. 22(")<< what's giving the problem

Code: Select all

SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Widescreen LCD Monitor"' at line 3 [1064]

SQL

SELECT topic_title FROM phpbb_topics WHERE topic_title = "tgbot | Lenovo L220X 22" Widescreen LCD Monitor"

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_lastrss_autopost.php
LINE: 176
CALL: dbal_mysql->sql_query()

FILE: includes/functions_lastrss_autopost.php
LINE: 91
CALL: autopost()

FILE: includes/functions_lastrss_autopost.php
LINE: 268
CALL: autopost_init()

FILE: index.php
LINE: 33
CALL: include('includes/functions_lastrss_autopost.php')
Any idea how I can fix this?
User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Tripp »

Seems the post title has quotes in it so it messes up the SQL?
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs
GFreeman
Registered User
Posts: 23
Joined: Fri Feb 22, 2008 11:42 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by GFreeman »

I think so yea that's because of the 20" containing in the post title.. I guess the sql query needs to be modified, because the boards accept a board title with quotes in it.. Just goes wrong with this sql command.. If anyone can help greatly appreciated.
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Smix »

Hello,

4 NWCPNE1 : really strange behavior :? ...

4 GFreeman : This is really a standalone mod. If you get a blank page, you´ve probably did something wrong. The other mod (if you are talking about agregator) is doing different things and is not connected with your problem ...
And about the bug, it´s known bug and it will be fixed in next version ... Please wait for a few days ... I´m now packing RC2 of agregator and after that, I can continue in this mod ...
greensmachine_snake
Registered User
Posts: 117
Joined: Sun Jun 03, 2007 12:53 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by greensmachine_snake »

mr mod man lol forgot your username lol

when you release upcoming stable versions i would request if you do modX you still include manual instructions so many mod developers dont do this and i have so many customized things throught diff themes these modX' ussually dont do the trick so i refuse to use em after theyve cause me countless time of resetting my setup so if you can please keep txt documantation going throughtout your mod thanks and hope to see the final done
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by Smix »

Hello,
I´ll pack this mod with MODX when I´ll finish the ACP (release with ACP will include MODX install file) as I previously declared. I´m not using it at this time, because writing MODX gets some time ... MODX will be available when we´ll reach BETA versions ;)

About updating, I´m not much sure how to use MODX for update instructions yet, I think I´ve seen it once and it wasn´t working as I hoped, so I don´t know yet, how to use MODX for update instructions (/contrib/update) and I´ll provide update instructions still in txt - but I want to do the updating most easy as possible, so you´ll always need only to copy new files over new and run the db update script (and possibly do some new edits to phpBB if I´ll do some new feature) ...

Thank you for suggestion ;)

btw. all documentation will be available (later - when the mod will be more stable) in my Knowledge base
andrewgalpin
Registered User
Posts: 78
Joined: Fri Sep 07, 2007 11:32 pm

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by andrewgalpin »

awesome i cant wait for the beta release :)
El-Cherubin
Registered User
Posts: 30
Joined: Thu Dec 27, 2007 11:48 pm
Contact:

Re: [DEV] lastRSS autoposting bot MOD (0.1.1)

Post by El-Cherubin »

I think this mod will become a real bomber! :D I'm unpatient, i want to try it, but i will wait a little time to use the beta!

Godd work! :, i think it's what i search (http://www.phpbb.com/community/viewtopi ... 5#p5759235)

Thank you so much :)
Neuron Partners Neurosciences serve Digital Marketing
Locked

Return to “[3.0.x] Abandoned MODs”